Bug 257314 - KTorrent crashed during download
Summary: KTorrent crashed during download
Status: RESOLVED DUPLICATE of bug 247984
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-19 12:45 UTC by Amichai Rothman
Modified: 2010-11-19 22:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Amichai Rothman 2010-11-19 12:45:14 UTC
Application: ktorrent (4.0.3)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I wasn't doing anything - KTorrent wasn't the active window, and hadn't been touched in an hour or so. It was in the middle of downloading from two torrents simultaniously. The crash report showed up while I was doing something unrelated in a browser.
Note that this has happened once before a few days ago, under similar circumstances (non-interactive use, 2 torrents running in the background)

-- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ffa3c259760 (LWP 28106))]

Thread 5 (Thread 0x7ffa27358710 (LWP 28108)):
#0  0x00007ffa37ddb2b3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7ffa18127710 (LWP 28127)):
#0  net::DownloadThread::waitForSocketReady (this=0x2698320) at ../../src/net/downloadthread.cpp:121
#1  0x00007ffa3bd767e6 in net::DownloadThread::update (this=0x315c640) at ../../src/net/downloadthread.cpp:48
#2  0x00007ffa3bd772c9 in net::NetworkThread::run (this=0x2698320) at ../../src/net/networkthread.cpp:48
#3  0x00007ffa3979827e in QThreadPrivate::start (arg=0x2698320) at thread/qthread_unix.cpp:266
#4  0x00007ffa3950d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#5  0x00007ffa37de291d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ffa17926710 (LWP 28128)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007ffa39797845 in thread_sleep (ti=0x7ffa17925da0) at thread/qthread_unix.cpp:416
#2  0x00007ffa397979b0 in QThread::msleep (msecs=<value optimized out>) at thread/qthread_unix.cpp:442
#3  0x00007ffa3bd7607d in net::UploadThread::update (this=0x2698990) at ../../src/net/uploadthread.cpp:89
#4  0x00007ffa3bd772c9 in net::NetworkThread::run (this=0x2698990) at ../../src/net/networkthread.cpp:48
#5  0x00007ffa3979827e in QThreadPrivate::start (arg=0x2698990) at thread/qthread_unix.cpp:266
#6  0x00007ffa3950d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#7  0x00007ffa37de291d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97
#8  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ffa27b59710 (LWP 28140)):
#0  0x00007ffa37dd61d3 in __poll (fds=0x7ffa2001a2a0, nfds=1, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:93
#1  0x00007ffa32c31009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007ffa32c3145c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007ffa398b81e6 in QEventDispatcherGlib::processEvents (this=0x42992b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007ffa3988aa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007ffa3988adec in QEventLoop::exec (this=0x7ffa27b58db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007ffa397952fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007ffa3986a5f8 in QInotifyFileSystemWatcherEngine::run (this=0x43166b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ffa3979827e in QThreadPrivate::start (arg=0x43166b0) at thread/qthread_unix.cpp:266
#9  0x00007ffa3950d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007ffa37de291d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffa3c259760 (LWP 28106)):
[KCrash Handler]
#6  memcpy () at ../sysdeps/x86_64/memcpy.S:267
#7  0x00007ffa377fd0b6 in QCA::MemoryRegion::MemoryRegion(QByteArray const&) () from /usr/lib/libqca.so.2
#8  0x00007ffa378134c5 in QCA::Hash::update(QByteArray const&) () from /usr/lib/libqca.so.2
#9  0x00007ffa3bd5f4ab in bt::SHA1HashGen::update (this=0x4d5bbc0, data=0x7ffa2661edd3 "\257\335>|\351", len=16384) at ../../src/util/sha1hashgen.cpp:240
#10 0x00007ffa3bd9a0e3 in bt::ChunkDownload::updateHash (this=0x4d5bb00) at ../../src/download/chunkdownload.cpp:555
#11 0x00007ffa3bd9c2e8 in bt::ChunkDownload::piece (this=0x4d5bb00, p=..., ok=<value optimized out>) at ../../src/download/chunkdownload.cpp:127
#12 0x00007ffa3bda2bde in bt::Downloader::pieceReceived (this=0x45e1c70, p=...) at ../../src/download/downloader.cpp:134
#13 0x00007ffa3bd86315 in bt::Peer::packetReady (this=0x4ddaa10, packet=0x7ffa0818b0a0 "\a", len=<value optimized out>) at ../../src/peer/peer.cpp:283
#14 0x00007ffa3bd91248 in bt::PacketReader::update (this=0x4f0e530) at ../../src/peer/packetreader.cpp:141
#15 0x00007ffa3bd850d5 in bt::Peer::update (this=0x4ddaa10) at ../../src/peer/peer.cpp:538
#16 0x00007ffa3bd8a995 in bt::PeerManager::update (this=0x27529a0) at ../../src/peer/peermanager.cpp:144
#17 0x00007ffa3bdbc8a4 in bt::TorrentControl::update (this=0x315d910) at ../../src/torrent/torrentcontrol.cpp:163
#18 0x00000000004289fb in kt::Core::update (this=0x288a230) at ../../ktorrent/core.cpp:1030
#19 0x0000000000431222 in kt::Core::qt_metacall (this=0x288a230, _c=QMetaObject::InvokeMetaMethod, _id=233, _a=0x7fff50a84970) at ./core.moc:167
#20 0x00007ffa398a3b27 in QMetaObject::activate (sender=0x288a258, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ba) at kernel/qobject.cpp:3280
#21 0x00007ffa3989d8f9 in QObject::event (this=0x288a258, e=0x7ffa2661f000) at kernel/qobject.cpp:1183
#22 0x00007ffa389d5fdc in QApplicationPrivate::notify_helper (this=0x26d2ce0, receiver=0x288a258, e=0x7fff50a850a0) at kernel/qapplication.cpp:4396
#23 0x00007ffa389dbaed in QApplication::notify (this=0x7fff50a853d0, receiver=0x288a258, e=0x7fff50a850a0) at kernel/qapplication.cpp:4277
#24 0x0000000000437d1a in kt::App::notify (this=0x4e800a5, receiver=0x7ffa2661f000, event=0x3ffb) at ../../ktorrent/app.cpp:97
#25 0x00007ffa3988bcdc in QCoreApplication::notifyInternal (this=0x7fff50a853d0, receiver=0x288a258, event=0x7fff50a850a0) at kernel/qcoreapplication.cpp:732
#26 0x00007ffa398bb6f2 in sendEvent (this=0x26c8ad0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QTimerInfoList::activateTimers (this=0x26c8ad0) at kernel/qeventdispatcher_unix.cpp:602
#28 0x00007ffa398b84c8 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#29 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#30 0x00007ffa32c2d342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007ffa32c312a8 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007ffa32c3145c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007ffa398b8193 in QEventDispatcherGlib::processEvents (this=0x2696320, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#34 0x00007ffa38a88a4e in QGuiEventDispatcherGlib::processEvents (this=0x4e800a5, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007ffa3988aa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007ffa3988adec in QEventLoop::exec (this=0x7fff50a85340, flags=) at kernel/qeventloop.cpp:201
#37 0x00007ffa3988eebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x0000000000426a8b in main (argc=<value optimized out>, argv=<value optimized out>) at ../../ktorrent/main.cpp:176

Possible duplicates by query: bug 256822, bug 256348, bug 256345, bug 255263, bug 254562.

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-19 22:17:45 UTC
[Comment from a bug triager]
This issue is fixed in the latest version and it was being tracked at bug 247984. Merging. Thanks

*** This bug has been marked as a duplicate of bug 247984 ***