Bug 245977 - Kontact crash when clicking on Korganizer Reminder Deamon
Summary: Kontact crash when clicking on Korganizer Reminder Deamon
Status: RESOLVED DUPLICATE of bug 245005
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-28 05:32 UTC by Justin
Modified: 2010-08-15 13:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin 2010-07-28 05:32:30 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Several times when clicking on the reminder Deamon is has crashed Kontact and triggered a error report, first time I've posted it though...

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8299f2c780 (LWP 1595))]

Thread 2 (Thread 0x7f8277388710 (LWP 1679)):
#0  0x00007f8296ffaf83 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f828fb2f4a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f828fb2f8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f82983e6566 in QEventDispatcherGlib::processEvents (this=0x26d6db0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f82983bb992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f82983bbd6c in QEventLoop::exec (this=0x7f8277387d90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f82982c5d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f829839c178 in QInotifyFileSystemWatcherEngine::run (this=0x263fca0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f82982c8775 in QThreadPrivate::start (arg=0x263fca0) at thread/qthread_unix.cpp:248
#9  0x00007f82920a69ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f82970076fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8299f2c780 (LWP 1595)):
[KCrash Handler]
#5  0x000000000530b830 in ?? ()
#6  0x00007f829958d879 in KontactInterface::Plugin::part (this=0x27d9b10) at ../../kontactinterface/plugin.cpp:191
#7  0x00007f82819867e1 in KOrganizerUniqueAppHandler::newInstance (this=0x27faeb0) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0x00007f829958f0a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x27faeb0, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00007f829958f114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x27faeb0, _c=QMetaObject::InvokeMetaMethod, _id=41971776, _a=0x7fff509e8b90) at ./uniqueapphandler.moc:79
#10 0x00007f8295808486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#11 0x00007f82958096ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x27faeb0, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00007f8295809f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#13 0x00007f829580a468 in QDBusActivateObjectEvent::placeMetaCall (this=0x4483230) at qdbusintegrator.cpp:1477
#14 0x00007f82983ccd49 in QObject::event (this=0x27faeb0, e=0x4483230) at kernel/qobject.cpp:1248
#15 0x00007f829777622c in QApplicationPrivate::notify_helper (this=0x230fc40, receiver=0x27faeb0, e=0x4483230) at kernel/qapplication.cpp:4300
#16 0x00007f829777c6fb in QApplication::notify (this=0x7fff509e9910, receiver=0x27faeb0, e=0x4483230) at kernel/qapplication.cpp:4183
#17 0x00007f8298da5526 in KApplication::notify (this=0x7fff509e9910, receiver=0x27faeb0, event=0x4483230) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f82983bd06c in QCoreApplication::notifyInternal (this=0x7fff509e9910, receiver=0x27faeb0, event=0x4483230) at kernel/qcoreapplication.cpp:704
#19 0x00007f82983bf7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x22e1620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x22e1620) at kernel/qcoreapplication.cpp:1345
#21 0x00007f82983e69d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#22 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#23 0x00007f828fb2b8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007f828fb2f748 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007f828fb2f8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007f82983e6513 in QEventDispatcherGlib::processEvents (this=0x22e0d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#27 0x00007f829782646e in QGuiEventDispatcherGlib::processEvents (this=0x27d9b10, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f82983bb992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007f82983bbd6c in QEventLoop::exec (this=0x7fff509e9850, flags=) at kernel/qeventloop.cpp:201
#30 0x00007f82983bfaab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#31 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 245005, bug 242278, bug 240876, bug 239984, bug 235846.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-15 13:53:00 UTC

*** This bug has been marked as a duplicate of bug 245005 ***