Bug 247000 - kontact crash when click the Korganizer
Summary: kontact crash when click the Korganizer
Status: RESOLVED DUPLICATE of bug 245005
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-07 17:16 UTC by Michael DING
Modified: 2010-08-15 13:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael DING 2010-08-07 17:16:34 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
First I tried to start kontact,but I don't know why,it doesn't come up,living korganizer runing as daemon,.Then I click the korganizer on the System tray.it crashed,I repeated and it happened every time

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7898990 (LWP 2587))]

Thread 2 (Thread 0xb1233b70 (LWP 2668)):
#0  0x00855422 in __kernel_vsyscall ()
#1  0x023deb86 in *__GI___poll (fds=0x2474ff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x048104eb in g_poll () from /lib/libglib-2.0.so.0
#3  0x048030ac in ?? () from /lib/libglib-2.0.so.0
#4  0x048034b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00e6b60f in QEventDispatcherGlib::processEvents (this=0x8c63a00, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x00e3e059 in QEventLoop::processEvents (this=0xb1233270, flags=) at kernel/qeventloop.cpp:149
#7  0x00e3e4aa in QEventLoop::exec (this=0xb1233270, flags=...) at kernel/qeventloop.cpp:201
#8  0x00d3a5a8 in QThread::exec (this=0x8c64500) at thread/qthread.cpp:487
#9  0x00e1dc1b in QInotifyFileSystemWatcherEngine::run (this=0x8c64500) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00d3d32e in QThreadPrivate::start (arg=0x8c64500) at thread/qthread_unix.cpp:248
#11 0x00a3996e in start_thread (arg=0xb1233b70) at pthread_create.c:300
#12 0x023eca4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7898990 (LWP 2587)):
[KCrash Handler]
#6  0x00888b50 in KontactInterface::Plugin::part (this=0x8dc1888) at ../../kontactinterface/plugin.cpp:190
#7  0x036a3d7a in KOrganizerUniqueAppHandler::newInstance (this=0x8dc1578) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0x0088a7e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x8dc1578, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x0088a874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x8dc1578, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf829c2c) at ./uniqueapphandler.moc:79
#10 0x07f63b34 in QDBusConnectionPrivate::deliverCall (this=0x8a78d60, object=0x8dc1578, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x07f64ddf in QDBusConnectionPrivate::activateCall (this=0x8a78d60, object=0x8dc1578, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x07f655ac in QDBusConnectionPrivate::activateObject (this=0x8a78d60, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1383
#13 0x07f65b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x94c20b8) at qdbusintegrator.cpp:1477
#14 0x00e503fe in QObject::event (this=0x8dc1578, e=0x94c20b8) at kernel/qobject.cpp:1248
#15 0x0108a4dc in QApplicationPrivate::notify_helper (this=0x8a80b00, receiver=0x8dc1578, e=0x94c20b8) at kernel/qapplication.cpp:4300
#16 0x0109105e in QApplication::notify (this=0xbf82a644, receiver=0x8dc1578, e=0x94c20b8) at kernel/qapplication.cpp:3704
#17 0x0066af2a in KApplication::notify (this=0xbf82a644, receiver=0x8dc1578, event=0x94c20b8) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00e3fa3b in QCoreApplication::notifyInternal (this=0xbf82a644, receiver=0x8dc1578, event=0x94c20b8) at kernel/qcoreapplication.cpp:704
#19 0x00e42473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8a614e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8a614e0) at kernel/qcoreapplication.cpp:1345
#21 0x00e425dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x00e6badf in QCoreApplication::sendPostedEvents (s=0x8a86a80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x8a86a80) at kernel/qeventdispatcher_glib.cpp:276
#24 0x047ff5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x048032d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x048034b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x00e6b5d5 in QEventDispatcherGlib::processEvents (this=0x8a61070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x0114a135 in QGuiEventDispatcherGlib::processEvents (this=0x8a61070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00e3e059 in QEventLoop::processEvents (this=0xbf82a5a4, flags=) at kernel/qeventloop.cpp:149
#30 0x00e3e4aa in QEventLoop::exec (this=0xbf82a5a4, flags=...) at kernel/qeventloop.cpp:201
#31 0x00e4269f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x0108a577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in main (argc=1, argv=0xbf82a864) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 245977.

Possible duplicates by query: bug 246954, bug 246813, bug 246445, bug 245977, bug 245005.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-15 13:54:31 UTC

*** This bug has been marked as a duplicate of bug 245005 ***