Bug 246954 - Crash on click of KOrganizer Reminder Daemon
Summary: Crash on click of KOrganizer Reminder Daemon
Status: RESOLVED DUPLICATE of bug 245005
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-07 01:23 UTC by Blue
Modified: 2010-10-25 08:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.99 KB, text/plain)
2010-10-25 08:14 UTC, Johannes Engel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Blue 2010-08-07 01:23:56 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
This bug report generated after clicking the KOrganizer Reminder Daemon... 

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76f9990 (LWP 1612))]

Thread 2 (Thread 0xb1fd8b70 (LWP 1774)):
#0  0x0275ee16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x009686fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x0096d825 in QTimerInfoList::updateCurrentTime (this=0xb1601834) at kernel/qeventdispatcher_unix.cpp:340
#3  0x0096d86a in QTimerInfoList::timerWait (this=0xb1601834, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x0096b818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb1fd80ac) at kernel/qeventdispatcher_glib.cpp:136
#5  0x0096b8a5 in timerSourcePrepare (source=0x0, timeout=0x2762ff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x01ac1aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x01ac1ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x01ac24b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x0096b60f in QEventDispatcherGlib::processEvents (this=0xb1600468, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x0093e059 in QEventLoop::processEvents (this=0xb1fd8270, flags=) at kernel/qeventloop.cpp:149
#11 0x0093e4aa in QEventLoop::exec (this=0xb1fd8270, flags=...) at kernel/qeventloop.cpp:201
#12 0x0083a5a8 in QThread::exec (this=0x93a0818) at thread/qthread.cpp:487
#13 0x0091dc1b in QInotifyFileSystemWatcherEngine::run (this=0x93a0818) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x0083d32e in QThreadPrivate::start (arg=0x93a0818) at thread/qthread_unix.cpp:248
#15 0x065cc96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x044a8a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb76f9990 (LWP 1612)):
[KCrash Handler]
#6  0x0000000c in ?? ()
#7  0x00503b73 in KontactInterface::Plugin::part (this=0x8fbc1b8) at ../../kontactinterface/plugin.cpp:191
#8  0x066e8eaa in KOrganizerUniqueAppHandler::newInstance (this=0x8fc2780) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#9  0x005057e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x8fc2780, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#10 0x00505874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x8fc2780, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff2ef5c) at ./uniqueapphandler.moc:79
#11 0x01ed6b34 in QDBusConnectionPrivate::deliverCall (this=0x8c87f48, object=0x8fc2780, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#12 0x01ed7ddf in QDBusConnectionPrivate::activateCall (this=0x8c87f48, object=0x8fc2780, flags=272, msg=...) at qdbusintegrator.cpp:809
#13 0x01ed85ac in QDBusConnectionPrivate::activateObject (this=0x8c87f48, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1383
#14 0x01ed8b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x8dc7d58) at qdbusintegrator.cpp:1477
#15 0x009503fe in QObject::event (this=0x8fc2780, e=0x8dc7d58) at kernel/qobject.cpp:1248
#16 0x010024dc in QApplicationPrivate::notify_helper (this=0x8c91048, receiver=0x8fc2780, e=0x8dc7d58) at kernel/qapplication.cpp:4300
#17 0x0100905e in QApplication::notify (this=0xbff2f974, receiver=0x8fc2780, e=0x8dc7d58) at kernel/qapplication.cpp:3704
#18 0x00ca7f2a in KApplication::notify (this=0xbff2f974, receiver=0x8fc2780, event=0x8dc7d58) at ../../kdeui/kernel/kapplication.cpp:302
#19 0x0093fa3b in QCoreApplication::notifyInternal (this=0xbff2f974, receiver=0x8fc2780, event=0x8dc7d58) at kernel/qcoreapplication.cpp:704
#20 0x00942473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8c704e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8c704e0) at kernel/qcoreapplication.cpp:1345
#22 0x009425dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#23 0x0096badf in QCoreApplication::sendPostedEvents (s=0x8c95710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=0x8c95710) at kernel/qeventdispatcher_glib.cpp:276
#25 0x01abe5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x01ac22d8 in ?? () from /lib/libglib-2.0.so.0
#27 0x01ac24b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x0096b5d5 in QEventDispatcherGlib::processEvents (this=0x8c70070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#29 0x010c2135 in QGuiEventDispatcherGlib::processEvents (this=0x8c70070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x0093e059 in QEventLoop::processEvents (this=0xbff2f8d4, flags=) at kernel/qeventloop.cpp:149
#31 0x0093e4aa in QEventLoop::exec (this=0xbff2f8d4, flags=...) at kernel/qeventloop.cpp:201
#32 0x0094269f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#33 0x01002577 in QApplication::exec () at kernel/qapplication.cpp:3579
#34 0x0804b472 in main (argc=3, argv=0xbff2fb94) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 245977.

Possible duplicates by query: bug 246813, bug 246445, bug 245977, bug 245005, bug 242278.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-15 13:52:50 UTC

*** This bug has been marked as a duplicate of bug 245005 ***
Comment 2 Johannes Engel 2010-10-25 08:14:01 UTC
Created attachment 52841 [details]
New crash information added by DrKonqi

kontact (4.4.7) on KDE Platform 4.5.2 (KDE 4.5.2) using Qt 4.7.0

- What I was doing when the application crashed:

click the korganizer reminder button in the tray.

-- Backtrace (Reduced):
#7  0x00007fe0569e7809 in KontactInterface::Plugin::part (this=0x87d660) at /usr/src/debug/kdepimlibs-4.5.2/kontactinterface/plugin.cpp:191
#8  0x00007fe03d490981 in KOrganizerUniqueAppHandler::newInstance (this=0xf078d0) at /usr/src/debug/kdepim-4.4.7/kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#9  0x00007fe0569e5cd9 in KontactInterface::UniqueAppHandler::newInstance (this=0xf078d0, asn_id=<value optimized out>, args=...)
    at /usr/src/debug/kdepimlibs-4.5.2/kontactinterface/uniqueapphandler.cpp:129
#10 0x00007fe0569e78d4 in KontactInterface::UniqueAppHandler::qt_metacall (this=0xf078d0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffec04f190)
    at /usr/src/debug/kdepimlibs-4.5.2/build/kontactinterface/uniqueapphandler.moc:79
#11 0x00007fe052cb23f8 in QDBusConnectionPrivate::deliverCall (this=0x62f5b0, object=0xf078d0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:919