Bug 246445 - Kontact failed as I started it the very first time
Summary: Kontact failed as I started it the very first time
Status: RESOLVED DUPLICATE of bug 245005
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-01 18:39 UTC by Andreas Hencke
Modified: 2010-08-15 13:53 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.35 KB, text/plain)
2010-08-02 17:04 UTC, AUM
Details
New crash information added by DrKonqi (4.74 KB, text/plain)
2010-08-04 14:34 UTC, AUM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Hencke 2010-08-01 18:39:48 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I don't know what and why the crash happend. I installed Kubuntu 10.04 on Friday

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb777e990 (LWP 1609))]

Thread 2 (Thread 0xb2a19b70 (LWP 1763)):
#0  0x02d26a0f in ?? () from /lib/tls/i686/cmov/libc.so.6
#1  0x013ce794 in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x013cf0ce in ?? () from /lib/libglib-2.0.so.0
#3  0x013cf4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00bbd60f in QEventDispatcherGlib::processEvents (this=0x9afb468, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#5  0x00b90059 in QEventLoop::processEvents (this=0xb2a19270, flags=) at kernel/qeventloop.cpp:149
#6  0x00b904aa in QEventLoop::exec (this=0xb2a19270, flags=...) at kernel/qeventloop.cpp:201
#7  0x00a8c5a8 in QThread::exec (this=0x9ae85b8) at thread/qthread.cpp:487
#8  0x00b6fc1b in QInotifyFileSystemWatcherEngine::run (this=0x9ae85b8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00a8f32e in QThreadPrivate::start (arg=0x9ae85b8) at thread/qthread_unix.cpp:248
#10 0x039ac96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#11 0x02ddda4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb777e990 (LWP 1609)):
[KCrash Handler]
#6  0x0028eb50 in KontactInterface::Plugin::part (this=0x97c7dd8) at ../../kontactinterface/plugin.cpp:190
#7  0x0192eeaa in KOrganizerUniqueAppHandler::newInstance (this=0x97ba260) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0x002907e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x97ba260, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00290874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x97ba260, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff2d83c) at ./uniqueapphandler.moc:79
#10 0x00782b34 in QDBusConnectionPrivate::deliverCall (this=0x946cf58, object=0x97ba260, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x00783ddf in QDBusConnectionPrivate::activateCall (this=0x946cf58, object=0x97ba260, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x007845ac in QDBusConnectionPrivate::activateObject (this=0x946cf58, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1383
#13 0x00784b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x97b9e10) at qdbusintegrator.cpp:1477
#14 0x00ba23fe in QObject::event (this=0x97ba260, e=0x97b9e10) at kernel/qobject.cpp:1248
#15 0x03df14dc in QApplicationPrivate::notify_helper (this=0x9477808, receiver=0x97ba260, e=0x97b9e10) at kernel/qapplication.cpp:4300
#16 0x03df805e in QApplication::notify (this=0xbff2e254, receiver=0x97ba260, e=0x97b9e10) at kernel/qapplication.cpp:3704
#17 0x00ee1f2a in KApplication::notify (this=0xbff2e254, receiver=0x97ba260, event=0x97b9e10) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00b91a3b in QCoreApplication::notifyInternal (this=0xbff2e254, receiver=0x97ba260, event=0x97b9e10) at kernel/qcoreapplication.cpp:704
#19 0x00b94473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x94554e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x94554e0) at kernel/qcoreapplication.cpp:1345
#21 0x00b945dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x00bbdadf in QCoreApplication::sendPostedEvents (s=0x9479590) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x9479590) at kernel/qeventdispatcher_glib.cpp:276
#24 0x013cb5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x013cf2d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x013cf4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x00bbd5d5 in QEventDispatcherGlib::processEvents (this=0x9455070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x03eb1135 in QGuiEventDispatcherGlib::processEvents (this=0x9455070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00b90059 in QEventLoop::processEvents (this=0xbff2e1b4, flags=) at kernel/qeventloop.cpp:149
#30 0x00b904aa in QEventLoop::exec (this=0xbff2e1b4, flags=...) at kernel/qeventloop.cpp:201
#31 0x00b9469f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x03df1577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in main (argc=3, argv=0xbff2e474) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 245005.

Possible duplicates by query: bug 245977, bug 245005, bug 242278, bug 240876, bug 239984.

Reported using DrKonqi
Comment 1 AUM 2010-08-02 17:04:49 UTC
Created attachment 49754 [details]
New crash information added by DrKonqi


I couldn't start Kontact (even with repeating the operation several times), I couldn't update ubuntu LTS 10.04 so I think I have updated it on the terminal of gnome (sudo apt-get update...), I couldn't configure Korganiser and Kadressebook its impossible : the configuration dialogue box can not appears entirely (it's a big problem) (I have kubuntu-desktop on Ubuntu 10.04 LTS) and finally I can not start kubuntu-desktop on Ubuntu 10.04 LTS even with kubuntu 10.04 on a USB key. On every moment I want to start kubuntu-desktop on Ubuntu 10.04 LTS the screen shows me the graphic GDM. I am ready to give you more informations. Thank you infinitely for your help.
Comment 2 AUM 2010-08-04 14:34:44 UTC
Created attachment 49804 [details]
New crash information added by DrKonqi

Somtimes, it's impossible to start Kontact even if repeating the same operation.
Comment 3 Nicolas L. 2010-08-15 13:53:49 UTC

*** This bug has been marked as a duplicate of bug 245005 ***