Bug 169124 - Rendering error when opening many tabs at once
Summary: Rendering error when opening many tabs at once
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR major with 40 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 171508 186312 186854 201305 202224 206203 207864 208431 209685 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-14 14:18 UTC by Richard Hartmann
Modified: 2010-01-21 19:48 UTC (History)
21 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
picture of bottom status bar messed up (188.32 KB, image/png)
2009-02-22 04:24 UTC, Leon Maurer
Details
another picture of bottom status bar messed up (475.17 KB, image/png)
2009-02-22 04:26 UTC, Leon Maurer
Details
this shows both the pdf sidebar and the status bar messed up (181.23 KB, image/png)
2009-02-22 04:26 UTC, Leon Maurer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Hartmann 2008-08-14 14:18:16 UTC
Version:           4.1.00 (KDE 4.1.0) (using 4.1.00 (KDE 4.1.0), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.26-1-686

I have a viewing profile which opens 20+ tabs with news site, comics and whatnot. When I switch to that profile, I see two things happening which should not happen. As they are probably caused by the same issue, I decided not to file separate issues. If you think I should do that, please tell me and I will.

1) Flash content from other tabs is displayed on the current tab. In most cases, this flickers on and off, with the flash disappearing to the correct tab, again. That is not always the case, though. Sometimes, the flash content will simply sit there, overlaying all content the current tab. Switching tabs does not help, said flash applet will stay in the same position, overlaying all else.
This is fixed as soon as I enter the tab where the applet actually belongs.

2) The status bar on the bottom of Konqueror will display a random portion of one of the websites in another tab.
Again, this does not change when switching to other tabs. As soon as I switch to the tab that has the content which is shown in the status bar, this is fixed.

I did not attach my viewing profile due to privacy concerns, but you can contact me on IRC as RichiH or via email and I can give you the profile in question.
Comment 1 Dario Andres 2008-12-26 16:57:19 UTC
Have you experienced this bug again with a recent KDE version? (4.1.3 / 4.2beta2 / 4.2svn) ?  Thanks :) 
Comment 2 Richard Hartmann 2008-12-26 23:41:21 UTC
I did not experience 1) recently, but I see 2) each and every day :/
Comment 3 Leon Maurer 2009-02-22 04:24:14 UTC
Created attachment 31531 [details]
picture of bottom status bar messed up
Comment 4 Leon Maurer 2009-02-22 04:26:08 UTC
Created attachment 31532 [details]
another picture of bottom status bar messed up

After going to the tab that contained the material at the bottom of the status bar in the last picture, it switched what was displayed there to stuff from another tab.
Comment 5 Leon Maurer 2009-02-22 04:26:57 UTC
Created attachment 31533 [details]
this shows both the pdf sidebar and the status bar messed up
Comment 6 Leon Maurer 2009-02-22 04:28:13 UTC
I have both problems 1 and 2 too -- I'm using 4.2.0. For problem 2, It not just the status bar where it happens, but also places like the pdf sidebar. I've attached some pictures. As you can see, this kind of thing is super annoying.
Comment 7 Maksim Orlovich 2009-02-22 17:56:51 UTC
*** Bug 171508 has been marked as a duplicate of this bug. ***
Comment 8 Vadym Krevs 2009-02-28 10:05:15 UTC
I can confirm 2 with the latest 4.2.0 packages for openSUSE 11.1 from openSUSE's build service.
Comment 9 Maksim Orlovich 2009-03-06 16:29:44 UTC
*** Bug 186312 has been marked as a duplicate of this bug. ***
Comment 10 Vadym Krevs 2009-03-06 17:14:51 UTC
I can confirm 2 with the latest 4.2.1 packages for openSUSE 11.1 from
openSUSE's build service.
Comment 11 Maksim Orlovich 2009-03-11 15:32:52 UTC
*** Bug 186854 has been marked as a duplicate of this bug. ***
Comment 12 Graham P Davis 2009-04-15 12:54:32 UTC
This bug is more serious than would at first seem. The bleeding through to the top tab from the one below also, on rare occasions, affects actions. Dragging-and-dropping a file into a folder on the visible tab can perform the action on a different tab. I witnessed this happening once and suspect that it's happened before. 

If one is not careful in having confirmation on and reading what is in the box before clicking on "OK", one could lose data. I therefore think "normal" is too low a level of severity for this bug.

This fault is still happening with KDE 4.2.2 on OpenSUSE 11.1.
Comment 13 Richard Hartmann 2009-04-15 15:31:12 UTC
Are you _certain_ of this? If yes, I will set it to critical as per https://bugs.kde.org/page.cgi?id=fields.html#bug_severity
Comment 14 Stefano Crocco 2009-04-15 15:41:26 UTC
I've noticed something like this, but for me it is more an annoyance than a true problem. What happens to me is the following: I open a profile with several tabs, then open another tab with another address. Part of one of the previous pages is displayed on the status bar and when I use the mouse wheel to scroll the page in the new tab, that page remains still, and the one shown on the status bar is scrolled.
Comment 15 Richard Hartmann 2009-04-15 15:58:17 UTC
As the 'hidden focus' can lead to possible data loss, I am setting this to critical.

It may be a corner case, but those are all the more evil from the user's POV.
Comment 16 Pino Toscano 2009-04-15 16:18:26 UTC
Can you please try with a different style than Oxygen?
$ konqueror --style plastique
Comment 17 Graham P Davis 2009-04-15 17:54:46 UTC
Richard, I'm sure about the wrong file being moved - I had to un-move it. I tried to repeat the problem but without success. On previous occasions I've moved files and nothing seemed to happen so repeated the move - something similar may have occurred but I can't be sure of that.

Pino, Change of style had no effect on behaviour.
Comment 18 Richard Hartmann 2009-04-15 19:33:20 UTC
Pino: Why the downgrade? Not that I object, I just want to learn :)
Comment 19 Marcel Schaal 2009-04-27 17:41:27 UTC
Happens in Fedora 11 and kubuntu 9.04 too. Both use kde 4.2.2
Comment 20 S. Burmeister 2009-05-15 18:02:45 UTC
I can reproduce this by leaving a konqueror session with some open tabs opened when shutting down KDE. After the session is restored I can see that other webpage's content is displayed in the status-bar when scrolling.
Comment 21 Dario Andres 2009-05-31 01:29:44 UTC
Mmm.. that last description will fit with bug 158900.... I wonder if both bugs are related.
Comment 22 Leon Maurer 2009-06-13 16:55:45 UTC
The bug is still here in  KDE 4.3 Beta 2. Any news on eradicating it?

I should also add, that if #2 is happening, sometimes when I try to scroll, the page in the status bar scrolls rather than the page being displayed. This behavior is less common, but it has been happening for some time. The fix is to switch to other tabs -- sometimes I've got to try a couple of tabs before I can scroll the right page again.
Comment 23 Richard Hartmann 2009-06-14 11:45:13 UTC
A sure way of fixing this is to press ctrl-. and just hold it until you cycled through all tabs twice.

That will also get rid of the bug where you always see the content of the next (on the right-hand side) tab in you status bar which seems to have become more common with 4.2.4
Comment 24 Richard Hartmann 2009-06-14 11:49:49 UTC
PS: Strangely enough, holding ctrl-, (i.e. moving left) will not always fix this issue. Sometimes, you need to go through everything three times and sometimes it does not help at all.
Comment 25 Dario Andres 2009-07-24 17:48:46 UTC
*** Bug 201305 has been marked as a duplicate of this bug. ***
Comment 26 Bob Willan 2009-08-28 23:25:57 UTC
*** Bug 202224 has been marked as a duplicate of this bug. ***
Comment 27 Tommi Tervo 2009-09-04 08:28:44 UTC
*** Bug 206203 has been marked as a duplicate of this bug. ***
Comment 28 Tommi Tervo 2009-09-19 11:36:14 UTC
*** Bug 207864 has been marked as a duplicate of this bug. ***
Comment 29 Tommi Tervo 2009-09-24 21:33:22 UTC
*** Bug 208431 has been marked as a duplicate of this bug. ***
Comment 30 Tommi Tervo 2009-10-07 09:48:28 UTC
*** Bug 209685 has been marked as a duplicate of this bug. ***
Comment 31 m.wege 2009-10-07 14:30:25 UTC
A while ago I reported memory problems with Konqueror https://bugs.kde.org/show_bug.cgi?id=196051
when having many tabs open and when closing them again the memory is not freed. May be these problems are related in a way. At least from my logic as a non programmer this seems possible :-)
Comment 32 Leon Maurer 2009-10-09 04:48:23 UTC
Well, the problem is still here in 4.3.2. Are the people with the power/kowledge to fix this aware of this problem? This bug is over a year old, and it can be a real show stopper.

Anyhow, I may have found a solution: ditch KHTML and move to WebKit. To do this install the WebKit KPart (on kubuntu, it's the 'webkitkde' package). Then follow the instructions at:

http://websvn.kde.org/*checkout*/trunk/playground/libs/webkitkde/README

I've been using this for two days and I have yet to see this bug. I hope it stays that way. Plus WebKit seems to render more websites correctly than KHTML. Win win.

The WebKit KPart is listed as a "work in progress", but that seems to be an apt description for many things around here.
Comment 33 David Faure 2009-12-01 01:29:24 UTC
I can't see how the statusbar rendering bug is a showstopper - simply resize the window and it goes away. FWIW, I did spend some time looking into it already, and it's really puzzling. I have no idea what's happening, must be a bug in Qt's backing store, because at the konqueror level I see nothing funky.
This bug is definitely *not* trivial.

Richard: please don't report two bugs in one, because now it's confusing which bug we're talking about. I assume number 2 from the initial report, although that would be a duplicate of the earlier 158900...
Comment 34 Leon Maurer 2009-12-01 01:40:32 UTC
When you try to scoll on the page your viewing, but the page in the statusbar scrolls instead, that means the web broswer cannot browse. Unless I'm mistaken, that's what konqueror is supposed to do, so that is a showstopper. The best solution I have found is closing the tab and opening it again. In some cases, the page your were accessing cannot be accessed directly (you have to go through some other links to get there), in which case this process is trouble (it's not fun even if getting back to the page is easy).

Does changing the window size fix this the scrolling bug? If so, it would be very useful. As I reported before, switching to WebKit eliminates this problem (although it introduces others). The best solution I've found is Firefox.
Comment 35 David Faure 2009-12-01 01:49:57 UTC
The statusbar rendering bug happens with KDEWebkit too, it's unrelated to the part being used.

My testcase:
1) konqueror www.kde.org www.koffice.org www.konqueror.org www.konqueror.org
2) wait a little bit (for autosave)
3) Ctrl+C
4) konqueror, and say yes for restoring the session
-> the statusbar is messed up; portions of the last tab's webpage appear in the statusbar, until resizing the window.

Happen with both khtml and webkit as default engine.

I only see a rendering bug though, the scrolling keys still scroll the part.

I'm not saying there is no bug here. This bug is very real. I just have no idea how to attack it.
Comment 36 Raúl 2009-12-01 09:09:38 UTC
In case it's useful, what I usually do is cycling through all the tabs. When you are done, the status bar is sane (or saner) and you can typically browse correctly.

There are cases when this doesn't work, in those cases duplicating konqueror window (Ctrl-shift-D) may help.

Regards,
Comment 37 David Faure 2009-12-01 16:43:30 UTC
SVN commit 1057148 by dfaure:

Found it! Fix the "statusbar rendering bug when restoring multiple tabs" bug.
It was "simply" a wrong show() on a widget that is inside a tabwidget; we ended up with
multiple widgets in the stackedwidget shown at the same time, bad idea...
Fixed for: 4.4.0-beta2
BUG: 169124


 M  +18 -7     konqviewmanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1057148
Comment 38 Germain Garand 2009-12-01 17:03:54 UTC
whoohoo, thank you David! :-)
Comment 39 Leon Maurer 2009-12-01 17:14:16 UTC
Awesome! David, thanks for taking care of this!
Comment 40 Richard Hartmann 2009-12-01 17:17:52 UTC
dfaure: Yes, sorry. Issue 1 has been fixed for ages, issue 2 was current up to now. Thanks for your effort!
Comment 41 m.wege 2009-12-02 08:38:08 UTC
Great news! Thanks David for fixing that. This bug was amoung my most hated bugs in KDE.
Comment 42 S. Burmeister 2009-12-02 12:40:59 UTC
Will there be a backport to KDE 4.3.x? The patch does not apply cleanly to 4.3 branch.
Comment 43 Richard Hartmann 2009-12-02 12:43:31 UTC
4.3.4, released two days ago, was the last release in the 4.3.x branch.
Comment 44 S. Burmeister 2009-12-02 12:50:22 UTC
There are distros which ship 4.3.x which could include the patch.
Comment 45 Richard Hartmann 2009-12-02 13:34:35 UTC
For what it's worth, try to remove the line marked in red on http://websvn.kde.org/trunk/KDE/kdebase/apps/konqueror/src/konqviewmanager.cpp?r1=1057148&r2=1057147&pathrev=1057148
and 4.3 _should_ be fixed.

I did not test this, though!
Comment 46 David Faure 2009-12-02 16:04:24 UTC
Yep, removing the show() line is the actual fix.
I didn't backport because I'm not 100% sure this doesn't introduce any regressions, and indeed because there's no more release from the branch anyway.
Comment 47 S. Burmeister 2009-12-02 16:42:06 UTC
Thanks a bunch!
Comment 48 David Faure 2010-01-21 19:18:06 UTC
SVN commit 1078185 by dfaure:

Backport 1057148: Fixed statusbar rendering bug (multiple views visible) when restoring multiple tabs.
Fixed for: 4.3.5
CCBUG: 169124, 158900


 M  +18 -7     konqviewmanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1078185
Comment 49 Richard Hartmann 2010-01-21 19:48:38 UTC
Thanks!