Bug 158900 - Konqueror visually broken after restoring Multiple tabs
Summary: Konqueror visually broken after restoring Multiple tabs
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 10 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 163081 193861 195316 205213 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-07 10:56 UTC by Seb
Modified: 2010-09-18 23:01 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
visual description of bug (473.98 KB, image/png)
2008-03-07 11:00 UTC, Seb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Seb 2008-03-07 10:56:47 UTC
Version:            (using KDE 4.0.2)
Installed from:    SuSE RPMs
OS:                Linux

The background of konq. plugins, webpages, scrollbar and status bar is broken when konqueror opens with Multiple tabs. (sorry for writing capital "M", the sMall "M" does not work on My kde4.0.2). 

These backrounds contain iMages froM other webpages opened in the invisible tabs. The backround will be restored after going through all tabs.

The bug also appears  in 4.0.1

screenshot attached
Comment 1 Seb 2008-03-07 11:00:40 UTC
Created attachment 23821 [details]
visual description of bug
Comment 2 Seb 2008-05-24 10:41:59 UTC
still happens in 4.0.4. Can somebody else confirm this bug?
Comment 3 Seb 2008-07-29 23:28:12 UTC
This still happens on KDE 4.1.0 - It is evene worse. Now all scrollbars are broken in the same weay regardless of they belong to Konqui or plugins.
Comment 4 Dario Andres 2008-08-01 22:56:46 UTC
Using KDE 4.1.1 (KDE 4.1.0 (4.1 >= 20080722)) (KDEmod) in ArchLinux i686
I can't reproduce this behaviour.

Does this happen with specific files or URLs ?
Can you describe the steps to reproduce it ?
Comment 5 Dario Andres 2008-12-26 15:02:53 UTC
No response. If this is still a problem in a current version, please reopen with more information. Thanks :) 
Comment 6 Seb 2009-01-04 13:44:28 UTC
The bug still appears on 4.1.3.

It appears using random URLs - always!

Reproduce (for example):
o open Konqui
o go to some webpage
o open new tab and search some phrase using Google
o Open some search result as PDF using the Okular plugin in a new tab.
o Open another (or the same) PDF file in yet another tab.
o log out
o log in

Result:
Konqueror reopens with all tabs from the last session.
Go to one of the PDf tabs -> Background of Okular is misshaped as seen in the attachment.
Comment 7 Dario Andres 2009-01-04 17:41:49 UTC
Mh,I can't reproduce here using:

Qt: 4.4.3 + qt-copy-patches-889120 
KDE: 4.1.87 (KDE 4.1.87 (KDE 4.2 >= 20090101))
kdelibs svn rev. 905454 / kdebase svn rev. 905455
kdegraphivs svn rev.905508
on ArchLinux x86_64 - Kernel 2.6.27.10

Can anyone else confirm this?
Comment 8 Seb 2009-01-17 12:43:54 UTC
I installed KDE 4.2 RC1 from openSuse11.0:Factory
The bug is still there. I also noticed that not only visually something is broken, but also the mouse focus (eg.mouse wheel on  scrollbars) may refer to another tab as well. 
Comment 9 Seb 2009-01-29 10:06:54 UTC
This very annoying bug made it into 4.2 

I wonder why only I encounter this problem (I have KDE 4.1/4.2 on 3 machines installed here, it appears on all of them).

I found out a new interesting thing that may be helpful:

If restoring a KDE session and Konqui is started automatically, then the bug appears (notice: Okular-Kpart must have been opened in at least one of the tabs wereby the active tab after opening konqui shows something else)

If restoring a Konqui session after a segfault, and Konqui restarts with the old page contents, then everything is fine...
Comment 10 Seb 2009-01-29 10:10:01 UTC
btw: It is not only visually broken - also the keyboard affects another page... 
Comment 11 Aaron Digulla 2009-05-25 09:49:21 UTC
*** Bug 193861 has been marked as a duplicate of this bug. ***
Comment 12 Aaron Digulla 2009-05-25 09:51:00 UTC
Bug 193861 contains a couple of screenshots for KDE 4.2.2.
Comment 13 Dario Andres 2009-06-05 15:51:50 UTC
*** Bug 195316 has been marked as a duplicate of this bug. ***
Comment 14 Seb 2009-08-20 09:32:14 UTC
This bug still is "unconfirmed", though a few duplicate reports exist? 

I want to confirm that it still apears in 4.3.0 (btw: was fine in 3.x)
Comment 15 Dario Andres 2009-09-04 22:58:50 UTC
*** Bug 205213 has been marked as a duplicate of this bug. ***
Comment 16 David Faure 2009-12-01 01:32:26 UTC
Confirming, but this bug is really tricky (cf my comment #33 in bug 169124).

I don't understand comment #10; what do you mean about the keyboard? Up/down seems to scroll the active tab here, as expected.
Comment 17 Seb 2009-12-01 09:22:55 UTC
If some of the restored webpages contain the okular plugin, then Ctrl+F is redirected from konqueror search to the okular search. 

In case of the bug, where the contents of all tabs overlap in the window, also the key bindings overlap. That is, Ctrl+F leads to an error (multiple combinations for this short cut, exact match of the error message is (German):

"Der Kurzbefehl „Ctrl+F“ ist doppeldeutig. Rufen Sie bitte „Einstellungen“ -> „Kurzbefehle festlegen“
im Menü auf und beheben Sie den Konflikt.
Es wird keine Aktion ausgeführt."
Comment 18 David Faure 2009-12-01 18:14:47 UTC
SVN commit 1057148 by dfaure:

Found it! Fix the "statusbar rendering bug when restoring multiple tabs" bug.
It was "simply" a wrong show() on a widget that is inside a tabwidget; we ended
up with multiple widgets in the stackedwidget shown at the same time, bad idea...
Fixed for: 4.4.0-beta2
BUG: 169124


 M  +18 -7     konqviewmanager.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1057148
Comment 19 FiNeX 2010-09-18 23:01:32 UTC
*** Bug 163081 has been marked as a duplicate of this bug. ***