Bug 171508 - Konqueror displays site content in status bar when using large viewing profiles
Summary: Konqueror displays site content in status bar when using large viewing profiles
Status: RESOLVED DUPLICATE of bug 169124
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.1.1
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 166998 172204 180967 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-23 14:14 UTC by Richard Hartmann
Modified: 2009-02-22 17:56 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
n/a (147.37 KB, image/png)
2008-09-23 14:17 UTC, Richard Hartmann
Details
n/a (77.65 KB, image/png)
2008-09-23 14:17 UTC, Richard Hartmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Hartmann 2008-09-23 14:14:15 UTC
Version:           4.1.1 (KDE 4.1.1) (using 4.1.1 (KDE 4.1.1), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.26-1-686

When loading http://bugs.kde.org/attachment.cgi?id=27527 from
http://bugs.kde.org/show_bug.cgi?id=171506 , Konqueror puts a part of whatever was loaded into tab 1 (i.e. the second one) into the status bar.

This can be solved by making tab 1 the active tab, after which the status bar is OK for both tab 1 and for all other tabs.


I will attach screenshots. Please note that the section of tab1 which is shown in the status bar across all other tabs is in the 'correct' place as far as page heigth is concerned.
Comment 1 Richard Hartmann 2008-09-23 14:17:13 UTC
Created attachment 27528 [details]
n/a
Comment 2 Richard Hartmann 2008-09-23 14:17:38 UTC
Created attachment 27529 [details]
n/a
Comment 3 Richard Hartmann 2008-09-23 14:20:30 UTC
Please note that, due to the nature of the viewing profile, kde.org was loaded several times. I.e. what you see in screenshot 1 is not a 'correct' continuation of the page. It is a part loaded from _a different tab_.
Screenshot 2 hopefully shows this as I scrolled down to the bottom, for it.

I hope the screenshots are OK, I realized that they are not ideal after uploading. If you need a new set to understand what I am babbling about, please tell me and I will provide them.
Comment 4 kgw 2008-11-28 10:30:11 UTC
The same happens to me when I log into KDE4.2 beta (built today from SVN) and have konqueror restore the last session of 6 open sites. Strangely enough switching between these sometimes retains contents that really belongs to the previously shown site in the status bar intermixed with the status messages for the current selected tab... 
Comment 5 Richard Hartmann 2008-11-28 10:38:27 UTC
I wonder why there are so few reports about this. Are we alone? Does it happen to people but don't they bother to file bugs? Are there so few people who open many tabs at once?
Comment 6 Arne Schmitz 2008-12-08 08:13:06 UTC
Nope, you are not alone. I use the viewing profiles daily, and this is rally annoying, since you cannot read the link targets in the status bar.

Cheers,

Arne
Comment 7 George Kiagiadakis 2009-01-16 22:50:50 UTC
*** Bug 166998 has been marked as a duplicate of this bug. ***
Comment 8 George Kiagiadakis 2009-01-16 22:52:50 UTC
*** Bug 172204 has been marked as a duplicate of this bug. ***
Comment 9 George Kiagiadakis 2009-01-16 22:53:27 UTC
*** Bug 180967 has been marked as a duplicate of this bug. ***
Comment 10 George Kiagiadakis 2009-01-16 22:58:12 UTC
I can confirm this bug. I just reproduced it accidentaly after restoring my session that had a konqueror window open with multiple tabs, and now I realized that I can also reproduce any time by loading the profile in attachment 27527 [details]. See bug 171506 for instructions.
Comment 11 Maksim Orlovich 2009-02-22 17:56:50 UTC

*** This bug has been marked as a duplicate of bug 169124 ***