Bug 128357 - Crash after hovering the mouse over an URL [KMMessage::bodyPart, AttachmentURLHandler::statusBarMessage, KMail::URLHandlerManager::statusBarMessage, KMReaderWin::slotUrlOn]
Summary: Crash after hovering the mouse over an URL [KMMessage::bodyPart, AttachmentUR...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: messageviewer (show other bugs)
Version: 1.9.1
Platform: unspecified Linux
: NOR crash with 55 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 130844 136174 136774 139239 140411 150019 151763 151937 184025 196031 196151 208858 209084 209845 211461 212199 213236 214257 215161 216027 218090 218903 219836 222366 223510 223647 224453 227352 230369 235170 237130 238839 244067 247275 251390 258213 266084 266177 274519 275137 275905 277106 277125 278181 281470 281523 282382 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-05-31 11:22 UTC by Florian Faber
Modified: 2012-08-19 11:07 UTC (History)
50 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.41 KB, text/plain)
2010-03-12 12:02 UTC, Diego
Details
New crash information added by DrKonqi (7.82 KB, text/plain)
2011-03-23 13:13 UTC, hgeerts
Details
New crash information added by DrKonqi (14.63 KB, text/plain)
2011-05-27 15:31 UTC, Alex Ball
Details
New crash information added by DrKonqi (7.83 KB, text/plain)
2011-06-21 16:43 UTC, Nicos Gollan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Faber 2006-05-31 11:22:36 UTC
Version:           1.9.1 (using KDE 3.5.2, Gentoo)
Compiler:          Target: x86_64-pc-linux-gnu
OS:                Linux (x86_64) release 2.6.16-gentoo

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47190788357504 (LWP 1546)]
[New Thread 1107310928 (LWP 1551)]
[New Thread 1098918224 (LWP 1550)]
[New Thread 1090525520 (LWP 1549)]
[New Thread 1082132816 (LWP 1548)]
[KCrash handler]
#5  0x00002aeb6f5b1d6f in KMMessage::bodyPart (aDwBodyPart=0xcb68f0, 
    aPart=0xdfefc8, withBody=true) at string.h:620
#6  0x00002aeb6f5b9251 in (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=<value optimized out>, url=@0x7ffffff37310, 
    w=<value optimized out>) at partNode.h:98
#7  0x00002aeb6f4c6070 in KMail::URLHandlerManager::statusBarMessage (
    this=0xd36510, url=@0x7ffffff37310, w=0x9914d0)
    at urlhandlermanager.cpp:312
#8  0x00002aeb6f59319c in KMReaderWin::slotUrlOn (this=0x9914d0, 
    aUrl=<value optimized out>) at kmreaderwin.cpp:1848
#9  0x00002aeb6f67195a in KMReaderWin::qt_invoke (this=0x9914d0, _id=57, 
    _o=0x7ffffff374e0) at kmreaderwin.moc:290
#10 0x00002aeb73bde33c in QObject::activate_signal (this=0x99d0e0, 
    clist=<value optimized out>, o=0x7ffffff374e0) at kernel/qobject.cpp:2356
#11 0x00002aeb73bdec0e in QObject::activate_signal (this=0x99d0e0, 
    signal=<value optimized out>, param=<value optimized out>)
    at kernel/qobject.cpp:2451
#12 0x00002aeb6fa4aff5 in KHTMLPart::onURL (this=0x99d0e0, 
    t0=<value optimized out>) at khtml_part.moc:410
#13 0x00002aeb6fa5339c in KHTMLPart::overURL (this=0x99d0e0, url=@0x9eae68, 
    target=@0x7ffffff38440) at khtml_part.cpp:3711
#14 0x00002aeb6fa74554 in KHTMLPart::khtmlMouseMoveEvent (this=0x99d0e0, 
    event=<value optimized out>) at khtml_part.cpp:6459
#15 0x00002aeb73bdde16 in QObject::event (this=0x99d0e0, e=0x7ffffff387c0)
    at kernel/qobject.cpp:755
#16 0x00002aeb73b88245 in QApplication::internalNotify (
    this=<value optimized out>, receiver=0x99d0e0, e=0x7ffffff387c0)
    at kernel/qapplication.cpp:2635
#17 0x00002aeb73b88e47 in QApplication::notify (this=0x7ffffff395d0, 
    receiver=0x99d0e0, e=0x7ffffff387c0) at kernel/qapplication.cpp:2358
#18 0x00002aeb72fe12df in KApplication::notify (this=0x7ffffff395d0, 
    receiver=0x99d0e0, event=0x7ffffff387c0) at kapplication.cpp:550
#19 0x00002aeb6fa6e641 in KHTMLView::viewportMouseMoveEvent (this=0x9e6760, 
    _mouse=0x7ffffff38f70) at qapplication.h:496
#20 0x00002aeb73cd76a9 in QScrollView::eventFilter (this=0x9e6760, 
    obj=0x9e9370, e=0x7ffffff38f70) at widgets/qscrollview.cpp:1511
#21 0x00002aeb6fa3f263 in KHTMLView::eventFilter (this=0x9e6760, o=0x9e9370, 
    e=0x7ffffff38f70) at khtmlview.cpp:1977
#22 0x00002aeb73bddd52 in QObject::activate_filters (this=0x9e9370, 
    e=0x7ffffff38f70) at kernel/qobject.cpp:903
#23 0x00002aeb73bddda7 in QObject::event (this=0x9e9370, e=0x7ffffff38f70)
    at kernel/qobject.cpp:735
#24 0x00002aeb73c10a08 in QWidget::event (this=0x2aeb762c7980, 
    e=0x2aeb761a6550) at kernel/qwidget.cpp:4659
#25 0x00002aeb73b88245 in QApplication::internalNotify (
    this=<value optimized out>, receiver=0x9e9370, e=0x7ffffff38f70)
    at kernel/qapplication.cpp:2635
#26 0x00002aeb73b89031 in QApplication::notify (this=0x7ffffff395d0, 
    receiver=0x9e9370, e=0x7ffffff38f70) at kernel/qapplication.cpp:2421
#27 0x00002aeb72fe12df in KApplication::notify (this=0x7ffffff395d0, 
    receiver=0x9e9370, event=0x7ffffff38f70) at kapplication.cpp:550
#28 0x00002aeb73b31b44 in QETWidget::translateMouseEvent (
    this=<value optimized out>, event=<value optimized out>)
    at qapplication.h:499
#29 0x00002aeb73b30c61 in QApplication::x11ProcessEvent (this=0x7ffffff395d0, 
    event=0x7ffffff39410) at kernel/qapplication_x11.cpp:3560
#30 0x00002aeb73b3f8ff in QEventLoop::processEvents (this=0x5bdaa0, flags=4)
    at kernel/qeventloop_x11.cpp:192
#31 0x00002aeb73b9ca22 in QEventLoop::enterLoop (this=0x2aeb762c7980)
    at kernel/qeventloop.cpp:198
#32 0x00002aeb73b9c8d2 in QEventLoop::exec (this=0x2aeb762c7980)
    at kernel/qeventloop.cpp:145
#33 0x0000000000402d1d in main (argc=<value optimized out>, 
    argv=<value optimized out>) at main.cpp:110
#34 0x00002aeb760bd134 in __libc_start_main (main=0x402be0 <main>, argc=1, 
    ubp_av=0x7ffffff39aa8, init=<value optimized out>, 
    fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7ffffff39a98) at libc-start.c:238
#35 0x0000000000402aa9 in _start ()
Current language:  auto; currently c
Comment 1 Bram Schoenmakers 2006-10-23 15:13:23 UTC
*** Bug 136174 has been marked as a duplicate of this bug. ***
Comment 2 Robert Penz 2006-10-23 15:24:13 UTC
The as duplicate marked bug is with kde 3.5.5 so this bug is still valid in the newest version.
Comment 3 Tommi Tervo 2006-11-04 15:44:54 UTC
*** Bug 136774 has been marked as a duplicate of this bug. ***
Comment 4 Rodrigo Ventura 2006-11-08 12:52:02 UTC
kmail jas just crashed with a different backtrace. This one happened when rreading next unread message:

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1248544208 (LWP 4276)]
[New Thread -1280119904 (LWP 4306)]
[New Thread -1271727200 (LWP 4305)]
[New Thread -1263334496 (LWP 4304)]
[New Thread -1254941792 (LWP 4303)]
[KCrash handler]
#5  0x0a3e7470 in ?? ()
#6  0xb7ddbd50 in KMail::ImapJob::slotGetNextMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#7  0xb7ddcad9 in KMail::ImapJob::init () from /opt/kde3/lib/libkmailprivate.so
#8  0xb7dddfad in KMail::ImapJob::execute ()
   from /opt/kde3/lib/libkmailprivate.so
#9  0xb7dd117d in KMail::FolderJob::start ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0xb7daedcd in KMMainWidget::slotMsgSelected ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0xb7dc29f0 in KMMainWidget::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb733366d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb7bffcbe in KMHeaders::selected () from /opt/kde3/lib/libkmailprivate.so
#14 0xb7c01d29 in KMHeaders::highlightMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#15 0xb7c0211c in KMHeaders::highlightMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#16 0xb7c0f636 in KMHeaders::qt_invoke () from /opt/kde3/lib/libkmailprivate.so
#17 0xb733366d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb767ff54 in QListView::currentChanged ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb7415357 in QListView::setCurrentItem ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb741827d in QListView::contentsMousePressEventEx ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb7418c14 in QListView::contentsMousePressEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb603513c in KListView::contentsMousePressEvent ()
   from /opt/kde3/lib/libkdeui.so.4
#23 0xb7c02259 in KMHeaders::contentsMousePressEvent ()
   from /opt/kde3/lib/libkmailprivate.so
#24 0xb744aa25 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb7447e9a in QScrollView::eventFilter ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb7416116 in QListView::eventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb7c03929 in KMHeaders::eventFilter ()
   from /opt/kde3/lib/libkmailprivate.so
#28 0xb7332f6c in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb7332fdb in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb736c01c in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb72d4547 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0xb72d547b in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb798ee03 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#34 0xb7273e72 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb7273046 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb728368a in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb72eb368 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0xb72eb1fe in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb72d40ff in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0x0804a0db in main ()
Comment 5 Michael Seiwert 2006-11-08 16:49:25 UTC
This bt looks like the ones of bug 126715. Dupe ?
Comment 6 Philip Rodrigues 2006-11-08 18:43:50 UTC
Comment 4 looks like a dupe of 126715, as you say, but the BT in the original report is different.
Comment 7 Florian Faber 2006-11-08 18:47:55 UTC
I haven't seen that bug for quite some time now (currently using kmail 1.9.5 from gentoo's kdepim-3.5.5-r2), was it fixed in the meantime?
Comment 8 Bram Schoenmakers 2006-12-27 14:17:45 UTC
*** Bug 139239 has been marked as a duplicate of this bug. ***
Comment 9 Bram Schoenmakers 2007-01-22 10:31:24 UTC
*** Bug 140411 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Roeder 2007-07-10 09:07:02 UTC
Today I got this too.

Kontact 1.2.5, KDE 3.5.7 (Kubuntu)

~~~~~~~~~~~~~~~~~~~~~~~~~
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1243420976 (LWP 19244)]
[New Thread -1287865456 (LWP 19248)]
[New Thread -1279472752 (LWP 19247)]
[New Thread -1271080048 (LWP 19246)]
[New Thread -1262687344 (LWP 19245)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb514b896 in KMMessage::bodyPart () from /usr/lib/libkmailprivate.so
#7  0xb514caf7 in (anonymous namespace)::AttachmentURLHandler::statusBarMessage () from /usr/lib/libkmailprivate.so
#8  0xb4f93149 in KMail::URLHandlerManager::statusBarMessage ()
   from /usr/lib/libkmailprivate.so
#9  0xb5113fa9 in KMReaderWin::slotUrlOn () from /usr/lib/libkmailprivate.so
#10 0xb51b5166 in KMReaderWin::qt_invoke () from /usr/lib/libkmailprivate.so
#11 0xb6f2d88b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb6f2ddc0 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb79e7630 in KHTMLPart::onURL () from /usr/lib/libkhtml.so.4
#14 0xb79f09fd in KHTMLPart::overURL () from /usr/lib/libkhtml.so.4
#15 0xb7a1477e in KHTMLPart::khtmlMouseMoveEvent ()
   from /usr/lib/libkhtml.so.4
#16 0xb79d2d10 in KHTMLPart::customEvent () from /usr/lib/libkhtml.so.4
#17 0xb6f2cf8d in QObject::event () from /usr/lib/libqt-mt.so.3
#18 0xb6ec4a60 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#19 0xb6ec688f in QApplication::notify () from /usr/lib/libqt-mt.so.3
#20 0xb7600c32 in KApplication::notify () from /usr/lib/libkdecore.so.4
#21 0xb7a0ddf2 in KHTMLView::viewportMouseMoveEvent ()
   from /usr/lib/libkhtml.so.4
#22 0xb7064522 in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#23 0xb79ea449 in KHTMLView::eventFilter () from /usr/lib/libkhtml.so.4
#24 0xb6f2ce38 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#25 0xb6f2ceb6 in QObject::event () from /usr/lib/libqt-mt.so.3
#26 0xb6f6458f in QWidget::event () from /usr/lib/libqt-mt.so.3
#27 0xb6ec4a60 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#28 0xb6ec6c1e in QApplication::notify () from /usr/lib/libqt-mt.so.3
#29 0xb7600c32 in KApplication::notify () from /usr/lib/libkdecore.so.4
#30 0xb6e5725d in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#31 0xb6e55ec2 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#32 0xb6e53fac in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#33 0xb6e6b180 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#34 0xb6edf136 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#35 0xb6edef46 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#36 0xb6ec6609 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#37 0x08061e25 in ?? ()
#38 0xbff1580c in ?? ()
#39 0x00000001 in ?? ()
#40 0x00000001 in ?? ()
#41 0x00000000 in ?? ()
Comment 11 Thomas McGuire 2007-11-02 19:56:51 UTC
*** Bug 151763 has been marked as a duplicate of this bug. ***
Comment 12 Thomas McGuire 2007-11-02 19:58:05 UTC
*** Bug 150019 has been marked as a duplicate of this bug. ***
Comment 13 Thomas McGuire 2007-11-02 19:59:08 UTC
*** Bug 130844 has been marked as a duplicate of this bug. ***
Comment 14 Thomas McGuire 2007-11-06 13:23:00 UTC
*** Bug 151937 has been marked as a duplicate of this bug. ***
Comment 15 Ronny Standtke 2008-12-16 19:55:07 UTC
I opened an attachment (doc file) with OpenOffice.org, closed OOo, switched back to Kontact and selected a folder. Then Kontact just crashed with a similar backtrace:

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5eb56c0 (LWP 8896)]
[New Thread 0xb3433b90 (LWP 8900)]
[New Thread 0xb3c34b90 (LWP 8899)]
[New Thread 0xb4435b90 (LWP 8898)]
[New Thread 0xb4c36b90 (LWP 8897)]
[KCrash handler]
#6  0xb4d002c0 in DwHeaders::FindField () from /usr/lib/libmimelib.so.1
#7  0xb4d003e7 in DwHeaders::HasContentType () from /usr/lib/libmimelib.so.1
#8  0xb4eda6fe in ?? () from /usr/lib/libkmailprivate.so
#9  0xb4edb20b in KMMessage::bodyPart () from /usr/lib/libkmailprivate.so
#10 0xb51802d9 in ?? () from /usr/lib/libkmailprivate.so
#11 0xb517fb09 in KMail::URLHandlerManager::statusBarMessage ()
   from /usr/lib/libkmailprivate.so
#12 0xb4fbea2f in KMReaderWin::slotUrlOn () from /usr/lib/libkmailprivate.so
#13 0xb4fbf12b in KMReaderWin::qt_invoke () from /usr/lib/libkmailprivate.so
#14 0xb676e704 in QObject::activate_signal (this=0x874f170, clist=0x876bad0, 
    o=0xbfd9b650) at kernel/qobject.cpp:2359
#15 0xb676ec55 in QObject::activate_signal (this=0x874f170, signal=8, 
    param=@0xbfd9b6cc) at kernel/qobject.cpp:2454
#16 0xb787ba30 in KHTMLPart::onURL (this=0x874f170, t0=@0x8752b28)
    at ./khtml_part.moc:409
#17 0xb7884b8d in KHTMLPart::overURL (this=0x874f170, url=@0x8752b28, 
    target=@0xbfd9bf5c)
    at /build/buildd/kdelibs-3.5.10/./khtml/khtml_part.cpp:3727
#18 0xb78ac00e in KHTMLPart::khtmlMouseMoveEvent (this=0x874f170, 
    event=0xbfd9c2d4)
    at /build/buildd/kdelibs-3.5.10/./khtml/khtml_part.cpp:6483
#19 0xb78682d0 in KHTMLPart::customEvent (this=0x874f170, event=0xbfd9c2d4)
    at /build/buildd/kdelibs-3.5.10/./khtml/khtml_part.cpp:5955
#20 0xb676c5e7 in QObject::event (this=0x874f170, e=0xbfd9c2d4)
    at kernel/qobject.cpp:758
#21 0xb6702c36 in QApplication::internalNotify (this=0xbfd9cf4c, 
    receiver=0x874f170, e=0xbfd9c2d4) at kernel/qapplication.cpp:2638
#22 0xb6704a5f in QApplication::notify (this=0xbfd9cf4c, receiver=0x874f170, 
    e=0xbfd9c2d4) at kernel/qapplication.cpp:2361
#23 0xb6ec39b2 in KApplication::notify (this=0xbfd9cf4c, receiver=0x874f170, 
    event=0xbfd9c2d4)
    at /build/buildd/kdelibs-3.5.10/./kdecore/kapplication.cpp:550
#24 0xb78a1e32 in KHTMLView::viewportMouseMoveEvent (this=0x87511d8, 
    _mouse=0xbfd9c980) at /usr/share/qt3/include/qapplication.h:523
#25 0xb68a3770 in QScrollView::eventFilter (this=0x87511d8, obj=0x8751da0, 
    e=0xbfd9c980) at widgets/qscrollview.cpp:1514
#26 0xb787e779 in KHTMLView::eventFilter (this=0x87511d8, o=0x8751da0, 
    e=0xbfd9c980) at /build/buildd/kdelibs-3.5.10/./khtml/khtmlview.cpp:1983
#27 0xb676c492 in QObject::activate_filters (this=0x8751da0, e=0xbfd9c980)
    at kernel/qobject.cpp:906
#28 0xb676c510 in QObject::event (this=0x8751da0, e=0xbfd9c980)
    at kernel/qobject.cpp:738
#29 0xb67a4d65 in QWidget::event (this=0x8751da0, e=0xbfd9c980)
    at kernel/qwidget.cpp:4681
#30 0xb6702c36 in QApplication::internalNotify (this=0xbfd9cf4c, 
    receiver=0x8751da0, e=0xbfd9c980) at kernel/qapplication.cpp:2638
#31 0xb6704de5 in QApplication::notify (this=0xbfd9cf4c, receiver=0x8751da0, 
    e=0xbfd9c980) at kernel/qapplication.cpp:2424
#32 0xb6ec39b2 in KApplication::notify (this=0xbfd9cf4c, receiver=0x8751da0, 
    event=0xbfd9c980)
    at /build/buildd/kdelibs-3.5.10/./kdecore/kapplication.cpp:550
#33 0xb6693301 in QApplication::sendSpontaneousEvent (receiver=0x8751da0, 
    event=0xbfd9c980) at kernel/qapplication.h:526
#34 0xb6691f8d in QETWidget::translateMouseEvent (this=0x8751da0, 
    event=0xbfd9cdc8) at kernel/qapplication_x11.cpp:4306
#35 0xb669012f in QApplication::x11ProcessEvent (this=0xbfd9cf4c, 
    event=0xbfd9cdc8) at kernel/qapplication_x11.cpp:3483
#36 0xb66a7943 in QEventLoop::processEvents (this=0x80b8bf0, flags=4)
    at kernel/qeventloop_x11.cpp:195
#37 0xb671df90 in QEventLoop::enterLoop (this=0x80b8bf0)
    at kernel/qeventloop.cpp:201
#38 0xb671dc8e in QEventLoop::exec (this=0x80b8bf0)
    at kernel/qeventloop.cpp:148
#39 0xb67047df in QApplication::exec (this=0xbfd9cf4c)
    at kernel/qapplication.cpp:2761
#40 0x0805c123 in ?? ()
#41 0xb5f19450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#42 0x0805b7f1 in ?? ()
Comment 16 Christophe Giboudeaux 2009-06-12 11:29:14 UTC
*** Bug 196151 has been marked as a duplicate of this bug. ***
Comment 17 Christophe Giboudeaux 2009-06-12 11:31:30 UTC
*** Bug 184025 has been marked as a duplicate of this bug. ***
Comment 18 Christophe Giboudeaux 2009-06-12 11:32:12 UTC
*** Bug 196031 has been marked as a duplicate of this bug. ***
Comment 19 Thomas Capricelli 2009-06-12 15:01:48 UTC
Here's another crash for my kmail. I feel strange that my crashes are considered as duplicate as this one, but my bug has been closed so i put the backtrace here (I was not composing or sending an email, as this bug description suggest)

This time it happened exactly when i clicked on another mail in the message list.
I added the (quite verbose) output of kmail in gdb before the bt. Not sure it's helpful.


......
0x2a337c0                                                                                                                                                                      
kmail(15676)/kmail (storage internals) KMFolderIndex::openInternal: KDE_fopen(indexLocation()= "/home/orzel/Mail/.outbox.index" , "r+") == mIndexStream ==  0xa58570                        
kmail(15676)/kmail (storage internals) KMFolderMaildir::getDwString: KDE_fopen(abs_file= "/home/orzel/Mail/outbox/cur/1244811460.15676.CkTzq" , "r+") == stream ==  0x2bf8210               
kmail(15676)/kmail (storage internals) KMFolderMaildir::getDwString: fclose(mIndexStream =  0x2bf8210 )                                                                                     
[New Thread 0x7faade418910 (LWP 15753)]                                                                                                                                                     
kmail(15676)/kmail (storage internals) KMFolderIndex::writeIndex: KDE_fopen(tempName= "/home/orzel/Mail/.outbox.index.temp" , "w") == tmpIndexStream ==  0x216fee0                          
kmail(15676)/kmail (storage internals) KMFolderIndex::writeIndex: fclose(tmpIndexStream =  0x216fee0 )                                                                                      
kmail(15676)/kmail (storage internals) KMFolderIndex::writeIndex: fclose(mIndexStream =  0xa58570 )                                                                                         
kmail(15676)/kmail (storage internals) KMFolderIndex::writeIndex: KDE_fopen(indexName= "/home/orzel/Mail/.outbox.index" , "r+") == mIndexStream ==  0xa507d0                                
kmail(15676)/kmail (storage internals) KMFolderMaildir::reallyDoClose: fclose(mIndexStream =  0xa507d0 )                                                                                    

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7faaf9314760 (LWP 15676)]    
0x00007faaf7e616f2 in KMMessage::bodyPart () from /usr/kde/4.2/lib64/libkmailprivate.so.4
(gdb)
(gdb) bt
#0  0x00007faaf7e616f2 in KMMessage::bodyPart () from /usr/kde/4.2/lib64/libkmailprivate.so.4
#1  0x00007faaf81dee49 in (anonymous namespace)::AttachmentURLHandler::statusBarMessage () from /usr/kde/4.2/lib64/libkmailprivate.so.4
#2  0x00007faaf81ded05 in KMail::URLHandlerManager::statusBarMessage () from /usr/kde/4.2/lib64/libkmailprivate.so.4
#3  0x00007faaf7f6f5ca in KMReaderWin::slotUrlOn () from /usr/kde/4.2/lib64/libkmailprivate.so.4
#4  0x00007faaf7f75141 in KMReaderWin::qt_metacall () from /usr/kde/4.2/lib64/libkmailprivate.so.4
#5  0x00007faaf4d3aef5 in QMetaObject::activate () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007faaf093a232 in KHTMLPart::onURL () from /usr/kde/4.2/lib64/libkhtml.so.5
#7  0x00007faaf0952512 in KHTMLPart::overURL () from /usr/kde/4.2/lib64/libkhtml.so.5
#8  0x00007faaf0954459 in KHTMLPart::handleMouseMoveEventOver () from /usr/kde/4.2/lib64/libkhtml.so.5
#9  0x00007faaf095483b in KHTMLPart::khtmlMouseMoveEvent () from /usr/kde/4.2/lib64/libkhtml.so.5
#10 0x00007faaf4d3797d in QObject::event () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007faaf3b4f91d in QApplicationPrivate::notify_helper () from /usr/lib64/qt4/libQtGui.so.4
#12 0x00007faaf3b581ea in QApplication::notify () from /usr/lib64/qt4/libQtGui.so.4
#13 0x00007faaf8e63d26 in KApplication::notify () from /usr/kde/4.2/lib64/libkdeui.so.5
#14 0x00007faaf4d28d03 in QCoreApplication::notifyInternal () from /usr/lib64/qt4/libQtCore.so.4
#15 0x00007faaf092e0dc in KHTMLView::mouseMoveEvent () from /usr/kde/4.2/lib64/libkhtml.so.5
#16 0x00007faaf3b9c750 in QWidget::event () from /usr/lib64/qt4/libQtGui.so.4
#17 0x00007faaf3ede10b in QFrame::event () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007faaf092a5a5 in KHTMLView::widgetEvent () from /usr/kde/4.2/lib64/libkhtml.so.5
#19 0x00007faaf092a817 in KHTMLView::eventFilter () from /usr/kde/4.2/lib64/libkhtml.so.5
#20 0x00007faaf4d28067 in QCoreApplicationPrivate::sendThroughObjectEventFilters () from /usr/lib64/qt4/libQtCore.so.4
#21 0x00007faaf3b4f8ec in QApplicationPrivate::notify_helper () from /usr/lib64/qt4/libQtGui.so.4
#22 0x00007faaf3b58943 in QApplication::notify () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007faaf8e63d26 in KApplication::notify () from /usr/kde/4.2/lib64/libkdeui.so.5
#24 0x00007faaf4d28d03 in QCoreApplication::notifyInternal () from /usr/lib64/qt4/libQtCore.so.4
#25 0x00007faaf3b57c18 in QApplicationPrivate::sendMouseEvent () from /usr/lib64/qt4/libQtGui.so.4
#26 0x00007faaf3bb20bc in QETWidget::translateMouseEvent () from /usr/lib64/qt4/libQtGui.so.4
#27 0x00007faaf3bb0bd5 in QApplication::x11ProcessEvent () from /usr/lib64/qt4/libQtGui.so.4
#28 0x00007faaf3bd5514 in x11EventSourceDispatch () from /usr/lib64/qt4/libQtGui.so.4
#29 0x00007faaec2ce63d in g_main_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0x00007faaec2d03dd in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#31 0x00007faaec2d054c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0x00007faaf4d4dc3f in QEventDispatcherGlib::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#33 0x00007faaf3bd4ddf in QGuiEventDispatcherGlib::processEvents () from /usr/lib64/qt4/libQtGui.so.4
#34 0x00007faaf4d27702 in QEventLoop::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#35 0x00007faaf4d27895 in QEventLoop::exec () from /usr/lib64/qt4/libQtCore.so.4
#36 0x00007faaf4d29894 in QCoreApplication::exec () from /usr/lib64/qt4/libQtCore.so.4
#37 0x0000000000403331 in main ()
Comment 20 Christophe Giboudeaux 2009-09-30 13:03:40 UTC
*** Bug 208858 has been marked as a duplicate of this bug. ***
Comment 21 Christophe Giboudeaux 2009-10-01 18:56:19 UTC
*** Bug 209084 has been marked as a duplicate of this bug. ***
Comment 22 Christophe Giboudeaux 2009-10-08 11:03:28 UTC
*** Bug 209845 has been marked as a duplicate of this bug. ***
Comment 23 Christophe Giboudeaux 2009-10-22 18:59:22 UTC
*** Bug 211461 has been marked as a duplicate of this bug. ***
Comment 24 Christophe Giboudeaux 2009-10-28 16:41:57 UTC
*** Bug 212199 has been marked as a duplicate of this bug. ***
Comment 25 Christophe Giboudeaux 2009-11-05 18:53:35 UTC
*** Bug 213236 has been marked as a duplicate of this bug. ***
Comment 26 Dario Andres 2009-11-12 22:45:47 UTC
Updated backtrace:
---

Thread 1 (Thread 0xb48e9700 (LWP 3867)):
[KCrash Handler]
#6  0xb597e30a in memmove () from /lib/tls/i686/cmov/libc.so.6
#7  0xb0944690 in DwString::_copy (this=0xaaa98b8) at
/usr/include/bits/string3.h:59
#8  0xb0da77c5 in KMMessage::bodyPart (aDwBodyPart=0xaaa9890, aPart=0xaca03ac,
withBody=true) at /build/buildd/kdepim-4.3.2/mimelib/mimelib/string.h:620
#9  0xb111b7f7 in statusBarMessage (this=0xb325470, url=@0xbfdcbab0,
w=0xa115870) at /build/buildd/kdepim-4.3.2/kmail/partNode.h:99
#10 0xb111b661 in KMail::URLHandlerManager::statusBarMessage (this=0xa04f070,
url=@0xbfdcbab0, w=0xa115870) at
/build/buildd/kdepim-4.3.2/kmail/urlhandlermanager.cpp:323
#11 0xb0eb0bfc in KMReaderWin::slotUrlOn (this=0xa115870, aUrl=@0xa127748) at
/build/buildd/kdepim-4.3.2/kmail/kmreaderwin.cpp:2023
#12 0xb0eb1ca5 in KMReaderWin::qt_metacall (this=0xa115870,
_c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbfdcbbfc) at
/build/buildd/kdepim-4.3.2/obj-i486-linux-gnu/kmail/kmreaderwin.moc:178
#13 0xb5ce51b8 in QMetaObject::activate (sender=0xa1227b8,
from_signal_index=14, to_signal_index=14, argv=0xbfdcbbfc) at
kernel/qobject.cpp:3113
#14 0xb5ce5e42 in QMetaObject::activate (sender=0xa1227b8, m=0xb7ffde88,
local_signal_index=0, argv=0xbfdcbbfc) at kernel/qobject.cpp:3187
#15 0xb7ae8693 in KHTMLPart::onURL (this=0xa1227b8, _t1=@0xa127748) at
/build/buildd/kde4libs-4.3.2/obj-i486-linux-gnu/khtml/khtml_part.moc:400
#16 0xb7b00549 in KHTMLPart::overURL (this=0xa1227b8, url=@0xa127748,
target=@0xbfdcc3a8) at /build/buildd/kde4libs-4.3.2/khtml/khtml_part.cpp:3521
#17 0xb7b029dc in KHTMLPart::handleMouseMoveEventOver (this=0xa1227b8,
event=0xbfdcc888) at /build/buildd/kde4libs-4.3.2/khtml/khtml_part.cpp:6351
#18 0xb7b02e7c in KHTMLPart::khtmlMouseMoveEvent (this=0xa1227b8,
event=0xbfdcc888) at /build/buildd/kde4libs-4.3.2/khtml/khtml_part.cpp:6399
#19 0xb7ae92a7 in KHTMLPart::customEvent (this=0xa1227b8, event=0xbfdcc888) at
/build/buildd/kde4libs-4.3.2/khtml/khtml_part.cpp:5944
Comment 27 Dario Andres 2009-11-12 22:45:52 UTC
*** Bug 214257 has been marked as a duplicate of this bug. ***
Comment 28 Christophe Giboudeaux 2009-11-18 21:45:21 UTC
*** Bug 215161 has been marked as a duplicate of this bug. ***
Comment 29 Dario Andres 2009-11-25 02:28:47 UTC
*** Bug 216027 has been marked as a duplicate of this bug. ***
Comment 30 Thomas Capricelli 2009-12-02 09:57:52 UTC
kde 4.3.4 is out. I confirm the bug is still there. Though my new fix for is now....

sudo rm /usr/kde/4.3/lib64/kde4/libexec/kscreenlocker

(the file name has changed, beware)
Comment 31 Thomas Capricelli 2009-12-02 09:59:43 UTC
oops, the previous comment was meant for another bug. Weird how bugzilla redirect you to another bug once a comment was posted. Sorry for this, and please disregard previous comment.
Comment 32 Dario Andres 2009-12-10 17:53:33 UTC
*** Bug 218090 has been marked as a duplicate of this bug. ***
Comment 33 Dario Andres 2009-12-17 00:51:21 UTC
*** Bug 218903 has been marked as a duplicate of this bug. ***
Comment 34 Dario Andres 2009-12-23 17:41:31 UTC
*** Bug 219836 has been marked as a duplicate of this bug. ***
Comment 35 Dario Andres 2010-01-12 19:27:44 UTC
*** Bug 222366 has been marked as a duplicate of this bug. ***
Comment 36 Dario Andres 2010-01-20 01:16:43 UTC
*** Bug 223510 has been marked as a duplicate of this bug. ***
Comment 37 Dario Andres 2010-01-21 13:34:33 UTC
*** Bug 223647 has been marked as a duplicate of this bug. ***
Comment 38 Dario Andres 2010-01-31 00:13:27 UTC
From bug 224453:
-- What I was doing when the application crashed:
kmail crashes at sending a forward e-mail. The mail contained an attachment
(~50k). The e-mail was sent successfully.
Comment 39 Dario Andres 2010-01-31 00:13:34 UTC
*** Bug 224453 has been marked as a duplicate of this bug. ***
Comment 40 Dario Andres 2010-02-17 13:55:41 UTC
*** Bug 227352 has been marked as a duplicate of this bug. ***
Comment 41 Diego 2010-03-12 12:02:24 UTC
Created attachment 41565 [details]
New crash information added by DrKonqi

While trying to send an email KMail crashed.
Comment 42 Björn Ruberg 2010-03-14 22:32:55 UTC
*** Bug 230369 has been marked as a duplicate of this bug. ***
Comment 43 Kumaran Santhanam 2010-05-18 16:12:27 UTC
I obtained a crash and stack trace from Kontact v4.4.2.  Given the number of years that this bug has been opened, as well as the large number of duplicates, can somebody please elevate the priority of this bug so that it gets fixed?  Having Kontact crash a few times daily is more than a minor inconvenience to business users who rely on email.

----

Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x00007ffed8ca4a71 in c_str (aDwBodyPart=0x2c45e50, aPart=0x57f7d78, withBody=true) at /usr/src/debug/kdepim-4.4.2/mimelib/mimelib/string.h:618
#6  partId (aDwBodyPart=0x2c45e50, aPart=0x57f7d78, withBody=true) at /usr/src/debug/kdepim-4.4.2/mimelib/mimelib/msgcmp.h:259
#7  KMMessage::bodyPart (aDwBodyPart=0x2c45e50, aPart=0x57f7d78, withBody=true) at /usr/src/debug/kdepim-4.4.2/kmail/kmmessage.cpp:2677
#8  0x00007ffed8f68d71 in msgPart (this=0x3dc1174e88, url=..., w=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/kmail/partNode.h:103
#9  (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=0x3dc1174e88, url=..., w=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/kmail/urlhandlermanager.cpp:688
#10 0x00007ffed8f672a4 in KMail::URLHandlerManager::statusBarMessage (this=0x4358e60, url=..., w=0x25d2e60) at /usr/src/debug/kdepim-4.4.2/kmail/urlhandlermanager.cpp:355
#11 0x00007ffed8d6c0a4 in KMReaderWin::slotUrlOn (this=0x25d2e60, aUrl=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/kmail/kmreaderwin.cpp:1966
#12 0x00007ffed8d6e0ae in KMReaderWin::qt_metacall (this=0x25d2e60, _c=InvokeMetaMethod, _id=16, _a=0x7fff3f05aac0) at /usr/src/debug/kdepim-4.4.2/x86_64-redhat-linux-gnu/kmail/kmreaderwin.moc:189
#13 0x0000003dcc76a2af in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#14 0x0000003ddfde1322 in KHTMLPart::onURL(QString const&) () from /usr/lib64/libkhtml.so.5
#15 0x0000003ddfe02575 in KHTMLPart::overURL(QString const&, QString const&, bool) () from /usr/lib64/libkhtml.so.5
#16 0x0000003ddfe045b3 in KHTMLPart::handleMouseMoveEventOver(khtml::MouseMoveEvent*) () from /usr/lib64/libkhtml.so.5
#17 0x0000003ddfe0494b in KHTMLPart::khtmlMouseMoveEvent(khtml::MouseMoveEvent*) () from /usr/lib64/libkhtml.so.5
#18 0x0000003dcc766974 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#19 0x0000003dd07aa9dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#20 0x0000003dd07b0aab in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#21 0x0000003dce006856 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#22 0x0000003dcc75774c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#23 0x0000003ddfddb164 in KHTMLView::mouseMoveEvent(QMouseEvent*) () from /usr/lib64/libkhtml.so.5
#24 0x0000003dd07f5797 in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#25 0x0000003dd0b70416 in QFrame::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#26 0x0000003ddfdd71d5 in KHTMLView::widgetEvent(QEvent*) () from /usr/lib64/libkhtml.so.5
#27 0x0000003ddfdd750f in KHTMLView::eventFilter(QObject*, QEvent*) () from /usr/lib64/libkhtml.so.5
#28 0x0000003dcc756b67 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#29 0x0000003dd07aa9ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#30 0x0000003dd07b127d in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#31 0x0000003dce006856 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#32 0x0000003dcc75774c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#33 0x0000003dd07b046e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
#34 0x0000003dd0822405 in ?? () from /usr/lib64/libQtGui.so.4
#35 0x0000003dd0821128 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
#36 0x0000003dd0849d82 in ?? () from /usr/lib64/libQtGui.so.4
#37 0x0000003dc323923e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#38 0x0000003dc323cc28 in ?? () from /lib64/libglib-2.0.so.0
#39 0x0000003dc323cd4a in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#40 0x0000003dcc77d063 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x0000003dd0849a4e in ?? () from /usr/lib64/libQtGui.so.4
#42 0x0000003dcc756192 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#43 0x0000003dcc75645c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#44 0x0000003dcc758749 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#45 0x0000000000403cce in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/kontact/src/main.cpp:224
Comment 44 Jonathan Thomas 2010-05-27 15:10:10 UTC
*** Bug 238839 has been marked as a duplicate of this bug. ***
Comment 45 Jonathan Thomas 2010-05-27 15:11:37 UTC
*** Bug 237130 has been marked as a duplicate of this bug. ***
Comment 46 Christophe Giboudeaux 2010-06-07 01:30:46 UTC
*** Bug 235170 has been marked as a duplicate of this bug. ***
Comment 47 Dario Andres 2010-11-18 17:21:20 UTC
[Comment from a bug triager]
Bug 231768 have some duplicates with similar backtraces, it may be related/duplicate.
Thanks
Comment 48 Christophe Giboudeaux 2010-11-29 13:48:28 UTC
*** Bug 258213 has been marked as a duplicate of this bug. ***
Comment 49 Dario Andres 2010-12-14 14:10:50 UTC
*** Bug 244067 has been marked as a duplicate of this bug. ***
Comment 50 Dario Andres 2010-12-14 14:11:00 UTC
*** Bug 247275 has been marked as a duplicate of this bug. ***
Comment 51 Christophe Giboudeaux 2011-02-14 10:52:25 UTC
*** Bug 266177 has been marked as a duplicate of this bug. ***
Comment 52 Christophe Giboudeaux 2011-02-14 10:53:14 UTC
*** Bug 266084 has been marked as a duplicate of this bug. ***
Comment 53 Christophe Giboudeaux 2011-02-14 10:53:56 UTC
*** Bug 251390 has been marked as a duplicate of this bug. ***
Comment 54 Chris Samuel 2011-02-14 12:17:07 UTC
5.5 years old, 38 duplicates and still marked as "NEW" and with a priority of "NORMAL" ?

Would everyone affected by this please vote for this bug if you feel it's worth noticing by the Kmail developers please ?
Comment 55 hgeerts 2011-03-23 13:13:10 UTC
Created attachment 58286 [details]
New crash information added by DrKonqi

kmail (1.13.5) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:
kmail running in the background and crashed after receiving focus.

-- Backtrace (Reduced):
#6  0x00007f0fa60dce71 in c_str (aDwBodyPart=0x730c480, aPart=0x80d5cc8, withBody=true) at ../../mimelib/mimelib/string.h:618
#7  partId (aDwBodyPart=0x730c480, aPart=0x80d5cc8, withBody=true) at ../../mimelib/mimelib/msgcmp.h:259
#8  KMMessage::bodyPart (aDwBodyPart=0x730c480, aPart=0x80d5cc8, withBody=true) at ../../kmail/kmmessage.cpp:2677
#9  0x00007f0fa6404a01 in msgPart (this=<value optimized out>, url=..., w=<value optimized out>) at ../../kmail/partNode.h:103
#11 0x00007f0fa64034d4 in KMail::URLHandlerManager::statusBarMessage (this=0x222e9e0, url=..., w=0x7fc3e0) at ../../kmail/urlhandlermanager.cpp:355
Comment 56 Alex Ball 2011-05-27 15:31:07 UTC
Created attachment 60385 [details]
New crash information added by DrKonqi

kontact (4.4.10) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.2

- What I was doing when the application crashed:
Viewing an email, and about to click on an embedded URL (I guess that counts as hovering).

I'm providing this report firstly to indicate that the problem still exists in KDESC 4.6.3 and secondly because the backtrace looked somewhat different to those already provided.

-- Backtrace (Reduced):
#6  0x00007f74395f4d1f in c_str (aDwBodyPart=0x2bd9e40, aPart=0x38504a8, withBody=true) at ../../mimelib/mimelib/string.h:618
#7  partId (aDwBodyPart=0x2bd9e40, aPart=0x38504a8, withBody=true) at ../../mimelib/mimelib/msgcmp.h:259
#8  KMMessage::bodyPart (aDwBodyPart=0x2bd9e40, aPart=0x38504a8, withBody=true) at ../../kmail/kmmessage.cpp:2677
#9  0x00007f74398d1981 in msgPart (this=<value optimized out>, url=..., w=<value optimized out>) at ../../kmail/partNode.h:103
#10 (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=<value optimized out>, url=..., w=<value optimized out>) at ../../kmail/urlhandlermanager.cpp:688
Comment 57 Christophe Giboudeaux 2011-06-06 17:03:21 UTC
*** Bug 274519 has been marked as a duplicate of this bug. ***
Comment 58 Nicos Gollan 2011-06-21 16:43:25 UTC
Created attachment 61215 [details]
New crash information added by DrKonqi

kontact (4.4.11) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.3

- What I was doing when the application crashed:
Looking at a mail with a PDF attachment in a filtered mailbox view (nonempty search term)

-- Backtrace (Reduced):
#6  0x00007fc8ccb826ef in c_str (aDwBodyPart=0x3096880, aPart=0x2f15a98, withBody=true) at ../../mimelib/mimelib/string.h:618
#7  partId (aDwBodyPart=0x3096880, aPart=0x2f15a98, withBody=true) at ../../mimelib/mimelib/msgcmp.h:259
#8  KMMessage::bodyPart (aDwBodyPart=0x3096880, aPart=0x2f15a98, withBody=true) at ../../kmail/kmmessage.cpp:2677
#9  0x00007fc8cce54009 in msgPart (this=<value optimized out>, url=..., w=<value optimized out>) at ../../kmail/partNode.h:103
#10 (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=<value optimized out>, url=..., w=<value optimized out>) at ../../kmail/urlhandlermanager.cpp:688
Comment 59 Christophe Giboudeaux 2011-07-08 08:42:54 UTC
*** Bug 277125 has been marked as a duplicate of this bug. ***
Comment 60 Christophe Giboudeaux 2011-07-08 08:43:09 UTC
*** Bug 277106 has been marked as a duplicate of this bug. ***
Comment 61 Christophe Giboudeaux 2011-07-08 09:11:30 UTC
*** Bug 275905 has been marked as a duplicate of this bug. ***
Comment 62 Christophe Giboudeaux 2011-07-08 09:11:40 UTC
*** Bug 275137 has been marked as a duplicate of this bug. ***
Comment 63 Christophe Giboudeaux 2011-07-22 09:15:10 UTC
*** Bug 278181 has been marked as a duplicate of this bug. ***
Comment 64 Christophe Giboudeaux 2011-09-06 11:45:44 UTC
*** Bug 281470 has been marked as a duplicate of this bug. ***
Comment 65 Christophe Giboudeaux 2011-09-07 08:24:15 UTC
*** Bug 281523 has been marked as a duplicate of this bug. ***
Comment 66 Christophe Giboudeaux 2011-09-24 13:10:38 UTC
*** Bug 282382 has been marked as a duplicate of this bug. ***
Comment 67 Myriam Schweingruber 2012-08-19 11:07:46 UTC
Thank you for your report. Kmail1 is currently unmaintained and the code has changed sufficiently in Kmail2 so the backtraces are not really useful anymore. Should you experience the same crash in Kmail 4.8.5 or later, please open a new report for Kmail2. Thank you for your understanding