Bug 136774 - kmail crashes randomly right after clicking something
Summary: kmail crashes randomly right after clicking something
Status: RESOLVED DUPLICATE of bug 128357
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.5
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-03 15:05 UTC by Rodrigo Ventura
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Ventura 2006-11-03 15:05:12 UTC
Version:           1.9.5 (using KDE KDE 3.5.5)
Installed from:    SuSE RPMs

kmail crashes randomly right after clicking on some thing for some operation. No relationship was found between operation and crash. Unable to reproduce, since it is not very often (1-3 times per day).

Crash backtrace:

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1247688144 (LWP 16045)]
[New Thread -1279263840 (LWP 16055)]
[New Thread -1270871136 (LWP 16054)]
[New Thread -1262478432 (LWP 16053)]
[New Thread -1254085728 (LWP 16052)]
[KCrash handler]
#6  0xb6fa108d in memmove () from /lib/libc.so.6
#7  0xb66f334a in DwString::_copy () from /opt/kde3/lib/libmimelib.so.1
#8  0xb7c1f0fe in KMMessage::bodyPart () from /opt/kde3/lib/libkmailprivate.so
#9  0xb7ea2b47 in (anonymous namespace)::AttachmentURLHandler::statusBarMessage
    () from /opt/kde3/lib/libkmailprivate.so
#10 0xb7ea2269 in KMail::URLHandlerManager::statusBarMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0xb7cf12b9 in KMReaderWin::slotUrlOn ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb7cf163d in KMReaderWin::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#13 0xb73cff1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb73d0782 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0xb6c93f50 in KHTMLPart::onURL () from /opt/kde3/lib/libkhtml.so.4
#16 0xb6c9d58a in KHTMLPart::overURL () from /opt/kde3/lib/libkhtml.so.4
#17 0xb6cbdc55 in KHTMLPart::khtmlMouseMoveEvent ()
   from /opt/kde3/lib/libkhtml.so.4
#18 0xb6c73790 in KHTMLPart::customEvent () from /opt/kde3/lib/libkhtml.so.4
#19 0xb73cf8fe in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb7370f07 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb7371cd1 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb7a2abd3 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#23 0xb6cb00d2 in KHTMLView::viewportMouseMoveEvent ()
   from /opt/kde3/lib/libkhtml.so.4
#24 0xb74e4773 in QScrollView::eventFilter ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb6c7c389 in KHTMLView::eventFilter () from /opt/kde3/lib/libkhtml.so.4
#26 0xb73cf81c in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb73cf88b in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb74088cc in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb7370f07 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb7371e3b in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb7a2abd3 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#32 0xb7310e12 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb730ffe6 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb732062a in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb7387d28 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb7387bbe in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb7370abf in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0x0804a0dd in main ()
Comment 1 Rodrigo Ventura 2006-11-03 18:40:55 UTC
Another crash, another backtrace:

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1247589840 (LWP 4037)]
[New Thread -1279165536 (LWP 4047)]
[New Thread -1270772832 (LWP 4046)]
[New Thread -1262380128 (LWP 4045)]
[New Thread -1253987424 (LWP 4044)]
[KCrash handler]
#6  0xb706b477 in main_arena () from /lib/libc.so.6
#7  0x095bdc58 in ?? ()
#8  0x00000002 in ?? ()
#9  0x00000001 in ?? ()
#10 0x00000000 in ?? ()
Comment 2 Tommi Tervo 2006-11-04 15:44:53 UTC

*** This bug has been marked as a duplicate of 128357 ***