Bug 230369 - Crash by responding to a mail
Summary: Crash by responding to a mail
Status: RESOLVED DUPLICATE of bug 128357
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.13.1
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-11 21:56 UTC by David Kremer
Modified: 2010-03-14 22:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kremer 2010-03-11 21:56:28 UTC
Application: kmail (1.13.1)
KDE Platform Version: 4.4.1 (KDE 4.4.1) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-ARCH i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
Basically, I have three email account set up in kmail. Two are pop gmail and the other is IMAP. By responding to an IMAP mail, just after sending the kmail crashed. It's all

 -- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[KCrash Handler]
#6  0xb6a7a7f7 in KMMessage::bodyPart(DwBodyPart*, KMMessagePart*, bool) () from /usr/lib/libkmailprivate.so.4
#7  0xb6ddf765 in (anonymous namespace)::AttachmentURLHandler::statusBarMessage(KUrl const&, KMReaderWin*) const () from /usr/lib/libkmailprivate.so.4
#8  0xb6ddde5c in KMail::URLHandlerManager::statusBarMessage(KUrl const&, KMReaderWin*) const () from /usr/lib/libkmailprivate.so.4
#9  0xb6b80d0a in KMReaderWin::slotUrlOn(QString const&) () from /usr/lib/libkmailprivate.so.4
#10 0xb6b82de3 in KMReaderWin::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkmailprivate.so.4
#11 0xb6730eba in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#12 0xb673f47f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#13 0xb4cef9f3 in KHTMLPart::onURL(QString const&) () from /usr/lib/libkhtml.so.5
#14 0xb4d13b6a in KHTMLPart::overURL(QString const&, QString const&, bool) () from /usr/lib/libkhtml.so.5
#15 0xb4d15f33 in KHTMLPart::handleMouseMoveEventOver(khtml::MouseMoveEvent*) () from /usr/lib/libkhtml.so.5
#16 0xb4d163ec in KHTMLPart::khtmlMouseMoveEvent(khtml::MouseMoveEvent*) () from /usr/lib/libkhtml.so.5
#17 0xb4cf04cf in KHTMLPart::customEvent(QEvent*) () from /usr/lib/libkhtml.so.5
#18 0xb673c53c in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb5c925dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb5c991ee in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb757705a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb672bcbb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb4ce81d9 in KHTMLView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libkhtml.so.5
#24 0xb5ceffda in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#25 0xb60e3023 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb4ce3c6c in KHTMLView::widgetEvent(QEvent*) () from /usr/lib/libkhtml.so.5
#27 0xb4ce3f65 in KHTMLView::eventFilter(QObject*, QEvent*) () from /usr/lib/libkhtml.so.5
#28 0xb672af5a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#29 0xb5c925b9 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#30 0xb5c99dcf in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#31 0xb757705a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#32 0xb672bcbb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#33 0xb5c98af7 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#34 0xb5d22f6c in ?? () from /usr/lib/libQtGui.so.4
#35 0xb5d224d3 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#36 0xb5d4ef82 in ?? () from /usr/lib/libQtGui.so.4
#37 0xb3f7e378 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#38 0xb3f81bf0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#39 0xb3f81d23 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#40 0xb67575d5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#41 0xb5d4eae5 in ?? () from /usr/lib/libQtGui.so.4
#42 0xb672a2f9 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#43 0xb672a74a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#44 0xb672e8bf in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#45 0xb5c92677 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#46 0x0804a80e in _start ()

Reported using DrKonqi
Comment 1 Björn Ruberg 2010-03-14 22:32:55 UTC

*** This bug has been marked as a duplicate of bug 128357 ***