Bug 277125 - KMail crashed after replying to an email
Summary: KMail crashed after replying to an email
Status: RESOLVED DUPLICATE of bug 128357
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-05 09:44 UTC by Vamp898
Modified: 2011-12-07 18:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vamp898 2011-07-05 09:44:38 UTC
Application: kmail (1.13.6)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
replyed to an email, reply was sent, everything was fine. I closed KMail and i was finished. Then suddenly this crash report appeared (but the mail arrived)
- Custom settings of the application:
Connected to an MS Exchange Server using IMAP

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f802a3b4840 (LWP 3175))]

Thread 3 (Thread 0x7f80066ad700 (LWP 3178)):
#0  0x00007f802730bf03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f801f214104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f801f2149f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8016445c44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f801f23b3e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f8024ec8d8c in start_thread (arg=0x7f80066ad700) at pthread_create.c:304
#6  0x00007f802731904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7ffbfd6700 (LWP 3180)):
#0  __pthread_mutex_unlock_usercnt (mutex=0x29cd9e8) at pthread_mutex_unlock.c:38
#1  __pthread_mutex_unlock (mutex=0x29cd9e8) at pthread_mutex_unlock.c:290
#2  0x00007f801f214661 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8027c69446 in QEventDispatcherGlib::processEvents (this=0x29d7300, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f8027c3d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8027c3dabc in QEventLoop::exec (this=0x7f7ffbfd5d10, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f8027b54924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f8027c1fc2f in QInotifyFileSystemWatcherEngine::run (this=0x29d6940) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8027b57175 in QThreadPrivate::start (arg=0x29d6940) at thread/qthread_unix.cpp:320
#9  0x00007f8024ec8d8c in start_thread (arg=0x7f7ffbfd6700) at pthread_create.c:304
#10 0x00007f802731904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f802a3b4840 (LWP 3175)):
[KCrash Handler]
#6  0x00007f80272b7d00 in memmove (dest=0x2a90f00, src=<value optimized out>, len=<value optimized out>) at memmove.c:82
#7  0x00007f8021d39868 in mem_copy (this=0x2a98a70) at /usr/include/bits/string3.h:58
#8  DwString::_copy (this=0x2a98a70) at ../../mimelib/dwstring.cpp:1228
#9  0x00007f8028d05d3a in c_str (aDwBodyPart=0x2a98a20, aPart=0x29d97c8, withBody=true) at ../../mimelib/mimelib/string.h:620
#10 partId (aDwBodyPart=0x2a98a20, aPart=0x29d97c8, withBody=true) at ../../mimelib/mimelib/msgcmp.h:259
#11 KMMessage::bodyPart (aDwBodyPart=0x2a98a20, aPart=0x29d97c8, withBody=true) at ../../kmail/kmmessage.cpp:2677
#12 0x00007f8028fe2981 in msgPart (this=<value optimized out>, url=..., w=<value optimized out>) at ../../kmail/partNode.h:103
#13 (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=<value optimized out>, url=..., w=<value optimized out>) at ../../kmail/urlhandlermanager.cpp:688
#14 0x00007f8028fe5894 in KMail::URLHandlerManager::statusBarMessage (this=0x27e02e0, url=..., w=0x23ca2b0) at ../../kmail/urlhandlermanager.cpp:355
#15 0x00007f8028dc6cf5 in KMReaderWin::slotUrlOn (this=0x23ca2b0, aUrl=<value optimized out>) at ../../kmail/kmreaderwin.cpp:1966
#16 0x00007f8028ddb4ae in KMReaderWin::qt_metacall (this=0x23ca2b0, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fff00718760) at ./kmreaderwin.moc:189
#17 0x00007f8027c535f8 in QMetaObject::activate (sender=0x23d9960, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff00718760) at kernel/qobject.cpp:3287
#18 0x00007f802402e9b2 in KHTMLPart::onURL (this=<value optimized out>, _t1=<value optimized out>) at ./khtml_part.moc:408
#19 0x00007f802403fa87 in KHTMLPart::overURL (this=0x23d9960, url=..., target=...) at ../../khtml/khtml_part.cpp:3511
#20 0x00007f802404273d in KHTMLPart::handleMouseMoveEventOver (this=0x23d9960, event=<value optimized out>) at ../../khtml/khtml_part.cpp:6481
#21 0x00007f8024042c8b in KHTMLPart::khtmlMouseMoveEvent (this=0x23d9960, event=0x7fff00719bc0) at ../../khtml/khtml_part.cpp:6529
#22 0x00007f8027c524fc in QObject::event (this=0x23d9960, e=<value optimized out>) at kernel/qobject.cpp:1257
#23 0x00007f802812c9f4 in QApplicationPrivate::notify_helper (this=0x1f10370, receiver=0x23d9960, e=0x7fff00719bc0) at kernel/qapplication.cpp:4462
#24 0x00007f80281313ba in QApplication::notify (this=<value optimized out>, receiver=0x23d9960, e=0x7fff00719bc0) at kernel/qapplication.cpp:4341
#25 0x00007f8029ddc866 in KApplication::notify (this=0x7fff0071b880, receiver=0x23d9960, event=0x7fff00719bc0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f8027c3e49c in QCoreApplication::notifyInternal (this=0x7fff0071b880, receiver=0x23d9960, event=0x7fff00719bc0) at kernel/qcoreapplication.cpp:731
#27 0x00007f8024014273 in sendEvent (this=0x242ec20, _mouse=0x7fff0071aa70) at /usr/include/qt4/QtCore/qcoreapplication.h:215
#28 KHTMLView::mouseMoveEvent (this=0x242ec20, _mouse=0x7fff0071aa70) at ../../khtml/khtmlview.cpp:1539
#29 0x00007f802817dcfc in QWidget::event (this=0x242ec20, event=0x7fff0071aa70) at kernel/qwidget.cpp:8244
#30 0x00007f8028530156 in QFrame::event (this=0x242ec20, e=0x7fff0071aa70) at widgets/qframe.cpp:557
#31 0x00007f8024015f05 in KHTMLView::widgetEvent (this=0x242ec20, e=<value optimized out>) at ../../khtml/khtmlview.cpp:2208
#32 0x00007f8024015754 in KHTMLView::eventFilter (this=0x242ec20, o=0x24396c0, e=0x7fff0071aa70) at ../../khtml/khtmlview.cpp:2053
#33 0x00007f8027c3e627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x24396c0, event=0x7fff0071aa70) at kernel/qcoreapplication.cpp:846
#34 0x00007f802812c9c1 in QApplicationPrivate::notify_helper (this=0x1f10370, receiver=0x24396c0, e=0x7fff0071aa70) at kernel/qapplication.cpp:4458
#35 0x00007f8028131dc3 in QApplication::notify (this=<value optimized out>, receiver=0x24396c0, e=0x7fff0071aa70) at kernel/qapplication.cpp:4023
#36 0x00007f8029ddc866 in KApplication::notify (this=0x7fff0071b880, receiver=0x24396c0, event=0x7fff0071aa70) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007f8027c3e49c in QCoreApplication::notifyInternal (this=0x7fff0071b880, receiver=0x24396c0, event=0x7fff0071aa70) at kernel/qcoreapplication.cpp:731
#38 0x00007f802812da1d in sendEvent (receiver=0x24396c0, event=0x7fff0071aa70, alienWidget=0x24396c0, nativeWidget=0x23cac60, buttonDown=0x7f8028c10218, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QApplicationPrivate::sendMouseEvent (receiver=0x24396c0, event=0x7fff0071aa70, alienWidget=0x24396c0, nativeWidget=0x23cac60, buttonDown=0x7f8028c10218, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3122
#40 0x00007f80281af190 in QETWidget::translateMouseEvent (this=0x23cac60, event=<value optimized out>) at kernel/qapplication_x11.cpp:4558
#41 0x00007f80281adab7 in QApplication::x11ProcessEvent (this=0x7fff0071b880, event=0x7fff0071b3c0) at kernel/qapplication_x11.cpp:3680
#42 0x00007f80281d6842 in x11EventSourceDispatch (s=0x1f0ea00, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#43 0x00007f801f213bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007f801f2143a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f801f214639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f8027c693ef in QEventDispatcherGlib::processEvents (this=0x1e7c310, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#47 0x00007f80281d64de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x00007f8027c3d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#49 0x00007f8027c3dabc in QEventLoop::exec (this=0x7fff0071b6c0, flags=...) at kernel/qeventloop.cpp:201
#50 0x00007f8027c41ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#51 0x0000000000403175 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../kmail/main.cpp:158

This bug may be a duplicate of or related to bug 277106.

Possible duplicates by query: bug 277106.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-07-08 08:42:54 UTC

*** This bug has been marked as a duplicate of bug 128357 ***