Bug 281523 - crash when reply mail window received focus
Summary: crash when reply mail window received focus
Status: RESOLVED DUPLICATE of bug 128357
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.10
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-07 08:10 UTC by Michael Monnerie
Modified: 2011-09-07 08:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Monnerie 2011-09-07 08:10:36 UTC
Application: kontact (4.4.10)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 3.0.3-zmi x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I pressed "reply" to an email. It's window opened. Then I switched to another App (LibreOffice Writer) to mark some text that should be copied to the mail. But upon clicking on the email, kmail instantly crashed when receiving focus.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe7b568a760 (LWP 13506))]

Thread 2 (Thread 0x7fe792a34700 (LWP 5213)):
#0  0x00007fe7b274b503 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe7aaee2114 in g_main_context_poll (context=0x7fe784010280, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3404
#2  g_main_context_iterate (context=0x7fe784010280, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3086
#3  0x00007fe7aaee2650 in g_main_context_iteration (context=0x7fe784010280, may_block=1) at gmain.c:3154
#4  0x00007fe7b3b1f976 in QEventDispatcherGlib::processEvents (this=0x10a54800, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fe7b3af4052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fe7b3af4265 in QEventLoop::exec (this=0x7fe792a33de0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fe7b3a091e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007fe7b3ad5968 in QInotifyFileSystemWatcherEngine::run (this=0x10a541e0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fe7b3a0ba5e in QThreadPrivate::start (arg=0x10a541e0) at thread/qthread_unix.cpp:285
#10 0x00007fe7ad8f4a3f in start_thread (arg=0x7fe792a34700) at pthread_create.c:297
#11 0x00007fe7b275467d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe7b568a760 (LWP 13506)):
[KCrash Handler]
#6  0x00007fe798696282 in c_str (aDwBodyPart=0x60d6a5f0, aPart=0x609b5b88, withBody=true) at /usr/src/debug/kdepim-4.4.10/mimelib/mimelib/string.h:618
#7  partId (aDwBodyPart=0x60d6a5f0, aPart=0x609b5b88, withBody=true) at /usr/src/debug/kdepim-4.4.10/mimelib/mimelib/msgcmp.h:259
#8  KMMessage::bodyPart (aDwBodyPart=0x60d6a5f0, aPart=0x609b5b88, withBody=true) at /usr/src/debug/kdepim-4.4.10/kmail/kmmessage.cpp:2677
#9  0x00007fe79895eca9 in msgPart (this=<value optimized out>, url=..., w=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/partNode.h:103
#10 (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=<value optimized out>, url=..., w=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/urlhandlermanager.cpp:688
#11 0x00007fe7989617c4 in KMail::URLHandlerManager::statusBarMessage (this=0x40163a0, url=..., w=0x436d790) at /usr/src/debug/kdepim-4.4.10/kmail/urlhandlermanager.cpp:355
#12 0x00007fe79874ed84 in KMReaderWin::slotUrlOn (this=0x436d790, aUrl=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/kmreaderwin.cpp:1966
#13 0x00007fe79876330e in KMReaderWin::qt_metacall (this=0x436d790, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fff8ed44720) at /usr/src/debug/kdepim-4.4.10/build/kmail/kmreaderwin.moc:189
#14 0x00007fe7b3b09def in QMetaObject::activate (sender=0x25d3540, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff8ed44720) at kernel/qobject.cpp:3272
#15 0x00007fe7b1cb2d22 in KHTMLPart::onURL (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/build/khtml/khtml_part.moc:408
#16 0x00007fe7b1cc3ca5 in KHTMLPart::overURL (this=0x25d3540, url=..., target=...) at /usr/src/debug/kdelibs-4.6.0/khtml/khtml_part.cpp:3511
#17 0x00007fe7b1cc6883 in KHTMLPart::handleMouseMoveEventOver (this=0x25d3540, event=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/khtml/khtml_part.cpp:6481
#18 0x00007fe7b1cc6d9b in KHTMLPart::khtmlMouseMoveEvent (this=0x25d3540, event=0x7fff8ed45cd0) at /usr/src/debug/kdelibs-4.6.0/khtml/khtml_part.cpp:6529
#19 0x00007fe7b3b08acc in QObject::event (this=0x25d3540, e=<value optimized out>) at kernel/qobject.cpp:1242
#20 0x00007fe7b2ec0d14 in QApplicationPrivate::notify_helper (this=0x1c7c370, receiver=0x25d3540, e=0x7fff8ed45cd0) at kernel/qapplication.cpp:4445
#21 0x00007fe7b2ec922a in QApplication::notify (this=<value optimized out>, receiver=0x25d3540, e=0x7fff8ed45cd0) at kernel/qapplication.cpp:4324
#22 0x00007fe7b44559e6 in KApplication::notify (this=0x7fff8ed478d0, receiver=0x25d3540, event=0x7fff8ed45cd0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#23 0x00007fe7b3af4bfc in QCoreApplication::notifyInternal (this=0x7fff8ed478d0, receiver=0x25d3540, event=0x7fff8ed45cd0) at kernel/qcoreapplication.cpp:732
#24 0x00007fe7b1c990af in sendEvent (this=0x25d74c0, _mouse=<value optimized out>) at /usr/include/QtCore/qcoreapplication.h:215
#25 KHTMLView::mouseMoveEvent (this=0x25d74c0, _mouse=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/khtml/khtmlview.cpp:1539
#26 0x00007fe7b2f1256c in QWidget::event (this=0x25d74c0, event=0x7fff8ed46ba0) at kernel/qwidget.cpp:8185
#27 0x00007fe7b32b6906 in QFrame::event (this=0x25d74c0, e=0x7fff8ed46ba0) at widgets/qframe.cpp:557
#28 0x00007fe7b1c9a2f5 in KHTMLView::widgetEvent (this=0x25d74c0, e=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/khtml/khtmlview.cpp:2208
#29 0x00007fe7b1c9a694 in KHTMLView::eventFilter (this=0x25d74c0, o=0x25dadf0, e=0x7fff8ed46ba0) at /usr/src/debug/kdelibs-4.6.0/khtml/khtmlview.cpp:2053
#30 0x00007fe7b3af4d87 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x25dadf0, event=0x7fff8ed46ba0) at kernel/qcoreapplication.cpp:847
#31 0x00007fe7b2ec0ce1 in QApplicationPrivate::notify_helper (this=0x1c7c370, receiver=0x25dadf0, e=0x7fff8ed46ba0) at kernel/qapplication.cpp:4441
#32 0x00007fe7b2ec9aac in QApplication::notify (this=<value optimized out>, receiver=0x25dadf0, e=0x7fff8ed46ba0) at kernel/qapplication.cpp:4006
#33 0x00007fe7b44559e6 in KApplication::notify (this=0x7fff8ed478d0, receiver=0x25dadf0, event=0x7fff8ed46ba0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#34 0x00007fe7b3af4bfc in QCoreApplication::notifyInternal (this=0x7fff8ed478d0, receiver=0x25dadf0, event=0x7fff8ed46ba0) at kernel/qcoreapplication.cpp:732
#35 0x00007fe7b2ec1d25 in sendEvent (receiver=0x25dadf0, event=0x7fff8ed46ba0, alienWidget=0x25dadf0, nativeWidget=0x25c4c10, buttonDown=0x7fe7b3990178, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:215
#36 QApplicationPrivate::sendMouseEvent (receiver=0x25dadf0, event=0x7fff8ed46ba0, alienWidget=0x25dadf0, nativeWidget=0x25c4c10, buttonDown=0x7fe7b3990178, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3105
#37 0x00007fe7b2f3fe08 in QETWidget::translateMouseEvent (this=0x25c4c10, event=<value optimized out>) at kernel/qapplication_x11.cpp:4438
#38 0x00007fe7b2f3e4c9 in QApplication::x11ProcessEvent (this=0x7fff8ed478d0, event=0x7fff8ed47500) at kernel/qapplication_x11.cpp:3564
#39 0x00007fe7b2f660f2 in x11EventSourceDispatch (s=0x1c8ab70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#40 0x00007fe7aaee1bd3 in g_main_dispatch (context=0x1c89ce0) at gmain.c:2440
#41 g_main_context_dispatch (context=0x1c89ce0) at gmain.c:3013
#42 0x00007fe7aaee23b0 in g_main_context_iterate (context=0x1c89ce0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3091
#43 0x00007fe7aaee2650 in g_main_context_iteration (context=0x1c89ce0, may_block=1) at gmain.c:3154
#44 0x00007fe7b3b1f91f in QEventDispatcherGlib::processEvents (this=0x1c51390, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#45 0x00007fe7b2f65d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x00007fe7b3af4052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#47 0x00007fe7b3af4265 in QEventLoop::exec (this=0x7fff8ed47820, flags=...) at kernel/qeventloop.cpp:201
#48 0x00007fe7b3af86ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#49 0x000000000040417e in _start ()

This bug may be a duplicate of or related to bug 128357.

Possible duplicates by query: bug 278181, bug 274519, bug 266177, bug 266084, bug 258213.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-09-07 08:24:15 UTC

*** This bug has been marked as a duplicate of bug 128357 ***