Bug 209084 - Kontact crashes on de-minimizing
Summary: Kontact crashes on de-minimizing
Status: RESOLVED DUPLICATE of bug 128357
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-01 11:42 UTC by Remco Bloemen
Modified: 2009-10-01 18:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Remco Bloemen 2009-10-01 11:42:51 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-gentoo-r6 x86_64

What I was doing when the application crashed:
Kontact crashed when I de-minimized the windowd by clicking on it taskbar entry. I may have moved the mouse over the window (I saw a MouseMove event in the backtrace).

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  DwStrcasecmp (aStr=@0x6e0068007800b2, aCstr=0x7f816fb00b60 "content-type") at /var/tmp/paludis/kde-base-mimelib-4.3.1/work/mimelib-4.3.1/mimelib/mimelib/string.h:627
#6  0x00007f816faeff65 in DwHeaders::FindField (this=<value optimized out>, aFieldName=0x7f816fb00b60 "content-type")
    at /var/tmp/paludis/kde-base-mimelib-4.3.1/work/mimelib-4.3.1/mimelib/headers.cpp:289
#7  0x00007f816faefff0 in DwHeaders::HasContentType (this=0x6e0068007800b2) at /var/tmp/paludis/kde-base-mimelib-4.3.1/work/mimelib-4.3.1/mimelib/headers.cpp:698
#8  0x00007f8171a49ec0 in applyHeadersToMessagePart (headers=@0x8c26ba0, aPart=0x7f816fb00b60) at /var/tmp/paludis/kde-base-kmail-4.3.1/work/kmail-4.3.1/kmail/kmmessage.cpp:2647
#9  0x00007f8171a4aa84 in KMMessage::bodyPart (aDwBodyPart=0x793dc70, aPart=0x75d8088, withBody=true) at /var/tmp/paludis/kde-base-kmail-4.3.1/work/kmail-4.3.1/kmail/kmmessage.cpp:2723
#10 0x00007f8171d6efc9 in statusBarMessage (this=<value optimized out>, url=@0x7fff47736a80, w=<value optimized out>) at /var/tmp/paludis/kde-base-kmail-4.3.1/work/kmail-4.3.1/kmail/partNode.h:99
#11 0x00007f8171d6ee53 in KMail::URLHandlerManager::statusBarMessage (this=0x7c8fd90, url=@0x7fff47736a80, w=0x210f6b0)
    at /var/tmp/paludis/kde-base-kmail-4.3.1/work/kmail-4.3.1/kmail/urlhandlermanager.cpp:323
#12 0x00007f8171b3834a in KMReaderWin::slotUrlOn (this=0x210f6b0, aUrl=@0x2105470) at /var/tmp/paludis/kde-base-kmail-4.3.1/work/kmail-4.3.1/kmail/kmreaderwin.cpp:2023
#13 0x00007f8171b391e6 in KMReaderWin::qt_metacall (this=0x210f6b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff47736cc0)
    at /var/tmp/paludis/kde-base-kmail-4.3.1/work/kmail-4.3.1_build/kmail/kmreaderwin.moc:178
#14 0x00007f8188efc4c0 in QMetaObject::activate (sender=0x20fc910, from_signal_index=<value optimized out>, to_signal_index=14, argv=0x0) at kernel/qobject.cpp:3101
#15 0x00007f818e6f2ac2 in KHTMLPart::onURL (this=0x6e0068007800b2, _t1=<value optimized out>) at /var/tmp/paludis/kde-base-kdelibs-4.3.1/work/kdelibs-4.3.1_build/khtml/khtml_part.moc:400
#16 0x00007f818e708a01 in KHTMLPart::overURL (this=0x20fc910, url=@0x2105470, target=@0x7fff47737890) at /var/tmp/paludis/kde-base-kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtml_part.cpp:3517
#17 0x00007f818e70abbc in KHTMLPart::handleMouseMoveEventOver (this=0x20fc910, event=<value optimized out>) at /var/tmp/paludis/kde-base-kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtml_part.cpp:6347
#18 0x00007f818e70af2b in KHTMLPart::khtmlMouseMoveEvent (this=0x20fc910, event=0x7fff47738030) at /var/tmp/paludis/kde-base-kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtml_part.cpp:6395
#19 0x00007f8188ef9225 in QObject::event (this=0x20fc910, e=0x7fff47738030) at kernel/qobject.cpp:1133
#20 0x00007f8189cac335 in QApplicationPrivate::notify_helper (this=0x18a4080, receiver=0x20fc910, e=0x7fff47738030) at kernel/qapplication.cpp:4056
#21 0x00007f8189cb389a in QApplication::notify (this=0x7fff4773add0, receiver=0x20fc910, e=0x7fff47738030) at kernel/qapplication.cpp:4021
#22 0x00007f818aa419aa in KApplication::notify (this=0x7fff4773add0, receiver=0x20fc910, event=0x7fff47738030)
    at /var/tmp/paludis/kde-base-kdelibs-4.3.1/work/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#23 0x00007f8188eea52b in QCoreApplication::notifyInternal (this=0x7fff4773add0, receiver=0x20fc910, event=0x7fff47738030) at kernel/qcoreapplication.cpp:606
#24 0x00007f818e6e5973 in KHTMLView::mouseMoveEvent (this=0x20febc0, _mouse=0x7fff47738f10) at /usr/include/qt4/QtCore/qcoreapplication.h:213
#25 0x00007f8189cf8917 in QWidget::event (this=0x20febc0, event=0x7fff47738f10) at kernel/qwidget.cpp:7534
#26 0x00007f818a00085c in QFrame::event (this=0x20febc0, e=0x7fff47738f10) at widgets/qframe.cpp:559
#27 0x00007f818e6e2d55 in KHTMLView::widgetEvent (this=0x20febc0, e=0x7f816fb00b60) at /var/tmp/paludis/kde-base-kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtmlview.cpp:2325
#28 0x00007f818e6e2fec in KHTMLView::eventFilter (this=0x20febc0, o=0x2101a10, e=0x7fff47738f10) at /var/tmp/paludis/kde-base-kdelibs-4.3.1/work/kdelibs-4.3.1/khtml/khtmlview.cpp:2189
#29 0x00007f8188ee9887 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x2101a10, event=0x7fff47738f10) at kernel/qcoreapplication.cpp:726
#30 0x00007f8189cac30e in QApplicationPrivate::notify_helper (this=0x18a4080, receiver=0x2101a10, e=0x7fff47738f10) at kernel/qapplication.cpp:4052
#31 0x00007f8189cb3fe3 in QApplication::notify (this=<value optimized out>, receiver=0x2101a10, e=0x7fff47738f10) at kernel/qapplication.cpp:3758
#32 0x00007f818aa419aa in KApplication::notify (this=0x7fff4773add0, receiver=0x2101a10, event=0x7fff47738f10)
    at /var/tmp/paludis/kde-base-kdelibs-4.3.1/work/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#33 0x00007f8188eea52b in QCoreApplication::notifyInternal (this=0x7fff4773add0, receiver=0x2101a10, event=0x7fff47738f10) at kernel/qcoreapplication.cpp:606
#34 0x00007f8189cb5471 in QApplicationPrivate::sendMouseEvent (receiver=0x2101a10, event=0x7fff47738f10, alienWidget=0x2101a10, nativeWidget=0x21153a0, buttonDown=<value optimized out>, 
    lastMouseReceiver=@0x7f818a5d4ef0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#35 0x00007f8189d0e36c in QETWidget::translateMouseEvent (this=0x21153a0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4404
#36 0x00007f8189d0cef6 in QApplication::x11ProcessEvent (this=0x7fff4773add0, event=0x7fff4773a900) at kernel/qapplication_x11.cpp:3545
#37 0x00007f8189d31624 in x11EventSourceDispatch (s=0x1899060, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#38 0x00007f81842d8329 in IA__g_main_context_dispatch (context=0x18a6520) at gmain.c:1824
#39 0x00007f81842db7c8 in g_main_context_iterate (context=0x18a6520, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2455
#40 0x00007f81842db97e in IA__g_main_context_iteration (context=0x18a6520, may_block=1) at gmain.c:2518
#41 0x00007f8188f0f96f in QEventDispatcherGlib::processEvents (this=0x186e960, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#42 0x00007f8189d30ec8 in QGuiEventDispatcherGlib::processEvents (this=0x6e0068007800b2, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#43 0x00007f8188ee8eb2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1198762992}) at kernel/qeventloop.cpp:149
#44 0x00007f8188ee905c in QEventLoop::exec (this=0x7fff4773ac30, flags={i = 1198763072}) at kernel/qeventloop.cpp:197
#45 0x00007f8188eeb0dc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#46 0x0000000000404bb9 in main (argc=1, argv=0x7fff4773b3a8) at /var/tmp/paludis/kde-base-kontact-4.3.1/work/kontact-4.3.1/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 207440

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-10-01 18:56:19 UTC

*** This bug has been marked as a duplicate of bug 128357 ***