Bug 231768 - Kmail crashed relating to attachments and replying messages [DwHeaders::FindField, DwHeaders::HasContentType, applyHeadersToMessagePart, KMMessage::bodyPart, ..., KMail::URLHandlerManager::statusBarMessage]
Summary: Kmail crashed relating to attachments and replying messages [DwHeaders::FindF...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 242693 253290 254146 255621 269765 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-22 14:05 UTC by Alejandro Ramón
Modified: 2012-08-19 11:08 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Ramón 2010-03-22 14:05:48 UTC
Application that crashed: kmail
Version of the application: 1.12.4
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-3-amd64 x86_64
Distribution: Debian GNU/Linux testing (squeeze)

What I was doing when the application crashed:
Kmail crashed with signal 11 when passed the mouse over an attachment to download it. It might be a duplicate of 128357

 -- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  DwHeaders::FindField (this=0x100000000, aFieldName=0x7fb8b287a874 "content-type") at ../../mimelib/headers.cpp:287
#6  0x00007fb8b286a0e0 in DwHeaders::HasContentType (this=0x100000000) at ../../mimelib/headers.cpp:698
#7  0x00007fb8b938c940 in applyHeadersToMessagePart (headers=<value optimized out>, aPart=0x7fb8b287a874) at ../../kmail/kmmessage.cpp:2649
#8  0x00007fb8b938d544 in KMMessage::bodyPart (aDwBodyPart=0x1adb9d0, aPart=0x2170bc8, withBody=true) at ../../kmail/kmmessage.cpp:2725
#9  0x00007fb8b96b1db9 in partNode::msgPart (this=<value optimized out>, url=..., w=0xe04da0) at ../../kmail/partNode.h:99
#10 statusBarMessage (this=<value optimized out>, url=..., w=0xe04da0) at ../../kmail/urlhandlermanager.cpp:549
#11 0x00007fb8b96b1a94 in KMail::URLHandlerManager::statusBarMessage (this=0x1a940d0, url=..., w=0xe04da0) at ../../kmail/urlhandlermanager.cpp:323
#12 0x00007fb8b947a36c in KMReaderWin::slotUrlOn (this=0xe04da0, aUrl=<value optimized out>) at ../../kmail/kmreaderwin.cpp:2031
#13 0x00007fb8b947ce4e in KMReaderWin::qt_metacall (this=0xe04da0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1a3eb0f0) at ./kmreaderwin.moc:178
#14 0x00007fb8b8c68df2 in QMetaObject::activate (sender=0xdf9790, from_signal_index=<value optimized out>, to_signal_index=14, argv=0x7fb8b8f48ac0) at kernel/qobject.cpp:3112
#15 0x00007fb8b4ca61c2 in KHTMLPart::onURL (this=0x100000000, _t1=<value optimized out>) at ./khtml_part.moc:400
#16 0x00007fb8b4cbc730 in KHTMLPart::overURL (this=0xdf9790, url=..., target=...) at ../../khtml/khtml_part.cpp:3521
#17 0x00007fb8b4cbe781 in KHTMLPart::handleMouseMoveEventOver (this=0xdf9790, event=<value optimized out>) at ../../khtml/khtml_part.cpp:6355
#18 0x00007fb8b4cbeb3b in KHTMLPart::khtmlMouseMoveEvent (this=0xdf9790, event=0x7fff1a3ec430) at ../../khtml/khtml_part.cpp:6403
#19 0x00007fb8b8c63715 in QObject::event (this=0xdf9790, e=0x7fff1a3ec430) at kernel/qobject.cpp:1141
#20 0x00007fb8b80cd01d in QApplicationPrivate::notify_helper (this=0x902e30, receiver=0xdf9790, e=0x7fff1a3ec430) at kernel/qapplication.cpp:4065
#21 0x00007fb8b80d507a in QApplication::notify (this=0x7fff1a3ef170, receiver=0xdf9790, e=0x7fff1a3ec430) at kernel/qapplication.cpp:4030
#22 0x00007fb8ba2f3de6 in KApplication::notify (this=0x7fff1a3ef170, receiver=0xdf9790, event=0x7fff1a3ec430) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00007fb8b8c53c9c in QCoreApplication::notifyInternal (this=0x7fff1a3ef170, receiver=0xdf9790, event=0x7fff1a3ec430) at kernel/qcoreapplication.cpp:610
#24 0x00007fb8b4c9a052 in QCoreApplication::sendEvent (this=0xe17e60, _mouse=<value optimized out>) at /usr/include/qt4/QtCore/qcoreapplication.h:213
#25 KHTMLView::mouseMoveEvent (this=0xe17e60, _mouse=<value optimized out>) at ../../khtml/khtmlview.cpp:1541
#26 0x00007fb8b811d218 in QWidget::event (this=0xe17e60, event=0x7fff1a3ed2c0) at kernel/qwidget.cpp:7539
#27 0x00007fb8b848592b in QFrame::event (this=0xe17e60, e=0x7fff1a3ed2c0) at widgets/qframe.cpp:559
#28 0x00007fb8b4c97095 in KHTMLView::widgetEvent (this=0xe17e60, e=0x7fb8b287a874) at ../../khtml/khtmlview.cpp:2338
#29 0x00007fb8b4c973af in KHTMLView::eventFilter (this=0xe17e60, o=0xe16ea0, e=0x7fff1a3ed2c0) at ../../khtml/khtmlview.cpp:2191
#30 0x00007fb8b8c52fb8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0xe16ea0, event=0x7fff1a3ed2c0) at kernel/qcoreapplication.cpp:726
#31 0x00007fb8b80ccfec in QApplicationPrivate::notify_helper (this=0x902e30, receiver=0xe16ea0, e=0x7fff1a3ed2c0) at kernel/qapplication.cpp:4061
#32 0x00007fb8b80d57ca in QApplication::notify (this=<value optimized out>, receiver=0xe16ea0, e=0x7fff1a3ed2c0) at kernel/qapplication.cpp:3767
#33 0x00007fb8ba2f3de6 in KApplication::notify (this=0x7fff1a3ef170, receiver=0xe16ea0, event=0x7fff1a3ed2c0) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x00007fb8b8c53c9c in QCoreApplication::notifyInternal (this=0x7fff1a3ef170, receiver=0xe16ea0, event=0x7fff1a3ed2c0) at kernel/qcoreapplication.cpp:610
#35 0x00007fb8b80d4a78 in QCoreApplication::sendSpontaneousEvent (receiver=0xe16ea0, event=0x7fff1a3ed2c0, alienWidget=0xe16ea0, nativeWidget=0xdd8370, buttonDown=<value optimized out>, 
    lastMouseReceiver=...) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#36 QApplicationPrivate::sendMouseEvent (receiver=0xe16ea0, event=0x7fff1a3ed2c0, alienWidget=0xe16ea0, nativeWidget=0xdd8370, buttonDown=<value optimized out>, lastMouseReceiver=...)
    at kernel/qapplication.cpp:2924
#37 0x00007fb8b813d659 in QETWidget::translateMouseEvent (this=0xdd8370, event=<value optimized out>) at kernel/qapplication_x11.cpp:4411
#38 0x00007fb8b813c40f in QApplication::x11ProcessEvent (this=0x7fff1a3ef170, event=0x7fff1a3eec90) at kernel/qapplication_x11.cpp:3552
#39 0x00007fb8b816476c in x11EventSourceDispatch (s=0x906830, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#40 0x00007fb8afbcb90e in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#41 0x00007fb8afbcf2c8 in ?? () from /lib/libglib-2.0.so.0
#42 0x00007fb8afbcf3f0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#43 0x00007fb8b8c7c39c in QEventDispatcherGlib::processEvents (this=0x8ceb40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#44 0x00007fb8b8163f1f in QGuiEventDispatcherGlib::processEvents (this=0x100000000, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#45 0x00007fb8b8c52562 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007fb8b8c52934 in QEventLoop::exec (this=0x7fff1a3eefc0, flags=...) at kernel/qeventloop.cpp:201
#47 0x00007fb8b8c54ba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#48 0x0000000000402fa9 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../kmail/main.cpp:146

Reported using DrKonqi
Comment 1 Björn Ruberg 2010-08-07 18:53:03 UTC
*** Bug 242693 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Lübking 2010-11-02 21:47:50 UTC
*** Bug 242693 has been marked as a duplicate of this bug. ***
Comment 3 Dario Andres 2010-11-18 17:19:02 UTC
[Comment from a bug triager]
Bug 128357 is indeed related to this bug. (in fact, several duplicates of bug 128357 have the same backtrace as this crash)
Comment 4 Dario Andres 2010-11-18 17:20:35 UTC
[Comment from a bug triager]
From bug 254146:
-- Information about the crash:
I clicked reply, typed a message and tried to send the message over my
gmx-account. After this, kmail crashed...

From bug 255621:
-- Information about the crash:
I had opened an email with a pdf attachment. After I finished reading it and
closed it, kmail crashed.

From bug 253290:
-- Information about the crash:
KMail and Kontact crashed while replying to an email and a PDF attachment was
opened. I don;t remember such a crash while no attachement was opened.
Comment 5 Dario Andres 2010-11-18 17:20:38 UTC
*** Bug 254146 has been marked as a duplicate of this bug. ***
Comment 6 Dario Andres 2010-11-18 17:20:42 UTC
*** Bug 255621 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2010-11-18 17:20:45 UTC
*** Bug 253290 has been marked as a duplicate of this bug. ***
Comment 8 Christophe Giboudeaux 2011-04-24 13:58:24 UTC
*** Bug 269765 has been marked as a duplicate of this bug. ***
Comment 9 Myriam Schweingruber 2012-08-19 11:08:05 UTC
Thank you for your report. Kmail1 is currently unmaintained and the code has changed sufficiently in Kmail2 so the backtraces are not really useful anymore. Should you experience the same crash in Kmail 4.8.5 or later, please open a new report for Kmail2. Thank you for your understanding