Bug 275137 - Random Segmentation Faults
Summary: Random Segmentation Faults
Status: RESOLVED DUPLICATE of bug 128357
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-07 19:14 UTC by Matt Edlefsen
Modified: 2011-12-07 18:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Edlefsen 2011-06-07 19:14:15 UTC
Application: kmail (1.13.6)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I had opened a compose window replying to an email and then switched to a different window to copy some information.  Not sure how quickly it happened buth within a few seconds KMail crashed with a segmentation fault.

I have had KMail segfault on me yesterday as well, but don't remember the circumstances.

There was no warning or anything, and I wasn't doing anything unusual.  I only have 2 accounts in KMail, a Gmail and my company email, both of which use IMAP.

I'm running a fresh installed of Kubuntu (natty) which has only been online for a few days.

Thanks

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fbe1d00f840 (LWP 13568))]

Thread 4 (Thread 0x7fbdfe5d3700 (LWP 13571)):
#0  0x00007fbe19f64f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbe11e6d104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbe11e6d9f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbe0909ec44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fbe11e943e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fbe17b21d8c in start_thread (arg=0x7fbdfe5d3700) at pthread_create.c:304
#6  0x00007fbe19f7204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fbdf4118700 (LWP 13574)):
#0  0x00007fbe11e6c0b3 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fbe11e6cf9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbe11e6d639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbe1a8c2446 in QEventDispatcherGlib::processEvents (this=0x1bb60f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fbe1a896882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbe1a896abc in QEventLoop::exec (this=0x7fbdf4117d10, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fbe1a7ad924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fbe1a878c2f in QInotifyFileSystemWatcherEngine::run (this=0x1f0e200) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fbe1a7b0175 in QThreadPrivate::start (arg=0x1f0e200) at thread/qthread_unix.cpp:320
#9  0x00007fbe17b21d8c in start_thread (arg=0x7fbdf4118700) at pthread_create.c:304
#10 0x00007fbe19f7204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fbdf3917700 (LWP 20463)):
#0  0x00007fbe19f64f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbe11e6d104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbe11e6d639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbe1a8c2446 in QEventDispatcherGlib::processEvents (this=0x41be4f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fbe1a896882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbe1a896abc in QEventLoop::exec (this=0x7fbdf3916d10, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fbe1a7ad924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fbe1a878c2f in QInotifyFileSystemWatcherEngine::run (this=0x4203040) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fbe1a7b0175 in QThreadPrivate::start (arg=0x4203040) at thread/qthread_unix.cpp:320
#9  0x00007fbe17b21d8c in start_thread (arg=0x7fbdf3917700) at pthread_create.c:304
#10 0x00007fbe19f7204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbe1d00f840 (LWP 13568)):
[KCrash Handler]
#6  0x00007fbe1b95ad1f in c_str (aDwBodyPart=0x3bbaee0, aPart=0x2c3ae38, withBody=true) at ../../mimelib/mimelib/string.h:618
#7  partId (aDwBodyPart=0x3bbaee0, aPart=0x2c3ae38, withBody=true) at ../../mimelib/mimelib/msgcmp.h:259
#8  KMMessage::bodyPart (aDwBodyPart=0x3bbaee0, aPart=0x2c3ae38, withBody=true) at ../../kmail/kmmessage.cpp:2677
#9  0x00007fbe1bc37981 in msgPart (this=<value optimized out>, url=..., w=<value optimized out>) at ../../kmail/partNode.h:103
#10 (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=<value optimized out>, url=..., w=<value optimized out>) at ../../kmail/urlhandlermanager.cpp:688
#11 0x00007fbe1bc3a894 in KMail::URLHandlerManager::statusBarMessage (this=0x1f9ed60, url=..., w=0x12fdf30) at ../../kmail/urlhandlermanager.cpp:355
#12 0x00007fbe1ba1bcf5 in KMReaderWin::slotUrlOn (this=0x12fdf30, aUrl=<value optimized out>) at ../../kmail/kmreaderwin.cpp:1966
#13 0x00007fbe1ba304ae in KMReaderWin::qt_metacall (this=0x12fdf30, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fff55d350f0) at ./kmreaderwin.moc:189
#14 0x00007fbe1a8ac5f8 in QMetaObject::activate (sender=0x1715df0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff55d350f0) at kernel/qobject.cpp:3287
#15 0x00007fbe16c879b2 in KHTMLPart::onURL (this=<value optimized out>, _t1=<value optimized out>) at ./khtml_part.moc:408
#16 0x00007fbe16c98a87 in KHTMLPart::overURL (this=0x1715df0, url=..., target=...) at ../../khtml/khtml_part.cpp:3511
#17 0x00007fbe16c9b73d in KHTMLPart::handleMouseMoveEventOver (this=0x1715df0, event=<value optimized out>) at ../../khtml/khtml_part.cpp:6481
#18 0x00007fbe16c9bc8b in KHTMLPart::khtmlMouseMoveEvent (this=0x1715df0, event=0x7fff55d36550) at ../../khtml/khtml_part.cpp:6529
#19 0x00007fbe1a8ab4fc in QObject::event (this=0x1715df0, e=<value optimized out>) at kernel/qobject.cpp:1257
#20 0x00007fbe1ad859e4 in QApplicationPrivate::notify_helper (this=0x12d50f0, receiver=0x1715df0, e=0x7fff55d36550) at kernel/qapplication.cpp:4462
#21 0x00007fbe1ad8a3aa in QApplication::notify (this=<value optimized out>, receiver=0x1715df0, e=0x7fff55d36550) at kernel/qapplication.cpp:4341
#22 0x00007fbe1ca31866 in KApplication::notify (this=0x7fff55d38210, receiver=0x1715df0, event=0x7fff55d36550) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x00007fbe1a89749c in QCoreApplication::notifyInternal (this=0x7fff55d38210, receiver=0x1715df0, event=0x7fff55d36550) at kernel/qcoreapplication.cpp:731
#24 0x00007fbe16c6d273 in sendEvent (this=0x18d1b50, _mouse=0x7fff55d37400) at /usr/include/qt4/QtCore/qcoreapplication.h:215
#25 KHTMLView::mouseMoveEvent (this=0x18d1b50, _mouse=0x7fff55d37400) at ../../khtml/khtmlview.cpp:1539
#26 0x00007fbe1add6cec in QWidget::event (this=0x18d1b50, event=0x7fff55d37400) at kernel/qwidget.cpp:8244
#27 0x00007fbe1b186a66 in QFrame::event (this=0x18d1b50, e=0x7fff55d37400) at widgets/qframe.cpp:557
#28 0x00007fbe16c6ef05 in KHTMLView::widgetEvent (this=0x18d1b50, e=<value optimized out>) at ../../khtml/khtmlview.cpp:2208
#29 0x00007fbe16c6e754 in KHTMLView::eventFilter (this=0x18d1b50, o=0x18dc4c0, e=0x7fff55d37400) at ../../khtml/khtmlview.cpp:2053
#30 0x00007fbe1a897627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x18dc4c0, event=0x7fff55d37400) at kernel/qcoreapplication.cpp:846
#31 0x00007fbe1ad859b1 in QApplicationPrivate::notify_helper (this=0x12d50f0, receiver=0x18dc4c0, e=0x7fff55d37400) at kernel/qapplication.cpp:4458
#32 0x00007fbe1ad8adb3 in QApplication::notify (this=<value optimized out>, receiver=0x18dc4c0, e=0x7fff55d37400) at kernel/qapplication.cpp:4023
#33 0x00007fbe1ca31866 in KApplication::notify (this=0x7fff55d38210, receiver=0x18dc4c0, event=0x7fff55d37400) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007fbe1a89749c in QCoreApplication::notifyInternal (this=0x7fff55d38210, receiver=0x18dc4c0, event=0x7fff55d37400) at kernel/qcoreapplication.cpp:731
#35 0x00007fbe1ad86a0d in sendEvent (receiver=0x18dc4c0, event=0x7fff55d37400, alienWidget=0x18dc4c0, nativeWidget=0x12fc200, buttonDown=0x7fbe1b866218, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QApplicationPrivate::sendMouseEvent (receiver=0x18dc4c0, event=0x7fff55d37400, alienWidget=0x18dc4c0, nativeWidget=0x12fc200, buttonDown=0x7fbe1b866218, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3122
#37 0x00007fbe1ae06600 in QETWidget::translateMouseEvent (this=0x12fc200, event=<value optimized out>) at kernel/qapplication_x11.cpp:4556
#38 0x00007fbe1ae0504a in QApplication::x11ProcessEvent (this=0x7fff55d38210, event=0x7fff55d37d50) at kernel/qapplication_x11.cpp:3678
#39 0x00007fbe1ae2d162 in x11EventSourceDispatch (s=0x12d3d50, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#40 0x00007fbe11e6cbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fbe11e6d3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fbe11e6d639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fbe1a8c23ef in QEventDispatcherGlib::processEvents (this=0x1242310, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#44 0x00007fbe1ae2cdfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007fbe1a896882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007fbe1a896abc in QEventLoop::exec (this=0x7fff55d38050, flags=...) at kernel/qeventloop.cpp:201
#47 0x00007fbe1a89aecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#48 0x0000000000403175 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../kmail/main.cpp:158

Reported using DrKonqi
Comment 1 Christophe Marin 2011-07-08 09:11:40 UTC

*** This bug has been marked as a duplicate of bug 128357 ***