Bug 235170 - Kontact crashes when double clicking to open a mail
Summary: Kontact crashes when double clicking to open a mail
Status: RESOLVED DUPLICATE of bug 128357
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-23 13:59 UTC by Stefan Kebekus
Modified: 2010-06-07 01:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Kebekus 2010-04-23 13:59:19 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2) "release 241"
Qt Version: 4.6.2
Operating System: Linux 2.6.31.12-0.2-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
I double clicked on an entry in the list of e-mail to open the e-mail in a separate window when the kontact application crashed.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x00007fd4f21e48c1 in c_str (this=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/mimelib/mimelib/string.h:618
#6  partId (this=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/mimelib/mimelib/msgcmp.h:259
#7  KMMessage::bodyPart (this=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/kmail/kmmessage.cpp:2677
#8  0x00007fd4f24fae11 in msgPart (this=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/kmail/partNode.h:103
#9  (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/kmail/urlhandlermanager.cpp:688
#10 0x00007fd4f24f9424 in KMail::URLHandlerManager::statusBarMessage (this=0x18d83e0, url=..., w=0x1313390) at /usr/src/debug/kdepim-4.4.2/kmail/urlhandlermanager.cpp:355
#11 0x00007fd4f22cdc44 in KMReaderWin::slotUrlOn (this=0x1313390, aUrl=<value optimized out>) at /usr/src/debug/kdepim-4.4.2/kmail/kmreaderwin.cpp:1966
#12 0x00007fd4f22cfc6e in KMReaderWin::qt_metacall (this=0x1313390, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff2bfa0600) at /usr/src/debug/kdepim-4.4.2/build/kmail/kmreaderwin.moc:189
#13 0x00007fd50ab7878f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#14 0x00007fd508b06432 in KHTMLPart::onURL (this=0x7fd509a51e60, _t1=<value optimized out>) at /usr/src/debug/kdelibs-4.4.2/build/khtml/khtml_part.moc:406
#15 0x00007fd508b282f5 in KHTMLPart::overURL (this=0x1325800, url=..., target=...) at /usr/src/debug/kdelibs-4.4.2/khtml/khtml_part.cpp:3523
#16 0x00007fd508b2a373 in KHTMLPart::handleMouseMoveEventOver (this=0x1325800, event=<value optimized out>) at /usr/src/debug/kdelibs-4.4.2/khtml/khtml_part.cpp:6360
#17 0x00007fd508b2a72b in KHTMLPart::khtmlMouseMoveEvent (this=0x1325800, event=0x7fff2bfa1a10) at /usr/src/debug/kdelibs-4.4.2/khtml/khtml_part.cpp:6408
#18 0x00007fd50ab75724 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#19 0x00007fd509f21e1c in QApplicationPrivate::notify_helper (this=0x6412b0, receiver=0x1325800, e=0x7fff2bfa1a10) at kernel/qapplication.cpp:4300
#20 0x00007fd509f283fb in QApplication::notify (this=0x7fff2bfa35c0, receiver=0x1325800, e=0x7fff2bfa1a10) at kernel/qapplication.cpp:4183
#21 0x00007fd50b4bf506 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#22 0x00007fd50ab6598c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#23 0x00007fd508affce4 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at /usr/include/QtCore/qcoreapplication.h:215
#24 KHTMLView::mouseMoveEvent (event=<value optimized out>, receiver=<value optimized out>) at /usr/src/debug/kdelibs-4.4.2/khtml/khtmlview.cpp:1551
#25 0x00007fd509f77dcf in QWidget::event (this=0x1325eb0, event=0x7fff2bfa28b0) at kernel/qwidget.cpp:7983
#26 0x00007fd50a31c606 in QFrame::event (this=0x1325eb0, e=0x7fff2bfa28b0) at widgets/qframe.cpp:557
#27 0x00007fd508afbcd5 in KHTMLView::widgetEvent (this=0x1325eb0, e=0x0) at /usr/src/debug/kdelibs-4.4.2/khtml/khtmlview.cpp:2362
#28 0x00007fd508afbfef in KHTMLView::eventFilter (this=0x1325eb0, o=0x132a5d0, e=0x7fff2bfa28b0) at /usr/src/debug/kdelibs-4.4.2/khtml/khtmlview.cpp:2207
#29 0x00007fd50ab64d97 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#30 0x00007fd509f21dec in QApplicationPrivate::notify_helper (this=0x6412b0, receiver=0x132a5d0, e=0x7fff2bfa28b0) at kernel/qapplication.cpp:4296
#31 0x00007fd509f28bdb in QApplication::notify (this=0x7fff2bfa35c0, receiver=0x132a5d0, e=0x7fff2bfa28b0) at kernel/qapplication.cpp:3865
#32 0x00007fd50b4bf506 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#33 0x00007fd50ab6598c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#34 0x00007fd509f27db6 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#35 QApplicationPrivate::sendMouseEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qapplication.cpp:2965
#36 0x00007fd509fa7765 in QETWidget::translateMouseEvent (this=0x1313bd0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4368
#37 0x00007fd509fa647a in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff2bfa31d0) at kernel/qapplication_x11.cpp:3501
#38 0x00007fd509fd0932 in x11EventSourceDispatch (s=0x652890, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#39 0x00007fd502592dee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#40 0x00007fd5025967b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#41 0x00007fd5025968e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#42 0x00007fd50ab8eeb3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#43 0x00007fd509fd051e in QGuiEventDispatcherGlib::processEvents (this=0x7fd509a51e60, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007fd50ab642a2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#45 0x00007fd50ab6467c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#46 0x00007fd50ab683cb in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#47 0x0000000000403ede in _start ()

Possible duplicates by query: bug 227352, bug 224453, bug 223647, bug 223510, bug 222366.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-07 01:30:46 UTC

*** This bug has been marked as a duplicate of bug 128357 ***