Bug 281470 - KMail crashes after closing an attachment on an email I have replied to
Summary: KMail crashes after closing an attachment on an email I have replied to
Status: RESOLVED DUPLICATE of bug 128357
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-06 11:16 UTC by Scott Neville
Modified: 2011-12-07 18:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Neville 2011-09-06 11:16:19 UTC
Application: kmail (1.13.6)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.5-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I had opened an email with the preview window, there was 5 attachments, I opened one of these and it was a PDF.  I then replied to the email with the attachment still open.  At this point the PDF viewer exhibited some strange behaviour (some of the pages went blank).  I closed the attachment then KDE crashed.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fce67a89760 (LWP 2756))]

Thread 2 (Thread 0x7fce459e4700 (LWP 8287)):
#0  0x00007fce6466d503 in poll () from /lib64/libc.so.6
#1  0x00007fce5c198114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fce5c198650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fce64fbb976 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007fce64f90052 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007fce64f90265 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007fce64ea51e4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007fce64f71968 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007fce64ea7a5e in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007fce6250da3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fce6467667d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fce67a89760 (LWP 2756)):
[KCrash Handler]
#6  0x00007fce66440282 in c_str (aDwBodyPart=0x2971ee0, aPart=0x26dd7f8, withBody=true) at /usr/src/debug/kdepim-4.4.10/mimelib/mimelib/string.h:618
#7  partId (aDwBodyPart=0x2971ee0, aPart=0x26dd7f8, withBody=true) at /usr/src/debug/kdepim-4.4.10/mimelib/mimelib/msgcmp.h:259
#8  KMMessage::bodyPart (aDwBodyPart=0x2971ee0, aPart=0x26dd7f8, withBody=true) at /usr/src/debug/kdepim-4.4.10/kmail/kmmessage.cpp:2677
#9  0x00007fce66708ca9 in msgPart (this=<value optimized out>, url=..., w=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/partNode.h:103
#10 (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=<value optimized out>, url=..., w=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/urlhandlermanager.cpp:688
#11 0x00007fce6670b7c4 in KMail::URLHandlerManager::statusBarMessage (this=0x1ed51c0, url=..., w=0x98a3a0) at /usr/src/debug/kdepim-4.4.10/kmail/urlhandlermanager.cpp:355
#12 0x00007fce664f8d84 in KMReaderWin::slotUrlOn (this=0x98a3a0, aUrl=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/kmreaderwin.cpp:1966
#13 0x00007fce6650d30e in KMReaderWin::qt_metacall (this=0x98a3a0, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fff3b96d480) at /usr/src/debug/kdepim-4.4.10/build/kmail/kmreaderwin.moc:189
#14 0x00007fce64fa5def in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#15 0x00007fce60c0bd22 in KHTMLPart::onURL(QString const&) () from /usr/lib64/libkhtml.so.5
#16 0x00007fce60c1cca5 in KHTMLPart::overURL(QString const&, QString const&, bool) () from /usr/lib64/libkhtml.so.5
#17 0x00007fce60c1f883 in KHTMLPart::handleMouseMoveEventOver(khtml::MouseMoveEvent*) () from /usr/lib64/libkhtml.so.5
#18 0x00007fce60c1fd9b in KHTMLPart::khtmlMouseMoveEvent(khtml::MouseMoveEvent*) () from /usr/lib64/libkhtml.so.5
#19 0x00007fce64fa4acc in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#20 0x00007fce6548ed14 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#21 0x00007fce6549722a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#22 0x00007fce674189e6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#23 0x00007fce64f90bfc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#24 0x00007fce60bf20af in KHTMLView::mouseMoveEvent(QMouseEvent*) () from /usr/lib64/libkhtml.so.5
#25 0x00007fce654e056c in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#26 0x00007fce65884906 in QFrame::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#27 0x00007fce60bf32f5 in KHTMLView::widgetEvent(QEvent*) () from /usr/lib64/libkhtml.so.5
#28 0x00007fce60bf3694 in KHTMLView::eventFilter(QObject*, QEvent*) () from /usr/lib64/libkhtml.so.5
#29 0x00007fce64f90d87 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#30 0x00007fce6548ece1 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#31 0x00007fce65497aac in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#32 0x00007fce674189e6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#33 0x00007fce64f90bfc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#34 0x00007fce6548fd25 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
#35 0x00007fce6550de08 in ?? () from /usr/lib64/libQtGui.so.4
#36 0x00007fce6550c4c9 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
#37 0x00007fce655340f2 in ?? () from /usr/lib64/libQtGui.so.4
#38 0x00007fce5c197bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#39 0x00007fce5c1983b0 in ?? () from /lib64/libglib-2.0.so.0
#40 0x00007fce5c198650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#41 0x00007fce64fbb91f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#42 0x00007fce65533d8e in ?? () from /usr/lib64/libQtGui.so.4
#43 0x00007fce64f90052 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#44 0x00007fce64f90265 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#45 0x00007fce64f946ab in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#46 0x00000000004033e8 in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/main.cpp:156

This bug may be a duplicate of or related to bug 128357.

Possible duplicates by query: bug 277125, bug 277106, bug 275905, bug 275137.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-09-06 11:45:44 UTC

*** This bug has been marked as a duplicate of bug 128357 ***