Bug 278181 - kmail/kontact crash answering mail
Summary: kmail/kontact crash answering mail
Status: RESOLVED DUPLICATE of bug 128357
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.10
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-21 07:31 UTC by Michael Monnerie
Modified: 2011-07-22 09:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Monnerie 2011-07-21 07:31:08 UTC
Application: kontact (4.4.10)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.39.1-zmi x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I had received an e-mail with a PDF attachment, clicked "reply" and later closed the e-mail as I didn't want to send it. All this on an IMAP account.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f9098509282 in c_str (aDwBodyPart=0x1fc55f10, aPart=0x1db19b88, withBody=true) at /usr/src/debug/kdepim-4.4.10/mimelib/mimelib/string.h:618
#7  partId (aDwBodyPart=0x1fc55f10, aPart=0x1db19b88, withBody=true) at /usr/src/debug/kdepim-4.4.10/mimelib/mimelib/msgcmp.h:259
#8  KMMessage::bodyPart (aDwBodyPart=0x1fc55f10, aPart=0x1db19b88, withBody=true) at /usr/src/debug/kdepim-4.4.10/kmail/kmmessage.cpp:2677
#9  0x00007f90987d1ca9 in msgPart (this=<value optimized out>, url=..., w=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/partNode.h:103
#10 (anonymous namespace)::AttachmentURLHandler::statusBarMessage (this=<value optimized out>, url=..., w=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/urlhandlermanager.cpp:688
#11 0x00007f90987d47c4 in KMail::URLHandlerManager::statusBarMessage (this=0x46cb6e0, url=..., w=0x2d00350) at /usr/src/debug/kdepim-4.4.10/kmail/urlhandlermanager.cpp:355
#12 0x00007f90985c1d84 in KMReaderWin::slotUrlOn (this=0x2d00350, aUrl=<value optimized out>) at /usr/src/debug/kdepim-4.4.10/kmail/kmreaderwin.cpp:1966
#13 0x00007f90985d630e in KMReaderWin::qt_metacall (this=0x2d00350, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fff031b9400) at /usr/src/debug/kdepim-4.4.10/build/kmail/kmreaderwin.moc:189
#14 0x00007f90b397adef in QMetaObject::activate (sender=0x2d0f170, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff031b9400) at kernel/qobject.cpp:3272
#15 0x00007f90b1b23d22 in KHTMLPart::onURL (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/build/khtml/khtml_part.moc:408
#16 0x00007f90b1b34ca5 in KHTMLPart::overURL (this=0x2d0f170, url=..., target=...) at /usr/src/debug/kdelibs-4.6.0/khtml/khtml_part.cpp:3511
#17 0x00007f90b1b37883 in KHTMLPart::handleMouseMoveEventOver (this=0x2d0f170, event=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/khtml/khtml_part.cpp:6481
#18 0x00007f90b1b37d9b in KHTMLPart::khtmlMouseMoveEvent (this=0x2d0f170, event=0x7fff031ba9b0) at /usr/src/debug/kdelibs-4.6.0/khtml/khtml_part.cpp:6529
#19 0x00007f90b3979acc in QObject::event (this=0x2d0f170, e=<value optimized out>) at kernel/qobject.cpp:1242
#20 0x00007f90b2d31d14 in QApplicationPrivate::notify_helper (this=0x23cf420, receiver=0x2d0f170, e=0x7fff031ba9b0) at kernel/qapplication.cpp:4445
#21 0x00007f90b2d3a22a in QApplication::notify (this=<value optimized out>, receiver=0x2d0f170, e=0x7fff031ba9b0) at kernel/qapplication.cpp:4324
#22 0x00007f90b42c69e6 in KApplication::notify (this=0x7fff031bc5b0, receiver=0x2d0f170, event=0x7fff031ba9b0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#23 0x00007f90b3965bfc in QCoreApplication::notifyInternal (this=0x7fff031bc5b0, receiver=0x2d0f170, event=0x7fff031ba9b0) at kernel/qcoreapplication.cpp:732
#24 0x00007f90b1b0a0af in sendEvent (this=0x2d130f0, _mouse=<value optimized out>) at /usr/include/QtCore/qcoreapplication.h:215
#25 KHTMLView::mouseMoveEvent (this=0x2d130f0, _mouse=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/khtml/khtmlview.cpp:1539
#26 0x00007f90b2d8356c in QWidget::event (this=0x2d130f0, event=0x7fff031bb880) at kernel/qwidget.cpp:8185
#27 0x00007f90b3127906 in QFrame::event (this=0x2d130f0, e=0x7fff031bb880) at widgets/qframe.cpp:557
#28 0x00007f90b1b0b2f5 in KHTMLView::widgetEvent (this=0x2d130f0, e=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/khtml/khtmlview.cpp:2208
#29 0x00007f90b1b0b694 in KHTMLView::eventFilter (this=0x2d130f0, o=0x2d16a20, e=0x7fff031bb880) at /usr/src/debug/kdelibs-4.6.0/khtml/khtmlview.cpp:2053
#30 0x00007f90b3965d87 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x2d16a20, event=0x7fff031bb880) at kernel/qcoreapplication.cpp:847
#31 0x00007f90b2d31ce1 in QApplicationPrivate::notify_helper (this=0x23cf420, receiver=0x2d16a20, e=0x7fff031bb880) at kernel/qapplication.cpp:4441
#32 0x00007f90b2d3aaac in QApplication::notify (this=<value optimized out>, receiver=0x2d16a20, e=0x7fff031bb880) at kernel/qapplication.cpp:4006
#33 0x00007f90b42c69e6 in KApplication::notify (this=0x7fff031bc5b0, receiver=0x2d16a20, event=0x7fff031bb880) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#34 0x00007f90b3965bfc in QCoreApplication::notifyInternal (this=0x7fff031bc5b0, receiver=0x2d16a20, event=0x7fff031bb880) at kernel/qcoreapplication.cpp:732
#35 0x00007f90b2d32d25 in sendEvent (receiver=0x2d16a20, event=0x7fff031bb880, alienWidget=0x2d16a20, nativeWidget=0x2d00bc0, buttonDown=0x7f90b3801178, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:215
#36 QApplicationPrivate::sendMouseEvent (receiver=0x2d16a20, event=0x7fff031bb880, alienWidget=0x2d16a20, nativeWidget=0x2d00bc0, buttonDown=0x7f90b3801178, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3105
#37 0x00007f90b2db0e08 in QETWidget::translateMouseEvent (this=0x2d00bc0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4438
#38 0x00007f90b2daf4c9 in QApplication::x11ProcessEvent (this=0x7fff031bc5b0, event=0x7fff031bc1e0) at kernel/qapplication_x11.cpp:3564
#39 0x00007f90b2dd70f2 in x11EventSourceDispatch (s=0x23ddb30, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#40 0x00007f90aad52bd3 in g_main_dispatch (context=0x23dc1e0) at gmain.c:2440
#41 g_main_context_dispatch (context=0x23dc1e0) at gmain.c:3013
#42 0x00007f90aad533b0 in g_main_context_iterate (context=0x23dc1e0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3091
#43 0x00007f90aad53650 in g_main_context_iteration (context=0x23dc1e0, may_block=1) at gmain.c:3154
#44 0x00007f90b399091f in QEventDispatcherGlib::processEvents (this=0x23a4390, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#45 0x00007f90b2dd6d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x00007f90b3965052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#47 0x00007f90b3965265 in QEventLoop::exec (this=0x7fff031bc500, flags=...) at kernel/qeventloop.cpp:201
#48 0x00007f90b39696ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#49 0x000000000040417e in _start ()

This bug may be a duplicate of or related to bug 128357.

Possible duplicates by query: bug 274519, bug 266177, bug 266084, bug 258213, bug 251390.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-07-22 09:15:10 UTC

*** This bug has been marked as a duplicate of bug 128357 ***