Bug 283657

Summary: Crash when closing
Product: [Frameworks and Libraries] kdelibs Reporter: Christoph Feck <cfeck>
Component: generalAssignee: Raphael Kubo da Costa <rakuco>
Status: RESOLVED FIXED    
Severity: crash CC: adomeij, daniel.pullen, dave, didier.garde, gackthugo, hrvoje.senjan, jakob, jakobwalz, keiliikuu, lutz, nucleo, r.pflaumer, rwklarin
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In: 4.7.4
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi

Description Christoph Feck 2011-10-09 17:14:44 UTC
Application: ark (2.18)
KDE Platform Version: 4.7.2 (4.7.2) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.1.0-rc7-3-desktop i686
Distribution: "openSUSE 12.1 Beta 1 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

I previewed an image inside a rar archive. Closing ark lead to this crash. The problem is probably caused by a recent commit to kdelibs.

The crash can be reproduced every time.

-- Backtrace:
Application: Ark (ark), signal: Segmentation fault
[KCrash Handler]
#7  0xb5c4a0f8 in typeinfo for QObjectUserData () from /local/qt4/lib/libQtCore.so.4
#8  0xb76c4e55 in KParts::StatusBarExtension::statusBar (this=0x83955b0) at /local/git/KDE/libs/kdelibs/kparts/statusbarextension.cpp:149
#9  0xb76c4b43 in KParts::StatusBarExtension::~StatusBarExtension (this=0x83955b0, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kparts/statusbarextension.cpp:99
#10 0xb76c4c5f in KParts::StatusBarExtension::~StatusBarExtension (this=0x83955b0, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kparts/statusbarextension.cpp:110
#11 0xb5adf2d8 in QObjectPrivate::deleteChildren (this=0x8326998) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:1955
#12 0xb5addb79 in QObject::~QObject (this=0x8308a68, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:946
#13 0xb76a58ff in KParts::Part::~Part (this=0x8308a68, __vtt_parm=0xb3737a28, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kparts/part.cpp:190
#14 0xb76a658d in KParts::ReadOnlyPart::~ReadOnlyPart (this=0x8308a68, __vtt_parm=0xb3737a24, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kparts/part.cpp:460
#15 0xb30c42ae in KHTMLImage::~KHTMLImage (this=0x8308a68, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /local/git/KDE/libs/kdelibs/khtml/khtmlimage.cpp:120
#16 0xb30c439f in KHTMLImage::~KHTMLImage (this=0x8308a68, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /local/git/KDE/libs/kdelibs/khtml/khtmlimage.cpp:133
#17 0xb76a6294 in KParts::Part::slotWidgetDestroyed (this=0x8308a68) at /local/git/KDE/libs/kdelibs/kparts/part.cpp:353
#18 0xb76a8f8c in KParts::Part::qt_metacall (this=0x8308a68, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfdcb108) at /local/build/KDE/libs/kdelibs/kparts/part.moc:82
#19 0xb76a910a in KParts::ReadOnlyPart::qt_metacall (this=0x8308a68, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfdcb108) at /local/build/KDE/libs/kdelibs/kparts/part.moc:168
#20 0xb30c5368 in KHTMLImage::qt_metacall (this=0x8308a68, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfdcb108) at /local/build/KDE/libs/kdelibs/khtml/khtmlimage.moc:125
#21 0xb5acf0ba in QMetaObject::metacall (object=0x8308a68, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfdcb108) at /local/git/Qt/qt/src/corelib/kernel/qmetaobject.cpp:237
#22 0xb5ae1f07 in QMetaObject::activate (sender=0x83083f8, m=0xb5c462f0, local_signal_index=0, argv=0xbfdcb108) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:3278
#23 0xb5ae3706 in QObject::destroyed (this=0x83083f8, _t1=0x83083f8) at .moc/debug-shared/moc_qobject.cpp:149
#24 0xb5add82e in QObject::~QObject (this=0x83083f8, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:843
#25 0xb618d47e in QWidget::~QWidget (this=0x83083f8, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/kernel/qwidget.cpp:1532
#26 0xb65fda17 in QFrame::~QFrame (this=0x83083f8, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/widgets/qframe.cpp:240
#27 0xb6ee5e07 in KHBox::~KHBox (this=0x83083f8, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kdeui/widgets/khbox.cpp:49
#28 0xb6f40169 in KVBox::~KVBox (this=0x83083f8, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kdeui/widgets/kvbox.cpp:27
#29 0xb6f401ab in KVBox::~KVBox (this=0x83083f8, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kdeui/widgets/kvbox.cpp:29
#30 0xb5adf2d8 in QObjectPrivate::deleteChildren (this=0x83242b0) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:1955
#31 0xb618d3d3 in QWidget::~QWidget (this=0x8325c30, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/kernel/qwidget.cpp:1655
#32 0xb65fda17 in QFrame::~QFrame (this=0x8325c30, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/widgets/qframe.cpp:240
#33 0xb6ee5e07 in KHBox::~KHBox (this=0x8325c30, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kdeui/widgets/khbox.cpp:49
#34 0xb6f40169 in KVBox::~KVBox (this=0x8325c30, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kdeui/widgets/kvbox.cpp:27
#35 0xb6f401ab in KVBox::~KVBox (this=0x8325c30, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kdeui/widgets/kvbox.cpp:29
#36 0xb5adf2d8 in QObjectPrivate::deleteChildren (this=0x831bb38) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:1955
#37 0xb618d3d3 in QWidget::~QWidget (this=0x83061f8, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/kernel/qwidget.cpp:1655
#38 0xb66e7e65 in QDialog::~QDialog (this=0x83061f8, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/dialogs/qdialog.cpp:318
#39 0xb6d67893 in KDialog::~KDialog (this=0x83061f8, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kdeui/dialogs/kdialog.cpp:201
#40 0xb3793f56 in ArkViewer::~ArkViewer (this=0x83061f8, __in_chrg=<optimized out>) at /local/git/KDE/utils/ark/part/arkviewer.cpp:56
#41 0xb3793f97 in ArkViewer::~ArkViewer (this=0x83061f8, __in_chrg=<optimized out>) at /local/git/KDE/utils/ark/part/arkviewer.cpp:58
#42 0xb5adf2d8 in QObjectPrivate::deleteChildren (this=0x81c0fa0) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:1955
#43 0xb618d3d3 in QWidget::~QWidget (this=0x81e3cd0, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/kernel/qwidget.cpp:1655
#44 0xb65fda17 in QFrame::~QFrame (this=0x81e3cd0, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/widgets/qframe.cpp:240
#45 0xb666df9e in QSplitter::~QSplitter (this=0x81e3cd0, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/widgets/qsplitter.cpp:1050
#46 0xb666dff9 in QSplitter::~QSplitter (this=0x81e3cd0, __in_chrg=<optimized out>) at /local/git/Qt/qt/src/gui/widgets/qsplitter.cpp:1056
#47 0xb76a58ba in KParts::Part::~Part (this=0x81ce080, __vtt_parm=0xb37af32c, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kparts/part.cpp:209
#48 0xb76a658d in KParts::ReadOnlyPart::~ReadOnlyPart (this=0x81ce080, __vtt_parm=0xb37af328, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kparts/part.cpp:460
#49 0xb76a7ab8 in KParts::ReadWritePart::~ReadWritePart (this=0x81ce080, __vtt_parm=0xb37af324, __in_chrg=<optimized out>) at /local/git/KDE/libs/kdelibs/kparts/part.cpp:773
#50 0xb3786c8c in Ark::Part::~Part (this=0x81ce080, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /local/git/KDE/utils/ark/part/part.cpp:131
#51 0xb3786cff in Ark::Part::~Part (this=0x81ce080, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /local/git/KDE/utils/ark/part/part.cpp:139
#52 0x08055ec8 in MainWindow::~MainWindow (this=0x8181ae8, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /local/git/KDE/utils/ark/app/mainwindow.cpp:72
#53 0x08055f8d in MainWindow::~MainWindow (this=0x8181ae8, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /local/git/KDE/utils/ark/app/mainwindow.cpp:74
#54 0xb5ae33ad in qDeleteInEventHandler (o=0x8181ae8) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:3986
#55 0xb5ade0a4 in QObject::event (this=0x8181ae8, e=0x8384540) at /local/git/Qt/qt/src/corelib/kernel/qobject.cpp:1200
#56 0xb619ed5e in QWidget::event (this=0x8181ae8, event=0x8384540) at /local/git/Qt/qt/src/gui/kernel/qwidget.cpp:8758
#57 0xb661fbfc in QMainWindow::event (this=0x8181ae8, event=0x8384540) at /local/git/Qt/qt/src/gui/widgets/qmainwindow.cpp:1478
#58 0xb6efe178 in KMainWindow::event (this=0x8181ae8, ev=0x8384540) at /local/git/KDE/libs/kdelibs/kdeui/widgets/kmainwindow.cpp:1084
#59 0xb6f45103 in KXmlGuiWindow::event (this=0x8181ae8, ev=0x8384540) at /local/git/KDE/libs/kdelibs/kdeui/xmlgui/kxmlguiwindow.cpp:126
#60 0xb613e2b0 in QApplicationPrivate::notify_helper (this=0x8080740, receiver=0x8181ae8, e=0x8384540) at /local/git/Qt/qt/src/gui/kernel/qapplication.cpp:4481
#61 0xb613dfeb in QApplication::notify (this=0xbfdcc324, receiver=0x8181ae8, e=0x8384540) at /local/git/Qt/qt/src/gui/kernel/qapplication.cpp:4446
#62 0xb6e1e22a in KApplication::notify (this=0xbfdcc324, receiver=0x8181ae8, event=0x8384540) at /local/git/KDE/libs/kdelibs/kdeui/kernel/kapplication.cpp:311
#63 0xb5ac7b2e in QCoreApplication::notifyInternal (this=0xbfdcc324, receiver=0x8181ae8, event=0x8384540) at /local/git/Qt/qt/src/corelib/kernel/qcoreapplication.cpp:787
#64 0xb5acb37f in QCoreApplication::sendEvent (receiver=0x8181ae8, event=0x8384540) at ../../include/QtCore/../../../../git/Qt/qt/src/corelib/kernel/qcoreapplication.h:215
#65 0xb5ac8bc0 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8066998) at /local/git/Qt/qt/src/corelib/kernel/qcoreapplication.cpp:1428
#66 0xb5ac887d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at /local/git/Qt/qt/src/corelib/kernel/qcoreapplication.cpp:1321
#67 0xb5afc392 in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../../../git/Qt/qt/src/corelib/kernel/qcoreapplication.h:220
#68 0xb5afb510 in postEventSourceDispatch (s=0x807fe78) at /local/git/Qt/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:277
#69 0xb4daaddf in g_main_dispatch (context=0x8082878) at gmain.c:2441
#70 g_main_context_dispatch (context=0x8082878) at gmain.c:3011
#71 0xb4dab510 in g_main_context_iterate (context=0x8082878, block=-1260675328, dispatch=1, self=<optimized out>) at gmain.c:3089
#72 0xb4dab7aa in g_main_context_iteration (context=0x8082878, may_block=1) at gmain.c:3152
#73 0xb5afbcc2 in QEventDispatcherGlib::processEvents (this=0x8080360, flags=...) at /local/git/Qt/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:422
#74 0xb6205f42 in QGuiEventDispatcherGlib::processEvents (this=0x8080360, flags=...) at /local/git/Qt/qt/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#75 0xb5ac58e9 in QEventLoop::processEvents (this=0xbfdcc2ac, flags=...) at /local/git/Qt/qt/src/corelib/kernel/qeventloop.cpp:149
#76 0xb5ac5a29 in QEventLoop::exec (this=0xbfdcc2ac, flags=...) at /local/git/Qt/qt/src/corelib/kernel/qeventloop.cpp:201
#77 0xb5ac8214 in QCoreApplication::exec () at /local/git/Qt/qt/src/corelib/kernel/qcoreapplication.cpp:1064
#78 0xb613b7f0 in QApplication::exec () at /local/git/Qt/qt/src/gui/kernel/qapplication.cpp:3755
#79 0x0805581d in main (argc=4, argv=0xbfdcc724) at /local/git/KDE/utils/ark/app/main.cpp:209

Reported using DrKonqi
Comment 1 Hrvoje Senjan 2011-11-09 12:54:36 UTC
Created attachment 65440 [details]
New crash information added by DrKonqi

ark (2.18) on KDE Platform 4.7.3 (4.7.3) "release 1" using Qt 4.8.0

- What I was doing when the application crashed:

Same as the original reporter. It happens almost every timr.

-- Backtrace (Reduced):
#7  0x00007fe7cab6784e in KParts::StatusBarExtension::statusBar (this=0xb0b570) at /usr/src/debug/kdelibs-4.7.46/kparts/statusbarextension.cpp:149
#8  0x00007fe7cab67d54 in KParts::StatusBarExtension::~StatusBarExtension (this=0xb0b570, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.46/kparts/statusbarextension.cpp:99
#9  0x00007fe7cab68109 in KParts::StatusBarExtension::~StatusBarExtension (this=0xb0b570, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.46/kparts/statusbarextension.cpp:110
#10 0x00007fe7c8b01265 in QObjectPrivate::deleteChildren (this=0xaf1080) at kernel/qobject.cpp:1908
#11 0x00007fe7c8b074cc in QObject::~QObject (this=0xadd6d0, __in_chrg=<optimized out>) at kernel/qobject.cpp:927
Comment 2 András Manţia 2011-11-10 09:40:29 UTC
Git commit 999eac446a49e6126df04aa8717f95e6aef136fc by Andras Mantia.
Committed on 10/11/2011 at 10:40.
Pushed by amantia into branch 'KDE/4.7'.

Don't try to access the parent() from the destructor, fixes crash on destruction.
BUG: 283657
REVIEW: 103098

M  +1    -1    kparts/statusbarextension.cpp

http://commits.kde.org/kdelibs/999eac446a49e6126df04aa8717f95e6aef136fc
Comment 3 Christoph Feck 2011-11-10 12:19:03 UTC
*** Bug 286124 has been marked as a duplicate of this bug. ***
Comment 4 Raphael Kubo da Costa 2011-11-24 12:23:56 UTC
*** Bug 287350 has been marked as a duplicate of this bug. ***
Comment 5 Rex Dieter 2011-11-26 15:48:34 UTC
*** Bug 286307 has been marked as a duplicate of this bug. ***
Comment 6 Raphael Kubo da Costa 2011-12-02 03:46:03 UTC
*** Bug 288023 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2011-12-08 10:48:08 UTC
*** Bug 288460 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2011-12-22 00:06:48 UTC
*** Bug 289546 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2012-01-01 17:08:26 UTC
*** Bug 290329 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2012-01-04 09:29:52 UTC
*** Bug 287007 has been marked as a duplicate of this bug. ***
Comment 11 Christophe Giboudeaux 2012-01-05 09:20:19 UTC
*** Bug 290669 has been marked as a duplicate of this bug. ***
Comment 12 daniel.pullen 2012-01-20 15:26:19 UTC
Created attachment 68039 [details]
New crash information added by DrKonqi

ark (2.17) on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

Similar to other crashes, I opened an archive inside Ark. After previewing an item inside the archive, Ark will crash when I attempt to close it. This occurs with both zip and rar archives.

The crash report shows this is fixed. Unfortunately, Kubuntu 11.10 does not have KDE 4.7.4 available but only 4.7.3. I am assuming this is when the fix was implemented.

-- Backtrace (Reduced):
#7  0x00007fa875f4f7ee in KParts::StatusBarExtension::statusBar (this=0x198cd90) at ../../kparts/statusbarextension.cpp:149
#8  0x00007fa875f4fcf4 in KParts::StatusBarExtension::~StatusBarExtension (this=0x198cd90, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:99
#9  0x00007fa875f500a9 in KParts::StatusBarExtension::~StatusBarExtension (this=0x198cd90, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:110
#10 0x00007fa873f2ed75 in QObjectPrivate::deleteChildren (this=0x198d600) at kernel/qobject.cpp:1955
#11 0x00007fa873f34349 in QObject::~QObject (this=0x1991790, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
Comment 13 Jekyll Wu 2012-02-25 00:52:51 UTC
*** Bug 294783 has been marked as a duplicate of this bug. ***
Comment 14 Jekyll Wu 2012-03-13 11:46:27 UTC
*** Bug 295910 has been marked as a duplicate of this bug. ***
Comment 15 Jekyll Wu 2012-05-31 19:23:48 UTC
*** Bug 291111 has been marked as a duplicate of this bug. ***
Comment 16 Jekyll Wu 2012-07-03 13:06:12 UTC
*** Bug 302283 has been marked as a duplicate of this bug. ***
Comment 17 Jekyll Wu 2012-07-03 13:07:35 UTC
*** Bug 302397 has been marked as a duplicate of this bug. ***