Bug 287350 - ARC Crashes on Close - latest version
Summary: ARC Crashes on Close - latest version
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-23 09:02 UTC by Dave Gordon
Modified: 2011-11-24 12:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Gordon 2011-11-23 09:02:38 UTC
Application: ark (2.17)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.1-2.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed: 
I opened an archive .zip - it contained a movie  .mwv After I watched the movie - I closed the player ... and then closed ARC which is when the application crashed.

ARC was just updated and the computer had not been restarted, This happens almost every single time; there is no reason why it does not occur every time as far as I can see.

-- Backtrace:
Application: Ark (ark), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x000000388fe3f6de in KParts::StatusBarExtension::statusBar (this=0x181c780) at /usr/src/debug/kdelibs-4.7.3/kparts/statusbarextension.cpp:149
#8  0x000000388fe3f774 in KParts::StatusBarExtension::~StatusBarExtension (this=0x181c780, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.3/kparts/statusbarextension.cpp:99
#9  0x000000388fe3fb19 in KParts::StatusBarExtension::~StatusBarExtension (this=0x181c780, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.3/kparts/statusbarextension.cpp:110
#10 0x0000003880189e95 in QObjectPrivate::deleteChildren (this=0x1813860) at kernel/qobject.cpp:1907
#11 0x000000388019013c in QObject::~QObject (this=0x181ce40, __in_chrg=<optimized out>) at kernel/qobject.cpp:926
#12 0x000000388fe24688 in KParts::Part::~Part (this=0x181ce40, __vtt_parm=0x7f1e28890af0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.3/kparts/part.cpp:190
#13 0x00007f1e2868bd3c in ~Part (this=0x181ce40, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdemultimedia-4.7.3/dragonplayer/src/app/part.h:40
#14 Dragon::Part::~Part (this=0x181ce40, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdemultimedia-4.7.3/dragonplayer/src/app/part.h:40
#15 0x000000388fe248f0 in KParts::Part::slotWidgetDestroyed (this=0x181ce40) at /usr/src/debug/kdelibs-4.7.3/kparts/part.cpp:353
#16 0x000000388018b7d1 in QMetaObject::activate (sender=0x1482cd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe856e5f0) at kernel/qobject.cpp:3546
#17 0x000000388018c17f in QObject::destroyed (this=<optimized out>, _t1=0x1482cd0) at .moc/release-shared/moc_qobject.cpp:149
#18 0x000000388018fc2e in QObject::~QObject (this=0x1482cd0, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#19 0x0000003882e1446d in QWidget::~QWidget (this=0x1482cd0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1550
#20 0x0000003882e146a9 in QWidget::~QWidget (this=0x1482cd0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1699
#21 0x0000003880189e95 in QObjectPrivate::deleteChildren (this=0x178b210) at kernel/qobject.cpp:1907
#22 0x0000003882e143d0 in QWidget::~QWidget (this=0x17fe990, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1675
#23 0x0000003884946929 in KVBox::~KVBox (this=0x17fe990, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.3/kdeui/widgets/kvbox.cpp:29
#24 0x0000003880189e95 in QObjectPrivate::deleteChildren (this=0x17fd490) at kernel/qobject.cpp:1907
#25 0x0000003882e143d0 in QWidget::~QWidget (this=0x17593c0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1675
#26 0x00007f1e2a351bb9 in ArkViewer::~ArkViewer (this=0x17593c0, __in_chrg=<optimized out>) at /usr/src/debug/kdeutils-4.7.3/ark/part/arkviewer.cpp:58
#27 0x0000003880189e95 in QObjectPrivate::deleteChildren (this=0x1565e60) at kernel/qobject.cpp:1907
#28 0x0000003882e143d0 in QWidget::~QWidget (this=0x1562da0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1675
#29 0x0000003883229739 in QSplitter::~QSplitter (this=0x1562da0, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1056
#30 0x000000388fe24663 in KParts::Part::~Part (this=0x1562980, __vtt_parm=0x7f1e2a566c78, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.3/kparts/part.cpp:209
#31 0x00007f1e2a3465df in Ark::Part::~Part (this=0x1562980, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.3/ark/part/part.cpp:131
#32 0x00007f1e2a346639 in Ark::Part::~Part (this=0x1562980, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.3/ark/part/part.cpp:139
#33 0x000000000040ddfd in MainWindow::~MainWindow (this=0x14a22f0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.3/ark/app/mainwindow.cpp:72
#34 0x000000000040dea9 in MainWindow::~MainWindow (this=0x14a22f0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.3/ark/app/mainwindow.cpp:74
#35 0x0000003880190a18 in QObject::event (this=0x14a22f0, e=<optimized out>) at kernel/qobject.cpp:1175
#36 0x0000003882e197bb in QWidget::event (this=0x14a22f0, event=0x1607600) at kernel/qwidget.cpp:8809
#37 0x00000038831eb25b in QMainWindow::event (this=0x14a22f0, event=0x1607600) at widgets/qmainwindow.cpp:1478
#38 0x000000388494bc98 in KXmlGuiWindow::event (this=0x14a22f0, ev=0x1607600) at /usr/src/debug/kdelibs-4.7.3/kdeui/xmlgui/kxmlguiwindow.cpp:126
#39 0x0000003882dc96f4 in notify_helper (e=0x1607600, receiver=0x14a22f0, this=0x1127b10) at kernel/qapplication.cpp:4518
#40 QApplicationPrivate::notify_helper (this=0x1127b10, receiver=0x14a22f0, e=0x1607600) at kernel/qapplication.cpp:4490
#41 0x0000003882dce573 in QApplication::notify (this=0x7fffe856f7a0, receiver=0x14a22f0, e=0x1607600) at kernel/qapplication.cpp:4379
#42 0x0000003884850396 in KApplication::notify (this=0x7fffe856f7a0, receiver=0x14a22f0, event=0x1607600) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#43 0x0000003880177b4c in QCoreApplication::notifyInternal (this=0x7fffe856f7a0, receiver=0x14a22f0, event=0x1607600) at kernel/qcoreapplication.cpp:876
#44 0x000000388017b5da in sendEvent (event=0x1607600, receiver=0x14a22f0) at kernel/qcoreapplication.h:231
#45 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1104070) at kernel/qcoreapplication.cpp:1500
#46 0x00000038801a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#47 postEventSourceDispatch (s=0x112b400) at kernel/qeventdispatcher_glib.cpp:279
#48 0x0000003877844a7d in g_main_dispatch (context=0x112b950) at gmain.c:2425
#49 g_main_context_dispatch (context=0x112b950) at gmain.c:2995
#50 0x0000003877845278 in g_main_context_iterate (context=0x112b950, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#51 0x000000387784544c in g_main_context_iteration (context=0x112b950, may_block=1) at gmain.c:3136
#52 0x00000038801a682f in QEventDispatcherGlib::processEvents (this=0x1105530, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#53 0x0000003882e6c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#54 0x0000003880176c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#55 0x0000003880176ed7 in QEventLoop::exec (this=0x7fffe856f730, flags=...) at kernel/qeventloop.cpp:204
#56 0x000000388017b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#57 0x000000000040a7c8 in main (argc=4, argv=0x7fffe85703f8) at /usr/src/debug/kdeutils-4.7.3/ark/app/main.cpp:209

Possible duplicates by query: bug 287007, bug 283657.

Reported using DrKonqi
Comment 1 Raphael Kubo da Costa 2011-11-24 12:23:56 UTC

*** This bug has been marked as a duplicate of bug 283657 ***