Bug 288023 - Ark 12.1 crash when closed
Summary: Ark 12.1 crash when closed
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-01 22:53 UTC by Anders
Modified: 2011-12-02 03:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anders 2011-12-01 22:53:32 UTC
Application: ark (2.17)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-default x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
Closing one of three (the first) Ark instances. The other 2 instances are stil activ on the desktop

-- Backtrace:
Application: Ark (ark), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9da039e760 (LWP 11081))]

Thread 7 (Thread 0x7f9d8cf41700 (LWP 11089)):
#0  0x00007f9d9ae4be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d86e249dc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9d877db200) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00007f9d86e24b09 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007f9d9ae47f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9d9d38a53d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f9d84b52700 (LWP 11090)):
#0  0x00007fff29f4f8de in ?? ()
#1  0x00007f9d977bbe91 in clock_gettime () from /lib64/librt.so.1
#2  0x00007f9d9da15114 in do_gettime (frac=0x7f9d84b51bf8, sec=0x7f9d84b51bf0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f9d9dad6d1d in QTimerInfoList::updateCurrentTime (this=0x7f9d88011e40) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007f9d9dad69a1 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:150
#6  timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:144
#7  0x00007f9d999e7264 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#8  0x00007f9d999e7ab2 in ?? () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f9d999e7f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f9d9dad6576 in QEventDispatcherGlib::processEvents (this=0x7f9d884663a0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00007f9d9daaaa22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f9d9daaac1f in QEventLoop::exec (this=0x7f9d84b51e20, flags=...) at kernel/qeventloop.cpp:201
#13 0x00007f9d9d9c25df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#14 0x00007f9d9d9c5025 in QThreadPrivate::start (arg=0xa4d240) at thread/qthread_unix.cpp:331
#15 0x00007f9d9ae47f05 in start_thread () from /lib64/libpthread.so.0
#16 0x00007f9d9d38a53d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f9d78d81700 (LWP 11094)):
#0  0x00007f9d9ae4be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d78da6c01 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007f9d9ae47f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f9d9d38a53d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f9d78580700 (LWP 11095)):
#0  0x00007f9d9ae4be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d78da6c01 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007f9d9ae47f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f9d9d38a53d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f9d77d7f700 (LWP 11096)):
#0  0x00007f9d9ae4be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d78da6c01 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007f9d9ae47f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f9d9d38a53d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9d35dfe700 (LWP 11496)):
#0  0x00007fff29f4f8de in ?? ()
#1  0x00007f9d977bbe91 in clock_gettime () from /lib64/librt.so.1
#2  0x00007f9d9da15114 in do_gettime (frac=0x7f9d35dfdb78, sec=0x7f9d35dfdb70) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f9d9dad6d1d in QTimerInfoList::updateCurrentTime (this=0x7f9d30001c80) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007f9d9dad7053 in QTimerInfoList::timerWait (this=0x7f9d30001c80, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007f9d9dad5abc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f9d35dfdc5c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f9d9dad5b65 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f9d999e6b22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f9d999e792d in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f9d999e7f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007f9d9dad6576 in QEventDispatcherGlib::processEvents (this=0x7f9d300053c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007f9d9daaaa22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f9d9daaac1f in QEventLoop::exec (this=0x7f9d35dfddf0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007f9d9d9c25df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007f9d9da8daef in QInotifyFileSystemWatcherEngine::run (this=0x1285400) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f9d9d9c5025 in QThreadPrivate::start (arg=0x1285400) at thread/qthread_unix.cpp:331
#17 0x00007f9d9ae47f05 in start_thread () from /lib64/libpthread.so.0
#18 0x00007f9d9d38a53d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9da039e760 (LWP 11081)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f9d9fac984e in KParts::StatusBarExtension::statusBar (this=0xe5cde0) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:149
#8  0x00007f9d9fac9d54 in KParts::StatusBarExtension::~StatusBarExtension (this=0xe5cde0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:99
#9  0x00007f9d9faca109 in KParts::StatusBarExtension::~StatusBarExtension (this=0xe5cde0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:110
#10 0x00007f9d9dabd455 in QObjectPrivate::deleteChildren (this=0xfb2f60) at kernel/qobject.cpp:1964
#11 0x00007f9d9dac29f9 in QObject::~QObject (this=0xfb2780, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007f9d9faaea98 in KParts::Part::~Part (this=0xfb2780, __vtt_parm=0x7f9d8c73d8f0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:190
#13 0x00007f9d8c505427 in ?? () from /usr/lib64/kde4/kwebkitpart.so
#14 0x00007f9d8c505469 in ?? () from /usr/lib64/kde4/kwebkitpart.so
#15 0x00007f9d9faaed00 in KParts::Part::slotWidgetDestroyed (this=0xfb2780) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:353
#16 0x00007f9d9fab02e4 in KParts::Part::qt_metacall (this=0xfb2780, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff29ed8a50) at /usr/src/debug/kdelibs-4.7.2/build/kparts/part.moc:82
#17 0x00007f9d9fab1ec5 in KParts::ReadOnlyPart::qt_metacall (this=0xfb2780, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff29ed8a50) at /usr/src/debug/kdelibs-4.7.2/build/kparts/part.moc:168
#18 0x00007f9d8c504ae5 in ?? () from /usr/lib64/kde4/kwebkitpart.so
#19 0x00007f9d9dabe59a in QMetaObject::activate (sender=0xfbd480, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff29ed8a50) at kernel/qobject.cpp:3287
#20 0x00007f9d9dabea4f in QObject::destroyed (this=<optimized out>, _t1=0xfbd480) at .moc/release-shared/moc_qobject.cpp:149
#21 0x00007f9d9dac25e7 in QObject::~QObject (this=0xfbd480, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#22 0x00007f9d9e4d5731 in QWidget::~QWidget (this=0xfbd480, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#23 0x00007f9d9e4d5949 in QWidget::~QWidget (this=0xfbd480, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#24 0x00007f9d9dabd455 in QObjectPrivate::deleteChildren (this=0xf86f90) at kernel/qobject.cpp:1964
#25 0x00007f9d9e4d56a3 in QWidget::~QWidget (this=0xf858e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#26 0x00007f9d9f294379 in KVBox::~KVBox (this=0xf858e0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kdeui/widgets/kvbox.cpp:29
#27 0x00007f9d9dabd455 in QObjectPrivate::deleteChildren (this=0xf88500) at kernel/qobject.cpp:1964
#28 0x00007f9d9e4d56a3 in QWidget::~QWidget (this=0xfafde0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#29 0x00007f9d905a6c29 in ArkViewer::~ArkViewer (this=0xfafde0, __in_chrg=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/part/arkviewer.cpp:58
#30 0x00007f9d9dabd455 in QObjectPrivate::deleteChildren (this=0x8c1560) at kernel/qobject.cpp:1964
#31 0x00007f9d9e4d56a3 in QWidget::~QWidget (this=0x8a18f0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#32 0x00007f9d9e8d5f29 in QSplitter::~QSplitter (this=0x8a18f0, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1056
#33 0x00007f9d9faaea73 in KParts::Part::~Part (this=0x880740, __vtt_parm=0x7f9d907bbd18, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:209
#34 0x00007f9d9059b9cf in Ark::Part::~Part (this=0x880740, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/part/part.cpp:131
#35 0x00007f9d9059ba29 in Ark::Part::~Part (this=0x880740, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/part/part.cpp:139
#36 0x000000000040e6fd in MainWindow::~MainWindow (this=0x78c450, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/app/mainwindow.cpp:72
#37 0x000000000040e7a9 in MainWindow::~MainWindow (this=0x78c450, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/app/mainwindow.cpp:74
#38 0x00007f9d9dac2178 in QObject::event (this=0x78c450, e=<optimized out>) at kernel/qobject.cpp:1209
#39 0x00007f9d9e4d9cfb in QWidget::event (this=0x78c450, event=0x11dd960) at kernel/qwidget.cpp:8754
#40 0x00007f9d9e897fab in QMainWindow::event (this=0x78c450, event=0x11dd960) at widgets/qmainwindow.cpp:1478
#41 0x00007f9d9f2996b8 in KXmlGuiWindow::event (this=0x78c450, ev=0x11dd960) at /usr/src/debug/kdelibs-4.7.2/kdeui/xmlgui/kxmlguiwindow.cpp:126
#42 0x00007f9d9e489be4 in notify_helper (e=0x11dd960, receiver=0x78c450, this=0x63f5b0) at kernel/qapplication.cpp:4481
#43 QApplicationPrivate::notify_helper (this=0x63f5b0, receiver=0x78c450, e=0x11dd960) at kernel/qapplication.cpp:4453
#44 0x00007f9d9e48ea71 in QApplication::notify (this=0x7fff29ed9bf0, receiver=0x78c450, e=0x11dd960) at kernel/qapplication.cpp:4360
#45 0x00007f9d9f19ce36 in KApplication::notify (this=0x7fff29ed9bf0, receiver=0x78c450, event=0x11dd960) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#46 0x00007f9d9daab81c in QCoreApplication::notifyInternal (this=0x7fff29ed9bf0, receiver=0x78c450, event=0x11dd960) at kernel/qcoreapplication.cpp:787
#47 0x00007f9d9daaebf8 in sendEvent (event=0x11dd960, receiver=0x78c450) at kernel/qcoreapplication.h:215
#48 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x61aad0) at kernel/qcoreapplication.cpp:1428
#49 0x00007f9d9dad60b3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#50 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#51 0x00007f9d999e758d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#52 0x00007f9d999e7d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#53 0x00007f9d999e7f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#54 0x00007f9d9dad650f in QEventDispatcherGlib::processEvents (this=0x61a2e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#55 0x00007f9d9e52cf2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#56 0x00007f9d9daaaa22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#57 0x00007f9d9daaac1f in QEventLoop::exec (this=0x7fff29ed9b80, flags=...) at kernel/qeventloop.cpp:201
#58 0x00007f9d9daaede7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#59 0x000000000040b0a8 in main (argc=4, argv=0x7fff29eda848) at /usr/src/debug/kdeutils-4.7.2/ark/app/main.cpp:209

Possible duplicates by query: bug 287350, bug 287007, bug 283657.

Reported using DrKonqi
Comment 1 Raphael Kubo da Costa 2011-12-02 03:46:03 UTC

*** This bug has been marked as a duplicate of bug 283657 ***