Bug 294783 - ark chrashes when closing
Summary: ark chrashes when closing
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-25 00:44 UTC by lueichmeyer
Modified: 2012-02-25 00:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lueichmeyer 2012-02-25 00:44:31 UTC
Application: ark (2.17)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I was reading the sauerbraten install.txt file. I have six desktops open, 12 browser windows

-- Backtrace:
Application: Ark (ark), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f61bf1f6760 (LWP 4482))]

Thread 3 (Thread 0x7f61ab6e6700 (LWP 4486)):
#0  0x00007f61b9ca3e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f61aa08e9dc in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f61aa08eb09 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f61b9c9ff05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f61bc1e263d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f61a3b13700 (LWP 4487)):
#0  0x00007f61bc1d9523 in poll () from /lib64/libc.so.6
#1  0x00007f61b883fa98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f61b883ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f61bc92e586 in QEventDispatcherGlib::processEvents (this=0x7f61a4519000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f61bc902a32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f61bc902c2f in QEventLoop::exec (this=0x7f61a3b12e20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f61bc81a5df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f61bc81d025 in QThreadPrivate::start (arg=0xdf5c20) at thread/qthread_unix.cpp:331
#8  0x00007f61b9c9ff05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f61bc1e263d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f61bf1f6760 (LWP 4482)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f61be92184e in KParts::StatusBarExtension::statusBar (this=0xb47580) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:149
#8  0x00007f61be921d54 in KParts::StatusBarExtension::~StatusBarExtension (this=0xb47580, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:99
#9  0x00007f61be922109 in KParts::StatusBarExtension::~StatusBarExtension (this=0xb47580, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:110
#10 0x00007f61bc915465 in QObjectPrivate::deleteChildren (this=0xe57570) at kernel/qobject.cpp:1964
#11 0x00007f61bc91aa09 in QObject::~QObject (this=0xe573c0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007f61be906a98 in KParts::Part::~Part (this=0xe573c0, __vtt_parm=0x7f61aaee28f0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:190
#13 0x00007f61aacaa427 in KWebKitPart::~KWebKitPart (this=0xe573c0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kwebkitpart-1.2.0git20111019/src/kwebkitpart.cpp:182
#14 0x00007f61aacaa469 in KWebKitPart::~KWebKitPart (this=0xe573c0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kwebkitpart-1.2.0git20111019/src/kwebkitpart.cpp:184
#15 0x00007f61be906d00 in KParts::Part::slotWidgetDestroyed (this=0xe573c0) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:353
#16 0x00007f61be9082e4 in KParts::Part::qt_metacall (this=0xe573c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd8939ff0) at /usr/src/debug/kdelibs-4.7.2/build/kparts/part.moc:82
#17 0x00007f61be909ec5 in KParts::ReadOnlyPart::qt_metacall (this=0xe573c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd8939ff0) at /usr/src/debug/kdelibs-4.7.2/build/kparts/part.moc:168
#18 0x00007f61aaca9ae5 in KWebKitPart::qt_metacall (this=0xe573c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd8939ff0) at /usr/src/debug/kwebkitpart-1.2.0git20111019/build/src/moc_kwebkitpart.cpp:112
#19 0x00007f61bc9165aa in QMetaObject::activate (sender=0x7d3370, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd8939ff0) at kernel/qobject.cpp:3287
#20 0x00007f61bc916a5f in QObject::destroyed (this=<optimized out>, _t1=0x7d3370) at .moc/release-shared/moc_qobject.cpp:149
#21 0x00007f61bc91a5f7 in QObject::~QObject (this=0x7d3370, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#22 0x00007f61bd32d781 in QWidget::~QWidget (this=0x7d3370, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#23 0x00007f61bd32d999 in QWidget::~QWidget (this=0x7d3370, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#24 0x00007f61bc915465 in QObjectPrivate::deleteChildren (this=0xe4a160) at kernel/qobject.cpp:1964
#25 0x00007f61bd32d6f3 in QWidget::~QWidget (this=0xe42a50, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#26 0x00007f61be0ec379 in KVBox::~KVBox (this=0xe42a50, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kdeui/widgets/kvbox.cpp:29
#27 0x00007f61bc915465 in QObjectPrivate::deleteChildren (this=0xe4be00) at kernel/qobject.cpp:1964
#28 0x00007f61bd32d6f3 in QWidget::~QWidget (this=0xe3c9d0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#29 0x00007f61af3b5c29 in ArkViewer::~ArkViewer (this=0xe3c9d0, __in_chrg=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/part/arkviewer.cpp:58
#30 0x00007f61bc915465 in QObjectPrivate::deleteChildren (this=0x7feb80) at kernel/qobject.cpp:1964
#31 0x00007f61bd32d6f3 in QWidget::~QWidget (this=0x8ae930, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#32 0x00007f61bd72dfc9 in QSplitter::~QSplitter (this=0x8ae930, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1056
#33 0x00007f61be906a73 in KParts::Part::~Part (this=0x7d0b70, __vtt_parm=0x7f61af5cad18, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:209
#34 0x00007f61af3aa9cf in Ark::Part::~Part (this=0x7d0b70, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/part/part.cpp:131
#35 0x00007f61af3aaa29 in Ark::Part::~Part (this=0x7d0b70, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/part/part.cpp:139
#36 0x000000000040e6fd in MainWindow::~MainWindow (this=0x7a1df0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/app/mainwindow.cpp:72
#37 0x000000000040e7a9 in MainWindow::~MainWindow (this=0x7a1df0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdeutils-4.7.2/ark/app/mainwindow.cpp:74
#38 0x00007f61bc91a188 in QObject::event (this=0x7a1df0, e=<optimized out>) at kernel/qobject.cpp:1209
#39 0x00007f61bd331d4b in QWidget::event (this=0x7a1df0, event=0x8b3430) at kernel/qwidget.cpp:8754
#40 0x00007f61bd6f004b in QMainWindow::event (this=0x7a1df0, event=0x8b3430) at widgets/qmainwindow.cpp:1478
#41 0x00007f61be0f16b8 in KXmlGuiWindow::event (this=0x7a1df0, ev=0x8b3430) at /usr/src/debug/kdelibs-4.7.2/kdeui/xmlgui/kxmlguiwindow.cpp:126
#42 0x00007f61bd2e1c34 in notify_helper (e=0x8b3430, receiver=0x7a1df0, this=0x63f170) at kernel/qapplication.cpp:4481
#43 QApplicationPrivate::notify_helper (this=0x63f170, receiver=0x7a1df0, e=0x8b3430) at kernel/qapplication.cpp:4453
#44 0x00007f61bd2e6ac1 in QApplication::notify (this=0x7fffd893b190, receiver=0x7a1df0, e=0x8b3430) at kernel/qapplication.cpp:4360
#45 0x00007f61bdff4e36 in KApplication::notify (this=0x7fffd893b190, receiver=0x7a1df0, event=0x8b3430) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#46 0x00007f61bc90382c in QCoreApplication::notifyInternal (this=0x7fffd893b190, receiver=0x7a1df0, event=0x8b3430) at kernel/qcoreapplication.cpp:787
#47 0x00007f61bc906c08 in sendEvent (event=0x8b3430, receiver=0x7a1df0) at kernel/qcoreapplication.h:215
#48 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x61aad0) at kernel/qcoreapplication.cpp:1428
#49 0x00007f61bc92e0c3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#50 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#51 0x00007f61b883f58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#52 0x00007f61b883fd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#53 0x00007f61b883ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#54 0x00007f61bc92e51f in QEventDispatcherGlib::processEvents (this=0x61a2e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#55 0x00007f61bd384f9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#56 0x00007f61bc902a32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#57 0x00007f61bc902c2f in QEventLoop::exec (this=0x7fffd893b120, flags=...) at kernel/qeventloop.cpp:201
#58 0x00007f61bc906df7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#59 0x000000000040b0a8 in main (argc=4, argv=0x7fffd893bde8) at /usr/src/debug/kdeutils-4.7.2/ark/app/main.cpp:209

Possible duplicates by query: bug 289546, bug 288460, bug 288023, bug 287350, bug 287007.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-25 00:52:51 UTC

*** This bug has been marked as a duplicate of bug 283657 ***