Bug 288460 - ark crashed on quit
Summary: ark crashed on quit
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-08 09:00 UTC by Piotr Keplicz
Modified: 2011-12-08 10:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Keplicz 2011-12-08 09:00:07 UTC
Application: ark (2.17)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-13-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

1. I opened a zip file from within KMail2.
2. The file contained a single TIFF file, which I opened (in the Ark's internal viewer) and closed.
3. When quitting, Ark crashed.

I tested again on the same file and Ark crashed again.

-- Backtrace:
Application: Ark (ark), signal: Segmentation fault
[KCrash Handler]
#7  0x0786816b in typeinfo for QObjectData () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0x0026fc26 in KParts::StatusBarExtension::statusBar (this=0x97bc3b8) at ../../kparts/statusbarextension.cpp:149
#9  0x00270159 in KParts::StatusBarExtension::~StatusBarExtension (this=0x97bc3b8, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:99
#10 0x002704f2 in KParts::StatusBarExtension::~StatusBarExtension (this=0x97bc3b8, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:110
#11 0x07746841 in QObjectPrivate::deleteChildren (this=0x97596f0) at kernel/qobject.cpp:1955
#12 0x0774b439 in QObject::~QObject (this=0x975c440, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#13 0x00251a84 in KParts::Part::~Part (this=0x975c440, __vtt_parm=0x2f8da68, __in_chrg=<optimized out>) at ../../kparts/part.cpp:190
#14 0x00252dec in KParts::ReadOnlyPart::~ReadOnlyPart (this=0x975c440, __vtt_parm=0x2f8da64, __in_chrg=<optimized out>) at ../../kparts/part.cpp:460
#15 0x02a9077e in KHTMLImage::~KHTMLImage (this=0x975c440, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../khtml/khtmlimage.cpp:120
#16 0x02a90872 in KHTMLImage::~KHTMLImage (this=0x975c440, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../khtml/khtmlimage.cpp:133
#17 0x00251d40 in KParts::Part::slotWidgetDestroyed (this=0x975c440) at ../../kparts/part.cpp:353
#18 0x002536bc in KParts::Part::qt_metacall (this=0x975c440, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe67648) at ./part.moc:82
#19 0x002554d2 in KParts::ReadOnlyPart::qt_metacall (this=0x975c440, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfe67648) at ./part.moc:168
#20 0x02a91f42 in KHTMLImage::qt_metacall (this=0x975c440, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfe67648) at ./khtmlimage.moc:125
#21 0x07738b7d in metacall (argv=0xbfe67648, idx=6, cl=QMetaObject::InvokeMetaMethod, object=0x975c440) at kernel/qmetaobject.cpp:237
#22 QMetaObject::metacall (object=0x975c440, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfe67648) at kernel/qmetaobject.cpp:232
#23 0x07747a6a in QMetaObject::activate (sender=0x97602f0, m=0x7864390, local_signal_index=0, argv=0xbfe67648) at kernel/qobject.cpp:3278
#24 0x07747f05 in QObject::destroyed (this=0x97602f0, _t1=0x97602f0) at .moc/release-shared/moc_qobject.cpp:149
#25 0x0774afed in QObject::~QObject (this=0x97602f0, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#26 0x0109c02f in QWidget::~QWidget (this=0x97602f0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#27 0x014a590f in QFrame::~QFrame (this=0x97602f0, __in_chrg=<optimized out>) at widgets/qframe.cpp:240
#28 0x00d614df in KHBox::~KHBox (this=0x97602f0, __in_chrg=<optimized out>) at ../../kdeui/widgets/khbox.cpp:49
#29 0x00dbb4cf in KVBox::~KVBox (this=0x97602f0, __in_chrg=<optimized out>) at ../../kdeui/widgets/kvbox.cpp:27
#30 0x00dbb512 in KVBox::~KVBox (this=0x97602f0, __in_chrg=<optimized out>) at ../../kdeui/widgets/kvbox.cpp:29
#31 0x07746841 in QObjectPrivate::deleteChildren (this=0x9751990) at kernel/qobject.cpp:1955
#32 0x0109bf8e in QWidget::~QWidget (this=0x97e4840, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#33 0x014a590f in QFrame::~QFrame (this=0x97e4840, __in_chrg=<optimized out>) at widgets/qframe.cpp:240
#34 0x00d614df in KHBox::~KHBox (this=0x97e4840, __in_chrg=<optimized out>) at ../../kdeui/widgets/khbox.cpp:49
#35 0x00dbb4cf in KVBox::~KVBox (this=0x97e4840, __in_chrg=<optimized out>) at ../../kdeui/widgets/kvbox.cpp:27
#36 0x00dbb512 in KVBox::~KVBox (this=0x97e4840, __in_chrg=<optimized out>) at ../../kdeui/widgets/kvbox.cpp:29
#37 0x07746841 in QObjectPrivate::deleteChildren (this=0x9755f58) at kernel/qobject.cpp:1955
#38 0x0109bf8e in QWidget::~QWidget (this=0x9758600, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#39 0x0157dc15 in QDialog::~QDialog (this=0x9758600, __in_chrg=<optimized out>) at dialogs/qdialog.cpp:318
#40 0x00bdd424 in KDialog::~KDialog (this=0x9758600, __in_chrg=<optimized out>) at ../../kdeui/dialogs/kdialog.cpp:201
#41 0x026e9823 in ArkViewer::~ArkViewer (this=0x9758600, __in_chrg=<optimized out>) at ../../../ark/part/arkviewer.cpp:56
#42 0x026e9862 in ArkViewer::~ArkViewer (this=0x9758600, __in_chrg=<optimized out>) at ../../../ark/part/arkviewer.cpp:58
#43 0x07746841 in QObjectPrivate::deleteChildren (this=0x9587858) at kernel/qobject.cpp:1955
#44 0x0109bf8e in QWidget::~QWidget (this=0x958c4a8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#45 0x014a590f in QFrame::~QFrame (this=0x958c4a8, __in_chrg=<optimized out>) at widgets/qframe.cpp:240
#46 0x01509c0c in QSplitter::~QSplitter (this=0x958c4a8, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1050
#47 0x01509c62 in QSplitter::~QSplitter (this=0x958c4a8, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1056
#48 0x00251a5b in KParts::Part::~Part (this=0x944d040, __vtt_parm=0x27014cc, __in_chrg=<optimized out>) at ../../kparts/part.cpp:209
#49 0x00252dec in KParts::ReadOnlyPart::~ReadOnlyPart (this=0x944d040, __vtt_parm=0x27014c8, __in_chrg=<optimized out>) at ../../kparts/part.cpp:460
#50 0x00252f30 in KParts::ReadWritePart::~ReadWritePart (this=0x944d040, __vtt_parm=0x27014c4, __in_chrg=<optimized out>) at ../../kparts/part.cpp:773
#51 0x026dd20d in Ark::Part::~Part (this=0x944d040, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../ark/part/part.cpp:131
#52 0x026dd282 in Ark::Part::~Part (this=0x944d040, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../ark/part/part.cpp:139
#53 0x08054079 in MainWindow::~MainWindow (this=0x9413690, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../ark/app/mainwindow.cpp:72
#54 0x08054130 in MainWindow::~MainWindow (this=0x9413690, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../ark/app/mainwindow.cpp:74
#55 0x077455f3 in qDeleteInEventHandler (o=0x9413690) at kernel/qobject.cpp:3986
#56 0x0774ab80 in QObject::event (this=0x9413690, e=0x9796b10) at kernel/qobject.cpp:1200
#57 0x010a0c62 in QWidget::event (this=0x9413690, event=0x9796b10) at kernel/qwidget.cpp:8754
#58 0x014c34cc in QMainWindow::event (this=0x9413690, event=0x9796b10) at widgets/qmainwindow.cpp:1478
#59 0x00d79194 in KMainWindow::event (this=0x9413690, ev=0x9796b10) at ../../kdeui/widgets/kmainwindow.cpp:1084
#60 0x00dc1372 in KXmlGuiWindow::event (this=0x9413690, ev=0x9796b10) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#61 0x01046d54 in notify_helper (e=0x9796b10, receiver=0x9413690, this=0x9328d50) at kernel/qapplication.cpp:4486
#62 QApplicationPrivate::notify_helper (this=0x9328d50, receiver=0x9413690, e=0x9796b10) at kernel/qapplication.cpp:4458
#63 0x0104c1a8 in QApplication::notify (this=0x9328d50, receiver=0x9413690, e=0x9796b10) at kernel/qapplication.cpp:4451
#64 0x00c9d681 in KApplication::notify (this=0xbfe685ac, receiver=0x9413690, event=0x9796b10) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x0773219e in QCoreApplication::notifyInternal (this=0xbfe685ac, receiver=0x9413690, event=0x9796b10) at kernel/qcoreapplication.cpp:787
#66 0x07735f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#67 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x930b520) at kernel/qcoreapplication.cpp:1428
#68 0x077360ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#69 0x077606a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#70 postEventSourceDispatch (s=0x932aea0) at kernel/qeventdispatcher_glib.cpp:277
#71 0x0568025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#72 0x05680990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#73 0x05680c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#74 0x07760ada in QEventDispatcherGlib::processEvents (this=0x930c248, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#75 0x010fee3a in QGuiEventDispatcherGlib::processEvents (this=0x930c248, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#76 0x077311dd in QEventLoop::processEvents (this=0xbfe684b4, flags=...) at kernel/qeventloop.cpp:149
#77 0x07731421 in QEventLoop::exec (this=0xbfe684b4, flags=...) at kernel/qeventloop.cpp:201
#78 0x0773619d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#79 0x010448f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#80 0x080507ac in main (argc=) at ../../../ark/app/main.cpp:209

Reported using DrKonqi
Comment 1 Christoph Feck 2011-12-08 10:48:08 UTC

*** This bug has been marked as a duplicate of bug 283657 ***