Bug 290669 - Crash of Kontact on Closing of Akregator 4.7.2 Tab
Summary: Crash of Kontact on Closing of Akregator 4.7.2 Tab
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.7.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-05 08:58 UTC by Ronald W. Klarin
Modified: 2012-01-05 09:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (12.04 KB, text/plain)
2012-01-05 09:00 UTC, Ronald W. Klarin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald W. Klarin 2012-01-05 08:58:18 UTC
Application: kontact (4.7.2)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: Was reading Planet OpenSUSE feed and closed tab in Akregator, Akregator and Kontact then crashed.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb70c1f2760 (LWP 6962))]

Thread 3 (Thread 0x7fb6f408e700 (LWP 6963)):
#0  0x00007fb70412be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fb708a749dc in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fb708a74b09 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fb704127f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fb70977c53d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fb6f3785700 (LWP 6964)):
#0  0x00007fb70412ce8b in pthread_getspecific () from /lib64/libpthread.so.0
#1  0x00007fb702dd7edd in g_thread_self () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fb702db1f49 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fb70ab68576 in QEventDispatcherGlib::processEvents (this=0x7fb6ec0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb70ab3ca22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb70ab3cc1f in QEventLoop::exec (this=0x7fb6f3784e20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb70aa545df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb70aa57025 in QThreadPrivate::start (arg=0x7a6010) at thread/qthread_unix.cpp:331
#8  0x00007fb704127f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fb70977c53d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fb70c1f2760 (LWP 6962)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fb70948e84e in KParts::StatusBarExtension::statusBar (this=0x1edb280) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:149
#8  0x00007fb70948ed54 in KParts::StatusBarExtension::~StatusBarExtension (this=0x1edb280, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:99
#9  0x00007fb70948f109 in KParts::StatusBarExtension::~StatusBarExtension (this=0x1edb280, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:110
#10 0x00007fb70ab4f455 in QObjectPrivate::deleteChildren (this=0x24892a0) at kernel/qobject.cpp:1964
#11 0x00007fb70ab549f9 in QObject::~QObject (this=0xafc3e0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007fb709473a98 in KParts::Part::~Part (this=0xafc3e0, __vtt_parm=0x7fb688aa88f0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:190
#13 0x00007fb688870427 in KWebKitPart::~KWebKitPart (this=0xafc3e0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kwebkitpart-1.2.0git20111019/src/kwebkitpart.cpp:182
#14 0x00007fb688870469 in KWebKitPart::~KWebKitPart (this=0xafc3e0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kwebkitpart-1.2.0git20111019/src/kwebkitpart.cpp:184
#15 0x00007fb69d3aaaf0 in Akregator::BrowserFrame::Private::~Private (this=0x2869250, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe_p.cpp:50
#16 0x00007fb69d3aabe9 in Akregator::BrowserFrame::Private::~Private (this=0x2869250, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe_p.cpp:51
#17 0x00007fb69d3a763a in Akregator::BrowserFrame::~BrowserFrame (this=0x2b3e070, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe.cpp:63
#18 0x00007fb69d3a76a9 in Akregator::BrowserFrame::~BrowserFrame (this=0x2b3e070, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe.cpp:64
#19 0x00007fb69d3a556a in Akregator::FrameManager::slotRemoveFrame (this=0x1f8b460, id=1) at /usr/src/debug/kdepim-4.7.2/akregator/src/framemanager.cpp:108
#20 0x00007fb69d3a65dc in Akregator::FrameManager::qt_metacall (this=0x1f8b460, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb1b2e420) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/framemanager.moc:155
#21 0x00007fb70ab5059a in QMetaObject::activate (sender=0x3460730, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffb1b2e420) at kernel/qobject.cpp:3287
#22 0x00007fb69d83d7b1 in Akregator::TabWidget::signalRemoveFrameRequest (this=<optimized out>, _t1=1) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/tabwidget.moc:153
#23 0x00007fb69d83dae8 in Akregator::TabWidget::slotCloseTab (this=0x3460730) at /usr/src/debug/kdepim-4.7.2/akregator/src/tabwidget.cpp:393
#24 0x00007fb69d83f42d in Akregator::TabWidget::qt_metacall (this=0x3460730, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb1b2e560) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/tabwidget.moc:131
#25 0x00007fb70ab5059a in QMetaObject::activate (sender=0x293cb10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffb1b2e560) at kernel/qobject.cpp:3287
#26 0x00007fb709f06622 in QAction::triggered (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#27 0x00007fb709f0680f in QAction::activate (this=0x293cb10, event=<optimized out>) at kernel/qaction.cpp:1257
#28 0x00007fb70a33ca09 in QMenuPrivate::activateCausedStack (this=0xe661b0, causedStack=..., action=0x293cb10, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1005
#29 0x00007fb70a342642 in QMenuPrivate::activateAction (this=0xe661b0, action=0x293cb10, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1097
#30 0x00007fb70b650d40 in KMenu::mouseReleaseEvent (this=0xfa1880, e=0x7fffb1b2f130) at /usr/src/debug/kdelibs-4.7.2/kdeui/widgets/kmenu.cpp:464
#31 0x00007fb709f5d306 in QWidget::event (this=0xfa1880, event=0x7fffb1b2f130) at kernel/qwidget.cpp:8295
#32 0x00007fb70a343bab in QMenu::event (this=0xfa1880, e=0x7fffb1b2f130) at widgets/qmenu.cpp:2405
#33 0x00007fb709f0cc34 in notify_helper (e=0x7fffb1b2f130, receiver=0xfa1880, this=0x639280) at kernel/qapplication.cpp:4481
#34 QApplicationPrivate::notify_helper (this=0x639280, receiver=0xfa1880, e=0x7fffb1b2f130) at kernel/qapplication.cpp:4453
#35 0x00007fb709f123bb in QApplication::notify (this=<optimized out>, receiver=0xfa1880, e=0x7fffb1b2f130) at kernel/qapplication.cpp:4042
#36 0x00007fb70b58ee36 in KApplication::notify (this=0x7fffb1b315d0, receiver=0xfa1880, event=0x7fffb1b2f130) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#37 0x00007fb70ab3d81c in QCoreApplication::notifyInternal (this=0x7fffb1b315d0, receiver=0xfa1880, event=0x7fffb1b2f130) at kernel/qcoreapplication.cpp:787
#38 0x00007fb709f0dc02 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#39 QApplicationPrivate::sendMouseEvent (receiver=0xfa1880, event=0x7fffb1b2f130, alienWidget=0x0, nativeWidget=0xfa1880, buttonDown=0x0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141
#40 0x00007fb709f8a271 in QETWidget::translateMouseEvent (this=0xfa1880, event=<optimized out>) at kernel/qapplication_x11.cpp:4409
#41 0x00007fb709f88a9a in QApplication::x11ProcessEvent (this=0x7fffb1b315d0, event=0x7fffb1b2f9f0) at kernel/qapplication_x11.cpp:3601
#42 0x00007fb709fb0312 in x11EventSourceDispatch (s=0x63bc70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#43 0x00007fb702db158d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#44 0x00007fb702db1d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#45 0x00007fb702db1f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#46 0x00007fb70ab6850f in QEventDispatcherGlib::processEvents (this=0x60c970, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#47 0x00007fb709faff9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x00007fb70ab3ca22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#49 0x00007fb70ab3cc1f in QEventLoop::exec (this=0x7fffb1b2fdc0, flags=...) at kernel/qeventloop.cpp:201
#50 0x00007fb70a33fb21 in QMenu::exec (this=<optimized out>, p=..., action=0x0) at widgets/qmenu.cpp:2049
#51 0x00007fb69d83d099 in Akregator::TabWidget::contextMenu (this=0x3460730, i=<optimized out>, p=...) at /usr/src/debug/kdepim-4.7.2/akregator/src/tabwidget.cpp:355
#52 0x00007fb70b67113d in KTabWidget::qt_metacall (this=0x3460730, _c=QMetaObject::InvokeMetaMethod, _id=23, _a=0x7fffb1b2ff70) at /usr/src/debug/kdelibs-4.7.2/build/kdeui/ktabwidget.moc:156
#53 0x00007fb69d83f1c0 in Akregator::TabWidget::qt_metacall (this=0x3460730, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb1b2ff70) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/tabwidget.moc:107
#54 0x00007fb70ab5059a in QMetaObject::activate (sender=0x2b153c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffb1b2ff70) at kernel/qobject.cpp:3287
#55 0x00007fb70b66e563 in KTabBar::contextMenu (this=<optimized out>, _t1=1, _t2=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/build/kdeui/ktabbar.moc:124
#56 0x00007fb70b66e6b4 in KTabBar::mousePressEvent (this=0x2b153c0, event=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kdeui/widgets/ktabbar.cpp:103
#57 0x00007fb709f5d5e9 in QWidget::event (this=0x2b153c0, event=0x7fffb1b308d0) at kernel/qwidget.cpp:8291
#58 0x00007fb70a364b36 in QTabBar::event (this=0x2b153c0, event=0x7fffb1b308d0) at widgets/qtabbar.cpp:1509
#59 0x00007fb709f0cc34 in notify_helper (e=0x7fffb1b308d0, receiver=0x2b153c0, this=0x639280) at kernel/qapplication.cpp:4481
#60 QApplicationPrivate::notify_helper (this=0x639280, receiver=0x2b153c0, e=0x7fffb1b308d0) at kernel/qapplication.cpp:4453
#61 0x00007fb709f123bb in QApplication::notify (this=<optimized out>, receiver=0x2b153c0, e=0x7fffb1b308d0) at kernel/qapplication.cpp:4042
#62 0x00007fb70b58ee36 in KApplication::notify (this=0x7fffb1b315d0, receiver=0x2b153c0, event=0x7fffb1b308d0) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#63 0x00007fb70ab3d81c in QCoreApplication::notifyInternal (this=0x7fffb1b315d0, receiver=0x2b153c0, event=0x7fffb1b308d0) at kernel/qcoreapplication.cpp:787
#64 0x00007fb709f0dc02 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#65 QApplicationPrivate::sendMouseEvent (receiver=0x2b153c0, event=0x7fffb1b308d0, alienWidget=0x2b153c0, nativeWidget=0x263e7d0, buttonDown=0x2b153c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141
#66 0x00007fb709f89bc5 in QETWidget::translateMouseEvent (this=0x263e7d0, event=<optimized out>) at kernel/qapplication_x11.cpp:4475
#67 0x00007fb709f88a9a in QApplication::x11ProcessEvent (this=0x7fffb1b315d0, event=0x7fffb1b31190) at kernel/qapplication_x11.cpp:3601
#68 0x00007fb709fb0312 in x11EventSourceDispatch (s=0x63bc70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#69 0x00007fb702db158d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#70 0x00007fb702db1d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#71 0x00007fb702db1f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#72 0x00007fb70ab6850f in QEventDispatcherGlib::processEvents (this=0x60c970, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#73 0x00007fb709faff9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#74 0x00007fb70ab3ca22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#75 0x00007fb70ab3cc1f in QEventLoop::exec (this=0x7fffb1b31560, flags=...) at kernel/qeventloop.cpp:201
#76 0x00007fb70ab40de7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#77 0x0000000000403919 in ?? ()
#78 0x00007fb7096c423d in __libc_start_main () from /lib64/libc.so.6
#79 0x0000000000403e61 in _start ()

This bug may be a duplicate of or related to bug 283988.

Possible duplicates by query: bug 289280, bug 289202, bug 287555, bug 287007, bug 286929.

Reported using DrKonqi
Comment 1 Ronald W. Klarin 2012-01-05 09:00:16 UTC
Created attachment 67478 [details]
New crash information added by DrKonqi

kontact (4.7.2) on KDE Platform 4.7.2 (4.7.2) "release 5" using Qt 4.7.4

- What I was doing when the application crashed: Tried to close tab a second time on restart of Kontact and Akgregator and Kontact crashed.

-- Backtrace (Reduced):
#7  0x00007f7f1c59884e in KParts::StatusBarExtension::statusBar (this=0xfcd2e0) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:149
#8  0x00007f7f1c598d54 in KParts::StatusBarExtension::~StatusBarExtension (this=0xfcd2e0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:99
#9  0x00007f7f1c599109 in KParts::StatusBarExtension::~StatusBarExtension (this=0xfcd2e0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:110
#10 0x00007f7f1dc59455 in QObjectPrivate::deleteChildren (this=0x1088fd0) at kernel/qobject.cpp:1964
#11 0x00007f7f1dc5e9f9 in QObject::~QObject (this=0x1061ba0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
Comment 2 Christophe Marin 2012-01-05 09:20:19 UTC

*** This bug has been marked as a duplicate of bug 283657 ***