Bug 295910 - Konqueror crashes
Summary: Konqueror crashes
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-13 10:59 UTC by jakobwalz
Modified: 2012-03-13 11:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jakobwalz 2012-03-13 10:59:43 UTC
Application: konqueror (4.7.2 (4.7.2) "release 5")
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: I tried to download a shellscript (*.sh) from a local server

The crash does not seem to be reproducible.

-- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff5346c3760 (LWP 28334))]

Thread 7 (Thread 0x7ff51b5e8700 (LWP 28335)):
#0  0x00007ff532faae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff52929a9dc in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007ff52929ab09 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007ff532fa6f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff531d3f63d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7ff51accf700 (LWP 28336)):
#0  0x00007ff531d36523 in poll () from /lib64/libc.so.6
#1  0x00007ff52eb2ba98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff52eb2bf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff533348586 in QEventDispatcherGlib::processEvents (this=0x7ff5140008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff53331ca32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff53331cc2f in QEventLoop::exec (this=0x7ff51accee20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff5332345df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007ff533237025 in QThreadPrivate::start (arg=0x8fa3f0) at thread/qthread_unix.cpp:331
#8  0x00007ff532fa6f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007ff531d3f63d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7ff5189ca700 (LWP 29472)):
#0  0x00007ff531d36523 in poll () from /lib64/libc.so.6
#1  0x00007ff52eb2ba98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff52eb2bf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff53334851f in QEventDispatcherGlib::processEvents (this=0x7ff4cc001f90, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#4  0x00007ff53331ca32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff53331cc2f in QEventLoop::exec (this=0x7ff5189c9df0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff5332345df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007ff5332ffaff in QInotifyFileSystemWatcherEngine::run (this=0x10a6660) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff533237025 in QThreadPrivate::start (arg=0x10a6660) at thread/qthread_unix.cpp:331
#9  0x00007ff532fa6f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff531d3f63d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7ff4c349b700 (LWP 32130)):
#0  0x00007ff532faae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff4c34c0c01 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007ff532fa6f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007ff531d3f63d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7ff4c2c9a700 (LWP 32131)):
#0  0x00007ff532faae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff4c34c0c01 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007ff532fa6f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007ff531d3f63d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7ff4c2499700 (LWP 32132)):
#0  0x00007ff532faae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff4c34c0c01 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007ff532fa6f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007ff531d3f63d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ff5346c3760 (LWP 28334)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007ff52a66584e in KParts::StatusBarExtension::statusBar (this=0x12fcaa0) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:149
#8  0x00007ff52a665d54 in KParts::StatusBarExtension::~StatusBarExtension (this=0x12fcaa0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:99
#9  0x00007ff52a666109 in KParts::StatusBarExtension::~StatusBarExtension (this=0x12fcaa0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:110
#10 0x00007ff53332f465 in QObjectPrivate::deleteChildren (this=0x1444530) at kernel/qobject.cpp:1964
#11 0x00007ff533334a09 in QObject::~QObject (this=0x15e4dc0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007ff52a64aa98 in KParts::Part::~Part (this=0x15e4dc0, __vtt_parm=0x7ff4bfe72970, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:190
#13 0x00007ff4bfc68c54 in ?? () from /usr/lib64/kde4/klinkstatuspart.so
#14 0x00007ff4bfc68c99 in ?? () from /usr/lib64/kde4/klinkstatuspart.so
#15 0x00007ff52a64ad00 in KParts::Part::slotWidgetDestroyed (this=0x15e4dc0) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:353
#16 0x00007ff52a64c2e4 in KParts::Part::qt_metacall (this=0x15e4dc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbbbd0e90) at /usr/src/debug/kdelibs-4.7.2/build/kparts/part.moc:82
#17 0x00007ff52a64dec5 in KParts::ReadOnlyPart::qt_metacall (this=0x15e4dc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbbbd0e90) at /usr/src/debug/kdelibs-4.7.2/build/kparts/part.moc:168
#18 0x00007ff4bfc6a788 in ?? () from /usr/lib64/kde4/klinkstatuspart.so
#19 0x00007ff5333305aa in QMetaObject::activate (sender=0x15e40d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbbbd0e90) at kernel/qobject.cpp:3287
#20 0x00007ff533330a5f in QObject::destroyed (this=<optimized out>, _t1=0x15e40d0) at .moc/release-shared/moc_qobject.cpp:149
#21 0x00007ff5333345f7 in QObject::~QObject (this=0x15e40d0, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#22 0x00007ff53251b781 in QWidget::~QWidget (this=0x15e40d0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#23 0x00007ff4bfa23e39 in View::~View() () from /usr/lib64/libklinkstatuscommon.so.4
#24 0x00007ff533334188 in QObject::event (this=0x15e40d0, e=<optimized out>) at kernel/qobject.cpp:1209
#25 0x00007ff53251fd4b in QWidget::event (this=0x15e40d0, event=0x1188260) at kernel/qwidget.cpp:8754
#26 0x00007ff5324cfc34 in notify_helper (e=0x1188260, receiver=0x15e40d0, this=0x6ccea0) at kernel/qapplication.cpp:4481
#27 QApplicationPrivate::notify_helper (this=0x6ccea0, receiver=0x15e40d0, e=0x1188260) at kernel/qapplication.cpp:4453
#28 0x00007ff5324d4ac1 in QApplication::notify (this=0x7fffbbbd1d00, receiver=0x15e40d0, e=0x1188260) at kernel/qapplication.cpp:4360
#29 0x00007ff5340afe36 in KApplication::notify (this=0x7fffbbbd1d00, receiver=0x15e40d0, event=0x1188260) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#30 0x00007ff53331d82c in QCoreApplication::notifyInternal (this=0x7fffbbbd1d00, receiver=0x15e40d0, event=0x1188260) at kernel/qcoreapplication.cpp:787
#31 0x00007ff533320c08 in sendEvent (event=0x1188260, receiver=0x15e40d0) at kernel/qcoreapplication.h:215
#32 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x615800) at kernel/qcoreapplication.cpp:1428
#33 0x00007ff5333480c3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#35 0x00007ff52eb2b58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#36 0x00007ff52eb2bd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#37 0x00007ff52eb2bf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#38 0x00007ff53334851f in QEventDispatcherGlib::processEvents (this=0x616ce0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#39 0x00007ff532572f9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007ff53331ca32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007ff53331cc2f in QEventLoop::exec (this=0x7fffbbbd1b30, flags=...) at kernel/qeventloop.cpp:201
#42 0x00007ff533320df7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#43 0x00007ff521e8b8e2 in kdemain () from /usr/lib64/libkdeinit4_konqueror.so
#44 0x0000000000408897 in _start ()

Possible duplicates by query: bug 287007, bug 283657.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-13 11:46:27 UTC

*** This bug has been marked as a duplicate of bug 283657 ***