Bug 302397 - Kontact crash when using Akregator - viewing pictures and closing these
Summary: Kontact crash when using Akregator - viewing pictures and closing these
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-23 11:55 UTC by Ron Pflaumer
Modified: 2012-07-03 13:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (17.36 KB, text/plain)
2012-06-25 09:23 UTC, Ron Pflaumer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ron Pflaumer 2012-06-23 11:55:02 UTC
Application: kontact (4.7.2)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.10-1.13-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was reading https://twitter.com/tsdgeos/status/215727012717924352/photo/1 and when I closed the tab, received this crash report.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe70dd7b760 (LWP 4321))]

Thread 7 (Thread 0x7fe6f5848700 (LWP 4347)):
#0  0x00007fe705cb4e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe70a5fd9dc in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fe70a5fdb09 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fe705cb0f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe70b30710d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fe6f4f47700 (LWP 4348)):
#0  0x00007fe70b2fdff3 in poll () from /lib64/libc.so.6
#1  0x00007fe70493aa98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe70493af59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe70c6f2586 in QEventDispatcherGlib::processEvents (this=0x7fe6f00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe70c6c6a32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe70c6c6c2f in QEventLoop::exec (this=0x7fe6f4f46e20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe70c5de5df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fe70c5e1025 in QThreadPrivate::start (arg=0x74cf50) at thread/qthread_unix.cpp:331
#8  0x00007fe705cb0f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fe70b30710d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fe6a663f700 (LWP 4431)):
#0  0x00007fff4d9ff98f in clock_gettime ()
#1  0x00007fe704beed9a in clock_gettime () from /lib64/librt.so.1
#2  0x00007fe70c631114 in do_gettime (frac=0x7fe6a663eba8, sec=0x7fe6a663eba0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fe70c6f2d2d in QTimerInfoList::updateCurrentTime (this=0x7fe698002060) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007fe70c6f3063 in QTimerInfoList::timerWait (this=0x7fe698002060, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007fe70c6f1acc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fe6a663ec8c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fe70c6f1b75 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fe704939b22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007fe70493a92d in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fe70493af59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fe70c6f2586 in QEventDispatcherGlib::processEvents (this=0x7fe6980008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007fe70c6c6a32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fe70c6c6c2f in QEventLoop::exec (this=0x7fe6a663ee20, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007fe70c5de5df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007fe70c5e1025 in QThreadPrivate::start (arg=0x108c700) at thread/qthread_unix.cpp:331
#16 0x00007fe705cb0f05 in start_thread () from /lib64/libpthread.so.0
#17 0x00007fe70b30710d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fe6a6e40700 (LWP 4450)):
#0  0x00007fe705cb4e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe691502fc1 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007fe705cb0f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fe70b30710d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fe6914de700 (LWP 4451)):
#0  0x00007fe705cb4e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe691502fc1 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007fe705cb0f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fe70b30710d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fe690cdd700 (LWP 4452)):
#0  0x00007fe705cb4e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe691502fc1 in queue_processor(void*) () from /usr/lib64/IcedTeaPlugin.so
#2  0x00007fe705cb0f05 in start_thread () from /lib64/libpthread.so.0
#3  0x00007fe70b30710d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fe70dd7b760 (LWP 4321)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fe70b01784e in KParts::StatusBarExtension::statusBar (this=0x16300f0) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:149
#8  0x00007fe70b017d54 in KParts::StatusBarExtension::~StatusBarExtension (this=0x16300f0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:99
#9  0x00007fe70b018109 in KParts::StatusBarExtension::~StatusBarExtension (this=0x16300f0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:110
#10 0x00007fe70c6d9465 in QObjectPrivate::deleteChildren (this=0x1392380) at kernel/qobject.cpp:1964
#11 0x00007fe70c6dea09 in QObject::~QObject (this=0x16335b0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007fe70affca98 in KParts::Part::~Part (this=0x16335b0, __vtt_parm=0x7fe697bd98f0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:190
#13 0x00007fe6979a1427 in KWebKitPart::~KWebKitPart (this=0x16335b0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kwebkitpart-1.2.0git20111019/src/kwebkitpart.cpp:182
#14 0x00007fe6979a1469 in KWebKitPart::~KWebKitPart (this=0x16335b0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kwebkitpart-1.2.0git20111019/src/kwebkitpart.cpp:184
#15 0x00007fe6a5210af0 in Akregator::BrowserFrame::Private::~Private (this=0x16251d0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe_p.cpp:50
#16 0x00007fe6a5210be9 in Akregator::BrowserFrame::Private::~Private (this=0x16251d0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe_p.cpp:51
#17 0x00007fe6a520d63a in Akregator::BrowserFrame::~BrowserFrame (this=0x11d5ac0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe.cpp:63
#18 0x00007fe6a520d6a9 in Akregator::BrowserFrame::~BrowserFrame (this=0x11d5ac0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe.cpp:64
#19 0x00007fe6a520b56a in Akregator::FrameManager::slotRemoveFrame (this=0xe8f0c0, id=2) at /usr/src/debug/kdepim-4.7.2/akregator/src/framemanager.cpp:108
#20 0x00007fe6a520c5dc in Akregator::FrameManager::qt_metacall (this=0xe8f0c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4d99ac10) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/framemanager.moc:155
#21 0x00007fe70c6da5aa in QMetaObject::activate (sender=0x10f27c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4d99ac10) at kernel/qobject.cpp:3287
#22 0x00007fe6a56a37b1 in Akregator::TabWidget::signalRemoveFrameRequest (this=<optimized out>, _t1=2) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/tabwidget.moc:153
#23 0x00007fe6a56a3a28 in Akregator::TabWidget::slotCloseRequest (this=0x10f27c0, widget=0x11d5ac0) at /usr/src/debug/kdepim-4.7.2/akregator/src/tabwidget.cpp:416
#24 0x00007fe6a56a544a in Akregator::TabWidget::qt_metacall (this=0x10f27c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4d99ad50) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/tabwidget.moc:132
#25 0x00007fe70c6da5aa in QMetaObject::activate (sender=0x10f27c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4d99ad50) at kernel/qobject.cpp:3287
#26 0x00007fe70d1fa7f2 in KTabWidget::closeRequest (this=<optimized out>, _t1=0x11d5ac0) at /usr/src/debug/kdelibs-4.7.2/build/kdeui/ktabwidget.moc:284
#27 0x00007fe70d1fb0d0 in KTabWidget::qt_metacall (this=0x10f27c0, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x7fff4d99ae90) at /usr/src/debug/kdelibs-4.7.2/build/kdeui/ktabwidget.moc:159
#28 0x00007fe6a56a51c0 in Akregator::TabWidget::qt_metacall (this=0x10f27c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4d99ae90) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/tabwidget.moc:107
#29 0x00007fe70c6da5aa in QMetaObject::activate (sender=0x198e900, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4d99ae90) at kernel/qobject.cpp:3287
#30 0x00007fe70bee97a1 in QTabBar::tabCloseRequested (this=<optimized out>, _t1=1) at .moc/release-shared/moc_qtabbar.cpp:208
#31 0x00007fe70bef0ab9 in QTabBar::qt_metacall (this=0x198e900, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x7fff4d99afd0) at .moc/release-shared/moc_qtabbar.cpp:141
#32 0x00007fe70d1f9080 in KTabBar::qt_metacall (this=0x198e900, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4d99afd0) at /usr/src/debug/kdelibs-4.7.2/build/kdeui/ktabbar.moc:93
#33 0x00007fe70c6da5aa in QMetaObject::activate (sender=0x1365380, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4d99afd0) at kernel/qobject.cpp:3287
#34 0x00007fe70c101dd2 in QAbstractButton::clicked (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#35 0x00007fe70be495ae in QAbstractButtonPrivate::emitClicked (this=<optimized out>) at widgets/qabstractbutton.cpp:546
#36 0x00007fe70be4a8eb in QAbstractButtonPrivate::click (this=0x11bb210) at widgets/qabstractbutton.cpp:539
#37 0x00007fe70be4ab5c in QAbstractButton::mouseReleaseEvent (this=0x1365380, e=0x7fff4d99b8a0) at widgets/qabstractbutton.cpp:1121
#38 0x00007fe70bae7306 in QWidget::event (this=0x1365380, event=0x7fff4d99b8a0) at kernel/qwidget.cpp:8295
#39 0x00007fe70ba96c34 in notify_helper (e=0x7fff4d99b8a0, receiver=0x1365380, this=0x63f700) at kernel/qapplication.cpp:4481
#40 QApplicationPrivate::notify_helper (this=0x63f700, receiver=0x1365380, e=0x7fff4d99b8a0) at kernel/qapplication.cpp:4453
#41 0x00007fe70ba9c3bb in QApplication::notify (this=<optimized out>, receiver=0x1365380, e=0x7fff4d99b8a0) at kernel/qapplication.cpp:4042
#42 0x00007fe70d118e36 in KApplication::notify (this=0x7fff4d99c5a0, receiver=0x1365380, event=0x7fff4d99b8a0) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#43 0x00007fe70c6c782c in QCoreApplication::notifyInternal (this=0x7fff4d99c5a0, receiver=0x1365380, event=0x7fff4d99b8a0) at kernel/qcoreapplication.cpp:787
#44 0x00007fe70ba97c02 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#45 QApplicationPrivate::sendMouseEvent (receiver=0x1365380, event=0x7fff4d99b8a0, alienWidget=0x1365380, nativeWidget=0xf1c170, buttonDown=0x1365380, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141
#46 0x00007fe70bb13bc5 in QETWidget::translateMouseEvent (this=0xf1c170, event=<optimized out>) at kernel/qapplication_x11.cpp:4475
#47 0x00007fe70bb12a9a in QApplication::x11ProcessEvent (this=0x7fff4d99c5a0, event=0x7fff4d99c160) at kernel/qapplication_x11.cpp:3601
#48 0x00007fe70bb3a312 in x11EventSourceDispatch (s=0x63cbc0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#49 0x00007fe70493a58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#50 0x00007fe70493ad88 in ?? () from /usr/lib64/libglib-2.0.so.0
#51 0x00007fe70493af59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#52 0x00007fe70c6f251f in QEventDispatcherGlib::processEvents (this=0x60c970, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#53 0x00007fe70bb39f9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x00007fe70c6c6a32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#55 0x00007fe70c6c6c2f in QEventLoop::exec (this=0x7fff4d99c530, flags=...) at kernel/qeventloop.cpp:201
#56 0x00007fe70c6cadf7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#57 0x0000000000403919 in ?? ()
#58 0x00007fe70b24d23d in __libc_start_main () from /lib64/libc.so.6
#59 0x0000000000403e61 in _start ()

Possible duplicates by query: bug 302283, bug 302012, bug 299926, bug 299543, bug 298056.

Reported using DrKonqi
Comment 1 Ron Pflaumer 2012-06-25 09:23:01 UTC
Created attachment 72118 [details]
New crash information added by DrKonqi

kontact (4.7.2) on KDE Platform 4.7.2 (4.7.2) "release 5" using Qt 4.7.4

- What I was doing when the application crashed:

I tried to close the window in Akregator and the program crashed again.
The following is a copy of the offending window/tab. I cannot seem to get rid of it.
https://twitter.com/tsdgeos/status/215727012717924352/photo/1

-- Backtrace (Reduced):
#7  0x00007f87d553184e in KParts::StatusBarExtension::statusBar (this=0x17c28c0) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:149
#8  0x00007f87d5531d54 in KParts::StatusBarExtension::~StatusBarExtension (this=0x17c28c0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:99
#9  0x00007f87d5532109 in KParts::StatusBarExtension::~StatusBarExtension (this=0x17c28c0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:110
#10 0x00007f87d6bf3465 in QObjectPrivate::deleteChildren (this=0x10da360) at kernel/qobject.cpp:1964
#11 0x00007f87d6bf8a09 in QObject::~QObject (this=0x1407d70, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
Comment 2 Jekyll Wu 2012-07-03 13:07:35 UTC

*** This bug has been marked as a duplicate of bug 283657 ***