Bug 291111 - Rekonq crash [KParts::StatusBarExtension::statusBar]
Summary: Rekonq crash [KParts::StatusBarExtension::statusBar]
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.8.0
Platform: Ubuntu Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
: 290480 291549 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-10 03:15 UTC by jakob
Modified: 2012-05-31 19:23 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jakob 2012-01-10 03:15:54 UTC
Application: rekonq (0.8.0)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I was looking at a WordPress podcast feed and either clicked back or used the backspace button on the keyboard and then Rekonq crashed.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa3fdc8d780 (LWP 16759))]

Thread 10 (Thread 0x7fa3dfa5a700 (LWP 16760)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa3fc56fc2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fa3fc56fd59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fa3f7ca3efc in start_thread (arg=0x7fa3dfa5a700) at pthread_create.c:304
#4  0x00007fa3fd4ce89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fa3df159700 (LWP 16761)):
#0  0x00007fa3fd4c2773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa3f60d6f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa3f60d7429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa3f8357f3e in QEventDispatcherGlib::processEvents (this=0x1819580, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fa3f832bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa3f832bef7 in QEventLoop::exec (this=0x7fa3df158e00, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fa3f824327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fa3f8245d05 in QThreadPrivate::start (arg=0x18151a0) at thread/qthread_unix.cpp:331
#8  0x00007fa3f7ca3efc in start_thread (arg=0x7fa3df159700) at pthread_create.c:304
#9  0x00007fa3fd4ce89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fa3de2e1700 (LWP 16762)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa3fd0d0fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fa3fd0d1019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fa3f7ca3efc in start_thread (arg=0x7fa3de2e1700) at pthread_create.c:304
#4  0x00007fa3fd4ce89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fa3dcde9700 (LWP 16763)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa3f82461ab in wait (time=18446744073709551615, this=0x15cbda0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x15cbb20, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fa3fa256864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x15cb2b0, th=0x183ad90) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa3fa258e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x15cb640, th=0x183ad90) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa3fa257ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7fa3dcde8e20, parent=0x15cb2b0, th=0x183ad90) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa3fa257d5b in ThreadWeaver::Thread::run (this=0x183ad90) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa3f8245d05 in QThreadPrivate::start (arg=0x183ad90) at thread/qthread_unix.cpp:331
#8  0x00007fa3f7ca3efc in start_thread (arg=0x7fa3dcde9700) at pthread_create.c:304
#9  0x00007fa3fd4ce89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fa3d655e700 (LWP 16764)):
#0  0x00007fa3fd4c2773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa3f60d6f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa3f60d7429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa3f8357f3e in QEventDispatcherGlib::processEvents (this=0x1b88090, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fa3f832bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa3f832bef7 in QEventLoop::exec (this=0x7fa3d655ddd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fa3f824327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fa3f830ecbf in QInotifyFileSystemWatcherEngine::run (this=0x1b97e90) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa3f8245d05 in QThreadPrivate::start (arg=0x1b97e90) at thread/qthread_unix.cpp:331
#9  0x00007fa3f7ca3efc in start_thread (arg=0x7fa3d655e700) at pthread_create.c:304
#10 0x00007fa3fd4ce89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fa391d55700 (LWP 16778)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa3f82461ab in wait (time=18446744073709551615, this=0x15cbda0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x15cbb20, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fa3fa256864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x15cb2b0, th=0x1bc1ce0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa3fa258e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x15cb640, th=0x1bc1ce0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa3fa257ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7fa391d54e20, parent=0x15cb2b0, th=0x1bc1ce0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa3fa257d5b in ThreadWeaver::Thread::run (this=0x1bc1ce0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa3f8245d05 in QThreadPrivate::start (arg=0x1bc1ce0) at thread/qthread_unix.cpp:331
#8  0x00007fa3f7ca3efc in start_thread (arg=0x7fa391d55700) at pthread_create.c:304
#9  0x00007fa3fd4ce89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fa38e6cb700 (LWP 16794)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa390d451f1 in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00007fa3f7ca3efc in start_thread (arg=0x7fa38e6cb700) at pthread_create.c:304
#3  0x00007fa3fd4ce89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa38deca700 (LWP 16795)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa390d451f1 in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00007fa3f7ca3efc in start_thread (arg=0x7fa38deca700) at pthread_create.c:304
#3  0x00007fa3fd4ce89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa38d6c9700 (LWP 16796)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa390d451f1 in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00007fa3f7ca3efc in start_thread (arg=0x7fa38d6c9700) at pthread_create.c:304
#3  0x00007fa3fd4ce89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa3fdc8d780 (LWP 16759)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fa3fa49f7ee in KParts::StatusBarExtension::statusBar (this=0x57a86b0) at ../../kparts/statusbarextension.cpp:149
#8  0x00007fa3fa49fcf4 in KParts::StatusBarExtension::~StatusBarExtension (this=0x57a86b0, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:99
#9  0x00007fa3fa4a00a9 in KParts::StatusBarExtension::~StatusBarExtension (this=0x57a86b0, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:110
#10 0x00007fa3f833ed75 in QObjectPrivate::deleteChildren (this=0x2189260) at kernel/qobject.cpp:1955
#11 0x00007fa3f8344349 in QObject::~QObject (this=0x58e83f0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007fa3fa484688 in KParts::Part::~Part (this=0x58e83f0, __vtt_parm=0x7fa388c13890, __in_chrg=<optimized out>) at ../../kparts/part.cpp:190
#13 0x00007fa388a0eedc in ?? () from /usr/lib/kde4/dragonpart.so
#14 0x00007fa3fa4848f0 in KParts::Part::slotWidgetDestroyed (this=0x58e83f0) at ../../kparts/part.cpp:353
#15 0x00007fa3fa485ed4 in KParts::Part::qt_metacall (this=0x58e83f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff5328b00) at ./part.moc:82
#16 0x00007fa3fa487ab5 in KParts::ReadOnlyPart::qt_metacall (this=0x58e83f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff5328b00) at ./part.moc:168
#17 0x00007fa388a0ed15 in ?? () from /usr/lib/kde4/dragonpart.so
#18 0x00007fa3f833feba in QMetaObject::activate (sender=0x18753e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff5328b00) at kernel/qobject.cpp:3278
#19 0x00007fa3f834036f in QObject::destroyed (this=<optimized out>, _t1=0x18753e0) at .moc/release-shared/moc_qobject.cpp:149
#20 0x00007fa3f8343ef7 in QObject::~QObject (this=0x18753e0, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#21 0x00007fa3f88a9162 in QWidget::~QWidget (this=0x18753e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#22 0x00007fa3f88a9379 in QWidget::~QWidget (this=0x18753e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#23 0x00007fa3f8343a88 in QObject::event (this=0x18753e0, e=<optimized out>) at kernel/qobject.cpp:1200
#24 0x00007fa3f88ad6eb in QWidget::event (this=0x18753e0, event=0x185cdd0) at kernel/qwidget.cpp:8754
#25 0x00007fa3f885d424 in notify_helper (e=0x185cdd0, receiver=0x18753e0, this=0x14bb100) at kernel/qapplication.cpp:4486
#26 QApplicationPrivate::notify_helper (this=0x14bb100, receiver=0x18753e0, e=0x185cdd0) at kernel/qapplication.cpp:4458
#27 0x00007fa3f8862291 in QApplication::notify (this=0x7ffff5329620, receiver=0x18753e0, e=0x185cdd0) at kernel/qapplication.cpp:4365
#28 0x00007fa3fad95126 in KApplication::notify (this=0x7ffff5329620, receiver=0x18753e0, event=0x185cdd0) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007fa3f832cafc in QCoreApplication::notifyInternal (this=0x7ffff5329620, receiver=0x18753e0, event=0x185cdd0) at kernel/qcoreapplication.cpp:787
#30 0x00007fa3f833051f in sendEvent (event=0x185cdd0, receiver=0x18753e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1487430) at kernel/qcoreapplication.cpp:1428
#32 0x00007fa3f8357a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007fa3f60d6a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007fa3f60d7258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007fa3f60d7429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007fa3f8357ed6 in QEventDispatcherGlib::processEvents (this=0x1488f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#38 0x00007fa3f890507e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007fa3f832bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#40 0x00007fa3f832bef7 in QEventLoop::exec (this=0x7ffff53295b0, flags=...) at kernel/qeventloop.cpp:201
#41 0x00007fa3f8330789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#42 0x00007fa3fd880b97 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_rekonq.so
#43 0x00007fa3fd40e30d in __libc_start_main (main=0x400630, argc=1, ubp_av=0x7ffff5329fb8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff5329fa8) at libc-start.c:226
#44 0x0000000000400661 in _start ()

Possible duplicates by query: bug 290480, bug 290329, bug 287007, bug 283657.

Reported using DrKonqi
Comment 1 Andrea Diamantini 2012-01-14 23:10:11 UTC
*** Bug 290480 has been marked as a duplicate of this bug. ***
Comment 2 Andrea Diamantini 2012-01-14 23:10:19 UTC
*** Bug 291549 has been marked as a duplicate of this bug. ***
Comment 3 Christopher Yeleighton 2012-03-08 14:37:28 UTC
Thread 1 (Thread 0x7f94ba698760 (LWP 3204)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f94b794284e in KParts::StatusBarExtension::statusBar (this=0x1471480) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:149
#8  0x00007f94b7942d54 in KParts::StatusBarExtension::~StatusBarExtension (this=0x1471480, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:99
#9  0x00007f94b7943109 in KParts::StatusBarExtension::~StatusBarExtension (this=0x1471480, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/statusbarextension.cpp:110
#10 0x00007f94b9003465 in QObjectPrivate::deleteChildren (this=0x14524c0) at kernel/qobject.cpp:1964
#11 0x00007f94b9008a09 in QObject::~QObject (this=0x144cf90, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007f94b7927a98 in KParts::Part::~Part (this=0x144cf90, __vtt_parm=0x7f944dcb28f0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/kparts/part.cpp:190
#13 0x00007f944da7a427 in KWebKitPart::~KWebKitPart (this=0x144cf90, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kwebkitpart-1.2.0git20111019/src/kwebkitpart.cpp:182
#14 0x00007f944da7a469 in KWebKitPart::~KWebKitPart (this=0x144cf90, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kwebkitpart-1.2.0git20111019/src/kwebkitpart.cpp:184
#15 0x00007f9451390af0 in Akregator::BrowserFrame::Private::~Private (this=0x12a8df0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe_p.cpp:50
#16 0x00007f9451390be9 in Akregator::BrowserFrame::Private::~Private (this=0x12a8df0, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe_p.cpp:51
#17 0x00007f945138d63a in Akregator::BrowserFrame::~BrowserFrame (this=0x146b590, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe.cpp:63
#18 0x00007f945138d6a9 in Akregator::BrowserFrame::~BrowserFrame (this=0x146b590, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kdepim-4.7.2/akregator/src/browserframe.cpp:64
#19 0x00007f945138b56a in Akregator::FrameManager::slotRemoveFrame (this=0x9cfc60, id=2) at /usr/src/debug/kdepim-4.7.2/akregator/src/framemanager.cpp:108
#20 0x00007f945138c5dc in Akregator::FrameManager::qt_metacall (this=0x9cfc60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8e3ed2b0) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/framemanager.moc:155
#21 0x00007f94b90045aa in QMetaObject::activate (sender=0x12da360, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8e3ed2b0) at kernel/qobject.cpp:3287
#22 0x00007f94518237b1 in Akregator::TabWidget::signalRemoveFrameRequest (this=<optimized out>, _t1=2) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/tabwidget.moc:153
#23 0x00007f9451833586 in Akregator::MainWidget::slotOnShutdown (this=0x12b7af0) at /usr/src/debug/kdepim-4.7.2/akregator/src/mainwidget.cpp:317
#24 0x00007f945182c1e0 in Akregator::Part::slotOnShutdown (this=0x1271f90) at /usr/src/debug/kdepim-4.7.2/akregator/src/akregator_part.cpp:305
#25 0x00007f9451830c44 in Akregator::Part::qt_metacall (this=0x1271f90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8e3ed380) at /usr/src/debug/kdepim-4.7.2/build/akregator/src/akregator_part.moc:171
#26 0x00007f94b90045aa in QMetaObject::activate (sender=0x7fff8e3ed460, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3287
#27 0x00007f94b8ff4e4d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1069
#28 0x0000000000403919 in ?? ()
#29 0x00007f94b7b7823d in __libc_start_main (main=0x402e30, argc=3, ubp_av=0x7fff8e3eda88, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff8e3eda78) at libc-start.c:226
#30 0x0000000000403e61 in _start ()
Comment 4 Jekyll Wu 2012-05-31 19:23:48 UTC

*** This bug has been marked as a duplicate of bug 283657 ***