Bug 290329 - For this
Summary: For this
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.8.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-01 16:26 UTC by Keijo
Modified: 2012-01-01 17:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keijo 2012-01-01 16:26:01 UTC
Application: rekonq (0.8.0)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- Custom settings of the application:
http://www.radiopooki.fi/nettiradio.php 
I tried to listen to radiopookia which I like to listen to that style, and other online radios.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fcc6697e780 (LWP 2682))]

Thread 8 (Thread 0x7fcc525a5700 (LWP 2683)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fcc6524cc2c in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7fcc65c03220) at wtf/FastMalloc.cpp:2495
#2  0x00007fcc6524cd59 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007fcc60980efc in start_thread (arg=0x7fcc525a5700) at pthread_create.c:304
#4  0x00007fcc661ab89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fcc51c9c700 (LWP 2684)):
#0  0x00007fcc6619f773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fcc5edb3f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcc5edb4429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcc61034f3e in QEventDispatcherGlib::processEvents (this=0x10a9fd0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fcc61008cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fcc61008ef7 in QEventLoop::exec (this=0x7fcc51c9be00, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fcc60f2027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fcc60f22d05 in QThreadPrivate::start (arg=0xff7b20) at thread/qthread_unix.cpp:331
#8  0x00007fcc60980efc in start_thread (arg=0x7fcc51c9c700) at pthread_create.c:304
#9  0x00007fcc661ab89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fcc50e14700 (LWP 2685)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fcc65dadfe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fcc65dae019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fcc60980efc in start_thread (arg=0x7fcc50e14700) at pthread_create.c:304
#4  0x00007fcc661ab89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fcc4b7c3700 (LWP 2686)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fcc60f231ab in wait (time=18446744073709551615, this=0xd90d90) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xd90e80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fcc62f33864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xd90d00, th=0x10f3960) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fcc62f35e0b in ThreadWeaver::WorkingHardState::applyForWork (this=0xd93eb0, th=0x10f3960) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fcc62f34ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7fcc4b7c2e20, parent=0xd90d00, th=0x10f3960) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fcc62f34d5b in ThreadWeaver::Thread::run (this=0x10f3960) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fcc60f22d05 in QThreadPrivate::start (arg=0x10f3960) at thread/qthread_unix.cpp:331
#8  0x00007fcc60980efc in start_thread (arg=0x7fcc4b7c3700) at pthread_create.c:304
#9  0x00007fcc661ab89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fcc08c88700 (LWP 2687)):
#0  0x00007fcc6619f773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fcc5edb3f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcc5edb4429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcc61034f3e in QEventDispatcherGlib::processEvents (this=0x7fcc4c016730, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fcc61008cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fcc61008ef7 in QEventLoop::exec (this=0x7fcc08c87dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fcc60f2027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fcc60febcbf in QInotifyFileSystemWatcherEngine::run (this=0x12c6780) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fcc60f22d05 in QThreadPrivate::start (arg=0x12c6780) at thread/qthread_unix.cpp:331
#9  0x00007fcc60980efc in start_thread (arg=0x7fcc08c88700) at pthread_create.c:304
#10 0x00007fcc661ab89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fcbf7592700 (LWP 2707)):
#0  0x00007fcc60983034 in __pthread_mutex_lock (mutex=0x1d25538) at pthread_mutex_lock.c:61
#1  0x00007fcc5edb3fcc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcc5edb4792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcbf5c399cb in ?? () from /usr/lib/gio/modules/libdconfsettings.so
#4  0x00007fcc5edd92b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fcc60980efc in start_thread (arg=0x7fcbf7592700) at pthread_create.c:304
#6  0x00007fcc661ab89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fcbf5a2f700 (LWP 2709)):
#0  0x00007fcc5edb3d77 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fcc5edb4792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcc03531516 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#3  0x00007fcc5edd92b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcc60980efc in start_thread (arg=0x7fcbf5a2f700) at pthread_create.c:304
#5  0x00007fcc661ab89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcc6697e780 (LWP 2682)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fcc6317c7ee in KParts::StatusBarExtension::statusBar (this=0x140a720) at ../../kparts/statusbarextension.cpp:149
#8  0x00007fcc6317ccf4 in KParts::StatusBarExtension::~StatusBarExtension (this=0x140a720, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:99
#9  0x00007fcc6317d0a9 in KParts::StatusBarExtension::~StatusBarExtension (this=0x140a720, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:110
#10 0x00007fcc6101bd75 in QObjectPrivate::deleteChildren (this=0x17de940) at kernel/qobject.cpp:1955
#11 0x00007fcc61021349 in QObject::~QObject (this=0x17db540, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007fcc63161688 in KParts::Part::~Part (this=0x17db540, __vtt_parm=0x7fcc01233890, __in_chrg=<optimized out>) at ../../kparts/part.cpp:190
#13 0x00007fcc0102eedc in ?? () from /usr/lib/kde4/dragonpart.so
#14 0x00007fcc6101bd75 in QObjectPrivate::deleteChildren (this=0x167bad0) at kernel/qobject.cpp:1955
#15 0x00007fcc61021349 in QObject::~QObject (this=0x140b260, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#16 0x00007fcc664fb319 in WebPage::~WebPage (this=0x140b260, __in_chrg=<optimized out>) at /build/buildd/rekonq-0.8.0/src/webpage.cpp:303
#17 0x00007fcc64989076 in QWebViewPrivate::detachCurrentPage (this=0x1669320) at Api/qwebview.cpp:364
#18 0x00007fcc649890a3 in ~QWebViewPrivate (this=0x1669320, __in_chrg=<optimized out>) at Api/qwebview.cpp:60
#19 QWebViewPrivate::~QWebViewPrivate (this=0x1669320, __in_chrg=<optimized out>) at Api/qwebview.cpp:61
#20 0x00007fcc64988d7f in QWebView::~QWebView (this=0x12a70d0, __in_chrg=<optimized out>) at Api/qwebview.cpp:327
#21 0x00007fcc665072ba in WebView::~WebView (this=0x12a70d0, __in_chrg=<optimized out>) at /build/buildd/rekonq-0.8.0/src/webview.cpp:106
#22 0x00007fcc665072f9 in WebView::~WebView (this=0x12a70d0, __in_chrg=<optimized out>) at /build/buildd/rekonq-0.8.0/src/webview.cpp:117
#23 0x00007fcc6101bd75 in QObjectPrivate::deleteChildren (this=0x1473d90) at kernel/qobject.cpp:1955
#24 0x00007fcc615860da in QWidget::~QWidget (this=0x12aff70, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#25 0x00007fcc6650a029 in WebTab::~WebTab (this=0x12aff70, __in_chrg=<optimized out>) at /build/buildd/rekonq-0.8.0/src/webtab.cpp:101
#26 0x00007fcc6101bd75 in QObjectPrivate::deleteChildren (this=0xdbc370) at kernel/qobject.cpp:1955
#27 0x00007fcc615860da in QWidget::~QWidget (this=0xdd7b20, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#28 0x00007fcc6198e469 in QStackedWidget::~QStackedWidget (this=0xdd7b20, __in_chrg=<optimized out>) at widgets/qstackedwidget.cpp:151
#29 0x00007fcc6101bd75 in QObjectPrivate::deleteChildren (this=0xdd7850) at kernel/qobject.cpp:1955
#30 0x00007fcc615860da in QWidget::~QWidget (this=0xdd77e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#31 0x00007fcc664d49a4 in ~MainView (this=0xdd77e0, __in_chrg=<optimized out>) at /build/buildd/rekonq-0.8.0/src/mainview.h:63
#32 MainView::~MainView (this=0xdd77e0, __in_chrg=<optimized out>) at /build/buildd/rekonq-0.8.0/src/mainview.h:63
#33 0x00007fcc6101bd75 in QObjectPrivate::deleteChildren (this=0xf22420) at kernel/qobject.cpp:1955
#34 0x00007fcc615860da in QWidget::~QWidget (this=0xf223f0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#35 0x00007fcc61586379 in QWidget::~QWidget (this=0xf223f0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#36 0x00007fcc6101bd75 in QObjectPrivate::deleteChildren (this=0xdd4c00) at kernel/qobject.cpp:1955
#37 0x00007fcc615860da in QWidget::~QWidget (this=0xc36450, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#38 0x00007fcc664d5171 in MainWindow::~MainWindow (this=0xc36450, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /build/buildd/rekonq-0.8.0/src/mainwindow.cpp:174
#39 0x00007fcc664d51c9 in MainWindow::~MainWindow (this=0xc36450, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /build/buildd/rekonq-0.8.0/src/mainwindow.cpp:181
#40 0x00007fcc61020a88 in QObject::event (this=0xc36450, e=<optimized out>) at kernel/qobject.cpp:1200
#41 0x00007fcc6158a6eb in QWidget::event (this=0xc36450, event=0x1da2730) at kernel/qwidget.cpp:8754
#42 0x00007fcc6194cceb in QMainWindow::event (this=0xc36450, event=0x1da2730) at widgets/qmainwindow.cpp:1478
#43 0x00007fcc6153a424 in notify_helper (e=0x1da2730, receiver=0xc36450, this=0xc37510) at kernel/qapplication.cpp:4486
#44 QApplicationPrivate::notify_helper (this=0xc37510, receiver=0xc36450, e=0x1da2730) at kernel/qapplication.cpp:4458
#45 0x00007fcc6153f291 in QApplication::notify (this=0x7fff60a6f170, receiver=0xc36450, e=0x1da2730) at kernel/qapplication.cpp:4365
#46 0x00007fcc63a72126 in KApplication::notify (this=0x7fff60a6f170, receiver=0xc36450, event=0x1da2730) at ../../kdeui/kernel/kapplication.cpp:311
#47 0x00007fcc61009afc in QCoreApplication::notifyInternal (this=0x7fff60a6f170, receiver=0xc36450, event=0x1da2730) at kernel/qcoreapplication.cpp:787
#48 0x00007fcc6100d51f in sendEvent (event=0x1da2730, receiver=0xc36450) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xc04430) at kernel/qcoreapplication.cpp:1428
#50 0x00007fcc61034a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#51 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#52 0x00007fcc5edb3a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#53 0x00007fcc5edb4258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#54 0x00007fcc5edb4429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#55 0x00007fcc61034ed6 in QEventDispatcherGlib::processEvents (this=0xc05f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#56 0x00007fcc615e207e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#57 0x00007fcc61008cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#58 0x00007fcc61008ef7 in QEventLoop::exec (this=0x7fff60a6f100, flags=...) at kernel/qeventloop.cpp:201
#59 0x00007fcc6100d789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#60 0x00007fcc6655db97 in kdemain (argc=1, argv=<optimized out>) at /build/buildd/rekonq-0.8.0/src/main.cpp:215
#61 0x00007fcc660eb30d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=1, ubp_av=0x7fff60a6fb08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff60a6faf8) at libc-start.c:226
#62 0x0000000000400661 in _start ()

Possible duplicates by query: bug 287007, bug 283657.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-01-01 17:08:26 UTC

*** This bug has been marked as a duplicate of bug 283657 ***