Bug 286124 - bookmark editor crashes on exit.
Summary: bookmark editor crashes on exit.
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: keditbookmarks
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-08 18:15 UTC by Hussam Al-Tayeb
Modified: 2011-11-10 12:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hussam Al-Tayeb 2011-11-08 18:15:15 UTC
Application: keditbookmarks (4.7.3 (4.7.3))
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.0-4-ARCH i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:
The bookmark editor crashes when I click update all favicons then later close the bookmark editor.

The crash can be reproduced every time.

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4aa1710 (LWP 14577))]

Thread 6 (Thread 0xae434b70 (LWP 14579)):
#0  0xb77ee424 in __kernel_vsyscall ()
#1  0xb55168fb in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb76e442c in pthread_cond_wait () from /lib/libc.so.6
#3  0xb17c9c53 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb17c9d6f in ?? () from /usr/lib/libQtWebKit.so.4
#5  0xb001a70c in ?? () from /usr/lib/libGL.so.1
#6  0x00000000 in ?? ()

Thread 5 (Thread 0xadaffb70 (LWP 14580)):
#0  0xb5515bf4 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb76e4684 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0xb52fb5cf in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#3  0xb52fc387 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb52fc97a in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb5df0b97 in QEventDispatcherGlib::processEvents (this=0x8b58f38, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb5db885d in QEventLoop::processEvents (this=0xadaff220, flags=...) at kernel/qeventloop.cpp:149
#7  0xb5db8af9 in QEventLoop::exec (this=0xadaff220, flags=...) at kernel/qeventloop.cpp:204
#8  0xb5c94c6d in QThread::exec (this=0x8b62298) at thread/qthread.cpp:501
#9  0xb5c94d3b in QThread::run (this=0x8b62298) at thread/qthread.cpp:568
#10 0xb5c97fba in QThreadPrivate::start (arg=0x8b62298) at thread/qthread_unix.cpp:298
#11 0xb001a70c in ?? () from /usr/lib/libGL.so.1
#12 0x00000000 in ?? ()

Thread 4 (Thread 0xac2a3b70 (LWP 14593)):
#0  0xb77ee424 in __kernel_vsyscall ()
#1  0xb55168fb in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb76e442c in pthread_cond_wait () from /lib/libc.so.6
#3  0xacb6712d in queue_processor(void*) () from /usr/lib/jvm/java-7-openjdk/lib/IcedTeaPlugin.so
#4  0xb001a70c in ?? () from /usr/lib/libGL.so.1
#5  0x00000000 in ?? ()

Thread 3 (Thread 0xabaa2b70 (LWP 14594)):
#0  0xb77ee424 in __kernel_vsyscall ()
#1  0xb55168fb in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb76e442c in pthread_cond_wait () from /lib/libc.so.6
#3  0xacb6712d in queue_processor(void*) () from /usr/lib/jvm/java-7-openjdk/lib/IcedTeaPlugin.so
#4  0xb001a70c in ?? () from /usr/lib/libGL.so.1
#5  0x00000000 in ?? ()

Thread 2 (Thread 0xab2a1b70 (LWP 14595)):
#0  0xb77ee424 in __kernel_vsyscall ()
#1  0xb55168fb in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb76e442c in pthread_cond_wait () from /lib/libc.so.6
#3  0xacb6712d in queue_processor(void*) () from /usr/lib/jvm/java-7-openjdk/lib/IcedTeaPlugin.so
#4  0xb001a70c in ?? () from /usr/lib/libGL.so.1
#5  0x00000000 in ?? ()

Thread 1 (Thread 0xb4aa1710 (LWP 14577)):
[KCrash Handler]
#7  0xb5ea62e2 in qt_meta_stringdata_QObject () from /usr/lib/libQtCore.so.4
#8  0xb75cba88 in KParts::StatusBarExtension::statusBar (this=0x8c0db18) at /home/hussam/packages/kdelibs/src/kdelibs/kparts/statusbarextension.cpp:149
#9  0xb75cc129 in KParts::StatusBarExtension::~StatusBarExtension (this=0x8c0db18, __in_chrg=<optimized out>) at /home/hussam/packages/kdelibs/src/kdelibs/kparts/statusbarextension.cpp:99
#10 0xb75cc212 in KParts::StatusBarExtension::~StatusBarExtension (this=0x8c0db18, __in_chrg=<optimized out>) at /home/hussam/packages/kdelibs/src/kdelibs/kparts/statusbarextension.cpp:110
#11 0xb5dd0c90 in QObjectPrivate::deleteChildren (this=0x8be7d20) at kernel/qobject.cpp:1907
#12 0xb5dd73f4 in QObject::~QObject (this=0x88d3e18, __in_chrg=<optimized out>) at kernel/qobject.cpp:926
#13 0xb75aea89 in KParts::Part::~Part (this=0x88d3e18, __vtt_parm=0xb1fe14e8, __in_chrg=<optimized out>) at /home/hussam/packages/kdelibs/src/kdelibs/kparts/part.cpp:190
#14 0xb75af96c in KParts::ReadOnlyPart::~ReadOnlyPart (this=0x88d3e18, __vtt_parm=0xb1fe14e4, __in_chrg=<optimized out>) at /home/hussam/packages/kdelibs/src/kdelibs/kparts/part.cpp:460
#15 0xb1fa449e in ?? () from /usr/lib/kde4/kwebkitpart.so
#16 0xb1fa4502 in ?? () from /usr/lib/kde4/kwebkitpart.so
#17 0xb77a4b89 in FavIconUpdater::~FavIconUpdater (this=0x8ac2608, __in_chrg=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/faviconupdater.cpp:73
#18 0xb77a4bd2 in FavIconUpdater::~FavIconUpdater (this=0x8ac2608, __in_chrg=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/faviconupdater.cpp:74
#19 0xb77a4151 in FavIconsItr::~FavIconsItr (this=0x8ada370, __in_chrg=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/favicons.cpp:44
#20 0xb77a4192 in FavIconsItr::~FavIconsItr (this=0x8ada370, __in_chrg=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/favicons.cpp:45
#21 0xb5dd0c90 in QObjectPrivate::deleteChildren (this=0x8928340) at kernel/qobject.cpp:1907
#22 0xb5dd73f4 in QObject::~QObject (this=0x88fb108, __in_chrg=<optimized out>) at kernel/qobject.cpp:926
#23 0xb77a2b30 in BookmarkIteratorHolder::~BookmarkIteratorHolder (this=0x88fb108, __in_chrg=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/bookmarkiterator.h:80
#24 0xb77a47c2 in FavIconsItrHolder::~FavIconsItrHolder (this=0x88fb108, __in_chrg=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/favicons.h:27
#25 0xb7799281 in ActionsImpl::~ActionsImpl (this=0x88e9458, __in_chrg=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/actionsimpl.cpp:456
#26 0xb77992d2 in ActionsImpl::~ActionsImpl (this=0x88e9458, __in_chrg=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/actionsimpl.cpp:458
#27 0xb77945eb in KEBApp::~KEBApp (this=0x877f028, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/toplevel.cpp:426
#28 0xb77946a2 in KEBApp::~KEBApp (this=0x877f028, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/toplevel.cpp:429
#29 0xb5dd0393 in qDeleteInEventHandler (o=0x877f028) at kernel/qobject.cpp:4276
#30 0xb5dd7c78 in QObject::event (this=0x877f028, e=0x8d105e8) at kernel/qobject.cpp:1175
#31 0xb63a96e3 in QWidget::event (this=0x877f028, event=0x8d105e8) at kernel/qwidget.cpp:8809
#32 0xb683dacc in QMainWindow::event (this=0x877f028, event=0x8d105e8) at widgets/qmainwindow.cpp:1478
#33 0xb7084434 in KMainWindow::event (this=0x877f028, ev=0x8d105e8) at /home/hussam/packages/kdelibs/src/kdelibs/kdeui/widgets/kmainwindow.cpp:1084
#34 0xb70cb902 in KXmlGuiWindow::event (this=0x877f028, ev=0x8d105e8) at /home/hussam/packages/kdelibs/src/kdelibs/kdeui/xmlgui/kxmlguiwindow.cpp:126
#35 0xb6345a9c in notify_helper (e=0x8d105e8, receiver=0x877f028, this=0x8786fa0) at kernel/qapplication.cpp:4518
#36 QApplicationPrivate::notify_helper (this=0x8786fa0, receiver=0x877f028, e=0x8d105e8) at kernel/qapplication.cpp:4490
#37 0xb634bb1d in QApplication::notify (this=0x8786fa0, receiver=0x877f028, e=0x8d105e8) at kernel/qapplication.cpp:4379
#38 0xb6fa4b88 in KApplication::notify (this=0xbfcfde4c, receiver=0x877f028, event=0x8d105e8) at /home/hussam/packages/kdelibs/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#39 0xb5dba4fe in QCoreApplication::notifyInternal (this=0xbfcfde4c, receiver=0x877f028, event=0x8d105e8) at kernel/qcoreapplication.cpp:876
#40 0xb5dbe2c0 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x874dce0) at kernel/qcoreapplication.cpp:1500
#42 0xb5dbe68c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#43 0xb5df06a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#44 postEventSourceDispatch (s=0x8789090) at kernel/qeventdispatcher_glib.cpp:279
#45 0xb52fbfaf in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#46 0xb52fc6e0 in ?? () from /usr/lib/libglib-2.0.so.0
#47 0xb52fc97a in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#48 0xb5df0b37 in QEventDispatcherGlib::processEvents (this=0x874d8d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#49 0xb6408a6a in QGuiEventDispatcherGlib::processEvents (this=0x874d8d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0xb5db885d in QEventLoop::processEvents (this=0xbfcfdda4, flags=...) at kernel/qeventloop.cpp:149
#51 0xb5db8af9 in QEventLoop::exec (this=0xbfcfdda4, flags=...) at kernel/qeventloop.cpp:204
#52 0xb5dbe73a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#53 0xb6343854 in QApplication::exec () at kernel/qapplication.cpp:3779
#54 0xb7792d98 in kdemain (argc=6, argv=0xbfcfe114) at /home/hussam/packages/kdebase/src/kde-baseapps/keditbookmarks/main.cpp:212
#55 0x0804851b in main (argc=6, argv=0xbfcfe114) at /home/hussam/packages/kdebase/src/build/keditbookmarks/keditbookmarks_dummy.cpp:3

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-10 12:19:03 UTC
It probably is a duplicate. If it is not fixed in KDE 4.7.4, please add a comment.

*** This bug has been marked as a duplicate of bug 283657 ***
Comment 2 Hussam Al-Tayeb 2011-11-10 12:49:06 UTC
yes, I did a update to latest 4.7 branch and crash stopped. thank you :)