Bug 289546 - Crash extracting .zip to desktop file
Summary: Crash extracting .zip to desktop file
Status: RESOLVED DUPLICATE of bug 283657
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-21 23:36 UTC by gackthugo
Modified: 2011-12-22 00:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gackthugo 2011-12-21 23:36:50 UTC
Application: ark (2.17)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Openned a .zip file, draged the content to the desktop, and crashed after. No file appeared in desktop, tried again, and asked to replace the file or change the name of it.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Ark (ark), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77fba50 (LWP 5043))]

Thread 2 (Thread 0xb668cb70 (LWP 5047)):
#0  0x006b8d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x02ff47d5 in do_gettime (frac=0xb668c020, sec=0xb668c018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x030c74b6 in QTimerInfoList::updateCurrentTime (this=0x9036a14) at kernel/qeventdispatcher_unix.cpp:339
#4  0x030c780a in QTimerInfoList::timerWait (this=0x9036a14, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x030c6053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb668c12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x030c60ed in timerSourcePrepare (source=0x90369e0, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x028ee88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x028ef637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x028efc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x030c6b37 in QEventDispatcherGlib::processEvents (this=0x8f956e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x030971dd in QEventLoop::processEvents (this=0xb668c2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x03097421 in QEventLoop::exec (this=0xb668c2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x02f9a90b in QThread::exec (this=0x8fcf778) at thread/qthread.cpp:498
#14 0x03077e2d in QInotifyFileSystemWatcherEngine::run (this=0x8fcf778) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x02f9d7b3 in QThreadPrivate::start (arg=0x8fcf778) at thread/qthread_unix.cpp:331
#16 0x006a0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x02e120ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77fba50 (LWP 5043)):
[KCrash Handler]
#7  0x031ce16b in typeinfo for QObjectData () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0x00a5dc26 in KParts::StatusBarExtension::statusBar (this=0x8fa5010) at ../../kparts/statusbarextension.cpp:149
#9  0x00a5e159 in KParts::StatusBarExtension::~StatusBarExtension (this=0x8fa5010, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:99
#10 0x00a5e4f2 in KParts::StatusBarExtension::~StatusBarExtension (this=0x8fa5010, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:110
#11 0x030ac841 in QObjectPrivate::deleteChildren (this=0x8fbcdc0) at kernel/qobject.cpp:1955
#12 0x030b1439 in QObject::~QObject (this=0x90fa410, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#13 0x00a3fa84 in KParts::Part::~Part (this=0x90fa410, __vtt_parm=0x568bc08, __in_chrg=<optimized out>) at ../../kparts/part.cpp:190
#14 0x00a40dec in KParts::ReadOnlyPart::~ReadOnlyPart (this=0x90fa410, __vtt_parm=0x568bc04, __in_chrg=<optimized out>) at ../../kparts/part.cpp:460
#15 0x056870ed in ?? () from /usr/lib/kde4/dragonpart.so
#16 0x00a3fd40 in KParts::Part::slotWidgetDestroyed (this=0x90fa410) at ../../kparts/part.cpp:353
#17 0x00a416bc in KParts::Part::qt_metacall (this=0x90fa410, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe0dc88) at ./part.moc:82
#18 0x00a434d2 in KParts::ReadOnlyPart::qt_metacall (this=0x90fa410, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfe0dc88) at ./part.moc:168
#19 0x05686ee2 in ?? () from /usr/lib/kde4/dragonpart.so
#20 0x0309eb7d in metacall (argv=0xbfe0dc88, idx=6, cl=QMetaObject::InvokeMetaMethod, object=0x90fa410) at kernel/qmetaobject.cpp:237
#21 QMetaObject::metacall (object=0x90fa410, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfe0dc88) at kernel/qmetaobject.cpp:232
#22 0x030ada6a in QMetaObject::activate (sender=0x8fb9790, m=0x31ca390, local_signal_index=0, argv=0xbfe0dc88) at kernel/qobject.cpp:3278
#23 0x030adf05 in QObject::destroyed (this=0x8fb9790, _t1=0x8fb9790) at .moc/release-shared/moc_qobject.cpp:149
#24 0x030b0fed in QObject::~QObject (this=0x8fb9790, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#25 0x010be02f in QWidget::~QWidget (this=0x8fb9790, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#26 0x010be262 in QWidget::~QWidget (this=0x8fb9790, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#27 0x030ac841 in QObjectPrivate::deleteChildren (this=0x90cd0b0) at kernel/qobject.cpp:1955
#28 0x010bdf8e in QWidget::~QWidget (this=0x90e25f0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#29 0x014c790f in QFrame::~QFrame (this=0x90e25f0, __in_chrg=<optimized out>) at widgets/qframe.cpp:240
#30 0x00d1d4df in KHBox::~KHBox (this=0x90e25f0, __in_chrg=<optimized out>) at ../../kdeui/widgets/khbox.cpp:49
#31 0x00d774cf in KVBox::~KVBox (this=0x90e25f0, __in_chrg=<optimized out>) at ../../kdeui/widgets/kvbox.cpp:27
#32 0x00d77512 in KVBox::~KVBox (this=0x90e25f0, __in_chrg=<optimized out>) at ../../kdeui/widgets/kvbox.cpp:29
#33 0x030ac841 in QObjectPrivate::deleteChildren (this=0x90e65a0) at kernel/qobject.cpp:1955
#34 0x010bdf8e in QWidget::~QWidget (this=0x90f2ce8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#35 0x0159fc15 in QDialog::~QDialog (this=0x90f2ce8, __in_chrg=<optimized out>) at dialogs/qdialog.cpp:318
#36 0x00b99424 in KDialog::~KDialog (this=0x90f2ce8, __in_chrg=<optimized out>) at ../../kdeui/dialogs/kdialog.cpp:201
#37 0x08419823 in ArkViewer::~ArkViewer (this=0x90f2ce8, __in_chrg=<optimized out>) at ../../../ark/part/arkviewer.cpp:56
#38 0x08419862 in ArkViewer::~ArkViewer (this=0x90f2ce8, __in_chrg=<optimized out>) at ../../../ark/part/arkviewer.cpp:58
#39 0x030ac841 in QObjectPrivate::deleteChildren (this=0x8dcef10) at kernel/qobject.cpp:1955
#40 0x010bdf8e in QWidget::~QWidget (this=0x8d94688, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#41 0x014c790f in QFrame::~QFrame (this=0x8d94688, __in_chrg=<optimized out>) at widgets/qframe.cpp:240
#42 0x0152bc0c in QSplitter::~QSplitter (this=0x8d94688, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1050
#43 0x0152bc62 in QSplitter::~QSplitter (this=0x8d94688, __in_chrg=<optimized out>) at widgets/qsplitter.cpp:1056
#44 0x00a3fa5b in KParts::Part::~Part (this=0x8da4c70, __vtt_parm=0x84314cc, __in_chrg=<optimized out>) at ../../kparts/part.cpp:209
#45 0x00a40dec in KParts::ReadOnlyPart::~ReadOnlyPart (this=0x8da4c70, __vtt_parm=0x84314c8, __in_chrg=<optimized out>) at ../../kparts/part.cpp:460
#46 0x00a40f30 in KParts::ReadWritePart::~ReadWritePart (this=0x8da4c70, __vtt_parm=0x84314c4, __in_chrg=<optimized out>) at ../../kparts/part.cpp:773
#47 0x0840d20d in Ark::Part::~Part (this=0x8da4c70, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../ark/part/part.cpp:131
#48 0x0840d282 in Ark::Part::~Part (this=0x8da4c70, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../ark/part/part.cpp:139
#49 0x08054079 in MainWindow::~MainWindow (this=0x8d69698, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../ark/app/mainwindow.cpp:72
#50 0x08054130 in MainWindow::~MainWindow (this=0x8d69698, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../ark/app/mainwindow.cpp:74
#51 0x030ab5f3 in qDeleteInEventHandler (o=0x8d69698) at kernel/qobject.cpp:3986
#52 0x030b0b80 in QObject::event (this=0x8d69698, e=0x90d35d0) at kernel/qobject.cpp:1200
#53 0x010c2c62 in QWidget::event (this=0x8d69698, event=0x90d35d0) at kernel/qwidget.cpp:8754
#54 0x014e54cc in QMainWindow::event (this=0x8d69698, event=0x90d35d0) at widgets/qmainwindow.cpp:1478
#55 0x00d35194 in KMainWindow::event (this=0x8d69698, ev=0x90d35d0) at ../../kdeui/widgets/kmainwindow.cpp:1084
#56 0x00d7d372 in KXmlGuiWindow::event (this=0x8d69698, ev=0x90d35d0) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#57 0x01068d54 in notify_helper (e=0x90d35d0, receiver=0x8d69698, this=0x8c0f080) at kernel/qapplication.cpp:4486
#58 QApplicationPrivate::notify_helper (this=0x8c0f080, receiver=0x8d69698, e=0x90d35d0) at kernel/qapplication.cpp:4458
#59 0x0106e1a8 in QApplication::notify (this=0x8c0f080, receiver=0x8d69698, e=0x90d35d0) at kernel/qapplication.cpp:4451
#60 0x00c59681 in KApplication::notify (this=0xbfe0eb8c, receiver=0x8d69698, event=0x90d35d0) at ../../kdeui/kernel/kapplication.cpp:311
#61 0x0309819e in QCoreApplication::notifyInternal (this=0xbfe0eb8c, receiver=0x8d69698, event=0x90d35d0) at kernel/qcoreapplication.cpp:787
#62 0x0309bf93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#63 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8bf1520) at kernel/qcoreapplication.cpp:1428
#64 0x0309c0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#65 0x030c66a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#66 postEventSourceDispatch (s=0x8c14150) at kernel/qeventdispatcher_glib.cpp:277
#67 0x028ef25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#68 0x028ef990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#69 0x028efc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#70 0x030c6ada in QEventDispatcherGlib::processEvents (this=0x8bf2248, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#71 0x01120e3a in QGuiEventDispatcherGlib::processEvents (this=0x8bf2248, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#72 0x030971dd in QEventLoop::processEvents (this=0xbfe0ea94, flags=...) at kernel/qeventloop.cpp:149
#73 0x03097421 in QEventLoop::exec (this=0xbfe0ea94, flags=...) at kernel/qeventloop.cpp:201
#74 0x0309c19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#75 0x010668f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#76 0x080507ac in main (argc=) at ../../../ark/app/main.cpp:209

Possible duplicates by query: bug 288460.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-12-22 00:06:47 UTC

*** This bug has been marked as a duplicate of bug 283657 ***