Bug 305534 - Annotations don't show all non-ASCII letters
Summary: Annotations don't show all non-ASCII letters
Status: RESOLVED UPSTREAM
Alias: None
Product: okular
Classification: Applications
Component: PDF backend (show other bugs)
Version: 21.08.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 310154 330527 349672 371214 385852 400474 407956 414349 417643 419414 421452 422044 422118 423258 424708 425290 425429 427154 427355 427470 431350 431833 431976 432176 432236 432435 433016 434583 435244 435857 436173 436475 436857 436860 436934 437086 437248 437375 437710 439056 439078 439304 445674 445919 453983 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-21 06:55 UTC by opensuse.lietuviu.kalba
Modified: 2022-08-04 14:50 UTC (History)
53 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
example (257.98 KB, image/png)
2012-08-21 06:55 UTC, opensuse.lietuviu.kalba
Details
attachment-13466-0.html (1.22 KB, text/html)
2021-01-28 09:25 UTC, Joao Lamares
Details

Note You need to log in before you can comment on or make changes to this bug.
Description opensuse.lietuviu.kalba 2012-08-21 06:55:01 UTC
I made a note in Okular, but it don't show all Lithuanian letters.


Reproducible: Always

Steps to Reproduce:
1. In Okular press F6
2. Select second type of notes/anotation
3. write text "Evoliucija nereiškia to, kad, pvz., paukščiams privalėjo atsirasti sparnai
arba/ir, kaip ir žmonėms, – sąmonė."
Actual Results:  
In new text box there is no letters: ą, č, ė

Expected Results:  
Text has all letters
Comment 1 opensuse.lietuviu.kalba 2012-08-21 06:55:39 UTC
Created attachment 73345 [details]
example
Comment 2 Fabio D'Urso 2014-05-08 15:24:54 UTC
*** Bug 330527 has been marked as a duplicate of this bug. ***
Comment 3 Fabio D'Urso 2014-05-08 15:26:59 UTC
It's a Poppler issue. I'm sure there is already some Poppler bug about this.
Anyway, thanks for caring about Okular :)
Comment 4 Fabio D'Urso 2014-05-11 19:57:51 UTC
*** Bug 310154 has been marked as a duplicate of this bug. ***
Comment 6 Yuri Chornoivan 2015-06-28 05:22:48 UTC
*** Bug 349672 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2016-10-20 00:50:02 UTC
*** Bug 371214 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2017-10-25 13:41:26 UTC
*** Bug 385852 has been marked as a duplicate of this bug. ***
Comment 9 Yuri Chornoivan 2018-10-30 10:13:21 UTC
*** Bug 400474 has been marked as a duplicate of this bug. ***
Comment 10 Rui Zhao 2019-05-26 10:33:05 UTC
*** Bug 407956 has been marked as a duplicate of this bug. ***
Comment 11 Yuri Chornoivan 2019-11-21 06:22:28 UTC
*** Bug 414349 has been marked as a duplicate of this bug. ***
Comment 12 opensuse.lietuviu.kalba 2020-01-06 10:28:03 UTC
Upstream bug URL:
https://gitlab.freedesktop.org/poppler/poppler/issues/362
Comment 13 Yuri Chornoivan 2020-02-14 14:49:55 UTC
*** Bug 417643 has been marked as a duplicate of this bug. ***
Comment 14 Yuri Chornoivan 2020-03-30 13:24:53 UTC
*** Bug 419414 has been marked as a duplicate of this bug. ***
Comment 15 Yuri Chornoivan 2020-05-13 09:53:43 UTC
*** Bug 421452 has been marked as a duplicate of this bug. ***
Comment 16 Yuri Chornoivan 2020-05-25 10:53:53 UTC
*** Bug 422044 has been marked as a duplicate of this bug. ***
Comment 17 Yuri Chornoivan 2020-05-27 05:35:18 UTC
*** Bug 422118 has been marked as a duplicate of this bug. ***
Comment 18 light9876 2020-05-27 10:43:23 UTC
Is there no hope for this issue to be fixed? It has persisted for nearly 8 years..
Comment 19 Krzysztof Kardas 2020-05-27 11:16:50 UTC
Same question from me - on the git there was a discussion about supporting the developer who will try to fix it but without any response. Sorry but Okular editor is useless without this support.
Comment 20 Oliver Sander 2020-05-27 11:28:32 UTC
It's still a lack of resources.  Okular is still mainly developed by part-time volunteers, and the problem is a bit too challenging for a small side-project.
Comment 21 Albert Astals Cid 2020-05-27 18:20:11 UTC
(In reply to Oliver Sander from comment #20)
> It's still a lack of resources.  Okular is still mainly developed by
> part-time volunteers, and the problem is a bit too challenging for a small
> side-project.

I disagree, nothing is too challenging for a small side project, fixing that issue is not harder than writing Okular from scratch like we did as part-time developers.

Also, as mentioned, this is not something that actually needs fixing on Okular, but on poppler, so please please please stop writing here.
Comment 22 Albert Astals Cid 2020-05-27 18:20:52 UTC
(In reply to Krzysztof Kardas from comment #19)
> Same question from me - on the git there was a discussion about supporting
> the developer who will try to fix it but without any response. Sorry but
> Okular editor is useless without this support.

I'll give you back the 0 euros you paid for it if you want.
Comment 23 Yuri Chornoivan 2020-06-20 07:31:01 UTC
*** Bug 423258 has been marked as a duplicate of this bug. ***
Comment 24 Yuri Chornoivan 2020-07-27 10:23:29 UTC
*** Bug 424708 has been marked as a duplicate of this bug. ***
Comment 25 Yuri Chornoivan 2020-08-13 11:30:00 UTC
*** Bug 425290 has been marked as a duplicate of this bug. ***
Comment 26 Sadi 2020-08-13 12:08:52 UTC
Sorry Yuri for the duplication and inconvenience.
I'd like to take this opportunity, however, to note here what seems to be the upstream (poppler) bug report: https://gitlab.freedesktop.org/poppler/poppler/-/issues/362
So it might be a good idea to join the conversation there in order to better follow any development on this issue.
I understand that there are insufficient resources to resolve this bug at the present, and therefore there might be an option to do it by outsourcing and crowdfunding.
In that case, people interested might like make a contribution...
Comment 27 opensuse.lietuviu.kalba 2020-08-13 12:17:39 UTC
As poppler is crappy (in this case), maybe KDE Okular could switch into another engine / library for rendering?
Comment 28 Oliver Sander 2020-08-13 12:30:52 UTC
It could, but that would be more work than simply fixing the poppler bug.
Comment 29 opensuse.lietuviu.kalba 2020-08-13 13:46:19 UTC
According to upstream bug comment, maybe problem is not rendering, but SAVING of annotation incorrectly?

See comment by Triffid Hunter <https://gitlab.freedesktop.org/poppler/poppler/-/issues/362#note_78739>:

PS I found a kludge: Open the saved PDF in Google Chrome's built-in viewer, select the affected fields, cut all text (clearing the field), focus another field, then paste it back into the relevant field, and non-ascii characters then become visible and can be printed/transmitted as expected - and are even visible when I 'print to PDF' from chrome and open the result in okular!


Apparently the way that okular stores non-ascii in form fields affects chrome, but when non-ascii is entered into an empty form field in chrome, chrome handles it correctly.
Comment 30 Yuri Chornoivan 2020-08-16 18:11:42 UTC
*** Bug 425429 has been marked as a duplicate of this bug. ***
Comment 31 Yuri Chornoivan 2020-09-30 14:26:28 UTC
*** Bug 427154 has been marked as a duplicate of this bug. ***
Comment 32 Yuri Chornoivan 2020-10-05 07:48:36 UTC
*** Bug 427355 has been marked as a duplicate of this bug. ***
Comment 33 Yuri Chornoivan 2020-10-09 03:40:08 UTC
*** Bug 427470 has been marked as a duplicate of this bug. ***
Comment 34 Yuri Chornoivan 2021-01-09 12:40:21 UTC
*** Bug 431350 has been marked as a duplicate of this bug. ***
Comment 35 Yuri Chornoivan 2021-01-20 06:31:39 UTC
*** Bug 431833 has been marked as a duplicate of this bug. ***
Comment 36 Yuri Chornoivan 2021-01-23 08:04:14 UTC
*** Bug 431976 has been marked as a duplicate of this bug. ***
Comment 37 Yuri Chornoivan 2021-01-26 18:52:01 UTC
*** Bug 432176 has been marked as a duplicate of this bug. ***
Comment 38 Yuri Chornoivan 2021-01-28 09:17:51 UTC
*** Bug 432236 has been marked as a duplicate of this bug. ***
Comment 39 Joao Lamares 2021-01-28 09:25:32 UTC
Created attachment 135261 [details]
attachment-13466-0.html

Please remove me for this list


JoaoLamares

Em 28/01/2021 à(s) 09:17, Yuri Chornoivan <bugzilla_noreply@kde.org>
escreveu:

https://bugs.kde.org/show_bug.cgi?id=305534

Yuri Chornoivan <yurchor@ukr.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |a.geno@libero.it

--- Comment #38 from Yuri Chornoivan <yurchor@ukr.net> ---
*** Bug 432236 has been marked as a duplicate of this bug. ***

--
You are receiving this mail because:
You are on the CC list for the bug.
Comment 40 Yuri Chornoivan 2021-02-02 21:17:22 UTC
*** Bug 432435 has been marked as a duplicate of this bug. ***
Comment 41 Luis Henrique 2021-02-02 21:30:07 UTC
I don't think it is too chalenging to solve this issue because the Okular version available on Ubuntu 20.04 repositories do accept the special characters. But I would like to use the Flatpak version because it has the dark mode whisch is best for working many hours.
I really want that you find a solution soon.
Comment 42 Allexus J 2021-02-03 20:37:51 UTC
Bug still happening in v20.12.1
Comment 43 Oliver Sander 2021-02-03 20:41:33 UTC
Closing again: This is a poppler issue.
Comment 44 Yuri Chornoivan 2021-02-16 17:45:54 UTC
*** Bug 433016 has been marked as a duplicate of this bug. ***
Comment 45 Yuri Chornoivan 2021-03-18 14:54:41 UTC
*** Bug 434583 has been marked as a duplicate of this bug. ***
Comment 46 Utku BERBEROĞLU 2021-03-20 03:41:35 UTC
(In reply to Oliver Sander from comment #43)
> Closing again: This is a poppler issue.

What can I do for  solving issue? Should i report the bug to popler or is there already there is a bug report in popler?
Comment 47 Yuri Chornoivan 2021-03-20 06:44:07 UTC
(In reply to Utku BERBEROĞLU from comment #46)
> (In reply to Oliver Sander from comment #43)
> > Closing again: This is a poppler issue.
> 
> What can I do for  solving issue? Should i report the bug to popler or is
> there already there is a bug report in popler?

Regretfully, almost nothing at this step unless you have a patch. The bug in poppler can be tracked here (the URL in the header of this bug report):

https://gitlab.freedesktop.org/poppler/poppler/issues/362
Comment 48 Yuri Chornoivan 2021-04-02 05:10:17 UTC
*** Bug 435244 has been marked as a duplicate of this bug. ***
Comment 49 Yuri Chornoivan 2021-04-17 22:33:17 UTC
*** Bug 435857 has been marked as a duplicate of this bug. ***
Comment 50 Yuri Chornoivan 2021-04-25 16:58:40 UTC
*** Bug 436173 has been marked as a duplicate of this bug. ***
Comment 51 opensuse.lietuviu.kalba 2021-04-30 10:43:47 UTC
Seems some progress happened here:
https://gitlab.freedesktop.org/poppler/poppler/-/issues/1070#note_897098
However buggy patch was introduced only 4 months ago, meanwhile bug in Okular exist for almost for 10 years.

According to comments in 
https://gitlab.freedesktop.org/poppler/poppler/-/issues/362#note_900139 and
https://gitlab.freedesktop.org/poppler/poppler/-/issues/1070#note_897098 ,
Okalar should show symbols correctly with poppler 20.12.1, fail with newer versions and show correctly again after partial revert of 
https://gitlab.freedesktop.org/poppler/poppler/-/commit/9db685f379c1c9195b5f0c9a693e7a581e6b214f
Comment 52 Yuri Chornoivan 2021-05-02 05:51:07 UTC
*** Bug 436475 has been marked as a duplicate of this bug. ***
Comment 53 Yuri Chornoivan 2021-05-10 07:51:38 UTC
*** Bug 436857 has been marked as a duplicate of this bug. ***
Comment 54 Yuri Chornoivan 2021-05-10 08:16:20 UTC
*** Bug 436860 has been marked as a duplicate of this bug. ***
Comment 55 Yuri Chornoivan 2021-05-11 15:21:29 UTC
*** Bug 436934 has been marked as a duplicate of this bug. ***
Comment 56 kojid 2021-05-11 15:35:02 UTC
(In reply to opensuse.lietuviu.kalba from comment #51)
> Seems some progress happened here:
> https://gitlab.freedesktop.org/poppler/poppler/-/issues/1070#note_897098
> However buggy patch was introduced only 4 months ago, meanwhile bug in
> Okular exist for almost for 10 years.
> 
> According to comments in 
> https://gitlab.freedesktop.org/poppler/poppler/-/issues/362#note_900139 and
> https://gitlab.freedesktop.org/poppler/poppler/-/issues/1070#note_897098 ,
> Okalar should show symbols correctly with poppler 20.12.1, fail with newer
> versions and show correctly again after partial revert of 
> https://gitlab.freedesktop.org/poppler/poppler/-/commit/
> 9db685f379c1c9195b5f0c9a693e7a581e6b214f


Looks like this has been fixed in poppler now. Are the okular devs informed about this so that they can merge it?
Comment 57 Albert Astals Cid 2021-05-11 17:17:28 UTC
(In reply to kojid from comment #56)
> (In reply to opensuse.lietuviu.kalba from comment #51)
> > Seems some progress happened here:
> > https://gitlab.freedesktop.org/poppler/poppler/-/issues/1070#note_897098
> > However buggy patch was introduced only 4 months ago, meanwhile bug in
> > Okular exist for almost for 10 years.
> > 
> > According to comments in 
> > https://gitlab.freedesktop.org/poppler/poppler/-/issues/362#note_900139 and
> > https://gitlab.freedesktop.org/poppler/poppler/-/issues/1070#note_897098 ,
> > Okalar should show symbols correctly with poppler 20.12.1, fail with newer
> > versions and show correctly again after partial revert of 
> > https://gitlab.freedesktop.org/poppler/poppler/-/commit/
> > 9db685f379c1c9195b5f0c9a693e7a581e6b214f
> 
> 
> Looks like this has been fixed in poppler now. Are the okular devs informed
> about this so that they can merge it?

It's not really fixed, only a recent regression that broke it a bit more has been fixed.

There's nothing to "merge"
Comment 58 Yuri Chornoivan 2021-05-14 13:24:11 UTC
*** Bug 437086 has been marked as a duplicate of this bug. ***
Comment 59 Yuri Chornoivan 2021-05-17 13:07:33 UTC
*** Bug 437248 has been marked as a duplicate of this bug. ***
Comment 60 Yuri Chornoivan 2021-05-19 21:05:03 UTC
*** Bug 437375 has been marked as a duplicate of this bug. ***
Comment 61 Yuri Chornoivan 2021-05-26 19:24:17 UTC
*** Bug 437710 has been marked as a duplicate of this bug. ***
Comment 62 Yuri Chornoivan 2021-06-23 09:57:23 UTC
*** Bug 439056 has been marked as a duplicate of this bug. ***
Comment 63 Yuri Chornoivan 2021-06-23 15:42:41 UTC
*** Bug 439078 has been marked as a duplicate of this bug. ***
Comment 64 Yuri Chornoivan 2021-06-29 15:26:42 UTC
*** Bug 439304 has been marked as a duplicate of this bug. ***
Comment 65 jack6th 2021-08-24 08:30:53 UTC
This issue is still not resolved.
Comment 66 Luigi Toscano 2021-08-29 22:28:35 UTC
(In reply to jack6th from comment #65)
> This issue is still not resolved.

As noted in a previous comment, this is a known issue in the poppler library.
Comment 67 Utku BERBEROĞLU 2021-09-11 18:04:36 UTC
I know there is no problem in Okular and this is a problem of Popler, i think there is a posible way for partial solution. Okular could automaticly change non-ASCII letters to similar ASCII characters. Example:

In "Berberoğlu", letter "ğ" could change to g, and at least we can see "Berberoglu" instead of "Berberolu".
Comment 68 Utku BERBEROĞLU 2021-09-20 04:10:59 UTC
This issue is not resolved. 

I know there is no problem in Okular and this is a problem of Popler, i think there is a posible way for partial solution. Okular could automaticly change non-ASCII letters to similar ASCII characters. Example:

In "Berberoğlu", letter "ğ" could change to g, and at least we can see "Berberoglu" instead of "Berberolu".
Comment 69 Albert Astals Cid 2021-09-20 17:30:17 UTC
Utku, Don't do this again.
Comment 70 Yuri Chornoivan 2021-11-18 07:16:21 UTC
*** Bug 445674 has been marked as a duplicate of this bug. ***
Comment 71 Yuri Chornoivan 2021-11-22 13:21:39 UTC
*** Bug 445919 has been marked as a duplicate of this bug. ***
Comment 72 Yuri Chornoivan 2022-05-18 13:10:54 UTC
*** Bug 453983 has been marked as a duplicate of this bug. ***
Comment 73 Albert Astals Cid 2022-05-18 20:45:43 UTC
For what is worth this is now fixed upstream in poppler 22.05.0

You can all wait until your distribution updates to that poppler version or meanwhile use okular from flathub https://flathub.org/apps/details/org.kde.okular