Bug 297533 - Application: muon-installer (1.2.1 "Caustic Carrionite")
Summary: Application: muon-installer (1.2.1 "Caustic Carrionite")
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: 1.2.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-05 13:31 UTC by Paul Elmore
Modified: 2012-04-05 13:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Error I received when trying to submit with bug reporter (9.83 KB, text/html)
2012-04-05 13:31 UTC, Paul Elmore
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Elmore 2012-04-05 13:31:07 UTC
Created attachment 70176 [details]
Error I received when trying to submit with bug reporter

Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-17-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Doesn't want to launch after doing updates.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5f33c2d780 (LWP 2129))]

Thread 2 (Thread 0x7f5f1cf28700 (LWP 2135)):
#0  0x00007f5f307f3473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5f2d066f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5f2d067429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5f329b1f3e in QEventDispatcherGlib::processEvents (this=0xf71cc0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f5f32985cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5f32985ef7 in QEventLoop::exec (this=0x7f5f1cf27dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f5f3289d27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f5f32968cbf in QInotifyFileSystemWatcherEngine::run (this=0xdf85c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f5f3289fd05 in QThreadPrivate::start (arg=0xdf85c0) at thread/qthread_unix.cpp:331
#9  0x00007f5f2db48efc in start_thread (arg=0x7f5f1cf28700) at pthread_create.c:304
#10 0x00007f5f307ff59d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5f33c2d780 (LWP 2129)):
[KCrash Handler]
#6  0x00007f5f328eda5e in QtPrivate::QStringList_contains (that=0x7fffe9f35440, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffe9f35440) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xda7470) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xda7470, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe9f35a10) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f5f32999eba in QMetaObject::activate (sender=0xe484d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xe484d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe9f35b70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f5f32999eba in QMetaObject::activate (sender=0xda7470, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe9f35b70) at kernel/qobject.cpp:3278
#13 0x00007f5f3380fe7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xd9ed00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f5f3380ff8e in MuonMainWindow::initObject (this=0xda7470) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xda7470) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xda7470, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe9f35c40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f5f32999eba in QMetaObject::activate (sender=0xe31ba0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f5f329a1f7f in QSingleShotTimer::timerEvent (this=0xe31ba0) at kernel/qtimer.cpp:308
#19 0x00007f5f3299d789 in QObject::event (this=0xe31ba0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f5f30fc0474 in notify_helper (e=0x7fffe9f361b0, receiver=0xe31ba0, this=0xc38bb0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xc38bb0, receiver=0xe31ba0, e=0x7fffe9f361b0) at kernel/qapplication.cpp:4458
#22 0x00007f5f30fc52e1 in QApplication::notify (this=0x7fffe9f364b0, receiver=0xe31ba0, e=0x7fffe9f361b0) at kernel/qapplication.cpp:4365
#23 0x00007f5f321a5466 in KApplication::notify (this=0x7fffe9f364b0, receiver=0xe31ba0, event=0x7fffe9f361b0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f5f32986afc in QCoreApplication::notifyInternal (this=0x7fffe9f364b0, receiver=0xe31ba0, event=0x7fffe9f361b0) at kernel/qcoreapplication.cpp:787
#25 0x00007f5f329b3d62 in sendEvent (event=0x7fffe9f361b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xc3de90) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f5f329b1514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f5f2d066a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f5f2d067258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f5f2d067429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f5f329b1ed6 in QEventDispatcherGlib::processEvents (this=0xc136f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f5f3106810e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f5f32985cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f5f32985ef7 in QEventLoop::exec (this=0x7fffe9f36440, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f5f3298a789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fffe9f36728) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 296988, bug 296854, bug 296828, bug 296789, bug 296663, bug 296602, bug 296593, bug 296573.

Possible duplicates by query: bug 297053, bug 296988, bug 296898, bug 296854, bug 296828.
Comment 1 Jekyll Wu 2012-04-05 13:43:19 UTC

*** This bug has been marked as a duplicate of bug 291262 ***