Bug 296663 - Muon Software Manager crashes on launch
Summary: Muon Software Manager crashes on launch
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 04:29 UTC by hoodlumbubo
Modified: 2012-04-14 21:06 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.08 KB, text/plain)
2012-03-24 11:21 UTC, Keld Sørensen
Details
New crash information added by DrKonqi (6.64 KB, text/plain)
2012-03-25 05:52 UTC, bundle
Details
New crash information added by DrKonqi (6.95 KB, text/plain)
2012-03-28 09:44 UTC, Cedric
Details
New crash information added by DrKonqi (7.21 KB, text/plain)
2012-04-14 21:06 UTC, thierry.guilhem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hoodlumbubo 2012-03-24 04:29:02 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Starting Muon Software Center without anything else running, with a newly installed version of Kubuntu (11.10) with all updates available in Muon Update Manager. After rebooting after installing Linux 3.0.0-16-generic* updates, Muon software center started crashing on launch.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb770c930 (LWP 1670))]

Thread 2 (Thread 0xb58cab70 (LWP 1674)):
#0  0x049167f3 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x04917637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x04917c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x008a2b37 in QEventDispatcherGlib::processEvents (this=0xa227800, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x008731dd in QEventLoop::processEvents (this=0xb58ca2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00873421 in QEventLoop::exec (this=0xb58ca2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0077690b in QThread::exec (this=0xa22b2c0) at thread/qthread.cpp:498
#7  0x00853e2d in QInotifyFileSystemWatcherEngine::run (this=0xa22b2c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x007797b3 in QThreadPrivate::start (arg=0xa22b2c0) at thread/qthread_unix.cpp:331
#9  0x0067ed31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x014e346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb770c930 (LWP 1670)):
[KCrash Handler]
#7  0x007cde11 in QtPrivate::QStringList_contains (that=0xbfeeace4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfeeace4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa0da920) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa0da920, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeeaf04) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0087ab7d in metacall (argv=0xbfeeaf04, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa0da920) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa0da920, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfeeaf04) at kernel/qmetaobject.cpp:232
#13 0x00889a6a in QMetaObject::activate (sender=0xa0cc1d0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa0cc1d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa0cc1d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeeb048) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0087ab7d in metacall (argv=0xbfeeb048, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa0cc1d0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa0cc1d0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfeeb048) at kernel/qmetaobject.cpp:232
#18 0x00889a6a in QMetaObject::activate (sender=0xa0da920, m=0x80950c0, local_signal_index=0, argv=0xbfeeb048) at kernel/qobject.cpp:3278
#19 0x006ad7c5 in MuonMainWindow::backendReady (this=0xa0da920, _t1=0xa1260f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x006ad933 in MuonMainWindow::initObject (this=0xa0da920) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa0da920) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa0da920, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeeb174) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0087ab7d in metacall (argv=0xbfeeb174, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa0da920) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa0da920, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfeeb174) at kernel/qmetaobject.cpp:232
#25 0x00889a6a in QMetaObject::activate (sender=0xa143188, m=0x9aa238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00891375 in QSingleShotTimer::timeout (this=0xa143188) at .moc/release-shared/qtimer.moc:82
#27 0x0089142c in QSingleShotTimer::timerEvent (this=0xa143188) at kernel/qtimer.cpp:308
#28 0x0088c994 in QObject::event (this=0xa143188, e=0xbfeeb56c) at kernel/qobject.cpp:1181
#29 0x09007d84 in notify_helper (e=0xbfeeb56c, receiver=0xa143188, this=0x9ff24e8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9ff24e8, receiver=0xa143188, e=0xbfeeb56c) at kernel/qapplication.cpp:4458
#31 0x0900d133 in QApplication::notify (this=0xbfeeb56c, receiver=0xa143188, e=0xbfeeb56c) at kernel/qapplication.cpp:3886
#32 0x011bd971 in KApplication::notify (this=0xbfeeb880, receiver=0xa143188, event=0xbfeeb56c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0087419e in QCoreApplication::notifyInternal (this=0xbfeeb880, receiver=0xa143188, event=0xbfeeb56c) at kernel/qcoreapplication.cpp:787
#34 0x008a4c10 in sendEvent (event=0xbfeeb56c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9ff3494) at kernel/qeventdispatcher_unix.cpp:603
#36 0x008a2122 in timerSourceDispatch (source=0x9ff3460) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0491725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x04917990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x04917c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x008a2ada in QEventDispatcherGlib::processEvents (this=0x9fd5238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x090bfe7a in QGuiEventDispatcherGlib::processEvents (this=0x9fd5238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x008731dd in QEventLoop::processEvents (this=0xbfeeb7e4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00873421 in QEventLoop::exec (this=0xbfeeb7e4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0087819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x09005924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 296602, bug 296593, bug 296573, bug 296545, bug 296452.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-24 04:51:12 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Keld Sørensen 2012-03-24 11:21:59 UTC
Created attachment 69848 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

try to open it, then it just crashed, and it cant install any progam from it

-- Backtrace (Reduced):
#6  0x00007f8f6736fa5e in QtPrivate::QStringList_contains (that=0x7fff8ec55fa0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff8ec55fa0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x103c060) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x103c060, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8ec56570) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x11fb690, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8ec566d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 3 bundle 2012-03-25 05:52:45 UTC
Created attachment 69874 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

I opened the program and it crashed, it does it everytime I open it. Firefox was open in the background

-- Backtrace (Reduced):
#7  0x0087be11 in QtPrivate::QStringList_contains (that=0xbf807a04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf807a04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8238120) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8238120, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf807c24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00928b7d in metacall (argv=0xbf807c24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8238120) at kernel/qmetaobject.cpp:237
Comment 4 Cedric 2012-03-28 09:44:13 UTC
Created attachment 69960 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
Starting Muon Software Centre. Crashed every time. However Muon Package Manager works fine.  This is a new Kubuntu (32bit) install on an Acer 7750Z (dual-boot). I had run an upgrade (froze on configuring hplip and needed to force reboot and use 'dpkg --configure -a' to allow update to complete successfully) and other apps seem to work fine.

-- Backtrace (Reduced):
#7  0xb71b6e11 in QtPrivate::QStringList_contains (that=0xbfcdca84, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfcdca84) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8bceca8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8bceca8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcdcca4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7263b7d in metacall (argv=0xbfcdcca4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8bceca8) at kernel/qmetaobject.cpp:237
Comment 5 thierry.guilhem 2012-04-14 21:06:12 UTC
Created attachment 70385 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

Muon Software Center crashes every time when launched

-- Backtrace (Reduced):
#7  0x004c1e11 in QtPrivate::QStringList_contains (that=0xbff9bb74, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff9bb74) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9c8d5c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9c8d5c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff9bd94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0056eb7d in metacall (argv=0xbff9bd94, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9c8d5c8) at kernel/qmetaobject.cpp:237