Bug 296602 - crasched muon
Summary: crasched muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-23 07:03 UTC by lambert
Modified: 2012-03-23 07:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lambert 2012-03-23 07:03:16 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed : nothing, i was working in internet ! and i reboot my computer

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7717930 (LWP 5643))]

Thread 2 (Thread 0xb571db70 (LWP 5647)):
#0  0x00f52d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x007137d5 in do_gettime (frac=0xb571d020, sec=0xb571d018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x007e64b6 in QTimerInfoList::updateCurrentTime (this=0x85a28b4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x007e680a in QTimerInfoList::timerWait (this=0x85a28b4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x007e5053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb571d12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x007e50ed in timerSourcePrepare (source=0x85a2880, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x018b288c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x018b3637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x018b3c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x007e5b37 in QEventDispatcherGlib::processEvents (this=0x85a0bf8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x007b61dd in QEventLoop::processEvents (this=0xb571d2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x007b6421 in QEventLoop::exec (this=0xb571d2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x006b990b in QThread::exec (this=0x859f128) at thread/qthread.cpp:498
#14 0x00796e2d in QInotifyFileSystemWatcherEngine::run (this=0x859f128) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x006bc7b3 in QThreadPrivate::start (arg=0x859f128) at thread/qthread_unix.cpp:331
#16 0x00b35d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x009f246e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7717930 (LWP 5643)):
[KCrash Handler]
#7  0x00710e11 in QtPrivate::QStringList_contains (that=0xbfc27e44, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc27e44) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8451e60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8451e60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc28064) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x007bdb7d in metacall (argv=0xbfc28064, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8451e60) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8451e60, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc28064) at kernel/qmetaobject.cpp:232
#13 0x007cca6a in QMetaObject::activate (sender=0x838e838, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x838e838) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x838e838, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc281a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x007bdb7d in metacall (argv=0xbfc281a8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x838e838) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x838e838, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc281a8) at kernel/qmetaobject.cpp:232
#18 0x007cca6a in QMetaObject::activate (sender=0x8451e60, m=0x80950c0, local_signal_index=0, argv=0xbfc281a8) at kernel/qobject.cpp:3278
#19 0x00b777c5 in MuonMainWindow::backendReady (this=0x8451e60, _t1=0x83fb2d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00b77933 in MuonMainWindow::initObject (this=0x8451e60) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8451e60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8451e60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc282d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x007bdb7d in metacall (argv=0xbfc282d4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8451e60) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8451e60, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc282d4) at kernel/qmetaobject.cpp:232
#25 0x007cca6a in QMetaObject::activate (sender=0x84bf740, m=0x8ed238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x007d4375 in QSingleShotTimer::timeout (this=0x84bf740) at .moc/release-shared/qtimer.moc:82
#27 0x007d442c in QSingleShotTimer::timerEvent (this=0x84bf740) at kernel/qtimer.cpp:308
#28 0x007cf994 in QObject::event (this=0x84bf740, e=0xbfc286cc) at kernel/qobject.cpp:1181
#29 0x0431ad84 in notify_helper (e=0xbfc286cc, receiver=0x84bf740, this=0x8393f80) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8393f80, receiver=0x84bf740, e=0xbfc286cc) at kernel/qapplication.cpp:4458
#31 0x04320133 in QApplication::notify (this=0xbfc286cc, receiver=0x84bf740, e=0xbfc286cc) at kernel/qapplication.cpp:3886
#32 0x01180971 in KApplication::notify (this=0xbfc289e0, receiver=0x84bf740, event=0xbfc286cc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x007b719e in QCoreApplication::notifyInternal (this=0xbfc289e0, receiver=0x84bf740, event=0xbfc286cc) at kernel/qcoreapplication.cpp:787
#34 0x007e7c10 in sendEvent (event=0xbfc286cc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x839644c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x007e5122 in timerSourceDispatch (source=0x8396418) at kernel/qeventdispatcher_glib.cpp:184
#37 0x018b325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x018b3990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x018b3c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x007e5ada in QEventDispatcherGlib::processEvents (this=0x8372238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x043d2e7a in QGuiEventDispatcherGlib::processEvents (this=0x8372238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x007b61dd in QEventLoop::processEvents (this=0xbfc28944, flags=...) at kernel/qeventloop.cpp:149
#43 0x007b6421 in QEventLoop::exec (this=0xbfc28944, flags=...) at kernel/qeventloop.cpp:201
#44 0x007bb19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x04318924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296593, bug 296573, bug 296545, bug 296452, bug 296441.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-23 07:10:52 UTC

*** This bug has been marked as a duplicate of bug 291262 ***