Bug 296593 - Software Muon Crash
Summary: Software Muon Crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-23 00:28 UTC by kikotiger
Modified: 2012-03-23 02:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kikotiger 2012-03-23 00:28:21 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
No funciona el Software Muon

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0118550780 (LWP 2006))]

Thread 2 (Thread 0x7f010391b700 (LWP 2007)):
#0  0x00007f0115117473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f011198af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f011198b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f01172d5f3e in QEventDispatcherGlib::processEvents (this=0x14c4f60, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f01172a9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f01172a9ef7 in QEventLoop::exec (this=0x7f010391add0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f01171c127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f011728ccbf in QInotifyFileSystemWatcherEngine::run (this=0x14922a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f01171c3d05 in QThreadPrivate::start (arg=0x14922a0) at thread/qthread_unix.cpp:331
#9  0x00007f011246cefc in start_thread (arg=0x7f010391b700) at pthread_create.c:304
#10 0x00007f011512359d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0118550780 (LWP 2006)):
[KCrash Handler]
#6  0x00007f0117211a5e in QtPrivate::QStringList_contains (that=0x7fff510047f0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff510047f0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1429560) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1429560, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff51004dc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f01172bdeba in QMetaObject::activate (sender=0x15e8af0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x15e8af0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff51004f20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f01172bdeba in QMetaObject::activate (sender=0x1429560, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff51004f20) at kernel/qobject.cpp:3278
#13 0x00007f0118133e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1422b00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f0118133f8e in MuonMainWindow::initObject (this=0x1429560) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1429560) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1429560, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff51004ff0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f01172bdeba in QMetaObject::activate (sender=0x148fb00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f01172c5f7f in QSingleShotTimer::timerEvent (this=0x148fb00) at kernel/qtimer.cpp:308
#19 0x00007f01172c1789 in QObject::event (this=0x148fb00, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f01158e4474 in notify_helper (e=0x7fff51005560, receiver=0x148fb00, this=0x12c0e70) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x12c0e70, receiver=0x148fb00, e=0x7fff51005560) at kernel/qapplication.cpp:4458
#22 0x00007f01158e92e1 in QApplication::notify (this=0x7fff51005860, receiver=0x148fb00, e=0x7fff51005560) at kernel/qapplication.cpp:4365
#23 0x00007f0116ac9466 in KApplication::notify (this=0x7fff51005860, receiver=0x148fb00, event=0x7fff51005560) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f01172aaafc in QCoreApplication::notifyInternal (this=0x7fff51005860, receiver=0x148fb00, event=0x7fff51005560) at kernel/qcoreapplication.cpp:787
#25 0x00007f01172d7d62 in sendEvent (event=0x7fff51005560, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x12be740) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f01172d5514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f011198aa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f011198b258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f011198b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f01172d5ed6 in QEventDispatcherGlib::processEvents (this=0x12996f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f011598c10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f01172a9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f01172a9ef7 in QEventLoop::exec (this=0x7fff510057f0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f01172ae789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff51005ad8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262, bug 291267.

Possible duplicates by query: bug 296573, bug 296545, bug 296452, bug 296441, bug 296357.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-23 02:47:54 UTC

*** This bug has been marked as a duplicate of bug 291262 ***