Bug 296898 - Muon Crashes Every Time when Opening
Summary: Muon Crashes Every Time when Opening
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-27 17:01 UTC by Rob V
Modified: 2012-03-28 19:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.23 KB, text/plain)
2012-03-28 19:25 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob V 2012-03-27 17:01:04 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I opened Muon. In the background I had Amarok, Firefox and Akregator running. Muon crashed with no explanation or error - just a segfault.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9e64398780 (LWP 2401))]

Thread 2 (Thread 0x7f9e4faec700 (LWP 2402)):
#0  0x00007f9e60f6c473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9e5d7dff68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9e5d7e0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9e6312af3e in QEventDispatcherGlib::processEvents (this=0x27e9a10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9e630fecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e630feef7 in QEventLoop::exec (this=0x7f9e4faebdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9e6301627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f9e630e1cbf in QInotifyFileSystemWatcherEngine::run (this=0x27a78d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9e63018d05 in QThreadPrivate::start (arg=0x27a78d0) at thread/qthread_unix.cpp:331
#9  0x00007f9e5e2c1efc in start_thread (arg=0x7f9e4faec700) at pthread_create.c:304
#10 0x00007f9e60f7859d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9e64398780 (LWP 2401)):
[KCrash Handler]
#6  0x00007f9e63066a5e in QtPrivate::QStringList_contains (that=0x7fffca93c260, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffca93c260) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x276c9f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x276c9f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffca93c830) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f9e63112eba in QMetaObject::activate (sender=0x2911390, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2911390, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffca93c990) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f9e63112eba in QMetaObject::activate (sender=0x276c9f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffca93c990) at kernel/qobject.cpp:3278
#13 0x00007f9e63f88e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x27cb9d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f9e63f88f8e in MuonMainWindow::initObject (this=0x276c9f0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x276c9f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x276c9f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffca93ca60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f9e63112eba in QMetaObject::activate (sender=0x27ccdd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f9e6311af7f in QSingleShotTimer::timerEvent (this=0x27ccdd0) at kernel/qtimer.cpp:308
#19 0x00007f9e63116789 in QObject::event (this=0x27ccdd0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f9e61739474 in notify_helper (e=0x7fffca93cfd0, receiver=0x27ccdd0, this=0x26091d0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x26091d0, receiver=0x27ccdd0, e=0x7fffca93cfd0) at kernel/qapplication.cpp:4458
#22 0x00007f9e6173e2e1 in QApplication::notify (this=0x7fffca93d2d0, receiver=0x27ccdd0, e=0x7fffca93cfd0) at kernel/qapplication.cpp:4365
#23 0x00007f9e6291e466 in KApplication::notify (this=0x7fffca93d2d0, receiver=0x27ccdd0, event=0x7fffca93cfd0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f9e630ffafc in QCoreApplication::notifyInternal (this=0x7fffca93d2d0, receiver=0x27ccdd0, event=0x7fffca93cfd0) at kernel/qcoreapplication.cpp:787
#25 0x00007f9e6312cd62 in sendEvent (event=0x7fffca93cfd0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x260f460) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f9e6312a514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f9e5d7dfa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f9e5d7e0258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f9e5d7e0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f9e6312aed6 in QEventDispatcherGlib::processEvents (this=0x25e56f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f9e617e110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f9e630fecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f9e630feef7 in QEventLoop::exec (this=0x7fffca93d260, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f9e63103789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffca93d548) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296854, bug 296828, bug 296789, bug 296663, bug 296602.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-27 17:06:10 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Michael 2012-03-28 19:25:40 UTC
Created attachment 69977 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Had just installed Kubuntu 11.10, and finished installing initial large wave of updates.
Muon Installer crashes every time I try to run it, while Muon-Updater and Muon Package Manager run without issue.

-- Backtrace (Reduced):
#6  0x00007fc179b6da5e in QtPrivate::QStringList_contains (that=0x7fffe8c043c0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffe8c043c0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xce5bb0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xce5bb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe8c04990) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xd55b60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe8c04af0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109