Bug 296789 - muon crash
Summary: muon crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-26 04:14 UTC by Petronio Mesquita
Modified: 2012-03-26 04:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petronio Mesquita 2012-03-26 04:14:07 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:just oppening it for the first time after kubuntu instalation, after that tried dpkg --configure -a, sudo apt-get update and sudo aptget upgrade.

Then I did this sudo rm /var/lib/apt/lib/lists/* ; sudo rm /var/lib/apt/lists/partial/* ; sudo apt-get -f install ; sudo apt-get clean ; sudo apt-get update.

Nothing more.

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff5bc071780 (LWP 2317))]

Thread 2 (Thread 0x7ff5a4924700 (LWP 2327)):
#0  0x00007ff5b54ac3ed in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff5b54ace6a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff5b54ad429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff5badf7f3e in QEventDispatcherGlib::processEvents (this=0xff6140, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff5badcbcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff5badcbef7 in QEventLoop::exec (this=0x7ff5a4923dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff5bace327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007ff5badaecbf in QInotifyFileSystemWatcherEngine::run (this=0xe07dd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff5bace5d05 in QThreadPrivate::start (arg=0xe07dd0) at thread/qthread_unix.cpp:331
#9  0x00007ff5b5f8eefc in start_thread (arg=0x7ff5a4924700) at pthread_create.c:304
#10 0x00007ff5b8c4559d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff5bc071780 (LWP 2317)):
[KCrash Handler]
#6  0x00007ff5bad33a5e in QtPrivate::QStringList_contains (that=0x7fff5fb467d0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff5fb467d0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xdb4bc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xdb4bc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5fb46da0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007ff5baddfeba in QMetaObject::activate (sender=0xe3f0e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xe3f0e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5fb46f00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007ff5baddfeba in QMetaObject::activate (sender=0xdb4bc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff5fb46f00) at kernel/qobject.cpp:3278
#13 0x00007ff5bbc55e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xe1ed60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007ff5bbc55f8e in MuonMainWindow::initObject (this=0xdb4bc0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xdb4bc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xdb4bc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5fb46fd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007ff5baddfeba in QMetaObject::activate (sender=0xe256c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007ff5bade7f7f in QSingleShotTimer::timerEvent (this=0xe256c0) at kernel/qtimer.cpp:308
#19 0x00007ff5bade3789 in QObject::event (this=0xe256c0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007ff5b9406474 in notify_helper (e=0x7fff5fb47540, receiver=0xe256c0, this=0xc53790) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xc53790, receiver=0xe256c0, e=0x7fff5fb47540) at kernel/qapplication.cpp:4458
#22 0x00007ff5b940b2e1 in QApplication::notify (this=0x7fff5fb47840, receiver=0xe256c0, e=0x7fff5fb47540) at kernel/qapplication.cpp:4365
#23 0x00007ff5ba5eb466 in KApplication::notify (this=0x7fff5fb47840, receiver=0xe256c0, event=0x7fff5fb47540) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007ff5badccafc in QCoreApplication::notifyInternal (this=0x7fff5fb47840, receiver=0xe256c0, event=0x7fff5fb47540) at kernel/qcoreapplication.cpp:787
#25 0x00007ff5badf9d62 in sendEvent (event=0x7fff5fb47540, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xc515a0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007ff5badf7514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007ff5b54aca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ff5b54ad258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007ff5b54ad429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007ff5badf7ed6 in QEventDispatcherGlib::processEvents (this=0xc2b6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007ff5b94ae10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007ff5badcbcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007ff5badcbef7 in QEventLoop::exec (this=0x7fff5fb477d0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007ff5badd0789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff5fb47ab8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 296663, bug 296602, bug 296593, bug 296573, bug 296545.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-26 04:23:41 UTC

*** This bug has been marked as a duplicate of bug 291262 ***