Bug 296828 - software center
Summary: software center
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-26 18:11 UTC by Peter
Modified: 2012-04-13 12:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.31 KB, text/plain)
2012-04-13 12:04 UTC, Antonio Sánchez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2012-03-26 18:11:54 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
I tried to open the  software center for updating.
but the programm did not start, i directly got an error

The crash can be reproduced every time.

-- Backtrace:
Application: Muon softwarecentrum (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7768930 (LWP 12297))]

Thread 2 (Thread 0xb571fb70 (LWP 12298)):
#0  0x00a0ed10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x001ed7d5 in do_gettime (frac=0xb571f020, sec=0xb571f018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x002c04b6 in QTimerInfoList::updateCurrentTime (this=0x9a07864) at kernel/qeventdispatcher_unix.cpp:339
#4  0x002c080a in QTimerInfoList::timerWait (this=0x9a07864, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x002bf053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb571f12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x002bf0ed in timerSourcePrepare (source=0x9a07830, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0144088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01441637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01441c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x002bfb37 in QEventDispatcherGlib::processEvents (this=0x99c2b58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x002901dd in QEventLoop::processEvents (this=0xb571f2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00290421 in QEventLoop::exec (this=0xb571f2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0019390b in QThread::exec (this=0x99e8088) at thread/qthread.cpp:498
#14 0x00270e2d in QInotifyFileSystemWatcherEngine::run (this=0x99e8088) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x001967b3 in QThreadPrivate::start (arg=0x99e8088) at thread/qthread_unix.cpp:331
#16 0x00b81d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0083546e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7768930 (LWP 12297)):
[KCrash Handler]
#7  0x001eae11 in QtPrivate::QStringList_contains (that=0xbfac2c04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfac2c04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x99935e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x99935e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfac2e24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00297b7d in metacall (argv=0xbfac2e24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x99935e0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x99935e0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfac2e24) at kernel/qmetaobject.cpp:232
#13 0x002a6a6a in QMetaObject::activate (sender=0x9acbad8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9acbad8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9acbad8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfac2f68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00297b7d in metacall (argv=0xbfac2f68, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9acbad8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9acbad8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfac2f68) at kernel/qmetaobject.cpp:232
#18 0x002a6a6a in QMetaObject::activate (sender=0x99935e0, m=0x80950c0, local_signal_index=0, argv=0xbfac2f68) at kernel/qobject.cpp:3278
#19 0x00f907c5 in MuonMainWindow::backendReady (this=0x99935e0, _t1=0x9acb908) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00f90933 in MuonMainWindow::initObject (this=0x99935e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x99935e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x99935e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfac3094) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00297b7d in metacall (argv=0xbfac3094, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x99935e0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x99935e0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfac3094) at kernel/qmetaobject.cpp:232
#25 0x002a6a6a in QMetaObject::activate (sender=0x99eac30, m=0x3c7238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x002ae375 in QSingleShotTimer::timeout (this=0x99eac30) at .moc/release-shared/qtimer.moc:82
#27 0x002ae42c in QSingleShotTimer::timerEvent (this=0x99eac30) at kernel/qtimer.cpp:308
#28 0x002a9994 in QObject::event (this=0x99eac30, e=0xbfac348c) at kernel/qobject.cpp:1181
#29 0x01788d84 in notify_helper (e=0xbfac348c, receiver=0x99eac30, this=0x989baa0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x989baa0, receiver=0x99eac30, e=0xbfac348c) at kernel/qapplication.cpp:4458
#31 0x0178e133 in QApplication::notify (this=0xbfac348c, receiver=0x99eac30, e=0xbfac348c) at kernel/qapplication.cpp:3886
#32 0x011ab971 in KApplication::notify (this=0xbfac37a0, receiver=0x99eac30, event=0xbfac348c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0029119e in QCoreApplication::notifyInternal (this=0xbfac37a0, receiver=0x99eac30, event=0xbfac348c) at kernel/qcoreapplication.cpp:787
#34 0x002c1c10 in sendEvent (event=0xbfac348c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x989e2ec) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002bf122 in timerSourceDispatch (source=0x989e2b8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0144125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01441990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01441c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x002bfada in QEventDispatcherGlib::processEvents (this=0x9879250, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01840e7a in QGuiEventDispatcherGlib::processEvents (this=0x9879250, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x002901dd in QEventLoop::processEvents (this=0xbfac3704, flags=...) at kernel/qeventloop.cpp:149
#43 0x00290421 in QEventLoop::exec (this=0xbfac3704, flags=...) at kernel/qeventloop.cpp:201
#44 0x0029519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01786924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296789, bug 296663, bug 296602, bug 296593, bug 296573.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-26 19:18:13 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Antonio Sánchez 2012-04-13 12:04:14 UTC
Created attachment 70363 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Just started software center and got crash  message. Everytime I try I got the message. Can't use Software center. Please fix.

Besides, I had problems with Muon package manager. After clean install and system update Muon hangs at 39%-41% progress. I had to reinstall and do apt-get update, apt-get dist-upgrade from command line.

-- Backtrace (Reduced):
#6  0x00007f0d35852a5e in QtPrivate::QStringList_contains (that=0x7fffa3ad8410, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffa3ad8410) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xe101f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xe101f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa3ad89e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xe5fc90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa3ad8b40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109