Bug 296988 - muon crash
Summary: muon crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-28 20:46 UTC by Igor
Modified: 2012-03-28 20:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Igor 2012-03-28 20:46:22 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: nothing special, just started the system and tried to start muon and it's crashing all the time

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f772f426780 (LWP 1992))]

Thread 2 (Thread 0x7f771aa0e700 (LWP 1995)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f771aa0daf0 in ?? ()
#2  0x00007fffc72ce7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f772f426780 (LWP 1992)):
[KCrash Handler]
#6  0x00007f772e0e7a5e in QtPrivate::QStringList_contains (that=0x7fffc7295120, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffc7295120) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x2096b30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x2096b30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc72956f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f772e193eba in QMetaObject::activate (sender=0x1f3adb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1f3adb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc7295850) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f772e193eba in QMetaObject::activate (sender=0x2096b30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc7295850) at kernel/qobject.cpp:3278
#13 0x00007f772f009e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x211bcb0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f772f009f8e in MuonMainWindow::initObject (this=0x2096b30) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x2096b30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x2096b30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc7295920) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f772e193eba in QMetaObject::activate (sender=0x21406e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f772e19bf7f in QSingleShotTimer::timerEvent (this=0x21406e0) at kernel/qtimer.cpp:308
#19 0x00007f772e197789 in QObject::event (this=0x21406e0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f772c7ba474 in notify_helper (e=0x7fffc7295e90, receiver=0x21406e0, this=0x1f49cd0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1f49cd0, receiver=0x21406e0, e=0x7fffc7295e90) at kernel/qapplication.cpp:4458
#22 0x00007f772c7bf2e1 in QApplication::notify (this=0x7fffc7296190, receiver=0x21406e0, e=0x7fffc7295e90) at kernel/qapplication.cpp:4365
#23 0x00007f772d99f466 in KApplication::notify (this=0x7fffc7296190, receiver=0x21406e0, event=0x7fffc7295e90) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f772e180afc in QCoreApplication::notifyInternal (this=0x7fffc7296190, receiver=0x21406e0, event=0x7fffc7295e90) at kernel/qcoreapplication.cpp:787
#25 0x00007f772e1add62 in sendEvent (event=0x7fffc7295e90, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1f4ccf0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f772e1ab538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f7728860a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f7728861258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f7728861429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f772e1abed6 in QEventDispatcherGlib::processEvents (this=0x1f246f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f772c86210e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f772e17fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f772e17fef7 in QEventLoop::exec (this=0x7fffc7296120, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f772e184789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=1, argv=0x7fffc7296408) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 296898, bug 296854, bug 296828, bug 296789, bug 296663.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-28 20:57:19 UTC

*** This bug has been marked as a duplicate of bug 291262 ***