Bug 296854 - crashing muon
Summary: crashing muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-27 05:03 UTC by lindsay
Modified: 2012-03-27 06:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lindsay 2012-03-27 05:03:37 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:opened muon, it then crashed/self closed, after 1-2 seconds.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc9d4a6e780 (LWP 2486))]

Thread 2 (Thread 0x7fc9c0041700 (LWP 2489)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fc9c0040af0 in ?? ()
#2  0x00007fffe02147e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7fc9d4a6e780 (LWP 2486)):
[KCrash Handler]
#6  0x00007fc9d373aa5e in QtPrivate::QStringList_contains (that=0x7fffe01ffce0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffe01ffce0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xee5450) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xee5450, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe02002b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fc9d37e6eba in QMetaObject::activate (sender=0xef66d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xef66d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe0200410) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fc9d37e6eba in QMetaObject::activate (sender=0xee5450, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe0200410) at kernel/qobject.cpp:3278
#13 0x00007fc9d465ce7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xe7cdd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fc9d465cf8e in MuonMainWindow::initObject (this=0xee5450) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xee5450) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xee5450, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe02004e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fc9d37e6eba in QMetaObject::activate (sender=0xf42660, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fc9d37eef7f in QSingleShotTimer::timerEvent (this=0xf42660) at kernel/qtimer.cpp:308
#19 0x00007fc9d37ea789 in QObject::event (this=0xf42660, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fc9d1e0d474 in notify_helper (e=0x7fffe0200a50, receiver=0xf42660, this=0xd3a620) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xd3a620, receiver=0xf42660, e=0x7fffe0200a50) at kernel/qapplication.cpp:4458
#22 0x00007fc9d1e122e1 in QApplication::notify (this=0x7fffe0200d50, receiver=0xf42660, e=0x7fffe0200a50) at kernel/qapplication.cpp:4365
#23 0x00007fc9d2ff2466 in KApplication::notify (this=0x7fffe0200d50, receiver=0xf42660, event=0x7fffe0200a50) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fc9d37d3afc in QCoreApplication::notifyInternal (this=0x7fffe0200d50, receiver=0xf42660, event=0x7fffe0200a50) at kernel/qcoreapplication.cpp:787
#25 0x00007fc9d3800d62 in sendEvent (event=0x7fffe0200a50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xd378f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fc9d37fe538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007fc9cdeb3a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fc9cdeb4258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fc9cdeb4429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007fc9d37feed6 in QEventDispatcherGlib::processEvents (this=0xd136f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007fc9d1eb510e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007fc9d37d2cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007fc9d37d2ef7 in QEventLoop::exec (this=0x7fffe0200ce0, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007fc9d37d7789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fffe0200fc8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 296828, bug 296789, bug 296663, bug 296602, bug 296593.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-27 06:07:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***