Bug 297053 - muon crashes every time
Summary: muon crashes every time
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-29 15:33 UTC by vladogrc005
Modified: 2012-04-12 00:38 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.31 KB, text/plain)
2012-04-01 07:54 UTC, Jorgen Petterson
Details
New crash information added by DrKonqi (7.23 KB, text/plain)
2012-04-12 00:38 UTC, mastermakka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vladogrc005 2012-03-29 15:33:52 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I just installed kubuntu 11.10 and when I opened muon software center, it crashes, every time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d2710 (LWP 23773))]

Thread 2 (Thread 0xb5b37b70 (LWP 23777)):
#0  0x009372af in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#1  0x03011b9b in g_main_context_query () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x03012664 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x03012c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x005abb37 in QEventDispatcherGlib::processEvents (this=0x90c79a8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x0057c1dd in QEventLoop::processEvents (this=0xb5b372b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x0057c421 in QEventLoop::exec (this=0xb5b372b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x0047f90b in QThread::exec (this=0x914b098) at thread/qthread.cpp:498
#8  0x0055ce2d in QInotifyFileSystemWatcherEngine::run (this=0x914b098) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x004827b3 in QThreadPrivate::start (arg=0x914b098) at thread/qthread_unix.cpp:331
#10 0x00de1d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x0092946e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77d2710 (LWP 23773)):
[KCrash Handler]
#7  0x004d6e11 in QtPrivate::QStringList_contains (that=0xbfe61544, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe61544) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x90ac528) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x90ac528, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe61764) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00583b7d in metacall (argv=0xbfe61764, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x90ac528) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x90ac528, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe61764) at kernel/qmetaobject.cpp:232
#13 0x00592a6a in QMetaObject::activate (sender=0x91064d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x91064d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x91064d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe618a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00583b7d in metacall (argv=0xbfe618a8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x91064d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x91064d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe618a8) at kernel/qmetaobject.cpp:232
#18 0x00592a6a in QMetaObject::activate (sender=0x90ac528, m=0x80950c0, local_signal_index=0, argv=0xbfe618a8) at kernel/qobject.cpp:3278
#19 0x00a097c5 in MuonMainWindow::backendReady (this=0x90ac528, _t1=0x90f9848) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00a09933 in MuonMainWindow::initObject (this=0x90ac528) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x90ac528) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x90ac528, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe619d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00583b7d in metacall (argv=0xbfe619d4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x90ac528) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x90ac528, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe619d4) at kernel/qmetaobject.cpp:232
#25 0x00592a6a in QMetaObject::activate (sender=0x9121070, m=0x6b3238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0059a375 in QSingleShotTimer::timeout (this=0x9121070) at .moc/release-shared/qtimer.moc:82
#27 0x0059a42c in QSingleShotTimer::timerEvent (this=0x9121070) at kernel/qtimer.cpp:308
#28 0x00595994 in QObject::event (this=0x9121070, e=0xbfe61dcc) at kernel/qobject.cpp:1181
#29 0x01579d84 in notify_helper (e=0xbfe61dcc, receiver=0x9121070, this=0x8fc2af8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8fc2af8, receiver=0x9121070, e=0xbfe61dcc) at kernel/qapplication.cpp:4458
#31 0x0157f133 in QApplication::notify (this=0xbfe61dcc, receiver=0x9121070, e=0xbfe61dcc) at kernel/qapplication.cpp:3886
#32 0x011cf971 in KApplication::notify (this=0xbfe620e0, receiver=0x9121070, event=0xbfe61dcc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0057d19e in QCoreApplication::notifyInternal (this=0xbfe620e0, receiver=0x9121070, event=0xbfe61dcc) at kernel/qcoreapplication.cpp:787
#34 0x005adc10 in sendEvent (event=0xbfe61dcc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8fc9ac4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x005ab122 in timerSourceDispatch (source=0x8fc9a90) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0301225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x03012990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03012c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x005abada in QEventDispatcherGlib::processEvents (this=0x8fa5238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01631e7a in QGuiEventDispatcherGlib::processEvents (this=0x8fa5238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0057c1dd in QEventLoop::processEvents (this=0xbfe62044, flags=...) at kernel/qeventloop.cpp:149
#43 0x0057c421 in QEventLoop::exec (this=0xbfe62044, flags=...) at kernel/qeventloop.cpp:201
#44 0x0058119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01577924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296988, bug 296898, bug 296854, bug 296828, bug 296789.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-29 15:35:22 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Jorgen Petterson 2012-04-01 07:54:20 UTC
Created attachment 70049 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
Installed kububtu 11.10 and tryed to open Muon program center. it craches instantly every time i try.

-- Backtrace (Reduced):
#7  0x005d2e11 in QtPrivate::QStringList_contains (that=0xbfb97cc4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb97cc4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x85f27c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x85f27c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb97ee4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0067fb7d in metacall (argv=0xbfb97ee4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x85f27c8) at kernel/qmetaobject.cpp:237
Comment 3 mastermakka 2012-04-12 00:38:33 UTC
Created attachment 70324 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

fresh kubuntu 11.10 install, muon software manager crashes every time its opened

-- Backtrace (Reduced):
#7  0x006dee11 in QtPrivate::QStringList_contains (that=0xbfbc30a4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfbc30a4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9dbf230) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9dbf230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbc32c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0078bb7d in metacall (argv=0xbfbc32c4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9dbf230) at kernel/qmetaobject.cpp:237