Bug 286801 - Google Chrome install crashes apper
Summary: Google Chrome install crashes apper
Status: RESOLVED FIXED
Alias: None
Product: apper
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
: 286853 286868 286969 286980 287131 287193 287219 287337 287420 287631 287745 287815 287979 288033 288275 288288 292905 295147 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-16 20:37 UTC by Matt
Modified: 2012-03-01 15:40 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.7.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt 2011-11-16 20:37:35 UTC
Application: apper-sentinel (0.7.0)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
Downloaded Chrome from Google and tried installing it with apper.  Installed tried multiple times with same result.  Error window 'Sorry- Dolphin"  KDEInit could not launch '/usr/bin/apper'

-- Backtrace:
Application: Apper (apper-sentinel), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f68d035b9f4 in QAbstractButton::isChecked (this=0x8012a0) at widgets/qabstractbutton.cpp:772
#7  0x00007f68d0f8ef75 in Requirements::~Requirements (this=0x877260, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:153
#8  0x00007f68d0f8efe9 in Requirements::~Requirements (this=0x877260, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:157
#9  0x00007f68d1966178 in QObject::event (this=0x877260, e=<optimized out>) at kernel/qobject.cpp:1209
#10 0x00007f68cfff8cfb in QWidget::event (this=0x877260, event=0x9952e0) at kernel/qwidget.cpp:8754
#11 0x00007f68cffa8be4 in notify_helper (e=0x9952e0, receiver=0x877260, this=0x67bab0) at kernel/qapplication.cpp:4481
#12 QApplicationPrivate::notify_helper (this=0x67bab0, receiver=0x877260, e=0x9952e0) at kernel/qapplication.cpp:4453
#13 0x00007f68cffada71 in QApplication::notify (this=0x7fff08c95db0, receiver=0x877260, e=0x9952e0) at kernel/qapplication.cpp:4360
#14 0x00007f68d2b26e36 in KApplication::notify (this=0x7fff08c95db0, receiver=0x877260, event=0x9952e0) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#15 0x00007f68d194f81c in QCoreApplication::notifyInternal (this=0x7fff08c95db0, receiver=0x877260, event=0x9952e0) at kernel/qcoreapplication.cpp:787
#16 0x00007f68d1952bf8 in sendEvent (event=0x9952e0, receiver=0x877260) at kernel/qcoreapplication.h:215
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x64c150) at kernel/qcoreapplication.cpp:1428
#18 0x00007f68d197a0b3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#19 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#20 0x00007f68cb74e58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f68cb74ed88 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f68cb74ef59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f68d197a50f in QEventDispatcherGlib::processEvents (this=0x64b930, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007f68d004bf2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f68d194ea22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f68d194ec1f in QEventLoop::exec (this=0x7fff08c95d40, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007f68d1952de7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#28 0x000000000041035d in main (argc=1, argv=0x7fff08c96098) at /usr/src/debug/apper-0.7.0/Sentinel/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-17 22:53:17 UTC
*** Bug 286853 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2011-11-17 22:53:35 UTC
*** Bug 286868 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Nicoletti 2011-11-18 11:52:41 UTC
Quick question is this happening with the final version of Apper on openSUSE? If so please ask for them to resync the package, I'll try to do a 0.7.1 release, but this bug was fixed a while ago when it was getting into fedora...
Comment 4 Frans Leerink 2011-11-19 00:19:51 UTC
On Fri, 2011-11-18 at 11:52 +0000, Daniel Nicoletti wrote:
> https://bugs.kde.org/show_bug.cgi?id=286801
> 
> 
> 
> 
> 
> --- Comment #3 from Daniel Nicoletti <dantti12 gmail com>  2011-11-18 11:52:41 ---
> Quick question is this happening with the final version of Apper on openSUSE?
> If so please ask for them to resync the package, I'll try to do a 0.7.1
> release, but this bug was fixed a while ago when it was getting into fedora...
> 

Hello, 

No this was in openSUSE 11.4
Comment 5 Daniel Nicoletti 2011-11-19 00:48:18 UTC
right so this bug is probably already fixed in openSUSE 12.1.
Thanks
Comment 6 Christoph Feck 2011-11-19 00:56:41 UTC
*** Bug 286969 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2011-11-19 00:58:21 UTC
As indicated in this bug report, openSUSE 12.1 still ships 0.7.0. You probably should report to their bug tracker, so they can update or backport.
Comment 8 Jekyll Wu 2011-11-19 10:21:13 UTC
*** Bug 286980 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2011-11-21 10:27:16 UTC
*** Bug 287131 has been marked as a duplicate of this bug. ***
Comment 10 Jekyll Wu 2011-11-21 23:40:16 UTC
*** Bug 287193 has been marked as a duplicate of this bug. ***
Comment 11 Jekyll Wu 2011-11-22 03:46:48 UTC
*** Bug 287219 has been marked as a duplicate of this bug. ***
Comment 12 Jekyll Wu 2011-11-23 07:10:04 UTC
*** Bug 287337 has been marked as a duplicate of this bug. ***
Comment 13 Jekyll Wu 2011-11-24 02:04:25 UTC
*** Bug 287420 has been marked as a duplicate of this bug. ***
Comment 14 Jekyll Wu 2011-11-26 19:53:24 UTC
*** Bug 287631 has been marked as a duplicate of this bug. ***
Comment 15 Jekyll Wu 2011-11-28 13:18:09 UTC
*** Bug 287745 has been marked as a duplicate of this bug. ***
Comment 16 Jekyll Wu 2011-11-29 07:33:52 UTC
*** Bug 287815 has been marked as a duplicate of this bug. ***
Comment 17 Jekyll Wu 2011-12-01 11:14:57 UTC
*** Bug 287979 has been marked as a duplicate of this bug. ***
Comment 18 Christoph Feck 2011-12-02 10:11:08 UTC
*** Bug 287193 has been marked as a duplicate of this bug. ***
Comment 19 Jekyll Wu 2011-12-02 19:58:18 UTC
*** Bug 288033 has been marked as a duplicate of this bug. ***
Comment 20 Jekyll Wu 2011-12-05 16:50:59 UTC
*** Bug 288275 has been marked as a duplicate of this bug. ***
Comment 21 Jekyll Wu 2011-12-05 21:01:51 UTC
*** Bug 288288 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Feck 2012-01-31 00:06:11 UTC
*** Bug 292905 has been marked as a duplicate of this bug. ***
Comment 23 Jekyll Wu 2012-03-01 15:40:52 UTC
*** Bug 295147 has been marked as a duplicate of this bug. ***