Bug 288288 - Apper crash
Summary: Apper crash
Status: RESOLVED DUPLICATE of bug 286801
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-05 20:57 UTC by Greg King
Modified: 2011-12-05 21:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg King 2011-12-05 20:57:53 UTC
Application: apper-sentinel (0.7.0)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I simply tried to install openvpn for openSUSE KDE.

Thank you,

Greg

The crash can be reproduced every time.

-- Backtrace:
Application: Apper (apper-sentinel), signal: Segmentation fault
[KCrash Handler]
#6  0x00007fa17fcf09f4 in QAbstractButton::isChecked (this=0x746480) at widgets/qabstractbutton.cpp:772
#7  0x00007fa180923f75 in Requirements::~Requirements (this=0x84ae00, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:153
#8  0x00007fa180923fe9 in Requirements::~Requirements (this=0x84ae00, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:157
#9  0x00007fa1812fb178 in QObject::event (this=0x84ae00, e=<optimized out>) at kernel/qobject.cpp:1209
#10 0x00007fa17f98dcfb in QWidget::event (this=0x84ae00, event=0x8bd860) at kernel/qwidget.cpp:8754
#11 0x00007fa17f93dbe4 in notify_helper (e=0x8bd860, receiver=0x84ae00, this=0x67abe0) at kernel/qapplication.cpp:4481
#12 QApplicationPrivate::notify_helper (this=0x67abe0, receiver=0x84ae00, e=0x8bd860) at kernel/qapplication.cpp:4453
#13 0x00007fa17f942a71 in QApplication::notify (this=0x7fff6fb0b9d0, receiver=0x84ae00, e=0x8bd860) at kernel/qapplication.cpp:4360
#14 0x00007fa1824bbe36 in KApplication::notify (this=0x7fff6fb0b9d0, receiver=0x84ae00, event=0x8bd860) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#15 0x00007fa1812e481c in QCoreApplication::notifyInternal (this=0x7fff6fb0b9d0, receiver=0x84ae00, event=0x8bd860) at kernel/qcoreapplication.cpp:787
#16 0x00007fa1812e7bf8 in sendEvent (event=0x8bd860, receiver=0x84ae00) at kernel/qcoreapplication.h:215
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x64bad0) at kernel/qcoreapplication.cpp:1428
#18 0x00007fa18130f0b3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#19 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#20 0x00007fa17b0e358d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fa17b0e3d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fa17b0e3f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fa18130f50f in QEventDispatcherGlib::processEvents (this=0x64b2e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007fa17f9e0f2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007fa1812e3a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007fa1812e3c1f in QEventLoop::exec (this=0x7fff6fb0b960, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007fa1812e7de7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#28 0x000000000041035d in main (argc=1, argv=0x7fff6fb0bcb8) at /usr/src/debug/apper-0.7.0/Sentinel/main.cpp:54

Possible duplicates by query: bug 288275, bug 288033, bug 287979, bug 287815, bug 287745.

Reported using DrKonqi
Comment 1 Jekyll Wu 2011-12-05 21:01:51 UTC

*** This bug has been marked as a duplicate of bug 286801 ***