Bug 287337 - apper crashing during install of any app
Summary: apper crashing during install of any app
Status: RESOLVED DUPLICATE of bug 286801
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-23 06:41 UTC by cipher0x
Modified: 2011-11-23 07:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cipher0x 2011-11-23 06:41:39 UTC
Application: apper-sentinel (0.7.0)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
A dialog box pops up with a title :”Sorry” and a message: “KDEInit could not launch '/usr/bin/apper'.” after typing in root password and clicking ok.

The crash can be reproduced every time.

-- Backtrace:
Application: Apper (apper-sentinel), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f31b3abe9f4 in QAbstractButton::isChecked (this=0x9954a0) at widgets/qabstractbutton.cpp:772
#7  0x00007f31b46f1f75 in Requirements::~Requirements (this=0x996910, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:153
#8  0x00007f31b46f1fe9 in Requirements::~Requirements (this=0x996910, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:157
#9  0x00007f31b50c9178 in QObject::event (this=0x996910, e=<optimized out>) at kernel/qobject.cpp:1209
#10 0x00007f31b375bcfb in QWidget::event (this=0x996910, event=0x994130) at kernel/qwidget.cpp:8754
#11 0x00007f31b370bbe4 in notify_helper (e=0x994130, receiver=0x996910, this=0x67b990) at kernel/qapplication.cpp:4481
#12 QApplicationPrivate::notify_helper (this=0x67b990, receiver=0x996910, e=0x994130) at kernel/qapplication.cpp:4453
#13 0x00007f31b3710a71 in QApplication::notify (this=0x7fff48fd6be0, receiver=0x996910, e=0x994130) at kernel/qapplication.cpp:4360
#14 0x00007f31b6289e36 in KApplication::notify (this=0x7fff48fd6be0, receiver=0x996910, event=0x994130) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#15 0x00007f31b50b281c in QCoreApplication::notifyInternal (this=0x7fff48fd6be0, receiver=0x996910, event=0x994130) at kernel/qcoreapplication.cpp:787
#16 0x00007f31b50b5bf8 in sendEvent (event=0x994130, receiver=0x996910) at kernel/qcoreapplication.h:215
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x64c150) at kernel/qcoreapplication.cpp:1428
#18 0x00007f31b50dd0b3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#19 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#20 0x00007f31aeeb158d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f31aeeb1d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f31aeeb1f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f31b50dd50f in QEventDispatcherGlib::processEvents (this=0x64b930, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007f31b37aef2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f31b50b1a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f31b50b1c1f in QEventLoop::exec (this=0x7fff48fd6b70, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007f31b50b5de7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#28 0x000000000041035d in main (argc=1, argv=0x7fff48fd6ec8) at /usr/src/debug/apper-0.7.0/Sentinel/main.cpp:54

This bug may be a duplicate of or related to bug 287219.

Possible duplicates by query: bug 287219, bug 287193, bug 287131, bug 286980, bug 286969.

Reported using DrKonqi
Comment 1 Jekyll Wu 2011-11-23 07:10:04 UTC

*** This bug has been marked as a duplicate of bug 286801 ***