Bug 286969 - Apper crashes when installing Skype
Summary: Apper crashes when installing Skype
Status: RESOLVED DUPLICATE of bug 286801
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-19 00:29 UTC by Tomek Grzejszczyk
Modified: 2011-11-19 00:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomek Grzejszczyk 2011-11-19 00:29:30 UTC
Application: apper-sentinel (0.7.0)
KDE Platform Version: 4.7.2 (4.7.2) "release 5" (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was installing Skype package skype-2.2.0.35-suse.i586.rpm.

The crash can be reproduced every time.

-- Backtrace:
Application: Apper (apper-sentinel), signal: Segmentation fault
[KCrash Handler]
#6  0x00007fb7fac869f4 in QAbstractButton::isChecked (this=0xa14ac0) at widgets/qabstractbutton.cpp:772
#7  0x00007fb7fb8b9f75 in Requirements::~Requirements (this=0x993900, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:153
#8  0x00007fb7fb8b9fe9 in Requirements::~Requirements (this=0x993900, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:157
#9  0x00007fb7fc291178 in QObject::event (this=0x993900, e=<optimized out>) at kernel/qobject.cpp:1209
#10 0x00007fb7fa923cfb in QWidget::event (this=0x993900, event=0xa11600) at kernel/qwidget.cpp:8754
#11 0x00007fb7fa8d3be4 in notify_helper (e=0xa11600, receiver=0x993900, this=0x67c250) at kernel/qapplication.cpp:4481
#12 QApplicationPrivate::notify_helper (this=0x67c250, receiver=0x993900, e=0xa11600) at kernel/qapplication.cpp:4453
#13 0x00007fb7fa8d8a71 in QApplication::notify (this=0x7ffffd316a70, receiver=0x993900, e=0xa11600) at kernel/qapplication.cpp:4360
#14 0x00007fb7fd451e36 in KApplication::notify (this=0x7ffffd316a70, receiver=0x993900, event=0xa11600) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#15 0x00007fb7fc27a81c in QCoreApplication::notifyInternal (this=0x7ffffd316a70, receiver=0x993900, event=0xa11600) at kernel/qcoreapplication.cpp:787
#16 0x00007fb7fc27dbf8 in sendEvent (event=0xa11600, receiver=0x993900) at kernel/qcoreapplication.h:215
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x64c150) at kernel/qcoreapplication.cpp:1428
#18 0x00007fb7fc2a50b3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#19 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#20 0x00007fb7f607958d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fb7f6079d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fb7f6079f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fb7fc2a550f in QEventDispatcherGlib::processEvents (this=0x64b930, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007fb7fa976f2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007fb7fc279a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007fb7fc279c1f in QEventLoop::exec (this=0x7ffffd316a00, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007fb7fc27dde7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#28 0x000000000041035d in main (argc=1, argv=0x7ffffd316d58) at /usr/src/debug/apper-0.7.0/Sentinel/main.cpp:54

Possible duplicates by query: bug 286868, bug 286853.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-19 00:56:41 UTC

*** This bug has been marked as a duplicate of bug 286801 ***