Bug 287193 - apper crashed/stopped during install from Firefox
Summary: apper crashed/stopped during install from Firefox
Status: RESOLVED DUPLICATE of bug 286801
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-21 21:09 UTC by barry_a_graham
Modified: 2011-12-02 10:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (3.38 KB, text/plain)
2011-11-26 13:06 UTC, Edward Cheadle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description barry_a_graham 2011-11-21 21:09:05 UTC
Application: apper-sentinel (0.7.0)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-default i686
Distribution: "openSUSE 12.1 (i586)"

-- Information about the crash:
I tried to download and install Adobe flash & Google Chrome from a Firefox session.  Both times Apper failed to complete - got part way through & gave up.....

The crash can be reproduced every time.

-- Backtrace:
Application: Apper (apper-sentinel), signal: Segmentation fault
[KCrash Handler]
#6  0xb6098867 in QAbstractButton::isChecked (this=0x81298b8) at widgets/qabstractbutton.cpp:772
#7  0xb68f4eae in Requirements::~Requirements (this=0x822d060, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:153
#8  0xb68f4f52 in Requirements::~Requirements (this=0x822d060, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:157
#9  0xb6e7d263 in qDeleteInEventHandler (o=0x822d060) at kernel/qobject.cpp:3995
#10 0xb6e82858 in QObject::event (this=0x822d060, e=0x82f4588) at kernel/qobject.cpp:1209
#11 0xb5cdef32 in QWidget::event (this=0x822d060, event=0x82f4588) at kernel/qwidget.cpp:8754
#12 0xb5c84ee4 in notify_helper (e=0x82f4588, receiver=0x822d060, this=0x80b3910) at kernel/qapplication.cpp:4481
#13 QApplicationPrivate::notify_helper (this=0x80b3910, receiver=0x822d060, e=0x82f4588) at kernel/qapplication.cpp:4453
#14 0xb5c8a328 in QApplication::notify (this=0x80b3910, receiver=0x822d060, e=0x82f4588) at kernel/qapplication.cpp:4446
#15 0xb75e6681 in KApplication::notify (this=0xbfc8ad18, receiver=0x822d060, event=0x82f4588) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#16 0xb6e6a42e in QCoreApplication::notifyInternal (this=0xbfc8ad18, receiver=0x822d060, event=0x82f4588) at kernel/qcoreapplication.cpp:787
#17 0xb6e6dbf4 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:215
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x808fd88) at kernel/qcoreapplication.cpp:1428
#19 0xb6e6dd3c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#20 0xb6e98404 in sendPostedEvents () at kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=0x80b3668) at kernel/qeventdispatcher_glib.cpp:277
#22 0xb510fe2f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb5110560 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb51107fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb6e98837 in QEventDispatcherGlib::processEvents (this=0x80afe98, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#26 0xb5d38aaa in QGuiEventDispatcherGlib::processEvents (this=0x80afe98, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0xb6e6944d in QEventLoop::processEvents (this=0xbfc8ac74, flags=...) at kernel/qeventloop.cpp:149
#28 0xb6e69691 in QEventLoop::exec (this=0xbfc8ac74, flags=...) at kernel/qeventloop.cpp:201
#29 0xb6e6ddea in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#30 0xb5c82d64 in QApplication::exec () at kernel/qapplication.cpp:3755
#31 0x08054d52 in main (argc=136108184, argv=0x0) at /usr/src/debug/apper-0.7.0/Sentinel/main.cpp:54

Possible duplicates by query: bug 286868, bug 286853.

Reported using DrKonqi
Comment 1 Jekyll Wu 2011-11-21 23:40:16 UTC

*** This bug has been marked as a duplicate of bug 286801 ***
Comment 2 Edward Cheadle 2011-11-26 13:06:55 UTC
Created attachment 66091 [details]
New crash information added by DrKonqi

apper-sentinel (0.7.0) on KDE Platform 4.7.2 (4.7.2) "release 5" using Qt 4.7.4

- What I was doing when the application crashed: I was installing Chrome. I selected open from the menu instead of save. When I used save and installed using the software installer instead of apper.
Error Message:

Sorry KMozillaHelper
KDEInit could not launch '/ussr/bin/apper'

-- Backtrace (Reduced):
#6  0xb5f86867 in QAbstractButton::isChecked (this=0x82cfb18) at widgets/qabstractbutton.cpp:772
#7  0xb67e2eae in Requirements::~Requirements (this=0x81cd008, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:153
#8  0xb67e2f52 in Requirements::~Requirements (this=0x81cd008, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:157
#9  0xb6d6b263 in qDeleteInEventHandler (o=0x81cd008) at kernel/qobject.cpp:3995
#10 0xb6d70858 in QObject::event (this=0x81cd008, e=0x82f3ca0) at kernel/qobject.cpp:1209
Comment 3 Jeremy Whiting 2011-12-01 22:53:00 UTC
Git commit 897b07485a8cd70f831b8f586dc84859016b2572 by Jeremy Whiting.
Committed on 01/12/2011 at 23:50.
Pushed by whiting into branch 'KDE/4.7'.

KTar already supports xz and lzma files, also support them in Plasma::Package.
BUG:287193

M  +2    -1    plasma/package.cpp

http://commits.kde.org/kdelibs/897b07485a8cd70f831b8f586dc84859016b2572
Comment 4 Christoph Feck 2011-12-02 10:11:08 UTC

*** This bug has been marked as a duplicate of bug 286801 ***