Bug 286980 - Apper crashes when trying to install adobe flash player
Summary: Apper crashes when trying to install adobe flash player
Status: RESOLVED DUPLICATE of bug 286801
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-19 10:12 UTC by L.
Modified: 2011-11-19 10:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description L. 2011-11-19 10:12:01 UTC
Application: apper-sentinel (0.7.0)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I downloaded adobe-release-x86_64-1.0-1.noarch.rpm from adobe.com, tried to install it via Apper - it crashes (crash-message) and after a few seconds another error-message appears "KDE init can't start "/usr/bin/apper""

-- Backtrace:
Application: Apper (apper-sentinel), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f52644259f4 in QAbstractButton::isChecked (this=0x762b70) at widgets/qabstractbutton.cpp:772
#7  0x00007f5265058f75 in Requirements::~Requirements (this=0x7630f0, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:153
#8  0x00007f5265058fe9 in Requirements::~Requirements (this=0x7630f0, __in_chrg=<optimized out>) at /usr/src/debug/apper-0.7.0/libapper/Requirements.cpp:157
#9  0x00007f5265a30178 in QObject::event (this=0x7630f0, e=<optimized out>) at kernel/qobject.cpp:1209
#10 0x00007f52640c2cfb in QWidget::event (this=0x7630f0, event=0x9b6a40) at kernel/qwidget.cpp:8754
#11 0x00007f5264072be4 in notify_helper (e=0x9b6a40, receiver=0x7630f0, this=0x67bd20) at kernel/qapplication.cpp:4481
#12 QApplicationPrivate::notify_helper (this=0x67bd20, receiver=0x7630f0, e=0x9b6a40) at kernel/qapplication.cpp:4453
#13 0x00007f5264077a71 in QApplication::notify (this=0x7ffff4d9e320, receiver=0x7630f0, e=0x9b6a40) at kernel/qapplication.cpp:4360
#14 0x00007f5266bf0e36 in KApplication::notify (this=0x7ffff4d9e320, receiver=0x7630f0, event=0x9b6a40) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#15 0x00007f5265a1981c in QCoreApplication::notifyInternal (this=0x7ffff4d9e320, receiver=0x7630f0, event=0x9b6a40) at kernel/qcoreapplication.cpp:787
#16 0x00007f5265a1cbf8 in sendEvent (event=0x9b6a40, receiver=0x7630f0) at kernel/qcoreapplication.h:215
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x64c150) at kernel/qcoreapplication.cpp:1428
#18 0x00007f5265a440b3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#19 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#20 0x00007f525f81858d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f525f818d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f525f818f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f5265a4450f in QEventDispatcherGlib::processEvents (this=0x64b930, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007f5264115f2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f5265a18a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f5265a18c1f in QEventLoop::exec (this=0x7ffff4d9e2b0, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007f5265a1cde7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#28 0x000000000041035d in main (argc=1, argv=0x7ffff4d9e608) at /usr/src/debug/apper-0.7.0/Sentinel/main.cpp:54

Possible duplicates by query: bug 286969, bug 286868, bug 286853.

Reported using DrKonqi
Comment 1 Jekyll Wu 2011-11-19 10:21:13 UTC

*** This bug has been marked as a duplicate of bug 286801 ***