Bug 264091 - Twitter API v1.1 should be used in twitter plugin for timelines and search
Summary: Twitter API v1.1 should be used in twitter plugin for timelines and search
Status: RESOLVED FIXED
Alias: None
Product: choqok
Classification: Unclassified
Component: general (show other bugs)
Version: 0.9.98 (1.0 RC1)
Platform: Compiled Sources Linux
: VHI critical with 141 votes (vote)
Target Milestone: 1.4
Assignee: Daniel Kreuter
URL:
Keywords:
: 320826 321049 321056 321057 321058 321069 321088 321137 322170 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-23 16:53 UTC by robert marshall
Modified: 2014-12-13 15:51 UTC (History)
40 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.4


Attachments
Fix direct_message sent api for twitter and fix uri for identi.ca (1.71 KB, patch)
2013-06-15 20:28 UTC, Mario Bensi
Details
Fix twitter search (12.01 KB, patch)
2013-06-15 22:34 UTC, Mario Bensi
Details
Gentoo patch from git (24.23 KB, patch)
2013-06-16 14:02 UTC, Daniel Dewald
Details
Fix for follow/unfollow/block/unblock (3.85 KB, patch)
2013-06-20 06:08 UTC, Daniel Kreuter
Details
Fix image upload (635 bytes, patch)
2013-06-21 08:46 UTC, Daniel Kreuter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robert marshall 2011-01-23 16:53:16 UTC
Version:           0.9.98 (1.0 RC1) (using KDE 4.4.5) 
OS:                Linux

If a user has protected their tweets - not from you! - and you you try the option 'Posts from x' when clicking on their name in one of their tweets you get the message 'The search result is empty'

Reproducible: Always

Steps to Reproduce:
as above

Actual Results:  
popup message as described

Expected Results:  
expect to get a new timeline of that user's tweets
Comment 1 robert marshall 2011-01-23 19:34:35 UTC
It would appear to also happen for some users who don't protect their tweets. I'm getting the error consistently for
UKOrdinariate and
goodinparts

the first doesn't protect their tweets (and I don't follow)
the second does protect (and I do follow!) when I try to view their timelines.
Could it be a twitter problem?
Comment 2 Mehrdad Momeny 2011-01-25 06:20:29 UTC
Check this out:
https://search.twitter.com/search.atom?q=from:UKOrdinariate

Twitter response is empty! Don't know why!? :/

For protected user, this is the Twitter search API that do not support/accept authentication!
Comment 3 robert marshall 2011-01-25 08:52:25 UTC
Yes i see the empty return with the other user too! Very odd!
Yet hotot manages to display the timeline ok, is that application doing things differently?
Comment 4 Adrián Chaves (Gallaecio) 2012-10-02 06:35:49 UTC
Does this still happen with a newer version of Choqok? Could this be considered a flaw in Twitter’s Search API, or is it Choqok’s fault for not using a different API that does allow this?
Comment 5 robert marshall 2012-10-21 15:02:53 UTC
I'm still seeing the protected user returning no tweets on a search (but ok with the other user I suggested). Sorry I don't know enough about the twitter API to respond to those other questions!
Comment 6 Daniel Kreuter 2013-06-10 17:01:11 UTC
Is this bug still valid? If I click on the link of comment #2 I get a list of tweets of that user.
Comment 7 Mehrdad Momeny 2013-06-11 01:28:12 UTC
(In reply to comment #6)
> Is this bug still valid? If I click on the link of comment #2 I get a list
> of tweets of that user.

Actually the main problem was because Twitter's search API v1 didn't accept authentication, but as I found in v1.1 it accepts. So we need to implement that v1.1 api
checkout bug 320826
Comment 8 Daniel Kreuter 2013-06-11 08:43:50 UTC
We should do the switch to the new a pi version fast because the retirement date of v1 is schedui
end for today.
Comment 9 Mehrdad Momeny 2013-06-11 08:47:46 UTC
(In reply to comment #8)
> We should do the switch to the new a pi version fast because the retirement
> date of v1 is schedui
> end for today.

Yes, and we will have a release once this bug fixed :D
Do you have time to do it?
Comment 10 Mehrdad Momeny 2013-06-12 06:11:43 UTC
*** Bug 320826 has been marked as a duplicate of this bug. ***
Comment 11 Mehrdad Momeny 2013-06-12 06:24:20 UTC
Due to twitter API changes, we need to upgrade api usage in twitter plugin to use API v1.1
Comment 12 Mehrdad Momeny 2013-06-12 06:25:30 UTC
*** Bug 321049 has been marked as a duplicate of this bug. ***
Comment 13 Shlomi Fish 2013-06-12 09:00:51 UTC
Adding myself to the CC list.
Comment 14 Mehrdad Momeny 2013-06-12 09:08:41 UTC
*** Bug 321056 has been marked as a duplicate of this bug. ***
Comment 15 Mehrdad Momeny 2013-06-12 09:29:36 UTC
*** Bug 321057 has been marked as a duplicate of this bug. ***
Comment 16 Jekyll Wu 2013-06-12 13:12:16 UTC
*** Bug 321058 has been marked as a duplicate of this bug. ***
Comment 17 Mehrdad Momeny 2013-06-13 02:06:52 UTC
*** Bug 321069 has been marked as a duplicate of this bug. ***
Comment 18 B. R. Ashley 2013-06-13 06:58:15 UTC
api obviously needs update ... how soon?
Comment 19 Mehrdad Momeny 2013-06-13 07:06:36 UTC
*** Bug 321088 has been marked as a duplicate of this bug. ***
Comment 20 Jessie A. Morris 2013-06-13 15:21:01 UTC
I might take an attempt at this later today. I use Choqok and not having V1.1 support is killing me.

We already have OAuth implemented, so this should (knock on wood) be an easy migration.
Comment 21 Daniel Kreuter 2013-06-13 15:56:33 UTC
Hi Jessie,

would be nice if you can help me.

What is needed to be done:
- Remove all XML stuff from the twitter api, because only json is supported
- make sure that every call to twitter is done using oauth, because now it's mandatory so we can remove the option to switch that on by the user

I'm working on the first item at the moment and hope to get timelines working quite soon to see some progress.

So long
Comment 22 Mehrdad Momeny 2013-06-14 02:22:57 UTC
(In reply to comment #21)
> Hi Jessie,
> 
> would be nice if you can help me.
> 
> What is needed to be done:
> - Remove all XML stuff from the twitter api, because only json is supported
> - make sure that every call to twitter is done using oauth, because now it's
> mandatory so we can remove the option to switch that on by the user
> 
> I'm working on the first item at the moment and hope to get timelines
> working quite soon to see some progress.
> 
> So long

Good job Daniel,
Just don't forget to check if those codes (you are removing) aren't being used in StatusNet plugin ;)
TwitterApiHelper is a shared lib between twitter and StatusNet
Comment 23 Daniel Kreuter 2013-06-14 06:08:44 UTC
> Good job Daniel,
> Just don't forget to check if those codes (you are removing) aren't being
> used in StatusNet plugin ;)
> TwitterApiHelper is a shared lib between twitter and StatusNet

Yeah some of these methods are used in StatusNet as well. I will check if we can switch to JSON in StatusNet as well so we will have only one api to maintain.

By the way I have timeline working now, but only if you click on the Update Timeline button.
Comment 24 Mehrdad Momeny 2013-06-14 08:56:19 UTC
*** Bug 321137 has been marked as a duplicate of this bug. ***
Comment 25 Mario Bensi 2013-06-14 12:10:23 UTC
Any chances you could push in branch or something like that ? 
To test and to help you if i can.
I'm probably not alone to be curious about your work.
Comment 26 Daniel Kreuter 2013-06-14 12:18:50 UTC
(In reply to comment #25)
> Any chances you could push in branch or something like that ? 
> To test and to help you if i can.
> I'm probably not alone to be curious about your work.

If I had an developer account for KDE, then I could do that. Maybe I can push my changes to github instead or someone else push them to KDE?
Comment 27 Alvaro Soliverez 2013-06-14 13:15:34 UTC
You could push it to github so we can test it from there. In the meantime, the project admin requests a KDE dev account for you, which shouldn't take long if everything is in order.
Comment 28 Jessie Morris 2013-06-14 13:57:23 UTC
By the way, hi128_choqok-offline.PNG isn't in the repo. Would someone that has the correct version put it in there?

Alvaro Soliverez <asoliverez@kde.org> wrote:

>https://bugs.kde.org/show_bug.cgi?id=264091
>
>--- Comment #27 from Alvaro Soliverez <asoliverez@kde.org> ---
>You could push it to github so we can test it from there. In the meantime, the
>project admin requests a KDE dev account for you, which shouldn't take long if
>everything is in order.
>
>-- 
>You are receiving this mail because:
>You are on the CC list for the bug.
Comment 29 Daniel Kreuter 2013-06-14 17:46:52 UTC
Hi,

I pushed my changes to git@github.com:xardas008/choqok_de.git so you can test and help me out a bit.
What works:
- Timelines (only via manuel update)
- Writing Tweets
- Reply
- Retweet

What doesn't work:
- Search

What needs to be tested:
- Identi.ca (I have no time until monday and no identi.ca account to test with)
Comment 30 Mark Fraser 2013-06-15 13:11:46 UTC
Successfully installed Choqok from git and it seems to be working OK so far.
Comment 31 Mark Fraser 2013-06-15 14:47:48 UTC
Auto updates are working for me too.
Comment 32 Mathias Homann 2013-06-15 15:26:45 UTC
I've built an openSUSE package from git,
1-click-install for openSUSE 12.2 is here:
http://software.opensuse.org/ymp/home:lemmy04/openSUSE_12.2/choqok.ymp?base=openSUSE%3A12.2&query=choqok

It's been built against KDE 4.10 so you'll also need that.
Comment 33 pfoo 2013-06-15 16:22:56 UTC
working great so far on kubuntu / kde 4.10.4

However, it seems like identiti.ca is switching from StatusNet to pumpio (http://identi.ca/doc/pumpio) which also has a different API ...
Comment 34 B. R. Ashley 2013-06-15 19:49:53 UTC
On 13-06-15 12:22 PM, pfoo@csnu.org wrote:
> https://bugs.kde.org/show_bug.cgi?id=264091
>
> --- Comment #33 from pfoo@csnu.org ---
> working great so far on kubuntu / kde 4.10.4
>
> However, it seems like identiti.ca is switching from StatusNet to pumpio
> (http://identi.ca/doc/pumpio) which also has a different API ...
>
Also true. And when will a .deb be ready for installation in Ubuntu?
Comment 35 B. R. Ashley 2013-06-15 19:52:52 UTC
Should ave said Xubuntu
Comment 36 Mario Bensi 2013-06-15 20:28:50 UTC
Created attachment 80541 [details]
Fix direct_message sent api for twitter and fix uri for identi.ca

Thanks for your implementation of twitter 1.1.

I sent to you a patch to fix direct_message sent api for twitter and fix uri for identi.ca (before switch to pump.io).
Comment 37 Vasileios P. Lourdas 2013-06-15 20:35:24 UTC
When should we expect a new version (maybe 1.4) ?
Comment 38 Mario Bensi 2013-06-15 22:34:50 UTC
Created attachment 80543 [details]
Fix twitter search
Comment 39 pfoo 2013-06-16 06:59:22 UTC
For people running *ubuntu (and other debian-based distributions), I've just uploaded a .deb package of the current git tree adding support for API 1.1

AMD64 build : https://launchpad.net/~pfoo/+archive/choqok/+build/4717889/+files/choqok_1.4-0ubuntu0_amd64.deb
i386 build : https://launchpad.net/~pfoo/+archive/choqok/+build/4717890/+files/choqok_1.4-0ubuntu0_i386.deb
Comment 40 B. R. Ashley 2013-06-16 07:19:28 UTC
thanks, pfoo, I shall try it tomorrow!
Comment 41 Dan Duris 2013-06-16 11:37:33 UTC
it works wonderfully with new API, thank you very much!
Comment 42 Daniel Dewald 2013-06-16 14:02:08 UTC
Created attachment 80553 [details]
Gentoo patch from git

Made a little something for you gentoo guys out there. Just use the layman kde overlay choqok-9999 ebuild, put that patch into /etc/portage/patches/net-im/choqok and rebuild choqok to get your timeline back. Thx guys for the quick changes. Hope they'll be in the official trunk soon.
Comment 43 Vasileios P. Lourdas 2013-06-16 16:04:21 UTC
(In reply to comment #42)
> Made a little something for you gentoo guys out there. Just use the layman
> kde overlay choqok-9999 ebuild, put that patch into
> /etc/portage/patches/net-im/choqok and rebuild choqok to get your timeline
> back. Thx guys for the quick changes. Hope they'll be in the official trunk
> soon.

Thanks! It seems to work fine, although it needs more work (search by hashtags does not work). Automatic timeline update also seems to work fine.
Comment 44 Daniel Dewald 2013-06-16 16:14:11 UTC
(In reply to comment #43)
> (In reply to comment #42)
> > Made a little something for you gentoo guys out there. Just use the layman
> > kde overlay choqok-9999 ebuild, put that patch into
> > /etc/portage/patches/net-im/choqok and rebuild choqok to get your timeline
> > back. Thx guys for the quick changes. Hope they'll be in the official trunk
> > soon.
> 
> Thanks! It seems to work fine, although it needs more work (search by
> hashtags does not work). Automatic timeline update also seems to work fine.

Just move my patch to something like 0000_twitter_api_1.1.patch and copy the two patches already in this thread also into /etc/portage/patches/net-im/choqok . That should improve things a bit ;). Didn't know those 2 patches weren't already in the git repository.
Comment 45 B. R. Ashley 2013-06-16 17:25:22 UTC
Okay, the choqok_1.4-0ubuntu0_i3886.deb works well for me so far in Xubuntu 13.04 i386 ... I shall keep an eye on it. thank you!
Comment 46 Colin J Thomson 2013-06-16 23:05:37 UTC
I've applied the patches and it seems to be working very well, search and auto update of the timelines. Thanks very much!
Uploading to TwitPic does not seem to work and my Favourites are not shown but this is a very minor problem. Sadly I do not have an  Identi.ca account to test.
Its great to be able to use Choqok again.
Comment 47 madgenius 2013-06-17 02:28:40 UTC
(In reply to comment #32)
> I've built an openSUSE package from git,
> 1-click-install for openSUSE 12.2 is here:
> http://software.opensuse.org/ymp/home:lemmy04/openSUSE_12.2/choqok.
> ymp?base=openSUSE%3A12.2&query=choqok
> 
> It's been built against KDE 4.10 so you'll also need that.

Could you check the one-click install for opensuse 12.3? I tried installing the one from your repository, but choqok still remains at version 1.3

Thank you.
Comment 48 Daniel Kreuter 2013-06-17 06:11:07 UTC
(In reply to comment #47)
> (In reply to comment #32)
> > I've built an openSUSE package from git,
> > 1-click-install for openSUSE 12.2 is here:
> > http://software.opensuse.org/ymp/home:lemmy04/openSUSE_12.2/choqok.
> > ymp?base=openSUSE%3A12.2&query=choqok
> > 
> > It's been built against KDE 4.10 so you'll also need that.
> 
> Could you check the one-click install for opensuse 12.3? I tried installing
> the one from your repository, but choqok still remains at version 1.3
> 
> Thank you.
That's because wie didn't release a new version, yet.
Comment 49 Daniel Kreuter 2013-06-17 06:13:15 UTC
(In reply to comment #47)
> (In reply to comment #32)
> > I've built an openSUSE package from git,
> > 1-click-install for openSUSE 12.2 is here:
> > http://software.opensuse.org/ymp/home:lemmy04/openSUSE_12.2/choqok.
> > ymp?base=openSUSE%3A12.2&query=choqok
> > 
> > It's been built against KDE 4.10 so you'll also need that.
> 
> Could you check the one-click install for opensuse 12.3? I tried installing
> the one from your repository, but choqok still remains at version 1.3
> 
> Thank you.
That's because wie didn't release a new version, yet.
Comment 50 pfoo 2013-06-17 07:31:49 UTC
Direct message and twitter search patchs are working great apart from a minor bug : twitter search result are displayed in reverse order (older on top). Timeline is however displayed as it should.

Debian/ubuntu/mint users : choqok with both patch is available at https://launchpad.net/~pfoo/+archive/choqok/+packages (compiled against kde4.10)
Comment 51 robert marshall 2013-06-17 08:05:14 UTC
pfoo thanks for the 1.4.1 build update - yes search now works for me too - lists aren't working yet but not so far seen anything else broken. Tested with identi.ca too
Comment 52 Vasileios P. Lourdas 2013-06-17 13:44:40 UTC
(In reply to comment #51)
> pfoo thanks for the 1.4.1 build update - yes search now works for me too -
> lists aren't working yet but not so far seen anything else broken. Tested
> with identi.ca too

Where is this version (1.4.1) ?
Comment 53 Fisiu 2013-06-17 15:25:00 UTC
(In reply to comment #32)
> I've built an openSUSE package from git,
> 1-click-install for openSUSE 12.2 is here:
> http://software.opensuse.org/ymp/home:lemmy04/openSUSE_12.2/choqok.
> ymp?base=openSUSE%3A12.2&query=choqok
> 
> It's been built against KDE 4.10 so you'll also need that.

Why don't You build packages against Update repo for released version? The most of users use stock KDE (especially with 12.3, official KDE updates lands in Update repository). If You're building against some KDE:xxx repo, please name repository accordingly to not confuse users, ie. openSUSE_12.3 means OSS + Update for 12.3 but Your repository involves also KR410... Use some suffix for them ;)
Comment 54 Daniel Kreuter 2013-06-17 16:08:47 UTC
I applied both patches from Mario Bensi and fixed the search order of each tweet.
Changes are pushed to my github repository.

I tried searching for hashtags, and it worked (testet for #kde).

Once my developer account got created by the sysadmins I will push the changes to the kde repository.

Please report any issues you find in the current github master so we can release the 1.4 version soon.
Comment 55 robert marshall 2013-06-17 18:37:07 UTC
(In reply to comment #52)
> Where is this version (1.4.1) ?

That's the version in the .deb file name from pfoo's latest link (the installed prog still is version 1.3.1)
Comment 56 Daniel Kreuter 2013-06-18 17:17:21 UTC
Git commit 44beb0bcc678a9d053f48d487ef53752f9dddb27 by Daniel Kreuter.
Committed on 18/06/2013 at 19:15.
Pushed by dkreuter into branch 'master'.

Changed API version from Twitter from 1.0 to 1.1

Changed API version from 1.0 to 1.1 because 1.0 has been shut down.

Also applied both patches from Mario Bensi regarding twitter search
and direct_messages.

M  +47   -70   helperlibs/twitterapihelper/twitterapimicroblog.cpp
M  +14   -14   helperlibs/twitterapihelper/twitterapimicroblog.h
M  +31   -2    helperlibs/twitterapihelper/twitterapisearch.cpp
M  +2    -0    helperlibs/twitterapihelper/twitterapisearch.h
M  +10   -10   microblogs/laconica/laconicamicroblog.cpp
M  +1    -1    microblogs/laconica/laconicamicroblog.h
M  +4    -1    microblogs/twitter/twitteraccount.cpp
M  +2    -2    microblogs/twitter/twittermicroblog.cpp
M  +68   -100  microblogs/twitter/twittersearch.cpp
M  +2    -4    microblogs/twitter/twittersearch.h

http://commits.kde.org/choqok/44beb0bcc678a9d053f48d487ef53752f9dddb27
Comment 57 Oleksandr Natalenko 2013-06-18 17:22:32 UTC
Thank you so much, Daniel!
Comment 58 Filipe Saraiva 2013-06-18 17:28:36 UTC
Thanks so much Daniel and choqok developers!
Will we have a new choqok release today?

I will request a backport and a new choqok package to Mageia KDE packagers.

Thanks,
Comment 59 Johannes Huber 2013-06-18 18:13:48 UTC
Current master does not build.
Comment 60 Daniel Kreuter 2013-06-18 18:29:19 UTC
(In reply to comment #59)
> Current master does not build.

Hi,

should work again. Sorry for this, I have no idea why the start of the comment was missing (didn't change anything there).

Hope it works now.
Comment 61 Vasileios P. Lourdas 2013-06-18 19:24:17 UTC
I seem to have an issue. I have set the limit of displayed tweets to 70. However, even when there are read (old) tweets, they are not deleted and exist in the timeline. Previously, this worked fine. Eg. if I had 90 unread tweets, they were all shown. If I read (from the old ones) 15 of them, at the next timeline refresh, the tweets shown would be 75. Now old read tweets above the threshold remain.
Comment 62 Fisiu 2013-06-18 19:32:14 UTC
Another bug. When marking tweets as favorite, they are marked only in client, not in server.
Mark some tweet in choqok and check its status in browser. They differ.

Should I open a new bug report about this issue?
Comment 63 Daniel Kreuter 2013-06-18 19:34:19 UTC
(In reply to comment #62)
> Another bug. When marking tweets as favorite, they are marked only in
> client, not in server.
> Mark some tweet in choqok and check its status in browser. They differ.
> 
> Should I open a new bug report about this issue?

Yes please, I already know of this issue, but have no idea yet where the problem is.
Since this report is already marked as resolved it would be better to track every new issue in a new report.

(In reply to comment #61)
> I seem to have an issue. I have set the limit of displayed tweets to 70.
> However, even when there are read (old) tweets, they are not deleted and
> exist in the timeline. Previously, this worked fine. Eg. if I had 90 unread
> tweets, they were all shown. If I read (from the old ones) 15 of them, at
> the next timeline refresh, the tweets shown would be 75. Now old read tweets
> above the threshold remain.
Can you report this in a new report please? I will have a look at it.

Cheers
Comment 64 robert marshall 2013-06-18 19:56:05 UTC
Do you have lists not working (they don't update and you can't add them) in your list(!) or would you like a report for this too?
Comment 65 Mehrdad Momeny 2013-06-19 02:27:53 UTC
Please keep this bug open for all of problems related to this API change, and report them here and don't open new bugs! it makes it easier to track this api update and its issues.

We will close this and release a new version once twitter support is back to normal :)

Thanks Daniel
Comment 66 robert marshall 2013-06-19 07:47:25 UTC
(In reply to comment #61)
> I seem to have an issue. I have set the limit of displayed tweets to 70.
> However, even when there are read (old) tweets, they are not deleted and
> exist in the timeline. Previously, this worked fine. Eg. if I had 90 unread
> tweets, they were all shown. If I read (from the old ones) 15 of them, at
> the next timeline refresh, the tweets shown would be 75. Now old read tweets
> above the threshold remain.

I think this only happens when you're not tweeting, if there's an update because of a tweet old ones get cleared out, if you don't and you update/autoupdate they remain
Comment 67 Daniel Kreuter 2013-06-19 17:09:06 UTC
Git commit e22372b15d8d17c099fabb7ee416a5ddf50eb8c8 by Daniel Kreuter.
Committed on 19/06/2013 at 17:06.
Pushed by dkreuter into branch 'master'.

Favorites switched to new twitter api version

Changed api version for favorites.

M  +16   -369  helperlibs/twitterapihelper/twitterapimicroblog.cpp
M  +0    -19   helperlibs/twitterapihelper/twitterapimicroblog.h

http://commits.kde.org/choqok/e22372b15d8d17c099fabb7ee416a5ddf50eb8c8
Comment 68 Dwayne MacKinnon 2013-06-19 19:36:42 UTC
I successfully compiled & installed the 2013-06-18 git commit on FreeBSD 9.1-RELEASE & KDE 4.10.3. When attempting to follow somebody new the action fails with "The server returned invalid data." 

Still though, great work so far. Happy to have my twitter feed back.
Comment 69 Daniel Kreuter 2013-06-20 06:08:07 UTC
Created attachment 80655 [details]
Fix for follow/unfollow/block/unblock

I'm working on the follow/unfollow problem and have a patch attached which works so far, I'm refining it a bit but you may test it and report any issues you find.
Comment 70 robert marshall 2013-06-21 06:50:01 UTC
Yesterday I was attempting to send a tweet - it appeared to work but never appeared, tried it twice without success, the text was (more or less) https://twitter.com/rajm/status/347713857134931969 - which I eventually posted with a browser. I've tried to replicate it this morning and so far can't trigger the problem :-( Using the deb package of 2013-06-17
Comment 71 Daniel Kreuter 2013-06-21 08:46:23 UTC
Created attachment 80681 [details]
Fix image upload

Uploaded a patch to get uploading of images working.

I will push this patch as well as the follow/unfollow patch later this evening.

Now with this two patches everything should work again regarding twitter.
Comment 72 Daniel Kreuter 2013-06-21 15:08:21 UTC
Git commit ec2ceb15bef3527a805a7f0cd482d56c63791886 by Daniel Kreuter.
Committed on 21/06/2013 at 15:07.
Pushed by dkreuter into branch 'master'.

Follow / Unfollow and Images

Switched from get method to post method for follow, unfollow and block.

Changed URL for Image uploading.

M  +33   -9    helperlibs/twitterapihelper/twitterapimicroblog.cpp
M  +1    -1    microblogs/twitter/twitteraccount.cpp

http://commits.kde.org/choqok/ec2ceb15bef3527a805a7f0cd482d56c63791886
Comment 73 Daniel Kreuter 2013-06-21 15:09:31 UTC
Hi,

as long as I've seen, everything should work now. Please test with the latest git commit and give us any feedback so we can release as soon as possible.

Cheers
Comment 74 pfoo 2013-06-22 04:34:29 UTC
updading my ppa right now with latest git from kde

Note for *ubuntu users : I strongly advise removing my build of choqok from your system (apt-get remove choqok and apt-get clean and apt-get autoclean) and my ppa from your sources as soon as an official build is released by kubuntu-ppa or kubuntu-ppa-backports
Comment 75 B. R. Ashley 2013-06-22 05:31:05 UTC
On 13-06-22 12:34 AM, pfoo wrote:
> https://bugs.kde.org/show_bug.cgi?id=264091
>
> --- Comment #74 from pfoo <pfoo@csnu.org> ---
> updading my ppa right now with latest git from kde
>
> Note for *ubuntu users : I strongly advise removing my build of choqok from
> your system (apt-get remove choqok and apt-get clean and apt-get autoclean) and
> my ppa from your sources as soon as an official build is released by
> kubuntu-ppa or kubuntu-ppa-backports
>
thanks, I shall take note of this. Presume it applies to xubuntu also.
Comment 76 robert marshall 2013-06-22 08:45:59 UTC
On installing the latest ppa build
- search now gives results with the latest at the top again :-)
- private messages are working - they weren't working in 13.04 :-)

However - 
- lists are still not working - if you 'Add User List' and enter a twitter id who has defined lists (e.g flowchainsensei or me (rajm)) and click 'load lists' you get 'there is no list record for user flowchainsensei') the user lists I have open (from before the breakage) don't update - they all contain 10 day old postings and nothing more recent. Both these used to work before the current problems.
Comment 77 George Labuschagne 2013-06-23 08:35:48 UTC
(In reply to comment #50)
> Direct message and twitter search patchs are working great apart from a
> minor bug : twitter search result are displayed in reverse order (older on
> top). Timeline is however displayed as it should.
> 
> Debian/ubuntu/mint users : choqok with both patch is available at
> https://launchpad.net/~pfoo/+archive/choqok/+packages (compiled against
> kde4.10)

Thanks a lot for the fix.
Comment 78 robert marshall 2013-07-02 19:07:55 UTC
I think there's also a problem with posts which include a link when the expanded form is too long - previously there used to be a popup message and you were returned to the tweet composition window so you could truncate it. Now the message appears to be posted and the timeline updates but the tweet doesn't appear.
I produced this problem with the following text:
'book group compared notes last nigh on PD James Death comes to Pemberley  - I think this reviewer liked it less than me! bit.ly/12ELWJJ'
Comment 79 Mehrdad Momeny 2013-07-07 03:44:13 UTC
Git commit c935bc88e172a0e6b531dca586fb96890951310f by Mehrdad Momeny.
Committed on 07/07/2013 at 03:39.
Pushed by momeny into branch 'master'.

Fetching list of twitter Lists that the requested user owns, fixed!
The trick here was that You should pass the base URL to TwitterApiMicroBlog::authorizationHeader() funtion to make OAuth signature based on that! (without parameters!)
CCMAIL:daniel.kreuter85@gmail.com

M  +1    -0    microblogs/twitter/twitterlistdialog.cpp
M  +11   -5    microblogs/twitter/twittermicroblog.cpp
M  +5    -5    microblogs/twitter/twittersearch.cpp

http://commits.kde.org/choqok/c935bc88e172a0e6b531dca586fb96890951310f
Comment 80 robert marshall 2013-07-07 06:56:45 UTC
I've just updated my git pull of choqok and it now crashes on start up
Thread 1 (Thread 0xb49a6980 (LWP 10338)):
[KCrash Handler]
#7  0xfffffff8 in ?? ()
#8  0xb726b150 in Choqok::UI::TimelineWidget::addNewPosts (this=0xc739f50, postList=...) at /home/robert/devel/choqok/libchoqok/ui/timelinewidget.cpp:237
#9  0xb02ac50d in TwitterApiSearchTimelineWidget::addNewPosts(QList<Choqok::Post*>&) () from /usr/lib/libtwitterapihelper.so.1
#10 0xb02aabe6 in TwitterApiMicroBlogWidget::slotSearchResultsReceived(SearchInfo const&, QList<Choqok::Post*>&) () from /usr/lib/libtwitterapihelper.so.1
#11 0xb02a91bd in ?? () from /usr/lib/libtwitterapihelper.so.1
#12 0xb62f5b56 in QMetaObject::activate (sender=0x8c16cf0, m=0xb02c40fc <TwitterApiSearch::staticMetaObject>, local_signal_index=0, argv=0xbfd98a34) at kernel/qobject.cpp:3539
#13 0xb028b4ad in TwitterApiSearch::searchResultsReceived(SearchInfo const&, QList<Choqok::Post*>&) () from /usr/lib/libtwitterapihelper.so.1
#14 0xb033d764 in ?? () from /usr/lib/kde4/choqok_twitter.so
#15 0xb033aa70 in ?? () from /usr/lib/kde4/choqok_twitter.so
#16 0xb62f5b56 in QMetaObject::activate (sender=sender@entry=0x8d74420, m=m@entry=0xb671146c <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0xbfd98bd8) at kernel/qobject.cpp:3539
#17 0xb6559025 in KJob::result (this=this@entry=0x8d74420, _t1=_t1@entry=0x8d74420) at ./kjob.moc:208
#18 0xb6559078 in KJob::emitResult (this=this@entry=0x8d74420) at ../../kdecore/jobs/kjob.cpp:318
#19 0xb57dee4d in KIO::SimpleJob::slotFinished (this=this@entry=0x8d74420) at ../../kio/kio/job.cpp:494
#20 0xb57df39d in KIO::TransferJob::slotFinished (this=0x8d74420) at ../../kio/kio/job.cpp:1081
#21 0xb57dd6a8 in qt_static_metacall (_a=0xbfd98dfc, _id=7, _o=0x8d74420, _c=<optimized out>) at ./jobclasses.moc:388
#22 KIO::TransferJob::qt_static_metacall (_o=0x8d74420, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfd98dfc) at ./jobclasses.moc:375
#23 0xb62f5b56 in QMetaObject::activate (sender=sender@entry=0xc392fe8, m=m@entry=0xb59b0480 <KIO::SlaveInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#24 0xb5888cc5 in KIO::SlaveInterface::finished (this=this@entry=0xc392fe8) at ./slaveinterface.moc:185
#25 0xb588c1c3 in KIO::SlaveInterface::dispatch (this=0xc392fe8, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#26 0xb58889fa in KIO::SlaveInterface::dispatch (this=0xc392fe8) at ../../kio/kio/slaveinterface.cpp:88
#27 0xb587b8c8 in KIO::Slave::gotInput (this=this@entry=0xc392fe8) at ../../kio/kio/slave.cpp:344
#28 0xb587bf24 in KIO::Slave::qt_static_metacall (_o=0xc392fe8, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfd990ac) at ./slave.moc:57
#29 0xb62f5b56 in QMetaObject::activate (sender=sender@entry=0x964d760, m=m@entry=0xb59ad110 <KIO::Connection::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#30 0xb57a2c15 in KIO::Connection::readyRead (this=0x964d760) at ./connection.moc:106
#31 0xb57a31f8 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#32 KIO::ConnectionPrivate::dequeue (this=0xd3b24f8) at ../../kio/kio/connection.cpp:71
#33 0xb62f1b4a in QMetaCallEvent::placeMetaCall (this=0xbd474a8, object=0x964d760) at kernel/qobject.cpp:524
#34 0xb62fb48b in QObject::event (this=0x964d760, e=0xbd474a8) at kernel/qobject.cpp:1194
#35 0xb6853c7c in QApplicationPrivate::notify_helper (this=0x8a20f80, receiver=0x964d760, e=0xbd474a8) at kernel/qapplication.cpp:4567
#36 0xb6856b94 in QApplication::notify (this=0xbd474a8, receiver=0x964d760, e=0xbd474a8) at kernel/qapplication.cpp:3949
#37 0xb7490d01 in KApplication::notify (this=0xbfd99958, receiver=0x964d760, event=0xbd474a8) at ../../kdeui/kernel/kapplication.cpp:311
#38 0xb62df90e in QCoreApplication::notifyInternal (this=0xbfd99958, receiver=0x964d760, event=0xbd474a8) at kernel/qcoreapplication.cpp:946
#39 0xb62e3721 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x89b6140) at kernel/qcoreapplication.cpp:1570
#41 0xb62e3a8c in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#42 0xb6311aa4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#43 postEventSourceDispatch (s=0x8a20338) at kernel/qeventdispatcher_glib.cpp:279
#44 0xb55723b3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#45 0xb5572750 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0xb5572831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0xb6311c21 in QEventDispatcherGlib::processEvents (this=this@entry=0x89b6cf8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#48 0xb690aa0a in QGuiEventDispatcherGlib::processEvents (this=0x89b6cf8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0xb62de3ec in QEventLoop::processEvents (this=this@entry=0xbfd99888, flags=...) at kernel/qeventloop.cpp:149
#50 0xb62de6e1 in QEventLoop::exec (this=this@entry=0xbfd99888, flags=...) at kernel/qeventloop.cpp:204
#51 0xb62e43fa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#52 0xb6851fc4 in QApplication::exec () at kernel/qapplication.cpp:3828
#53 0x0804f8bd in main (argc=1, argv=0xbfd99a34) at /home/robert/devel/choqok/choqok/main.cpp:63
I had a number of lists open when I closed the previous build - although previously they weren't being updated for when they worked again! - could this be the problem?
Comment 81 Mehrdad Momeny 2013-07-07 07:19:23 UTC
(In reply to comment #80)
> I had a number of lists open when I closed the previous build - although
> previously they weren't being updated for when they worked again! - could
> this be the problem?
It seems that this crash happens in a search result updating. but why? I can't undestand :/
And lists aren't fully usable yet!
Comment 82 robert marshall 2013-07-07 10:50:53 UTC
I've also got a couple of search tabs open on particular users (but maybe you realise that!)
Comment 83 robert marshall 2013-07-07 11:03:10 UTC
oh and what magic do you have to do to get gdb to get control when choqok crashes? For me it just exits returning to the gdb prompt with no program running. I assume there's a signal handler somewhere which catches it and gdb never sees the problem?
Comment 84 Mehrdad Momeny 2013-07-10 01:58:50 UTC
*** Bug 322170 has been marked as a duplicate of this bug. ***
Comment 85 Mehrdad Momeny 2013-07-10 02:26:58 UTC
*** Bug 322170 has been marked as a duplicate of this bug. ***
Comment 86 Chris Siebenmann 2013-07-10 15:56:02 UTC
(In reply to comment #83)
> oh and what magic do you have to do to get gdb to get control when choqok
> crashes?

I think you want the --nofork option. It's what I needed to do to run choqok under
valgrind.
Comment 87 robert marshall 2013-07-11 06:55:40 UTC
Just getting the following messages in .xsession-errors with the choqok installed from choqok_1.4-2-1git0_i386.deb and an OSD message about being unable to parse data

json_parser - syntax error found,  forcing abort, Line 1 Column 0 
json_parser - syntax error found,  forcing abort, Line 1 Column 0 
choqok(26497): JSON parsing failed.
Buffer was: 
 "Invalid / expired Token" 
json_parser - syntax error found,  forcing abort, Line 1 Column 0 
json_parser - syntax error found,  forcing abort, Line 1 Column 0 
choqok(26497): JSON parsing failed.
Buffer was: 
 "Invalid / expired Token" 
json_parser - syntax error found,  forcing abort, Line 1 Column 0 
json_parser - syntax error found,  forcing abort, Line 1 Column 0 
choqok(26497): JSON parsing failed.
Buffer was: 
 "Cannot GET /api/direct_messages.json?since_id=32113&amp;count=200&amp;page=1" 
json_parser - syntax error found,  forcing abort, Line 1 Column 0 
json_parser - syntax error found,  forcing abort, Line 1 Column 0 
choqok(26497): JSON parsing failed.
Buffer was: 
 "Invalid / expired Token"
Comment 88 robert marshall 2013-07-11 06:58:47 UTC
(In reply to comment #86)
> (In reply to comment #83)
> > oh and what magic do you have to do to get gdb to get control when choqok
> > crashes?
> 
> I think you want the --nofork option. It's what I needed to do to run choqok
> under valgrind.
It didn't work for me - I also tried --nocrashhandler without success
Comment 89 Chris Siebenmann 2013-07-12 17:19:11 UTC
Here's an issue I'm now confidant about: the current or near-current git
choqok re-orders Retweets when restarted, at least when restarted after
crashes. They should show in your timeline when they were RT'd into
it (and they do when initially fetched), but after a restart they get
re-ordered down to when they were originally posted (often much older
and thus much lower and less visible).

(I think it reorders some other tweets as well, but it definitely
re-orders RTs.)
Comment 90 Christoph Feck 2013-07-19 01:00:05 UTC
robert, to run choqok in gdb, use "gdb --args choqok --nofork", and then "run" at the gdb prompt. Upon crash, type "bt".

If the crash is reproducible, it is best to report it as a new bug.
Comment 91 Daniel Kreuter 2013-08-06 15:37:30 UTC
Git commit 3e8e6384a1595f832f2ec209bd00d8ca720e455a by Daniel Kreuter.
Committed on 06/08/2013 at 15:34.
Pushed by dkreuter into branch 'master'.

Fixed timelines of user lists

User lists are now fully working again.
REVIEW: 111855

M  +31   -16   helperlibs/twitterapihelper/twitterapimicroblog.cpp
M  +3    -7    microblogs/twitter/twittermicroblog.cpp

http://commits.kde.org/choqok/3e8e6384a1595f832f2ec209bd00d8ca720e455a
Comment 92 robert marshall 2013-08-07 10:14:52 UTC
Lists looking a lot better - thanks!
I can see one problem, if a user in a list retweets something, sometimes I'm getting that RT as a new message every time choqok updates (it only appears once in the timeline)

The sequence appears to be:
- RT is there
- do a refresh - RT disappears
- do a refresh - RT re-appears as new

I can give an example from one of my lists if required.
Comment 93 Vasileios P. Lourdas 2013-08-07 19:29:05 UTC
(In reply to comment #91)
> Git commit 3e8e6384a1595f832f2ec209bd00d8ca720e455a by Daniel Kreuter.
> Committed on 06/08/2013 at 15:34.
> Pushed by dkreuter into branch 'master'.
> 
> Fixed timelines of user lists

Ok, I would suggest to create a tag release with all the mentioned patches here. Why am I suggesting this? Because with the current situation, there are distros that could include all or most of the patches for Choqok, so any bug reports could be inconsistent because of the possibility of missing patches by the maintainer (distro). If there is a specific tagged release, it's much easier for a distro maintainer to follow the Choqok releases and for users to file bug reports against specific releases.

I hope I made my point clear.
Comment 94 Daniel Kreuter 2013-08-07 20:09:55 UTC
(In reply to comment #93)
> (In reply to comment #91)
> > Git commit 3e8e6384a1595f832f2ec209bd00d8ca720e455a by Daniel Kreuter.
> > Committed on 06/08/2013 at 15:34.
> > Pushed by dkreuter into branch 'master'.
> > 
> > Fixed timelines of user lists
> 
> Ok, I would suggest to create a tag release with all the mentioned patches
> here. Why am I suggesting this? Because with the current situation, there
> are distros that could include all or most of the patches for Choqok, so any
> bug reports could be inconsistent because of the possibility of missing
> patches by the maintainer (distro). If there is a specific tagged release,
> it's much easier for a distro maintainer to follow the Choqok releases and
> for users to file bug reports against specific releases.
> 
> I hope I made my point clear.

The patches mentioned here are all in master so once Mehrdad released version 1.4 the distributions can build the packages for it.
Comment 95 Daniel Kreuter 2013-09-04 18:05:55 UTC
Hi,

I close this bug since Choqok 1.4 has been release on 1st September (see also http://choqok.gnufolks.org/2013/09/choqok-1-4-released/)