Bug 321069 - Cannot post to twitter or refresh the timeline
Summary: Cannot post to twitter or refresh the timeline
Status: RESOLVED DUPLICATE of bug 264091
Alias: None
Product: choqok
Classification: Applications
Component: Twitter (show other bugs)
Version: 1.3
Platform: Gentoo Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Mehrdad Momeny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-12 17:16 UTC by Vasileios P. Lourdas
Modified: 2013-06-13 02:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vasileios P. Lourdas 2013-06-12 17:16:42 UTC
I try to refresh the timeline or post a new message to Twitter, but I get no response during the first procedure and I get a "Creating the new post failed. The result data could not be parsed.". After starting choqok from a terminal, when I try to post, I get the message:

choqok(15558): Creating post: XML parsing error:  "<?xml version="1.0" encoding="UTF-8"?><errors>  <error code="68">The Twitter REST API v1 will soon stop functioning. Please migrate to API v1.1. https://dev.twitter.com/docs/api/1.1/overview.</error></errors>"

I suppose the same error applies when trying to refresh the timeline.

Reproducible: Always

Steps to Reproduce:
1. Start choqok
2. Try to refresh the timeline
3. Try to post a new message
Actual Results:  
In case 2) nothing happens.
In case 3) I get the error "Creating the new post failed. The result data could not be parsed."

Expected Results:  
Timeline should be refreshed and message should be posted.

Linux 3.9.5 (x86_64), with KDE 4.10.3 from Gentoo tree.
Comment 1 Pablo 2013-06-12 19:51:08 UTC
Same issue here

Trying to posting I get that:
choqok(6189): Creating post: XML parsing error:  "<?xml version="1.0" encoding="UTF-8"?><errors>  <error code="68">The Twitter REST API v1 is no longer active. Please migrate to API v1.1. https://dev.twitter.com/docs/api/1.1/overview.</error></errors>" 


Linux 3.9.5-1-ARCH #1 SMP PREEMPT Sat Jun 8 09:22:45 CEST 2013 x86_64 GNU/Linux
Comment 2 Daniel Dewald 2013-06-12 20:41:17 UTC
This is actually a duplicate of #264091 the v1 API was (as warned) deprecated and deactivated today so a switch to v1.1 is necessary. To bad it is only done now that its broken.. it'll need time to ripple to distros.
Comment 3 Mehrdad Momeny 2013-06-13 02:06:52 UTC

*** This bug has been marked as a duplicate of bug 264091 ***